Difference between revisions of "Vnumlgui Debian"

From VNUML-WIKI
Jump to: navigation, search
(Installing VNUMLGUI over Debian)
Line 5: Line 5:
 
<ol>
 
<ol>
  
<li>Install required Debian packages:<li>
+
<li>Install required Debian packages:</li>
  
 
  gracia:~# apt-get install libgtk2-perl libextutils-depends-perl libextutils-pkgconfig-perl libglade2-dev libgnome2-perl
 
  gracia:~# apt-get install libgtk2-perl libextutils-depends-perl libextutils-pkgconfig-perl libglade2-dev libgnome2-perl

Revision as of 23:47, 2 October 2007

Installing VNUMLGUI over Debian

This HowTo describes how to install VNUMLGUI in a Debian system. It is assumed that VNUML has been previously installed. The procedure described here is based on the code downloaded from CVS, but I guess is the same when installing from the .tgz.

  1. Install required Debian packages:
  2. gracia:~# apt-get install libgtk2-perl libextutils-depends-perl libextutils-pkgconfig-perl libglade2-dev libgnome2-perl
    
  3. Install required Perl modules from CPAN. In order to do so, donwload the file, uncompress, then "perl Makefile ; make ; make install".
  4. Change directory to vnumlgui source (let's assume this directory is /tmp/vnumlgui), then make:
  5. gracia:~# cd /tmp/vnumlgui
    gracia:/tmp/vnumlgui#