Using Rational DOORS
IBM Rational DOORS
Using Rational DOORS
Release 9.2
Before using this information, be sure to read the general information under the "Notices" chapter on page 405.

This edition applies to IBM Rational DOORS, VERSION 9.2, and to all subsequent releases and modifications until otherwise indicated in new editions.

© Copyright IBM Corporation 1993, 2010
US Government Users Restricted Rights—Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.
# Table of contents

## Chapter 1: About this manual

- Typographical conventions .................................................. 1
- Related documentation .......................................................... 1

## Chapter 2: Basics

- Starting Rational DOORS ....................................................... 3
- Changing the Database Explorer display .................................. 5
- Making selections in the Database Explorer:  
  - Selecting multiple items .................................................. 7
- Changing the appearance of the Database Explorer toolbar ............. 7
- Changing the appearance of the module toolbar .......................... 7
- The Location field .................................................................. 8
- Favorites .............................................................................. 9
  - Organizing your favorites list ............................................. 9
  - How changes to the database affect Favorites......................... 10
- Opening a module .................................................................. 11
- Requesting a module lock ....................................................... 12
- Rational DOORS URLs ........................................................... 12
  - Following a Rational DOORS URL ..................................... 13
- Making selections in a module window:  
  - Selecting multiple objects ................................................. 16
  - Selecting everything ......................................................... 17
- Using drag-and-drop:  
  - In the Database Explorer ................................................. 17
  - In a module window ......................................................... 17
- Cutting, copying and pasting:  
  - In the Database Explorer ................................................. 19
  - In a module window ......................................................... 20
- Closing a module .................................................................. 22
- Stopping Rational DOORS ...................................................... 22
<table>
<thead>
<tr>
<th>Chapter 3: Managing formal modules</th>
<th>23</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a formal module</td>
<td>23</td>
</tr>
<tr>
<td>Controlling access to a formal module</td>
<td>24</td>
</tr>
<tr>
<td>Creating a new module using paste special</td>
<td>27</td>
</tr>
<tr>
<td>Showing module properties</td>
<td>29</td>
</tr>
<tr>
<td>Showing module statistics</td>
<td>31</td>
</tr>
<tr>
<td>Deleting, undeleting and purging a module</td>
<td>32</td>
</tr>
<tr>
<td>Managing open modules</td>
<td>33</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 4: Editing</th>
<th>35</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit modes</td>
<td>36</td>
</tr>
<tr>
<td>Changing the edit mode</td>
<td>36</td>
</tr>
<tr>
<td>Editable sections</td>
<td>37</td>
</tr>
<tr>
<td>Setting up a module for sharing</td>
<td>38</td>
</tr>
<tr>
<td>Working in shareable edit mode</td>
<td>39</td>
</tr>
<tr>
<td>Saving changes when editing in shareable mode</td>
<td>40</td>
</tr>
<tr>
<td>Colors of locked and unlocked sections</td>
<td>40</td>
</tr>
<tr>
<td>Requesting a section lock</td>
<td>41</td>
</tr>
<tr>
<td>In-place editing</td>
<td>41</td>
</tr>
<tr>
<td>Selecting and editing</td>
<td>42</td>
</tr>
<tr>
<td>Formatting text</td>
<td>43</td>
</tr>
<tr>
<td>Cut, copy and paste</td>
<td>45</td>
</tr>
<tr>
<td>Editing using the object properties sheet</td>
<td>46</td>
</tr>
<tr>
<td>Undoing edits</td>
<td>50</td>
</tr>
<tr>
<td>Extended undo</td>
<td>50</td>
</tr>
<tr>
<td>Saving your changes</td>
<td>51</td>
</tr>
<tr>
<td>Creating objects</td>
<td>51</td>
</tr>
<tr>
<td>Controlling access to an object</td>
<td>52</td>
</tr>
<tr>
<td>Promoting and demoting objects</td>
<td>54</td>
</tr>
<tr>
<td>Swapping Object Heading and Object Text attributes</td>
<td>55</td>
</tr>
<tr>
<td>Splitting Object Heading from Object Text</td>
<td>56</td>
</tr>
<tr>
<td>Deleting, undeleting, and purging objects</td>
<td>56</td>
</tr>
<tr>
<td>The spelling checker</td>
<td>58</td>
</tr>
</tbody>
</table>
Table of contents

Checking spelling .......................................................... 58
Inserting symbols .......................................................... 61
Inserting URLs .............................................................. 61
Inserting templates ......................................................... 62
Splitting objects ............................................................ 62
Copying objects ............................................................. 64
Merging object text ......................................................... 65

Chapter 5: Editing using forms 67
Forms ................................................................. 67
Creating a new form ....................................................... 67
Editing forms .............................................................. 69
Running forms ............................................................ 69
Deleting forms ............................................................. 70

Chapter 6: Using views 71
Views ................................................................. 71
Saving your current view ................................................. 72
Inheritance in views ....................................................... 74
  Views inheritance and access controls ................................ 74
Setting default views ...................................................... 75
Editing a view ............................................................ 76
Controlling access to a view ............................................. 79
Deleting a view ............................................................ 81

Chapter 7: Finding, filtering and sorting 83
Searching the database ................................................... 83
Finding text in a module .................................................. 84
Finding and replacing text ................................................. 85
Going to a particular object ............................................... 86
Filters ................................................................. 87
  Simple filters ............................................................ 87
  Advanced filters ........................................................ 88
<table>
<thead>
<tr>
<th>Chapter 8: Using attributes</th>
<th>99</th>
</tr>
</thead>
<tbody>
<tr>
<td>System attributes</td>
<td>99</td>
</tr>
<tr>
<td>Attribute types</td>
<td>102</td>
</tr>
<tr>
<td>Showing attribute types</td>
<td>104</td>
</tr>
<tr>
<td>Creating an attribute type</td>
<td>105</td>
</tr>
<tr>
<td>Controlling access to an attribute type</td>
<td>106</td>
</tr>
<tr>
<td>Editing an attribute type</td>
<td>108</td>
</tr>
<tr>
<td>Deleting an attribute type</td>
<td>109</td>
</tr>
<tr>
<td>Showing attribute definitions</td>
<td>109</td>
</tr>
<tr>
<td>Creating an attribute definition</td>
<td>110</td>
</tr>
<tr>
<td>Creating a new DXL attribute</td>
<td>113</td>
</tr>
<tr>
<td>Controlling access to an attribute definition</td>
<td>114</td>
</tr>
<tr>
<td>Controlling access to an attribute value</td>
<td>115</td>
</tr>
<tr>
<td>Editing an attribute definition</td>
<td>117</td>
</tr>
<tr>
<td>Editing a DXL attribute definition</td>
<td>120</td>
</tr>
<tr>
<td>Sharing attribute and type definitions</td>
<td>122</td>
</tr>
<tr>
<td>Deleting an attribute definition</td>
<td>123</td>
</tr>
<tr>
<td>DXL attributes and layout DXL columns</td>
<td>123</td>
</tr>
<tr>
<td>Copying attribute values</td>
<td>124</td>
</tr>
<tr>
<td>Measuring the frequency of attribute values</td>
<td>125</td>
</tr>
</tbody>
</table>
# Table of contents

## Chapter 9: Viewing data in formal modules  127
- Navigating using the keyboard .................................................. 127
- The view menu ............................................................................. 128
- The Module Explorer ..................................................................... 130
- Display modes .............................................................................. 131
- Changing the display mode ........................................................... 132
  - Selecting the attributes shown in graphics mode ......................... 132
- Controlling display levels ............................................................. 132
- Controlling table attribute display .............................................. 133
- Outlining ...................................................................................... 133
- Compression ............................................................................... 134
- Working with columns ................................................................. 134
- Showing column information ....................................................... 135
- Adding a column ......................................................................... 136
- Editing column information ........................................................... 137
- Color-coding your data ................................................................. 138
- Adding a graph column ................................................................. 139
- Adding an icon column ................................................................. 143

## Chapter 10: The Module Comparison Wizard  145
- What is the Module Comparison Wizard used for? ....................... 145
- How does the Module Comparison Wizard work? ....................... 145
- Running the Module Comparison Wizard ................................ 146
- The redline markup column ......................................................... 150

## Chapter 11: Working with tables  153
- Tables .......................................................................................... 153
- Creating a table ........................................................................... 154
- Inserting a module as a table ......................................................... 154
- Inserting rows ............................................................................. 155
- Inserting columns ....................................................................... 155
- Changing table properties ............................................................ 156
- Deleting, undeleting and purging tables ....................................... 159
Chapter 12: Working with pictures and OLE objects

Working with pictures .................................................. 163
OLE objects ..................................................................... 164
Activating and deactivating an OLE object ............................ 165
Inserting a new OLE object .............................................. 166
Inserting an existing file as an OLE object ......................... 167
Resizing OLE objects ...................................................... 169
Cutting, copying and pasting OLE objects ......................... 170
Editing OLE object properties ........................................ 170
Deleting OLE objects ..................................................... 172
OLE objects and history ................................................ 172
Setting the OLE open limit ............................................. 173
Registered and Unregistered OLE Objects ......................... 173
Actions affected by changes to the handling of OLE objects .... 174
    Edit in-place or using the object properties sheet .............. 174
    Copy and paste in-place or using the object properties sheet 176
    Cut and paste in-place or using the Object properties sheet 176
    Copy or cut a Rational DOORS object containing an unregistered OLE object in an attribute 177
    Copy objects using the Object Copier .............................. 177
Change Proposal System .................................................. 177
    Submit a change proposal ........................................... 177
    Review change proposals ......................................... 178
    Apply change proposals ........................................... 178
DXL ............................................................................... 178
History ............................................................................ 178
Split Object ..................................................................... 178
Export data from Rational DOORS ................................. 179
Paste unregistered OLE objects into other applications ......... 179
Spelling checker ............................................................. 179
Actions unaffected by changes to the handling of OLE objects 179
    Merge Objects ........................................................ 179
    Create a Baseline ...................................................... 180
    Copy a baseline ....................................................... 180
Table of contents

Chapter 13: Access rights .............................................. 183
About access rights ..................................................... 183
  Full access and no access ......................................... 184
About groups ............................................................... 184
How group rights and user rights interact .......................... 185
  When you are in several groups ................................. 185
About inheritance ......................................................... 185
Inheritance example .................................................... 187
Propagating extra access rights with create ....................... 188

Chapter 14: Managing folders ...................................... 191
Creating a folder ......................................................... 191
Controlling access to a folder ....................................... 192
Editing folder properties ............................................. 194
Deleting, undeleting and purging a folder ......................... 194
Managing locks ............................................................ 195

Chapter 15: Links ......................................................... 199
Links ................................................................. 199
External links ............................................................ 200
Link arrows ............................................................... 201
Creating links ............................................................ 202
  Using drag-and-drop ............................................... 202
  Explicitly defining the link start ............................... 203
Creating and editing external links ................................. 204
Table of contents

Clearing the link start .................................................. 207
Link modules and linksets ............................................. 207
  Rational DOORS Links, the default link modules .................. 207
  Why use other link modules? ........................................ 208
Controlling access to a link module .................................. 208
How copy and move affect links ....................................... 210
Editing links ............................................................. 213
Creating link attributes ............................................... 215
Deleting links ............................................................ 217
Creating links in bulk .................................................. 219
Linking by attribute .................................................... 221
Link module defaults ................................................... 222
  Changing the default link module .................................... 222
Creating default linkset pairings ..................................... 223
Control on links for process management ............................ 224
Showing link module information ..................................... 225
Creating a link module ................................................ 226
  Working with link modules ......................................... 227
Creating a linkset ....................................................... 228
Deleting a linkset ....................................................... 228

Chapter 16: Discussions ................................................ 231
About discussions ....................................................... 231
Controlling access for discussions in a module ...................... 232
Creating a module discussion ......................................... 233
Viewing a module discussion ......................................... 233
Adding a comment to a module discussion ........................... 233
Closing a module discussion .......................................... 234
Deleting a module discussion ......................................... 234
Reopening a module discussion ....................................... 235
Creating an object discussion ......................................... 235
Viewing an object discussion ......................................... 236
Adding a comment to an object discussion ........................... 236
Table of contents

Closing an object discussion ................................................................. 237
Deleting an object discussion .............................................................. 237
Reopening an object discussion .............................................................. 238

Chapter 17: Tracking changes and traceability ........................................ 239
Change bars ......................................................................................... 239
Showing module history ....................................................................... 240
Redlining .................................................................................................. 243
Link analysis .......................................................................................... 244
Running a link analysis ......................................................................... 245
Traceability columns .............................................................................. 246
Adding a traceability column ................................................................. 246
Using the traceability explorer .............................................................. 250
  Navigating ............................................................................................ 251
Suspect links ............................................................................................ 251
Showing suspect links ............................................................................ 252
  Filtering on suspect links .................................................................... 252
  Displaying suspect link indicators ....................................................... 253
  Displaying the last change .................................................................. 253
  Displaying all suspect link information ............................................... 254
Clearing suspect links ............................................................................ 255
  Access rights required for clearing suspect links ................................. 255
Using the Clear function ........................................................................ 256
  Using the clear all function .................................................................. 257
Checking data against history ............................................................... 257

Chapter 18: Using baselines .................................................................... 261
Baselines ................................................................................................. 261
  Using baselines to improve performance ............................................ 261
Viewing a baseline .................................................................................. 262
Baselining groups of modules ............................................................... 262
Creating a baseline ............................................................................... 263
Copying a baseline ................................................................................. 263

Using Rational DOORS
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comparing baselines</td>
<td>265</td>
</tr>
<tr>
<td>Deleting a baseline</td>
<td>266</td>
</tr>
<tr>
<td><strong>Chapter 19: Using Electronic Signatures</strong></td>
<td></td>
</tr>
<tr>
<td>Viewing signatures</td>
<td>267</td>
</tr>
<tr>
<td>Signing a baseline</td>
<td>268</td>
</tr>
<tr>
<td>Including signature information in printouts</td>
<td>269</td>
</tr>
<tr>
<td><strong>Chapter 20: Printing reports</strong></td>
<td></td>
</tr>
<tr>
<td>Applying saved page setups</td>
<td>271</td>
</tr>
<tr>
<td>Creating page setups</td>
<td>271</td>
</tr>
<tr>
<td>Printing a module</td>
<td>277</td>
</tr>
<tr>
<td>Using print preview</td>
<td>278</td>
</tr>
<tr>
<td>Creating a report</td>
<td>279</td>
</tr>
<tr>
<td>Printing and managing reports</td>
<td>280</td>
</tr>
<tr>
<td><strong>Chapter 21: Importing</strong></td>
<td></td>
</tr>
<tr>
<td>Importing from Microsoft Word</td>
<td>283</td>
</tr>
<tr>
<td>Editing imported Word style information</td>
<td>285</td>
</tr>
<tr>
<td>Importing plain text files</td>
<td>286</td>
</tr>
<tr>
<td>Basic import options</td>
<td>286</td>
</tr>
<tr>
<td>Controlling text decomposition</td>
<td>287</td>
</tr>
<tr>
<td>Attribute value assignment</td>
<td>288</td>
</tr>
<tr>
<td>Advanced importing options</td>
<td>289</td>
</tr>
<tr>
<td>Controlling list import</td>
<td>289</td>
</tr>
<tr>
<td>Capturing embedded data</td>
<td>290</td>
</tr>
<tr>
<td>Controlling line breaks and chapter numbering</td>
<td>290</td>
</tr>
<tr>
<td>Importing plain text</td>
<td>291</td>
</tr>
<tr>
<td>Using the import plain text advanced options</td>
<td>292</td>
</tr>
<tr>
<td>Adding and removing keywords or abbreviations</td>
<td>293</td>
</tr>
<tr>
<td>Importing RTF files</td>
<td>294</td>
</tr>
<tr>
<td>Importing spreadsheet files</td>
<td>295</td>
</tr>
<tr>
<td>Importing a spreadsheet or database file</td>
<td>296</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Defining attribute lists for import</td>
<td>298</td>
</tr>
<tr>
<td>Using attribute list elements for import</td>
<td>299</td>
</tr>
<tr>
<td>Loading saved attribute lists for import</td>
<td>299</td>
</tr>
<tr>
<td>Choosing attribute types</td>
<td>300</td>
</tr>
<tr>
<td>Importing FrameMaker files</td>
<td>300</td>
</tr>
<tr>
<td>Importing a MIF file</td>
<td>301</td>
</tr>
<tr>
<td>Using the import MIF advanced options</td>
<td>302</td>
</tr>
<tr>
<td>Chapter 22: Exporting</td>
<td>303</td>
</tr>
<tr>
<td>Exporting to Microsoft Word</td>
<td>303</td>
</tr>
<tr>
<td>Exporting to Microsoft Excel</td>
<td>306</td>
</tr>
<tr>
<td>Exporting to Microsoft Outlook</td>
<td>308</td>
</tr>
<tr>
<td>Exporting to Microsoft PowerPoint</td>
<td>308</td>
</tr>
<tr>
<td>Exporting to HTML</td>
<td>309</td>
</tr>
<tr>
<td>Exporting to plain text</td>
<td>311</td>
</tr>
<tr>
<td>Exporting to RTF</td>
<td>312</td>
</tr>
<tr>
<td>Exporting to spreadsheet</td>
<td>314</td>
</tr>
<tr>
<td>Exporting to FrameMaker</td>
<td>316</td>
</tr>
<tr>
<td>Chapter 23: Using the Change Proposal System</td>
<td>319</td>
</tr>
<tr>
<td>The Change Proposal System</td>
<td>319</td>
</tr>
<tr>
<td>Change proposals and suggestions</td>
<td>320</td>
</tr>
<tr>
<td>Change proposal roles</td>
<td>321</td>
</tr>
<tr>
<td>Change proposal partner modules</td>
<td>321</td>
</tr>
<tr>
<td>Duplicate sets</td>
<td>322</td>
</tr>
<tr>
<td>Groups</td>
<td>322</td>
</tr>
<tr>
<td>Creating groups</td>
<td>324</td>
</tr>
<tr>
<td>Editing groups</td>
<td>324</td>
</tr>
<tr>
<td>Submitting a change proposal</td>
<td>324</td>
</tr>
<tr>
<td>Submitting a suggestion</td>
<td>329</td>
</tr>
<tr>
<td>The review process</td>
<td>330</td>
</tr>
<tr>
<td>Showing and reviewing individual change proposals</td>
<td>331</td>
</tr>
<tr>
<td>Showing and reviewing groups</td>
<td>333</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Showing and reviewing suggestions</td>
<td>334</td>
</tr>
<tr>
<td>Showing information about change proposals</td>
<td>335</td>
</tr>
<tr>
<td>Managing duplicate sets</td>
<td>336</td>
</tr>
<tr>
<td>Checking the approved changes</td>
<td>338</td>
</tr>
<tr>
<td>Applying the approved changes</td>
<td>339</td>
</tr>
<tr>
<td><strong>Chapter 24: Using Rational DOORS to manage your testing</strong></td>
<td>341</td>
</tr>
<tr>
<td>Test Tracking</td>
<td>341</td>
</tr>
<tr>
<td>Creating a test definition</td>
<td>343</td>
</tr>
<tr>
<td>Updating test definitions</td>
<td>345</td>
</tr>
<tr>
<td>Creating a form for recording test results</td>
<td>345</td>
</tr>
<tr>
<td>Preparing the module for a test run</td>
<td>346</td>
</tr>
<tr>
<td>Running tests</td>
<td>347</td>
</tr>
<tr>
<td>Comparing test runs</td>
<td>347</td>
</tr>
<tr>
<td><strong>Chapter 25: Using descriptive modules</strong></td>
<td>349</td>
</tr>
<tr>
<td>Descriptive modules</td>
<td>349</td>
</tr>
<tr>
<td>Controlling access to a descriptive module</td>
<td>350</td>
</tr>
<tr>
<td>Marking up a descriptive module</td>
<td>351</td>
</tr>
<tr>
<td>Extracting marked up objects</td>
<td>352</td>
</tr>
<tr>
<td>Showing descriptive module properties</td>
<td>354</td>
</tr>
<tr>
<td>Displaying marked up items only</td>
<td>355</td>
</tr>
<tr>
<td><strong>Chapter 26: Configuring Rational DOORS</strong></td>
<td>357</td>
</tr>
<tr>
<td>Showing your user options</td>
<td>357</td>
</tr>
<tr>
<td>Display schemes</td>
<td>362</td>
</tr>
<tr>
<td>High contrast display schemes</td>
<td>363</td>
</tr>
<tr>
<td>Changing your display scheme</td>
<td>363</td>
</tr>
<tr>
<td>Display scheme items</td>
<td>365</td>
</tr>
<tr>
<td>Items that affect Print Preview</td>
<td>369</td>
</tr>
<tr>
<td>Configuring the spelling checker</td>
<td>369</td>
</tr>
</tbody>
</table>
### Table of contents

- Available languages .............................................. 369
- Grammar ...................................................... 370
- Checking options ............................................. 371
- Default language selection in Rational DOORS ................. 371
- Adding words to the dictionary .................................. 372
- Using the command line ......................................... 373
- Summary of command line switches ............................. 374
- Using shortcuts .................................................. 378
- Settings in the registry .......................................... 379
  - The EXPORTDIRECTORY keyword ............................... 380
  - The EXPORTDIRECTORY environment variable .................. 380
- Running Rational DOORS in batch mode ......................... 380
- Configuring the Welcome Screen .................................. 380
  - Configuring Home ............................................... 380
  - Configuring the links on the Welcome Screens.................. 381
- Changing the email address of the problem report ............... 382

**Chapter 27: Rational DOORS buttons** 383

- Module buttons .................................................. 383
- Database buttons .................................................. 386

**Chapter 28: Using DXL** 387

- DXL .......................................................................... 387
- Developing DXL programs ....................................... 387
- Browsing the DXL library ........................................... 389
- Converting layout DXL to attribute DXL ....................... 390

**Chapter 29: Keyboard shortcuts** 391

- CTRL keys ........................................................... 391
- Rich text ............................................................... 395
- Function keys ....................................................... 395
- Keypad keys .......................................................... 397
- Navigation Keys ..................................................... 398
## Chapter 30: Contacting support

Contacting IBM Rational Software Support ......................................................... 401
Prerequisites ........................................................................................................ 401
Submitting problems .......................................................................................... 402
Other information ............................................................................................... 404

## Chapter 31: Notices

Trademarks ........................................................................................................... 407
   Text proofing system copyrights .................................................................. 407
1

About this manual

Welcome to IBM® Rational® DOORS® 9.2, a powerful tool that helps you to capture, track and manage your user requirements.

This book describes how to use the basic features of IBM Rational DOORS. It assumes that you’ve read Getting Started with Rational DOORS, which introduces Rational DOORS and explains the concepts behind it.

Typographical conventions

The following typographical conventions are used in this manual:

<table>
<thead>
<tr>
<th>Typeface or Symbol</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Important items, and items that you can select, including buttons and menus: “Click <strong>Yes</strong> to continue”.</td>
</tr>
<tr>
<td><em>Italics</em></td>
<td>Book titles.</td>
</tr>
<tr>
<td><strong>Courier</strong></td>
<td>Commands, files, and directories; computer output: “Edit your .properties file”.</td>
</tr>
<tr>
<td>&gt;</td>
<td>A menu choice: “Select <strong>File &gt; Open</strong>”. This means select the <strong>File</strong> menu, and then select the <strong>Open</strong> option.</td>
</tr>
</tbody>
</table>

Related documentation

The following table describes where to find information in the documentation set:

<table>
<thead>
<tr>
<th>For information on</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>What’s new in version 9.2 of Rational DOORS</td>
<td>The Rational DOORS readme file</td>
</tr>
<tr>
<td>How to install Rational DOORS</td>
<td>Rational DOORS Installation Guide</td>
</tr>
<tr>
<td>How to set up licenses to use Rational DOORS</td>
<td>Rational Lifecycle Solutions Licensing Guide</td>
</tr>
</tbody>
</table>
### Table of Contents

<table>
<thead>
<tr>
<th>For information on</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>How to use Rational DOORS</td>
<td><em>Getting Started with Rational DOORS</em></td>
</tr>
<tr>
<td></td>
<td><em>Using Rational DOORS</em></td>
</tr>
<tr>
<td>How to write requirements</td>
<td><em>Get It Right the First Time</em></td>
</tr>
<tr>
<td>How to set up and manage Rational DOORS</td>
<td><em>Managing Rational DOORS</em></td>
</tr>
<tr>
<td>The DXL programming language</td>
<td><em>DXL Reference manual</em></td>
</tr>
<tr>
<td>How to integrate Rational DOORS with other applications</td>
<td><em>Rational DOORS API Manual</em></td>
</tr>
</tbody>
</table>

These documents are on the Rational Information Center at [http://publib.boulder.ibm.com/infocenter/rsdp/v1r0m0/index.jsp](http://publib.boulder.ibm.com/infocenter/rsdp/v1r0m0/index.jsp).
This chapter contains the following topics:

- Starting Rational DOORS
- Changing the Database Explorer display
- Making selections in the Database Explorer
- Changing the appearance of the module toolbar
- The Location field
- Favorites
- Opening a module
- Requesting a module lock
- Rational DOORS URLs
- Making selections in a module window
- Using drag-and-drop
- Cutting, copying and pasting
- Closing a module
- Stopping Rational DOORS

**Starting Rational DOORS**

To start Rational DOORS:

1. On Windows® computers, click **Start > Programs > IBM Rational > IBM Rational DOORS 9.2.**

2. When the **Login** screen is displayed, type in your Rational DOORS user name and password, and click **OK.**

   **Note** Your user name and password are case sensitive.

   If the user name or password box is unavailable, you do not have to type your user name or password.

3. If a message is displayed telling you that your password has expired, go to Step 4. This message is displayed if you have not run Rational DOORS before.
If this message is not displayed, go to Step 6.

4. Change your password:
   a. Click **OK** to dismiss the message.
   b. In the **Old password** box, type your current password. If you have not
      logged on to Rational DOORS before and do not have a password,
      leave the **Old password** box blank.
   c. In the **New password** and **Confirm new password** boxes, type the
      new password you want to use.
   d. Click **OK**.
   e. Click **OK**.

5. If Rational DOORS uses RDS for user authentication, and additional
   authentication is required, the **Authenticate** dialog box is displayed. Type
   your pin number and click **OK**.

6. The Database Explorer is displayed.

   Your user name and user type are shown on the status bar at the bottom of the
   window.

   **Note**  When your password expires, the next time you log in to
   Rational DOORS, you are asked to change your password. If
   you want to change it before it expires, click **Tools >
   Options**. Then click the **Security** tab, and click **Change
   Password**.
Changing the Database Explorer display

Use the following options on the **View** menu to change the way your screen looks and to control what data is displayed.

<table>
<thead>
<tr>
<th>View menu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database View</td>
<td>Switches between Database view and Project view. When you start Rational DOORS, the top-level items that are displayed in the left pane of the Database Explorer depend on your view:</td>
</tr>
<tr>
<td>Project View</td>
<td>• In Database view, the root of the database tree is displayed. Below this, the parts of the database you are allowed to access are displayed.</td>
</tr>
<tr>
<td></td>
<td>• In Project view, a list of the projects you are allowed to access is displayed.</td>
</tr>
<tr>
<td>Show Projects</td>
<td>Controls whether projects are displayed. Projects have icons like this: ✅.</td>
</tr>
<tr>
<td>Show Folders</td>
<td>Controls whether folders are displayed. Folders have icons like this: 📘.</td>
</tr>
<tr>
<td>Show Formal Modules</td>
<td>Controls whether formal modules are displayed. Formal modules have icons like this: ✏️.</td>
</tr>
<tr>
<td>Show Link Modules</td>
<td>Controls whether link modules are displayed. Link modules have icons like this: ✏️.</td>
</tr>
<tr>
<td>Show Descriptive Modules</td>
<td>Controls whether descriptive modules are displayed. Descriptive modules have icons like this: ✏️.</td>
</tr>
<tr>
<td>Show Deleted Items</td>
<td>Controls whether deleted projects, folders and modules are displayed. A deleted item has a red cross in the corner of its icon. For example, the icon for a deleted formal module looks like this: ❌.</td>
</tr>
<tr>
<td>Sort by Name</td>
<td>Sorts the items in the right pane using the values in the <strong>Name</strong> column. It sorts folders and projects first, followed by a sorted list of modules.</td>
</tr>
</tbody>
</table>
Note  If an object is not displayed in the Database Explorer, it is either because the appropriate menu option is not selected, or you do not have the access rights to see the object.

### Making selections in the Database Explorer

The Database Explorer works like Windows Explorer:

- In the left pane, click an item to select and open it. Its contents are displayed in the right pane.

  In Project view, the left pane contains one or more top-level projects. In Database view, the left pane contains a single top-level item (Database).

- The menu options apply to whatever is currently selected.

  For example, if you select the folder Myfolder, and then you click **File > Properties**, the properties sheet for **Myfolder** is displayed.

- Some project and folder options, such as Delete and Purge, are available only if you select the project or folder in the right pane. This is because the options are not available when the project or folder is open.

  The project or folder you select in the left pane is open. It has an open project or open folder icon.

- Modules are shown only in the right pane.

  Double-click a module to select and open it. Each module you double-click is opened in a separate module window.
**Selecting multiple items**

To select multiple items in the right pane of the Database Explorer, use **CTRL+Click** (hold down the **CTRL** key, and then click each item you want to select).

To quickly select a group of items that are next to each other, use **SHIFT+Click**:

1. Click the first item in the group.
2. Press and hold down **SHIFT**, and then click the last item in the group.
3. Release **SHIFT**.

**Changing the appearance of the Database Explorer toolbar**

To allow you to customize the appearance of the Database Explorer toolbar, buttons are arranged in logical groups that you can choose to hide or display. For example, buttons that can control favorites are grouped together on a separate **Favorites** toolbar.

**To change the appearance of the toolbar:**

1. In the Database Explorer, click **View > Customize Toolbars**.
   
   The **Customize Toolbars** dialog box is displayed.
2. Select or clear the check box for each group.
3. If you want to display the default toolbars, select **Reset to Default**.
   
   The toolbars that are displayed by default are:
   - Favorites
   - Location
   - Project
4. Click **Close**.

**Changing the appearance of the module toolbar**

To allow you to customize the appearance of the module toolbar, buttons are arranged in logical groups that you can choose to hide or display. For example, buttons that can control the alignment of columns are grouped together on a separate **Column Alignment** toolbar, buttons for use when working with tables are on the **Table** toolbar, and so on.

**To change the appearance of the toolbar:**

1. In the module, click **View > Customize Toolbars**.
The **Customize Toolbars** dialog box is displayed.

2. Select or clear the check box for each group.

3. If you want to display the default toolbars, select **Reset to Default**.

   The toolbars that are displayed by default are:
   - Column
   - Display
   - Link
   - Module
   - Object
   - Object Edit
   - View

4. Click **Close**.

**The Location field**

The path to the project or folder that is currently open is displayed in the **Location** field of the Database Explorer.

**Note** The path is from the nearest parent project, not from the database root.

As you navigate around the database, the path to each project and folder that you open is stored in the **Location** field. If you want to return to a folder or project you have opened previously, you can select it from the **Location** drop-down list. The project or folder is opened in the left pane of the Explorer, and its contents are displayed in the right pane.

**Note** The **Location** field is cleared when you close your current Rational DOORS session. If you want to be able to easily access a project, folder or module across sessions, you should add it to your favorites list. For more information about favorites, see “Favorites,” on page 29.

If you know the path to the project, folder or module you want to open, type the path into the **Location** field and press **Enter**. Alternatively, you can paste the Rational DOORS URL of an item into the **Location** field and press **Enter**. Projects and folders are opened in the left pane of the Database Explorer, modules are opened in default edit mode.
Favorites

If you use certain projects, folders or modules regularly, you can add them to your Favorites list. Instead of navigating through the database hierarchy to access your data, you can select the project, folder or module from your favorites list in the Database Explorer.

- If you select a project or folder from your favorites list, it is opened in the left pane of the Database Explorer and its contents are displayed in the right pane.
- If you select a module from your favorites list, it is opened. The edit mode in which the module is opened depends on your access rights and your default edit mode.

Note  Your location in the database does not change when you open a module from your favorites list. This means you can open a module in a different project or folder without having to navigate back through the database hierarchy to your original location.

To add a project, folder or module to your favorites list:

1. In the Database Explorer, select the project, folder or module you want to add to Favorites.
2. Click Favorites > Add to Favorites.
   The item is added to your favorites list.

Organizing your favorites list

As your favorites list grows, you can maintain it using Organize Favorites.

Click Favorites > Organize Favorites to open the Organize Favorites dialog box.
The buttons on the **Organize Favorites** dialog box are described in the table below.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Edit</strong></td>
<td>Select an item and click <strong>Edit</strong> to change its label in your favorites list. For example, you might want to distinguish between two identically named modules, or between a folder and module of the same name. <strong>Note</strong> You are not changing the actual name of the project, folder or module, just the label that is displayed in your favorites list.</td>
</tr>
<tr>
<td><strong>Remove</strong></td>
<td>Select an item and click <strong>Remove</strong> to remove it from your favorites list.</td>
</tr>
<tr>
<td><strong>Refresh</strong></td>
<td>Click this button to redraw your favorites list.</td>
</tr>
<tr>
<td><strong>Arrow buttons</strong></td>
<td>Select an item and click the up or down arrow to move it. The order in which the items appear in the Organize Favorites dialog is the order in which they appear in the drop down list on the Database Explorer.</td>
</tr>
</tbody>
</table>

**How changes to the database affect Favorites**

The following table describes how changes to the database are reflected in your favorites list.

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>A project, folder or module is moved</td>
<td>Rational DOORS automatically updates the path in your favorites list.</td>
</tr>
<tr>
<td>A project, folder or module is renamed</td>
<td>The name of the item in your favorites list does not change. You can still access it by selecting its old name from your favorites list.</td>
</tr>
<tr>
<td>A project, folder or module is deleted</td>
<td>The item is not removed from the drop down list in the Explorer, but if you select it, a message informs you that the item has been deleted. The item is marked as deleted in the <strong>Organize Favorites</strong> dialog box.</td>
</tr>
</tbody>
</table>
Opening a module

To open a module, do one of the following:

- Double-click it in the Database Explorer.
  The module is opened in your default edit mode, which is normally exclusive edit mode. For more information, see “Edit modes,” on page 58.

- Single-click the module in the Database Explorer to select it. Click File > Open, and then either Read-only, Shareable Edit or Exclusive Edit depending on which edit mode you want.

- Single-click the module in the Database Explorer to select it. Right-click Open, and then either Read-only, Shareable Edit or Exclusive Edit depending on which edit mode you want.

- In the Database Explorer, click the File menu. If Rational DOORS has been configured to display recently opened modules, and you have opened modules previously, a list of those modules is displayed in the File menu. Click on a module to open it in your default edit mode. For information about configuring the recent module list display, see “Showing your user options,” on page 403.

The title bar of the module window shows the module name followed by either Current or Baseline, the module version and the path to the module from the nearest project above it in the database tree. The path starts with a slash (/) followed by the name of the project.

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Your access to a project, folder or module is removed</td>
<td>The project, folder or module is removed from your favorites list.</td>
</tr>
</tbody>
</table>
Requesting a module lock

If you try to open a module that another user already has open, the Request Lock dialog box is displayed. The options on the dialog box are described in the following table. Select the options you want, and then click OK.

<table>
<thead>
<tr>
<th>Select...</th>
<th>To...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open module</td>
<td>Enable the edit mode drop down list. If another user has an exclusive edit lock on the module, the only option available is read-only. If one or more users have shareable edit locks on the module, you can select whether to open in shareable edit mode or read-only mode. When you click OK, the module is opened in the edit mode.</td>
</tr>
<tr>
<td>Send a message</td>
<td>Open a Lock Request Message dialog box when you click OK. You can type a message into the Lock Request Message dialog box, which will be displayed to the user or users who currently hold a lock. Those users can optionally reply to your message.</td>
</tr>
<tr>
<td>Alert me when lock is available</td>
<td>Receive a message alert when the lock on the module is released. You can open the module directly from the message alert.</td>
</tr>
</tbody>
</table>

Rational DOORS URLs

The Rational DOORS database, and each project, folder, module, module baseline and object in the database has a unique identifier, which is expressed as a URL, beginning doors: The URL of each item is stored in its properties sheet, and can be copied from there. You can also right-click on any item and select Copy URL.

For formal module objects only, you can use drag-and-drop to create external links to objects in other Rational DOORS modules, or to copy the object URL to Microsoft Word. The object URL might also be copied to other applications using drag-and-drop, but the behavior is governed by the application to which you drag-and-drop, not by Rational DOORS.

For example, you can use drag-and-drop to insert a hyperlink to a Rational DOORS object into a Microsoft Word document, or any application that
supports HTML, and the hyperlink would display the module name and the object number. Selecting the hyperlink displays the full URL.

If you use drag-and-drop to copy a hyperlink into an application that does not support HTML, for example Notepad or WordPad, the full URL is displayed.

When you copy the URL of a module, baseline or object and the current view is not the Standard view, view information is copied with the URL. When the URL is followed, the module, baseline or object is displayed with the view that was selected when the URL was copied.

**Note** View information is not copied with the module URL if the URL is copied from the Database Explorer.

Rational DOORS URLs can be inserted into a web page, stored as favorites or bookmarks in your browser, or simply pasted into other applications. You can also use Rational DOORS URLs for linking objects in different Rational DOORS databases, by inserting the Rational DOORS URL as an external link.

When Rational DOORS is installed, the Rational DOORS protocol scheme is registered with the operating system. This means that any URLs beginning doors: are recognized by the operating system and opened by the default browser. The browser looks for the Rational DOORS database that is referenced by the URL, and either starts a new client session for that database, or if a suitable session is already running, it will use that.

### Following a Rational DOORS URL

When you follow a Rational DOORS URL, the URL handler identifies which Rational DOORS database is referenced by the URL, and checks if a suitable session is running on the computer. A session running as one of the following is not a suitable session, and will not be used:

- Rational DOORS running in batch mode.
- A pre-8.1 version of Rational DOORS.
- A session that has not been authenticated. If a Rational DOORS session has been initiated, but you have not logged on, the browser ignores that session and starts a new one.
- A session that is running against a database other than the one referenced by the URL.

If the URL handler finds a suitable session, the item referenced by the URL is opened and displayed. If you do not have access to the item that is referenced, an error message is displayed.
**Note** When you try to follow an external link from an object in a Rational DOORS 9.x database to an object in a Rational DOORS 8.3 database, you need to make sure that a Rational DOORS 8.3 client is already running. Otherwise, an error will be displayed.

If the URL handler does not find a suitable session, it starts a Rational DOORS client. The Rational DOORS splash screen is displayed, followed by the Rational DOORS Login dialog box. Once you have entered your Rational DOORS user name and password, the item referenced by the URL is opened. The following table describes what happens for the different types of items.

<table>
<thead>
<tr>
<th>Item referenced by URL</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database</td>
<td>The database is opened and the database icon is selected</td>
</tr>
<tr>
<td>Project</td>
<td>The project is selected in the left pane of the <strong>Database Explorer</strong> window, and its contents are displayed in the right pane.</td>
</tr>
<tr>
<td>Folder</td>
<td>The folder is selected in the left pane of the <strong>Database Explorer</strong> window, and its contents are displayed in the right pane.</td>
</tr>
<tr>
<td>Module</td>
<td>The module is opened in the default edit mode. If view information has been copied with the module URL, and the user has read access to the view, that view is displayed. If view information has not been copied with the module URL, or the user does not have read access to the view specified by the URL, or the view specified by the URL has been deleted, the default view is displayed. If the module is already open and the URL specifies a view other than the current view, the behavior is dictated by the options that are set for the current user. For more information, see “Showing your user options,” on page 403.</td>
</tr>
</tbody>
</table>
### Rational DOORS URLs

<table>
<thead>
<tr>
<th>Item referenced by URL</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Baseline</td>
<td>The module baseline is opened. If view information has been copied with the baseline URL, and the user has read access to the view, that view is displayed. If view information has not been copied with the baseline URL, or the user does not have read access to the view specified by the URL, or the view specified by the URL has been deleted, the default view is displayed. If the baseline is already open and the URL specifies a view other than the current view, the behavior is dictated by the options that are set for the current user. For more information, see “Showing your user options,” on page 403.</td>
</tr>
<tr>
<td>Object</td>
<td>The module containing the object is opened in the default edit mode with the object selected. If view information has been copied with the object URL, and the user has read access to the view, that view is displayed. If view information has not been copied with the object URL, or the user does not have read access to the view specified by the URL, or the view specified by the URL has been deleted, the default view is displayed. If the module is already open and the URL specifies a view other than the current view, the behavior is dictated by the options that are set for the current user. For more information, see “Showing your user options,” on page 403. If the object is not visible in either the default view or the view specified by the URL, a message is displayed prompting the user to change to the Standard view.</td>
</tr>
</tbody>
</table>

**Note** When you open Rational DOORS using a URL, command line switches are not implemented. If you want command line switches to be used when you open Rational DOORS using a URL, you need to put the switches into the registry. For information about command line switches and the registry, see “Settings in the registry,” on page 426.
The Rational DOORS splash screen, **Login** dialog box, Database Explorer and module windows display in the normal way. They are not displayed in the browser window.

By default, you have 60 seconds from the time the Rational DOORS **Login** dialog box is displayed to enter your user name and password. If you do not log in within this time limit, the URL expires. You can still log in after the time limit expires, but an error is displayed and the item referenced by the URL is not displayed.

**Making selections in a module window**

In a module window, you click an object to make it the **current object**. The way in which the current object is differentiated from other objects depends on which display scheme you are using:

- In the modern display scheme, the current object has a line above and below it.
- In the classic display scheme, it is highlighted with a dark blue background.

To select an object, use **SHIFT+Click**. The text turns a maroon color.

**Selecting multiple objects**

**CTRL+Click** does not work in module windows. You cannot select objects that are not next to each other.

To select a group of objects that are next to each other, use **SHIFT+Click**:

1. Click the first object in the group.
2. Press and hold down **SHIFT**, and then click the last object in the group.
3. Release **SHIFT**.

   The objects that have been selected are displayed in a different color.

The object trees below the first and last objects that you select are automatically selected too. And if the first and last objects are at different levels in the database tree, additional objects are selected so that all selected objects have a common ancestor. This ensures that subsequent operations on the objects preserve the integrity of your data.

If you have a filter applied to the module, and you select multiple objects, the selection also includes objects that are hidden by the filter, but that exist between the first and last object in your selection.
Selecting everything

To select all the objects in a module:

1. Press HOME to go to the start of the module.
2. Press and hold down SHIFT while using the scroll bar to go to the end of the module.
3. Click the last object in the module.

The text in all the objects is displayed in a different color.

Using drag-and-drop

You can use drag-and-drop in the Database Explorer and in formal module windows.

For information about what happens to links when you use drag-and-drop, see “How copy and move affect links,” on page 242.

In the Database Explorer

Use drag-and-drop to move or copy projects, folders and modules:

- To move an item, click it and then drag it to the target location.

  You cannot move a module if it is open. You cannot move a folder or project if the folder or project, or anything in it, is open. For example, you cannot move a folder if it contains a module that is open.

- To copy an item, hold down CTRL while you drag-and-drop the item.

  You cannot copy a module if it is open in exclusive edit mode. You cannot copy a folder or project if the folder or project contains a module that is open in exclusive edit mode.

In a module window

Use drag-and-drop to either:

- Move objects within a module.
- Copy objects within a module or between modules.
- Copy then link objects within a module or between modules.

You cannot use drag and drop to copy or move objects within a module if a sort is applied. If you are using drag and drop to copy objects between modules, the source module can have a sort applied but the target module must have sorting turned off.
You can copy or move tables within a module or between modules using drag-and-drop. The **Below** and **Below with hierarchy** options are unavailable for all operations. To copy or move a table using drag-and-drop, click on any cell in the table, and follow the instructions below.

Click the object you want to move or copy, and then drag it to the target location. If you want to copy the current object after or below itself, drag it over the current object. When you release the mouse button, a pop-up menu is displayed that includes the following options:

<table>
<thead>
<tr>
<th>Pop-up menu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move &gt; After</td>
<td>Moves the object and all the objects in the tree below it to the same level as, and immediately after, the target object.</td>
</tr>
<tr>
<td>Move &gt; Below</td>
<td>Moves the object and all the objects in the tree below it to one level below the target object. If the target object already has children, the copied object becomes its first child.</td>
</tr>
<tr>
<td>Copy &gt; After (with hierarchy)</td>
<td>Copies the object and all the objects in the tree below it to the same level as, and immediately after, the target object.</td>
</tr>
<tr>
<td>Copy &gt; Below (with hierarchy)</td>
<td>Copies the object and all the objects in the tree below it to one level below the target object. If the target object already has children, the copied object becomes its first child.</td>
</tr>
<tr>
<td>Copy &gt; After</td>
<td>Copies the object to the same level as, and immediately after, the target object.</td>
</tr>
<tr>
<td>Copy &gt; Below</td>
<td>Copies the object to one level below the target object. If the target object already has children, the copied object becomes its first child.</td>
</tr>
<tr>
<td>Copy then link from Start &gt; After (with hierarchy)</td>
<td>Same as the <strong>Copy after (with hierarchy)</strong> option, except it also creates a link from each source object to its copy.</td>
</tr>
<tr>
<td>Copy then link from Start &gt; Below (with hierarchy)</td>
<td>Same as the <strong>Copy below (with hierarchy)</strong> option, except it also creates a link from each source object to its copy.</td>
</tr>
</tbody>
</table>
Cutting, copying and pasting

<table>
<thead>
<tr>
<th>Pop-up menu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy then link from Start &gt; After</td>
<td>Same as the <strong>Copy after</strong> option, except it also creates a link from the source object to its copy.</td>
</tr>
<tr>
<td>Copy then link from Start &gt; Below</td>
<td>Same as the <strong>Copy below</strong> option, except it also creates a link from the source object to its copy.</td>
</tr>
<tr>
<td>Copy then link to Start &gt; After (with hierarchy)</td>
<td>Same as the <strong>Copy after (with hierarchy)</strong> option, except it also creates a link to each source object from its copy.</td>
</tr>
<tr>
<td>Copy then link to Start &gt; Below (with hierarchy)</td>
<td>Same as the <strong>Copy below (with hierarchy)</strong> option, except it also creates a link to each source object from its copy.</td>
</tr>
<tr>
<td>Copy then link to Start &gt; After</td>
<td>Same as the <strong>Copy after</strong> option, except it also creates a link to the source object from its copy.</td>
</tr>
<tr>
<td>Copy then link to Start &gt; Below</td>
<td>Same as the <strong>Copy below</strong> option, except it also creates a link to the source object from its copy.</td>
</tr>
</tbody>
</table>

To drag multiple objects, do not release the mouse button after making the multiple object selection. You lose your selection if you release the mouse button between selecting the objects and dragging them.

When you use drag-and-drop to copy objects between modules, only the **Object Heading**, **Object Text** and **Object Short Text** attributes are copied. If you want to copy other attributes between modules, use the object copier (see “Copying objects,” on page 88).

When you use the **Copy then link to Start** and the **Copy then link from Start** options, the usual rules that control linking apply. You need to have the necessary access rights to make the links.

**Cutting, copying and pasting**

You can cut, copy and paste in the Database Explorer and in formal module windows.

For information about what happens to links when you cut, copy and paste, see “How copy and move affect links,” on page 242.
**In the Database Explorer**

Use the **Edit** menu or keyboard shortcuts to cut, copy and paste projects, folders and modules.

<table>
<thead>
<tr>
<th>Edit menu</th>
<th>Keyboard</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>CTRL+X</td>
<td>Cuts the currently selected items, and places them on the Database Explorer clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>CTRL+C</td>
<td>Copies the currently selected items to the Database Explorer clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td>CTRL+V</td>
<td>Pastes the contents of the Database Explorer clipboard.</td>
</tr>
<tr>
<td>Paste Special</td>
<td></td>
<td>Provides advanced options for pasting a module. This option is not available when a project or folder has been copied. For more information, see “Creating a new module using paste special,” on page 49.</td>
</tr>
<tr>
<td>Undo Cut</td>
<td>CTRL+Z</td>
<td>Undoes the last cut or copy operation.</td>
</tr>
<tr>
<td>Undo Copy</td>
<td>CTRL+Z</td>
<td>Un-does the last cut or copy operation.</td>
</tr>
<tr>
<td>Clear</td>
<td></td>
<td>Clears the Database Explorer clipboard. You should clear the clipboard after you finish pasting to avoid leaving share locks on modules. Share locks are not normally problematic, but can prevent users from changing edit modes within the module.</td>
</tr>
</tbody>
</table>

You cannot cut a module if it is open. You cannot cut a folder or project if the folder or project, or anything in it, is open. For example, you cannot cut a folder if it contains a module that is open.

You cannot copy a module if it is open in exclusive edit mode. You cannot copy a folder or project if the folder or project contains a module that is open in exclusive edit mode.

When you cut data to the Database Explorer clipboard, if you have not yet pasted it back and then do anything that could overwrite the data on the clipboard, such as copying other data to the clipboard, your original cut operation is automatically undone.
Note  Copying a module does not copy the baselines associated with the module. Copying a project containing modules that have baselines does not retain those baselines.

In a module window

In a module window, use the Edit menu or keyboard shortcuts to cut, copy and paste objects within a module.

Note  If you want to copy objects between modules, use the object copier (see “Copying objects,” on page 88).

<table>
<thead>
<tr>
<th>Edit menu</th>
<th>Keyboard</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>CTRL+X</td>
<td>Cuts the current object and all the objects in the tree below it. The objects are removed from the module and placed on the object clipboard for that module.</td>
</tr>
</tbody>
</table>
| Copy      | CTRL+C  | Copies objects to the object clipboard:  
• To copy the current object only, either press CTRL+C or click Copy > Copy.  
• To copy the current object and all the objects in the tree below it, click Copy > Copy with Hierarchy. |
| Paste     | CTRL+V  | Pastes the contents of the object clipboard:  
• To paste to the same level as, and immediately after, the current object, either press CTRL+V or click Paste, and then Paste.  
• To paste to one level below the current object, click Paste > Paste Below. |
| Clear     |          | Clears the contents of the object clipboard. |

Each module has its own object clipboard.

Note  When you are editing the attributes of an object, you can also use the keyboard shortcuts to cut, copy and paste selected text in the object. This uses your computer’s system clipboard. You can paste the contents of the system clipboard to other applications, such as Microsoft Word.
When you cut data to the object clipboard, if you have not yet pasted it back to the module and then do anything that could overwrite it, such as copying another object to the clipboard, a message is displayed warning that you have not pasted the data currently on the clipboard. You are offered three choices:

- **Delete**
  This overwrites the data currently on the clipboard with the new data.

- **Restore**
  This pastes the data currently on the clipboard back to where it was cut from, and then writes the new data to the clipboard.

- **Cancel**
  This cancels the operation, leaving the data currently on the clipboard unchanged.

**Closing a module**

To close a module:

1. In the module window, click **File > Close**.
2. If you have made any changes that you have not saved yet, a message is displayed asking if you want to save your changes.
   
   Click **Yes** to save your changes, or **No** to discard them.

**Note** Whenever you make any changes to a module, your changes are stored temporarily in your local computer’s memory. They are not saved in the database until you explicitly ask to save them. They are marked with a red change bar or , to show that they have not yet been saved in the database.

**Stopping Rational DOORS**

To stop Rational DOORS:

1. In the Database Explorer, click **File > Exit**.
   
   All the modules you opened are automatically closed.

2. If you edited a module and have not saved your changes, a dialog box is displayed asking if you want to save your changes before the module is closed.
   
   Click **Yes** to save your changes, or **No** to discard them.
Managing formal modules

This chapter contains the following topics:
- Creating a formal module
- Controlling access to a formal module
- Creating a new module using paste special
- Showing module properties
- Showing module statistics
- Deleting, undeleting and purging a module
- Managing open modules

Creating a formal module

This topic describes how to create an empty new module. You can also create a module by either:
- Copying an existing module in the Database Explorer, for example, using copy and paste.
- Cloning an existing module. This lets you select which bits of the module you want to copy. For example, you can select which attributes you want to copy. See “Creating a new module using paste special,” on page 49.
- Copying a baseline (see “Copying a baseline,” on page 302).

To create an empty formal module:
1. In the Database Explorer, select the folder or project in which you want to create the module. This is the module’s parent.
   You must have create access to the parent.
2. Click File > New > Formal Module.
3. Type the name of the new module in the Name box.
   The name is case sensitive. For example, the names Mymodule and MyMODULE are different.
   The name must be unique within the parent project or folder. All the projects, folders, and modules in the parent must have different names.
   The name can contain the following characters:
Managing formal modules

- Alphanumeric characters (letters of the alphabet and numbers)
- Space characters
- Periods (.)
- Underscores (_)
- Hyphens (-)

4. If you want to give the module a description, type it in the Description box. The description is used as the heading of the main column.

5. By default, the object identifiers start at 1 and have no prefix. If you want to override the default, use the Start at and Prefix boxes.

6. If you want to use a template to populate the new module, select the Use a template check box, and then use Browse to locate it.

Rational DOORS provides a library of templates to help get you up and running quickly. For example, there are DoD-STD and MIL-STD templates. Templates help you keep your modules consistent by encouraging people to use a standard structure and headings.

You can create your own templates and add them to the library, which is in the Rational DOORS home directory, in \doors_9.2\lib\dxl\standard. For more information, see the DXL Reference Manual, which can be accessed from Rational DOORS by clicking Help > DXL Reference Manual.

Note You can also insert a template into an existing module. For more information, see “Inserting templates,” on page 86.

7. Click OK.

The module is created. It inherits its access rights from its parent.

Note If you receive the error Cannot create this Module: Lock request timed out when you try to create the module, wait a moment, and then try again. This error is generated if another Rational DOORS user is performing a paste operation when you click OK to create the module.

Controlling access to a formal module

To change the access rights for a formal module, you must have admin access to the module.

To change the access rights for a formal module:

1. In the module window, click File > Module Properties.
Controlling access to a formal module

2. Click the **Access** tab.

The current access rights for the module are displayed.

**Note** You cannot open a module unless you have read access to the parent project or folder.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>See the module. If you do not have read access, the module is not displayed in your Database Explorer. Set your own default view for the module (see “Setting default views,” on page 99).</td>
</tr>
<tr>
<td>Create (C)</td>
<td>Create top-level objects in the module. Create attribute types and attribute definitions for the module.</td>
</tr>
<tr>
<td>Modify (M)</td>
<td>Change the name, description, attribute values, default view. Create baselines of the module.</td>
</tr>
<tr>
<td>Delete (D)</td>
<td>Delete, undelete, and purge the module. Cut the module to the Database Explorer clipboard.</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Partition the module out. Change the access rights for the module.</td>
</tr>
</tbody>
</table>

If the module is partitioned in, the access rights associated with the partition are displayed. These describe the maximum access that any user has. They override the RCMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RCMDA), but the module is partitioned in read-only, in practice the user has only read (R) access.
3. Make the changes you want.

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit from parent</td>
<td>Select this check box if you want the module to inherit its access rights from the project or folder that it is in. When this check box is selected, the list of access rights is unavailable, and shows what access rights the module is inheriting.</td>
</tr>
</tbody>
</table>
| Add             | To add a new entry to the list of access rights:  
  a. Click Add.  
    The Add Access window is displayed.  
  b. In the Name box, select the name of the user or group that you want to add an entry for.  
  c. Select the access rights you want to give them, and then click OK. |
| Remove          | To remove an entry from the list of access rights, select the entry, and then click Remove.                                             |
| Edit            | To edit an entry in the list of access rights:  
  a. Select the entry then click Edit.  
    The Edit Access window is displayed.  
  b. Select the access rights you want to give them, and then click OK. |
| Additional access | Select the additional access rights that you want to propagate with create access.  
  The additional rights are propagated to the objects in the module that inherit their access rights from the module.  
  **Note** Module attributes cannot inherit access rights, so additional access rights do not apply to module attributes and their values.  
  For more information, see “Propagating extra access rights with create,” on page 218 |

4. Click OK.
Creating a new module using paste special

When you select **Paste Special**, you create a module by copying the structure of an existing module. You can copy:

- Object Heading and Object Text
- The heading structure only, including the heading text
- The columns in a particular view
- Attribute types and definitions

Baselines are not copied.

**Note**  Using paste special to create a module copies only the structure of an existing module. Soft deleted objects and tables are not copied.

**To use Paste Special:**

1. In the Database Explorer, select the module you want to copy.
2. Click **Edit > Copy**.
3. Select the folder or project to which you want to copy the module and click **Edit > Paste Special**.

You must have create access to the folder or project.

4. In the **New module name** box, type the name you want to give the new module.

The name is case-sensitive. For example, the names **Mymodule** and **MyMODULE** are different.

The name must be unique within the parent project or folder. All the projects, folders and modules in the parent must have different names.

The name can contain the following characters:

- Alphanumeric characters (letters of the alphabet and numbers)
- Space characters
- Periods (.)
- Underscores (_)
- Hyphens (-)

The name cannot be more than 460 characters in length.

5. If you want to give the new module a description, type it in the **Description** box. The description is used as the heading of the main column.
6. By default, the object identifiers start at 1 and have no prefix. If you want to override the default, use the Start at and Prefix boxes.

7. In the list of views, select the view you want to copy.
   Note The standard view is always copied. If you select another view, you get the standard view as well as the view you select.

8. You can choose whether to copy Object Heading and Object Text, or just the Object Heading.
   - If you want to copy both Object Heading and Object Text select All objects.
     Note Soft deleted objects and tables are not copied.
   - If you want to copy only the Object Heading structure and text select Objects with object heading.
   - If you do not want to copy any objects, clear the Objects with object heading and All objects boxes.

9. By default, the main column is copied.
   Select the Columns check box if you want to copy all the columns in the view.

10. By default, no attribute types or definitions are copied.
    If you want to copy attribute types and definitions:
    a. Select the appropriate Copy check box.
    b. Click Select.
       A list of all the non-system attribute definitions or types is displayed.
    c. Select the ones you want to copy, and then click Close.

11. By default, the copied links in the new module use the same link modules as the links in the original module.
    If you want to use a different link module:
    a. Select the Links Copy check box.
    b. Click Select.
    c. Clear the Through same link module check box.
    d. Select the link module you want to use, and then click Close.
12. By default, external links are not copied. If you want to copy external links select the **External Links Copy** check box. If the module does not contain any external links, the check box is disabled.

13. Click **OK**.

**Showing module properties**

To show the properties of a formal module:

- In the module window, click **File > Module Properties**.

The properties sheet for the module is displayed.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the module.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the module.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of item whose properties are being displayed. This is <strong>Formal</strong> and cannot be edited.</td>
</tr>
<tr>
<td>URL</td>
<td>The URL of the module.</td>
</tr>
<tr>
<td>Copy URL</td>
<td>Copies the URL to the system clipboard. For more information about Rational DOORS URLs see “Rational DOORS URLs,” on page 32.</td>
</tr>
<tr>
<td>List of attributes</td>
<td>This is a list of all the attributes user in the module. For each attribute, it shows the name of the attribute, the description and its value. If you want to edit module attributes from the <strong>Properties</strong> window, open the module before you open the <strong>Module Properties</strong> dialog box.</td>
</tr>
<tr>
<td>View/Edit</td>
<td>To change the value of an attribute:</td>
</tr>
<tr>
<td></td>
<td>a. Select the attribute in the list of attributes, and then click <strong>View/Edit</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. Enter the new attribute value.</td>
</tr>
<tr>
<td></td>
<td>c. Click <strong>OK</strong>.</td>
</tr>
<tr>
<td>List of Baseline Set Definitions</td>
<td>The baseline set definitions that include the module</td>
</tr>
</tbody>
</table>
### Managing formal modules

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View</td>
<td>Select a baseline set definition and click <strong>View</strong> to view the definition.</td>
</tr>
<tr>
<td>Generate history for the creation and deletion of links</td>
<td>Select this option if you want to record the creation and deletion of links in the module history.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>For information on this tab</th>
<th>See</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• The help for the Access tab (click the <strong>Access</strong> tab, then click <strong>Help</strong>).</td>
</tr>
<tr>
<td></td>
<td>• “Controlling access to a formal module,” on page 24.</td>
</tr>
<tr>
<td>History</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• The help for the History tab (click the <strong>History</strong> tab, then click <strong>Help</strong>).</td>
</tr>
<tr>
<td></td>
<td>• “Showing module history,” on page 240.</td>
</tr>
<tr>
<td>Linksets</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• The help for the Linksets tab (click the <strong>Linkset</strong> tab, then click <strong>Help</strong>).</td>
</tr>
<tr>
<td></td>
<td>• “Links,” on page 199.</td>
</tr>
<tr>
<td>Statistics</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• The help for the Statistics tab (click the <strong>Statistics</strong> tab, then click <strong>Help</strong>).</td>
</tr>
<tr>
<td></td>
<td>• “Showing module statistics,” on page 31.</td>
</tr>
<tr>
<td>Discussions</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• The help for the Discussions tab (click the <strong>Discussions</strong> tab, then click <strong>Help</strong>).</td>
</tr>
<tr>
<td></td>
<td>• “Viewing a module discussion,” on page 233.</td>
</tr>
</tbody>
</table>
Showing module statistics

The statistics for a formal module record the number of words and characters in the module. If you have a filter applied to the module, the statistics function calculates only results for the displayed objects.

To show the statistics for a module:

1. In the module window, click File > Module Properties.
2. Click the Statistics tab.
3. Click Refresh. Rational DOORS fills in the values on the tab. For large modules, this can take some time.

<table>
<thead>
<tr>
<th>Statistics tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Total objects</td>
<td>Number of objects in the module.</td>
</tr>
<tr>
<td>Words in heading and text</td>
<td>Number of words in the Object Heading, Object Text and Object Short Text attributes.</td>
</tr>
<tr>
<td>Characters in heading and text</td>
<td>Number of characters in the Object Heading, Object Text and Object Short Text attributes.</td>
</tr>
<tr>
<td>Words in other attributes</td>
<td>Number of words in other attributes of type Text or String.</td>
</tr>
<tr>
<td>Characters in other attributes</td>
<td>Number of characters in other attributes of type Text and String.</td>
</tr>
<tr>
<td>Total words</td>
<td>Total number of words in attributes of type Text and String, including the Object Heading, Object Text and Object Short Text.</td>
</tr>
</tbody>
</table>
Deleting, undeleting and purging a module

Deleting a module does not destroy any of the module data. It simply marks the module as deleted, and stops users from being able to access it. To destroy the module, you must purge it once you have deleted it.

Purging deleted modules removes them permanently from the database.

You cannot delete a module if any user is accessing the module.

To delete, undelete or purge a module, you must have delete access to the module.

**To delete a module:**
1. If you currently have the module open, close it (click **File > Close**).
2. In the Database Explorer, select the module you want to delete, and then click **File > Delete**.

**To undelete a module:**
1. In the Database Explorer, make sure that deleted items are being displayed.
   - If necessary, click **View > Show Deleted**.
2. Select the module you want to undelete, and click **File > Undelete**.

**To purge a module:**
1. In the Database Explorer, make sure that deleted items are being displayed.
   - If necessary, click **View > Show Deleted**.
2. Select the module you want to purge then click **File > Purge**.
   - A message is displayed asking if you really want to purge the module.
3. Click **Yes**.
   - The module is permanently removed from the database.
Managing open modules

Sometimes Rational DOORS or DXL programs open modules in the background without displaying them on your screen. This topic describes how to close these modules or change their edit mode to read-only.

To close a module you cannot see or set its edit mode to read-only:

1. In the Database Explorer, click Tools > Manage Open Modules.
   A list of all the modules that you currently have open is displayed.
   The modules that were opened but not displayed on your screen have No in the Displayed column.

2. To close a module, select the module, and then click Close Modules.
   If you have made changes that have not yet been saved, a message is displayed asking if you want to save the changes.

3. Click Yes to save your changes, or No to discard them.

4. To change the edit mode of a module to read-only, select the module, and then click Set Modules Read-Only.
   If you have made changes that have not yet been saved, a message is displayed asking if you want to save the changes.

5. Click Yes to save your changes, or No to discard them.

6. To refresh the display, click Refresh.

7. When you have finished, click Close.
Managing formal modules
This chapter contains the following topics:

- Edit modes
- Changing the edit mode
- Editable sections
- Setting up a module for sharing
- Working in shareable edit mode
- Requesting a section lock
- In-place editing
- Editing using the object properties sheet
- Undoing edits
- Extended undo
- Saving your changes
- Creating objects
- Controlling access to an object
- Promoting and demoting objects
- Swapping Object Heading and Object Text attributes
- Splitting Object Heading from Object Text
- Deleting, undeleting, and purging objects
- The spelling checker
- Checking spelling
- Inserting symbols
- Inserting URLs
- Inserting templates
- Splitting objects
- Copying objects
- Merging object text
Editing

Edit modes

When you work with formal modules, you can use one of three edit modes.

<table>
<thead>
<tr>
<th>Edit mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read-only</td>
<td>You can read (look at) the module, but you cannot edit it.</td>
</tr>
<tr>
<td>Exclusive</td>
<td>You can edit the module, but other users can only read it.</td>
</tr>
<tr>
<td>Shareable</td>
<td>While you are editing one section of the module, another user can edit another section. You have to lock the section of the module that you want to edit, to stop other users from editing it. While you have the section locked, other users can only read the data in it. When you have finished, you unlock the section to allow another user to edit it. For more information, see “Setting up a module for sharing,” on page 61 and “Working in shareable edit mode,” on page 62. <strong>Note</strong> In shareable edit mode, you cannot create top-level objects in the module. And you cannot create, delete or edit attribute definitions or attribute types. You can only do these tasks in exclusive edit mode.</td>
</tr>
</tbody>
</table>

You must have modify access to a module to open it in either shareable or exclusive edit mode.

If you open a module by double-clicking it in the Database Explorer, it is opened in the default edit mode, exclusive edit mode. You can change the default edit mode. For information, see “Using the command line,” on page 420.

When you open a module using the **File** menu in the Database Explorer, you can select the mode in which you want to open the module. For example, if you want to open it in exclusive edit mode, click **File > Open > Exclusive Edit**.

You can change the edit mode of a module once it is open.

Changing the edit mode

The edit mode you are currently using is shown on the status bar at the bottom of the module window.

You must have modify access to a module to open it in either shareable or exclusive edit mode.

To change the edit mode of an open module:
1. In the module window, click **Edit > Edit Mode**, and then whichever edit mode you want (**Read-only**, **Shareable Edit** or **Exclusive Edit**).

   If you are changing the edit mode to read-only and you have made changes that you have not saved, a message is displayed asking if you want to save your changes.

2. Click **Yes** to save your changes, or **No** to discard them.

3. If you have copied an object, and you change edit modes, a message is displayed stating that the clipboard will be cleared when the edit mode is changed. Click **Confirm** to change edit mode and clear the clipboard, or **Cancel** to stay in the same edit mode and keep the contents of the clipboard.

   **Note** If you have opened a link module in read-only mode, you cannot change the edit mode from within the module. To change from read-only mode, you have to close the link module and reopen it in your chosen edit mode. This rule applies only to link modules.

### Editable sections

If you want to work in shareable edit mode, you first need to set up the module for sharing by dividing the module into **editable sections**. While one user is editing one section, another user can edit another section.

For example, you might want different users to be able to edit different top-level sections within a module.

**Note** Try not to set up editable sections unless you need them.

   Performance gets poorer as the number of editable sections increases, because each editable section is stored in a separate file in the database.

   To set up an editable section, you have to set up specific access rights for the object at the top of the section, and stop the object inheriting access rights from
its parent. On the **Access** tab of the object properties sheet, you clear the **Inherit from parent** check box.

In this picture two objects, A and D, are not inheriting access rights from their parents, so there are two editable sections:

- A’s section consists of A plus all the objects that inherit their access rights from A. These objects are illustrated in red.
- D’s section consists of D plus all the objects that inherit their access rights from D. These objects are illustrated in green.

If you select A and D at a later date to inherit their access rights, editable sections are switched off and performance is improved.

**Setting up a module for sharing**

To set up a module for sharing, you create editable sections in the module (see “Editable sections,” on page 59).

You can either:

- Divide a module into editable sections based on its current object section levels. For example, you can make an editable section for each level 1 section. Or you can make an editable section for each level 2 section.
- Create custom editable sections.
You must have modify access to the module, and admin access to the objects at the start of each new section.

**To divide a module into editable sections based on current section levels:**
1. Open the module in exclusive edit mode.
   For example, select the module in the Database Explorer, and then click **File > Open > Exclusive Edit**.
2. Click **Tools > Setup for Sharing**.
3. Select the section level that you want to make editable sections for, and then click **OK**.
**Note** If you then add a new section at the specified level, you must manually create an editable section for it. Follow the steps to create a custom editable section. For example, if you made editable sections at level 1 and you add a new level 1 section, you need to make a custom editable section for the new level 1 section.

**To create custom editable sections for a module:**
1. Open the module in exclusive edit mode.
   For example, select the module in the Database Explorer, and then click **File > Open > Exclusive Edit**.
2. Select the object where you want a new editable section to start, and click **Edit > Object > Properties**.
   The new editable section consists of this object and all objects in the tree below it that inherit their access rights from it.
3. Click the **Access** tab.
4. Clear the **Inherit from parent** check box.
5. Click **OK**.
6. Repeat Step 2 to Step 5 for each editable section.
7. Save the module (click **File > Save**).

**Working in shareable edit mode**

Once you have set up a module for sharing, you can work in shareable edit mode (see “Setting up a module for sharing,” on page 61).

You need to lock a section before you can edit the objects in it, create objects in it, or delete objects from it.
To lock a section:
1. In the module window, select any object in the section you want to lock.
2. Click **Edit > Section > Lock**.
   
The section containing the current object is locked. If someone else has edited the data in the section since you opened the module, Rational DOORS refreshes your screen to display the latest data before it locks the section.

   If another user already has the section locked, a **Request Lock** dialog box is displayed. For more information, see “Requesting a section lock,” on page 64.

   No other users can edit the section until you unlock it.

To unlock a section:
1. Select any object in the section you want to unlock, and then click **Edit > Section > Unlock**.
   
   If you have made any changes that you have not saved, a message is displayed asking if you want to save your changes.

2. Click **Yes** to save your changes, or **No** to discard them.

   All sections are automatically unlocked when you close the module.

Saving changes when editing in shareable mode

When you are editing in shareable edit mode:

<table>
<thead>
<tr>
<th>To...</th>
<th>Click...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save sections without unlocking.</td>
<td><strong>File &gt; Save</strong>, click <strong>Save</strong> ![save] or press <strong>CTRL+S</strong>.</td>
</tr>
<tr>
<td>Save changes and unlock all the sections you currently have locked.</td>
<td><strong>File &gt; Save and Unlock All Sections</strong>.</td>
</tr>
</tbody>
</table>

Colors of locked and unlocked sections

The colors used for locked and unlocked sections depend on which display scheme you are using. For example:

- In the modern scheme, the background color is pale gray for objects that are read-only, dark gray for objects in sections you have not locked, and white for objects in sections you have locked.
In the classic scheme, the text is black for objects that are read-only and blue for objects in sections you have locked. The background color is a pale blue for objects in sections, and does not change when you lock the sections.

**Requesting a section lock**

If you try to lock a section that another user already has locked, the Request Lock dialog box is displayed. The options on the dialog box are described in the following table. Select the options you want, and then click **OK**.

<table>
<thead>
<tr>
<th>Select...</th>
<th>To...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Send a message</td>
<td>Open a Lock Request Message dialog box when you click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>You can type a message into the Lock Request Message dialog box, which is displayed to the user who currently holds the lock. The user can optionally reply to your message.</td>
</tr>
<tr>
<td>Alert me when lock is available</td>
<td>Receive a message alert when the lock is released. You can lock the section directly from the message alert.</td>
</tr>
</tbody>
</table>

**In-place editing**

There are two ways to edit the values of object attributes:

- Editing objects in-place (described in this topic)
- Using the object properties sheet (see “Editing using the object properties sheet,” on page 69)

If you want to change the values of an attribute for lots of objects or for all the objects in a module, it is quicker to use the object properties sheet.

To edit in-place, double-click the attribute you want to edit, and then change its value.

Alternatively, start typing and Rational DOORS appends your text to the end of the text in the main column of the current object.

To edit the value of an attribute, you must have modify access to both the object and the attribute value.
## Selecting and editing

The following table describes the features you can use when you edit in-place:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select another object</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Single-click the other object to make it the current object.</td>
</tr>
<tr>
<td></td>
<td>• Double-click the other object to make it the current object and edit it in-place.</td>
</tr>
<tr>
<td></td>
<td>• Press <strong>SHIFT+RETURN</strong> to make the next object the current object and edit it in-place.</td>
</tr>
<tr>
<td></td>
<td>• Press the up or down arrow keys to make the previous or next object the current object and edit it in-place.</td>
</tr>
<tr>
<td>Select another attribute</td>
<td>Click or double-click the attribute.</td>
</tr>
<tr>
<td></td>
<td>If you want to edit the next attribute, click <strong>Edit &gt; In-Place &gt; Edit Next Attribute</strong>, or press <strong>CTRL+A</strong>.</td>
</tr>
<tr>
<td>Accept the edits you made to the current object</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Accept changes</strong> on the <strong>Commit</strong> toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press <strong>CTRL+M</strong> (the letter M is for Make the change).</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Edit &gt; In-Place &gt; Accept Changes</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click another object or another attribute.</td>
</tr>
<tr>
<td>Discard the edits you made to the current object</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Discard changes</strong> on the <strong>Commit</strong> toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press <strong>CTRL+D</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Edit &gt; In-Place &gt; Discard Changes</strong>.</td>
</tr>
<tr>
<td>Change the value of the current attribute to the default value for that attribute</td>
<td>Click <strong>Edit &gt; In-Place &gt; Reset to Default</strong>.</td>
</tr>
<tr>
<td></td>
<td>If the attribute does not have a default value, this changes its value to no value.</td>
</tr>
</tbody>
</table>
In-place editing

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit the Object Heading for the current object</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Double-click the existing heading.</td>
</tr>
<tr>
<td></td>
<td>• Click Edit Object Heading on the Object Edit toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press CTRL+H.</td>
</tr>
<tr>
<td></td>
<td>• Click Edit &gt; In-Place &gt; Edit Heading.</td>
</tr>
<tr>
<td>Edit the Object Text for the current object</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Double-click the existing text.</td>
</tr>
<tr>
<td></td>
<td>• Click Edit Object Text on the Object Edit toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press CTRL+T.</td>
</tr>
<tr>
<td></td>
<td>• Click Edit &gt; In-Place &gt; Edit Text.</td>
</tr>
</tbody>
</table>

If you do not discard the edits you make to the current object, your changes are stored temporarily in your local computer’s memory. They are marked with a red change bar, to show that they have not yet been saved in the database.

To save them in the database, save the module (see “Saving your changes,” on page 74).

**Formatting text**

When you edit a Text or String attribute, you can select some text then apply formatting to it.

<table>
<thead>
<tr>
<th>To make the currently selected text</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bold</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Click Bold B on the Formatting toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press CTRL+B.</td>
</tr>
<tr>
<td></td>
<td>• Right-click Bold.</td>
</tr>
</tbody>
</table>
**Editing**

<table>
<thead>
<tr>
<th>To make the currently selected text</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Italic</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Italic</strong> on the <strong>Formatting</strong> toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press <strong>CTRL+I</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Right-click <strong>Italic</strong>.</td>
</tr>
<tr>
<td>Underlined</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Underline</strong> on the <strong>Formatting</strong> toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press <strong>CTRL+U</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Right-click <strong>Underline</strong>.</td>
</tr>
<tr>
<td>Strikethrough</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Strikethrough</strong> on the <strong>Formatting</strong> toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press <strong>CTRL+SHIFT+S</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Right-click <strong>Strike thru</strong>.</td>
</tr>
<tr>
<td>Superscript</td>
<td>Right-click <strong>Superscript</strong>.</td>
</tr>
<tr>
<td>Subscript</td>
<td>Right-click <strong>Subscript</strong>.</td>
</tr>
</tbody>
</table>

Text can contain standard bullets and can be indented. Place the cursor in the text you want to apply the paragraph format to and do this:

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply bullet points</td>
<td>Click <strong>Bullets</strong> on the <strong>Formatting</strong> toolbar.</td>
</tr>
<tr>
<td>Increase indent</td>
<td>Click <strong>Increase Indent</strong> on the <strong>Formatting</strong> toolbar.</td>
</tr>
<tr>
<td>Decrease indent</td>
<td>Click <strong>Decrease Indent</strong> on the <strong>Formatting</strong> toolbar.</td>
</tr>
</tbody>
</table>
Cut, copy and paste

You can cut and copy the currently selected text to the system clipboard, and paste the contents of the system clipboard.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Copy objects or selected text</strong> on the <strong>Clipboard</strong> toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press <strong>CTRL+C</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Right-click <strong>Copy</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Edit &gt; Copy</strong>.</td>
</tr>
<tr>
<td>Cut</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Cut objects or selected text</strong> on the <strong>Clipboard</strong> toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press <strong>CTRL+X</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Right-click <strong>Cut</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Edit &gt; Cut</strong>.</td>
</tr>
<tr>
<td>Paste</td>
<td>Either:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Paste objects or text</strong> on the <strong>Clipboard</strong> toolbar.</td>
</tr>
<tr>
<td></td>
<td>• Press <strong>CTRL+V</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Right-click <strong>Paste</strong>.</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Edit &gt; Paste</strong>.</td>
</tr>
</tbody>
</table>

You can also copy text from other applications and paste it into Rational DOORS attributes. For example, you might want to copy some text from a Word document and paste it into a DOOR object.

**Note** You cannot copy a rich text table from a Word document into Rational DOORS.

If you copy an Omega symbol from a FrameMaker document and paste it into Rational DOORS, it loses its font family, and is pasted as **W**.
Editing using the object properties sheet

There are two ways to edit the values of object attributes:

- Editing objects in-place (see “In-place editing,” on page 64)
- Using the object properties sheet (described in this topic)

The properties sheet for an object shows various information, including all its attributes and their values.

To edit the value of an attribute, you must have modify access to the module, the object, and the attribute value.

To edit an object using its properties sheet:

1. In the module window, select the object you want to edit, and then right-click Properties.

   The properties sheet for the object is displayed.

   The status of the object is displayed as part of the title of the properties sheet: Possible values are:

   - Saved
   - Unsaved
   - New
   - Baselined
   - Deleted

   If you change the current object in the module window, the object properties sheet is updated to display the properties of the object you have selected.

2. Use the General tab to edit the attribute values.
The following table lists the attribute values you can edit.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
</table>
| Heading     | The **Object Heading** attribute. This attribute is displayed in the main column in Document mode. By default, heading text is displayed in the module in bold. This default is set in the display scheme (for information about changing it, see “Changing your display scheme,” on page 410).
Do not make it bold in the object properties sheet unless you have changed the display scheme.
Rational DOORS automatically generates and displays a heading number, which shows the position of the object in the hierarchy. If you move the object or add new objects, the heading number is automatically updated.
**Note** You cannot insert new lines in the **Object Heading** attribute. However, text with new lines can be copied into the attribute, and the new lines are preserved.
When you view **Object Heading** text that has new lines in the object properties sheet, only the first line of the text is displayed. If you edit this text in the object properties sheet, the text that is not displayed is removed from the attribute. |
| Short Text  | The **Object Short Text** attribute. This attribute is the default value displayed in the object box in Graphics mode. |
| Object Text | The **Object Text** attribute. This attribute is displayed in the main column in Document mode. |

Make each object either a heading (its Object Text is blank) or normal text (its Object Heading is blank), but not both. This gives a cleaner and more manageable structure to your module. It also means that if you export from Rational DOORS to other applications that do not have the concept of multi-attribute objects, you get what you expect.

For example, word processors do not let you combine heading and text in the same paragraph. If you do not combine heading and text in your
Rational DOORS objects, each object is exported as a separate paragraph, which is what you expect. If you combine heading and text in one object, when you export to a word processor, the object is exported as two paragraphs, one that contains the heading and another that contains the text.

**Note** The **General** tab of the object properties sheet also displays the URL of the object and a **Copy URL** button. Clicking **Copy URL** copies the URL of the object to the system clipboard. For more information about Rational DOORS URLs see “Rational DOORS URLs,” on page 32.

3. To edit other attribute values, click the **Attributes** tab.

   A list of all the attributes that apply to objects is displayed, along with the values they have for this particular object.

   Read-only is displayed to the left of attributes you cannot edit.

4. Select the attribute you want to view or edit, and then click **View/Edit**.

5. The screen that is displayed depends on the type of attribute that you are viewing.

   At the top, the name, description, and type of the attribute is displayed.

   If you only have read access to the attribute, you cannot edit the value. You can, however, select and copy it.

6. Select the **Inherit** check box if you want the object to inherit the value of this attribute:

   - The object inherits the value from the nearest ancestor object that is not inheriting the value of this attribute.
   - If all its ancestors are inheriting the value of this attribute, you get the default value of the attribute.

   If the attribute does not have a default value, you get no value.

7. If you clear the **Inherit** check box:

   a. Enter the value you want the object to have. If you are editing a multivalued enumerated attribute and want to maintain the current settings for the affected objects, but select or clear certain values for all objects, go to Step 8.

   b. Use the **Apply to** radio buttons to specify which objects you want the new value to apply to:
• Click **Current object** to apply the new value to the current object only.
• Click **Selected objects** to apply the new value to all currently selected objects.
• Click **Objects in current view** to apply the new value to every object in the current view.

**8.** You can edit the multi-valued enumerated attribute value of multiple objects without affecting the individual attribute values of those objects.

For example, you have a multi-valued enumerated attribute, with the values **A, B, and C**. There are three objects in your current view, which have the following values set for this attribute:

- **Object 1**: A, B
- **Object 2**: A, C
- **Object 3**: B, C

You want to remove value **A** from all the objects, while retaining the other values that are set. To do this:

a. Select **B** and **C** in the list of values, and clear **A**.

b. Select **Objects in current view**.

c. Select the **Remove unchecked values** check box, and make sure the **Add checked values** check box is cleared.

d. Click **OK**.

d. The objects now have values as follows:

- **Object 1**: B
- **Object 2**: C
- **Object 3**: B, C

**A** is removed from all the objects, but **B** and **C** are not added to the objects because the **Add checked values** check box was not selected.

In a similar way you can add values to selected objects, or objects in the current view by selecting the values you want to add, clearing the values you want to leave unchanged, and making sure that **Add checked values** is selected and **Remove unchecked values** is cleared.

The **Add checked values** and **Remove unchecked values** check boxes are unavailable if **Current object** is selected, or if the attribute you are editing is not a multi-valued enumerated attribute.

**9.** Click **OK**.
10. Click **Next** or **Previous** to display the properties sheet for the next or previous object in the current view.

11. When you have finished, click **OK**.

12. Save the module (click **File > Save**).

**Undoing edits**

To undo an edit, click **Edit > Undo**.

You cannot use this feature while you are editing in-place. To stop editing in-place, click another object or attribute (do not double-click it or you remain editing in-place).

**Note** If you cannot undo the last edit, the **Undo** option is unavailable.

**Extended undo**

Any change made to a Rational DOORS object that has been captured in the current history listing can be reversed (except for Move operations and links), giving you the power to undo all changes recorded in history, in any order.

**To use the extended undo facility:**

1. Click **Edit > Object > Properties**.
   
The object properties sheet is displayed.

2. Select the **History** tab.
   
The **Object History** window is displayed.

3. Select the history record you want to restore. Select the **View changes as redlining** check box to see the changes as redlined text.

4. Click the **Details** button to display the information about the history item in a separate window.
   
   Select the **View change as redlining** check box to turn on redlining, or clear the check box to view the history record without redlining.

5. Click the **OK** to return to the object properties sheet

6. Click **Restore**.
   
The object is now restored to the previous state. Links are not affected when you restore a history record. All links are retained, including links that have been created between the date of the history record you are restoring and the present time.
If the change you want to restore is not the most recent change, a warning message might be displayed:

Click **Continue** to restore the change.

You can control whether the message is displayed by selecting or clearing the **Warn when restoring a change other than the most recent from history** check box on the **Settings** tab of the **Options** dialog box (Tools > Options). For more information about the **Options** dialog box, see “Showing your user options,” on page 403.

**Note** You cannot cancel a Restore operation because the restore takes effect immediately. You can undo by closing the dialog, rerunning the process, and selecting the most recent history record.

### Saving your changes

When you edit data in a module, your changes are stored temporarily in your local computer’s memory. They are not saved in the database until you explicitly save them.

**To save your changes when you are editing a module:**

- Click **File > Save**.

When you close a module or exit Rational DOORS, if you have made changes that you have not saved, a message is displayed asking if you want to save the changes. Click **Yes** to save your changes, or **No** to discard them.

### Creating objects

To create an object, you need create access to its parent.

**To create a top-level object:**

- You need create and modify access to the module
- You must be in exclusive edit mode
The edit mode is shown on the status bar at the bottom of the module window. To change your edit mode, click Edit > Edit Mode > Exclusive Edit.

<table>
<thead>
<tr>
<th>To create an object</th>
<th>Do this</th>
</tr>
</thead>
</table>
| At the same level as the current object | Either:  
  • Click Insert > Object.  
  • Press CTRL+N.  
  • If you are editing the current object in-place, press CTRL+RETURN.  
  • Click New object at this level on the Object toolbar. |
| One level below the current object | Either:  
  • Click Insert, and then Object Below.  
  • Press CTRL+L (the letter L is for one Level below).  
  • Click New object below on the Object toolbar.  
  If the current object already has children, the new object becomes the first child. |

**Note** Remember to save the module after you have created new objects.

Each object you create has a unique Absolute Number. Once an absolute number has been assigned to an object, that number is not used again in the module, even if the module is closed without saving the new object.

**Controlling access to an object**

To change the access rights for an object, you must have admin access to it.

**To change the access rights for an object:**

1. In the module window, select the object, and then right-click Properties.
2. Click the Access tab.
Controlling access to an object

The current access rights for the object are displayed.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>See the object.</td>
</tr>
<tr>
<td>Modify (M)</td>
<td>Change the value of any attribute.</td>
</tr>
<tr>
<td></td>
<td>Create and delete links from this object to other objects.</td>
</tr>
<tr>
<td>Create (C)</td>
<td>Create objects one level below the object.</td>
</tr>
<tr>
<td></td>
<td>Move another object to one level below the object.</td>
</tr>
<tr>
<td>Delete (D)</td>
<td>Delete, undelete, and purge the object.</td>
</tr>
<tr>
<td></td>
<td>Move the object.</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Change the access rights for the object.</td>
</tr>
</tbody>
</table>

If the module is partitioned in, the access rights associated with the partition are displayed. The access rights describe the maximum access that any user has. They override the RCMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RMCDA), but the module is partitioned in read-only, in practice the user has only read (R) access to the object.

3. Make the changes you want.

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit from parent</td>
<td>Select this check box if you want the object to inherit its parent’s access rights. If it is a top-level object, it inherits access rights from the module.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>If you clear this check box you create an editable section for the current object. For best performance, try to use the Rational DOORS inheritance mechanism whenever possible, and avoid creating editable sections unless you need them. For more information, see “Editable sections,” on page 59.</td>
</tr>
</tbody>
</table>
4. Click **OK**.

5. Save the module (click **File > Save**).

### Promoting and demoting objects

You can manipulate the object hierarchy by promoting and demoting objects.

- When you promote an object it becomes the next sibling of the object that was its parent.
- When you demote an object it becomes the last child of the object that was its preceding sibling.
An object cannot be demoted to be the child of a deleted object, so the object must have an undeleted preceding sibling.

Children of objects that are being promoted or demoted move with their parent to the new location in the hierarchy.

Promotion and demotion of objects is restricted as follows to ensure that object ordering (with no sort applied) is not changed:

- You cannot promote or demote deleted objects. However, if you select an undeleted object and it has deleted children, the object can be promoted or demoted and its deleted children are promoted or demoted along with it.
- You cannot promote or demote objects when a sort or filter is applied to the module.

**To promote an object:**

1. Select the object or objects you want to promote.
2. Click `Edit > Object > Promote`, or click `Promote` on the **Object** toolbar.

   The object is promoted, and becomes the next sibling of its former parent.

**To demote an object:**

1. Select the object or objects you want to demote.

   The object must have an undeleted preceding sibling.
2. Click `Edit > Object > Demote`, or click `Demote` on the **Object** toolbar.

   The object is demoted and becomes the last child of the object that was its preceding sibling.

---

**Swapping Object Heading and Object Text attributes**

You can swap the **Object Heading** and **Object Text** attributes. When you swap the attributes the contents of the **Heading** attribute becomes **Object Text** and the contents of the **Text** attribute becomes **Object Heading**.

This operation can be used on objects that contain both **Object Heading** and **Object Text**, and on objects that contain one or other.

**Caution** When you swap **Object Text** with **Object Heading**, the text might be truncated, as the **Object Heading** attribute cannot hold as many characters as the **Object Text** attribute.
To swap attributes:

1. Select the object that contains the **Object Heading** or **Object Text** you want to swap. You must have read and modify access to the **Object Heading** and **Object Text** attributes in the module.

2. Click **Edit > Object > Swap**, or click **Swap** on the **Object Edit** toolbar.

   The contents of the **Object Heading** attribute becomes **Object Text** and the contents of the **Object Text** attribute becomes **Object Heading**.

---

**Splitting Object Heading from Object Text**

When you split an object, a new object is created to replace the selected object, and the text in the Object Heading is moved into the new object. The selected object retains the Object Text, and becomes the first child of the new object.

If the selected object has any children, they become siblings of the selected object, with the new object containing the Object Heading as their parent.

**Note** If you have a module open in shareable edit mode, you cannot split the top object in a locked section. However, you can split child objects.

**To split Object Heading from Object Text:**

1. Select the object you want to split. You must have read and modify access to the **Object Heading** attribute and read access to the **Object Text** attribute.

2. Click **Edit > Object > Split**.

   A new object is created to replace the selected object. The text in the **Object Heading** is moved into the new object.

---

**Deleting, undeleting, and purging objects**

Deleting an object does not destroy the object. It simply marks the object and all the objects in the tree below it as deleted, which stops users from being able to easily access them. To destroy the object, you must purge it once you have deleted it.

Purging deleted objects removes them permanently from the database.

If the object you want to delete has an in-link, this link must be deleted before the object can be deleted. If the object has descendants, any in-links to those objects must also be deleted before the parent object can be deleted, preventing dangling links being left at the source object.
Deleting, undeleting, and purging objects

To delete the link:

- The link module and the module containing the source object must be open.
- You must have modify access to the source object and the link module.

When you delete an object that has an out-link, the link is not deleted until you purge the object and then save the module after purging the object.

To delete, undelete or purge an object, you must have delete access to the object and to all objects in the tree below it.

**Note** You cannot delete or purge objects that have descendants if sorting is turned on. Leaf objects can be deleted when sorting is on.

**To delete an object:**

1. In the module window, select the object you want to delete, and then click Edit > Object > Delete.
2. Save the module (click File > Save).
   
The object is deleted. Its object identifier is never reused by any future objects.

**To undelete an object:**

1. In the module window, make sure that deleted objects are being displayed. If necessary, click View > Show > Deletions.
   
   Deleted objects have red text, and their change bars are black.
2. Select the object you want to undelete, and then click Edit > Object > Undelete.
3. Save the module (click File > Save).

**To purge an object:**

1. In the module window, make sure that deleted objects are being displayed. If necessary, click View > Show > Deletions.
2. Select the deleted object you want to purge, and then click Edit > Object > Purge.
   
   Deleted objects are colored red, and their change bars are black.
3. A message is displayed asking if you really want to purge the objects. Click Yes.
4. Save the module (click File > Save).
The object and all objects in the tree below it are permanently removed from the database.

To purge all deleted objects:

1. In the module window, click **Edit > Purge All**.
   A confirmation message is displayed.
2. Click **Yes** to purge all the deleted objects in the module.
   Deleted objects are purged even if they are not being displayed.

The spelling checker

The spelling checker allows you to check the spelling of Text and String attributes in any of the language dictionaries that are supported by Rational DOORS. For information about supported languages, see “Configuring the spelling checker,” on page 415.

Each attribute has a locale language, which is displayed beside the attribute name in the spelling checker. You can check more than one attribute at a time, but attributes that are checked together must have either the same locale or have no locale set.

The language that is used for the spelling check is displayed in the **Selected Language** list box. By default, the attribute is checked in its locale language, as displayed in the attribute list. If the attribute does not have an associated language, or if the language is not supported, the language that is used by default depends a setting on the **Spelling** tab of the **Options** dialog box. For information about this setting, see “Default language selection in Rational DOORS,” on page 418.

If you want to check the attribute in a different language, you can select the language you want to use from the **Selected Languages** list box.

Checking spelling

To check the spelling of the text in your module:

1. In the module window, click **Tools > Spelling**.
   The **Check Spelling** dialog box is displayed.
2. The attributes that can be checked are listed in the **Check** box. The list contains only the Text and String attributes that are displayed in the current view. The locale of each attribute is displayed in the **Language** column.
By default, Rational DOORS checks the spelling and grammar for the **Object Text** attribute. You can check additional attributes by selecting them from the list. You can only check attributes at the same time if they have the same locale or if they do not have a locale set. If you want to check the spelling in attributes that have different locales, you have to check them individually.

3. The language that is used for the spelling check is displayed in the **Selected Language** list. If you want to check in a different language, select it from the list.

**Note** If you want to correct an error, you must have an edit lock on the object or attribute and have modify access to it.

4. By default, all the objects in the current view are checked.

Select **Current Object Only** or **Current Object And Children**, if you want to limit the objects that are checked.

5. Click **Start** to start checking spelling and grammar.

When an error is detected:

- The sentence that contains the error is displayed in the **Sentence** box, with the error highlighted.
- A description of the error is given in the **Explanation** box.
- If there are any suggested corrections, they are listed in the **Alternatives** box.

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ignore</td>
<td>Leave the highlighted error unchanged, and continue checking.</td>
</tr>
<tr>
<td>Ignore All/Ignore Rule</td>
<td>Leave the highlighted error unchanged, and ignore any further occurrences of the highlighted word, or type of grammar error.</td>
</tr>
<tr>
<td>Ignore attribute</td>
<td>Leave the highlighted error unchanged, and ignore the attribute for the remainder of the spelling check.</td>
</tr>
<tr>
<td>Skip Sentence</td>
<td>Ignore any errors in the current sentence, and continue checking in the next sentence.</td>
</tr>
</tbody>
</table>
If an error is found in an object or attribute that you have read-only access to, you can choose to either:

- Continue checking values that you have read-only access to
- Check only the values that you have modify access to

You cannot correct errors unless you have modify access to the object or attribute.

6. Save the module (click **File > Save**).

You can configure the spelling checker using the **Options** dialog box. For more information, see “Configuring the spelling checker,” on page 415.

For more information about locales, see *Understanding locales and unicode options* in *Managing Rational DOORS*.

---

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
</table>
| Add        | Add the word to the client dictionary or the database dictionary. You must have modify access to the database dictionary to add words to it.  
If you select **Client**, the word is added to the client dictionary. This dictionary is not available to other Rational DOORS clients.  
If you select **Database**, the word is added to the database dictionary. This dictionary is available to all the Rational DOORS clients that access the database. |
| Replace    | Replace the highlighted word with the word you have selected in the **Alternatives** box.  
You can also edit the text in the **Sentence** box and apply rich text formatting to it, and then click **Replace** to commit the change.  
The sentence is checked again if you edit text in the **Sentence** box. |
| Replace All| Replace every occurrence of the highlighted word in the object with the word you have selected in the **Alternatives** box. |
| Stop       | Stop the spelling check.                                             |
| Close      | Finish the spelling check.                                           |
Inserting symbols

When you edit an object in-place, you can insert symbols, such as square root symbols, and Greek characters.

You can only insert symbols into attributes of type Text or String.

**To insert a symbol:**

1. In the module window, double-click the text you want to edit.
2. Position your cursor at the place where you want to insert the symbol.
3. Click **Insert > Symbol**.
4. In the **Character set** box, select the character set you want to use.
5. Click the symbol you want to insert.
   - The symbol is inserted at the position of your cursor.
6. Click **Close**.
7. Save the module (click **File > Save**).

Symbols are not displayed in the left pane of the Module Explorer. In the left pane, a text description of the symbol is displayed. For example, the text **diamond** is displayed instead of the diamond symbol.

**Note** The symbol ‿ is not displayed when it is inserted in text.
- This symbol inserts a soft hyphen in a word, which tells the text reader that the word can break across a line at this point.

**Inserting URLs**

The values of attributes of type Text or String can include live URLs. The URLs can have the following formats:

- `http://`
- `https://`
- `ftp://`
- `file://`

To insert a URL, simply type the URL. For example, type `http://www.ibm.com/software/rational/support/`.

The URL is automatically highlighted in blue.
The URL is live. If you double-click it, your browser opens the web page associated with URL.

A URL that is displayed in a traceability column is not live. To activate the URL, you must follow the link to the source or target object, and double-click the URL there.

You can also insert URLs as external links. For more information about external links see “External links,” on page 230.

Note Microsoft Project bookmarks are not supported in Rational DOORS.

Note Your user options specify which browser is used when you double-click a URL in Rational DOORS. To change the browser, in the Database Explorer, click Tools > Options, and then use the Settings tab to specify the browser you want to use.

Inserting templates

Rational DOORS provides a library of templates to help get you up and running quickly. For example, there are DoD-STD and MIL-STD templates.

Templates help you keep your modules consistent by encouraging people to use a standard structure and headings.

You can create your own templates and add them to the library, which is in the Rational DOORS home directory, in doors\lib\dxl\standard\template. Template DXL must be Latin1 or UTF8 encoded. For more information, see the DXL Reference Manual, which is available in PDF and from the Help menu.

Note You can also use a template to create a module (see “Creating a formal module,” on page 45).

To insert a template into your current module:

1. Select the object after which you want to insert the template.
2. Click Insert > Template.
3. Locate the template you want to insert, and then either double-click it, or select it and click OK.

Splitting objects

You can:
Splitting objects

- Split an object into two or more objects; you split the contents of its **Object Text** attribute across multiple objects.
- Optionally, create links between the original object and the new objects.

**To split objects:**

1. In the module window, make the object you want to split the current object.
2. Click **Tools > Functions > Split Object Text**.
3. In the **Object Text** box, select the text to specify where you want to make the split.

   For example, if the Object Text is **ABCDEFGHIJK**, the following table shows the different ways you can split the object.

<table>
<thead>
<tr>
<th>If you select this text</th>
<th>The original object contains</th>
<th>And the new objects contain</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABCD</td>
<td>ABCD</td>
<td>EFGHIJK</td>
</tr>
<tr>
<td>EFG</td>
<td>ABCD</td>
<td>EFG HIJK</td>
</tr>
<tr>
<td>JK</td>
<td>ABCDEFGHI</td>
<td>JK</td>
</tr>
</tbody>
</table>

4. Use the **New position** radio buttons to specify where you want to create the copies:
   - Click **After** to create the copies at the same level as, and immediately after, the current object.
   - Click **One level down** to create the copies one level below the current object.

5. If you want to create links between the original object and the copied objects:
   a. Select the **Create links** check box.
   b. In the **Link direction** drop-down list, select the direction of the links.

6. Click **Apply** to split the object.
7. Click **Next** or **Previous** to move to the next or previous object in the current view.
8. When you have finished, click **OK**.
9. Save the module (click **File > Save**).
Copying objects

You can:

• Copy objects between modules, and you want to copy attributes other than the Object Heading, Object Text and Object Short Text attributes.

  If you want to copy only these three attributes, you might find it easier to use drag-and-drop (see “Using drag-and-drop,” on page 37).

• Copy every object in a module or every object in the current view to another module.

To copy objects:

1. Open both the source and target modules.

2. In the target module, make the current object the one where you want to copy the data to.

   You can copy the data to either the same level or one level below this object.

3. In the source module, if you want to copy a particular object, select that object.

   If you want to copy either the entire module or all objects in the current view, it does not matter which object you select.

4. In the source module, click Tools > Functions > Copy Objects.

5. The Source module box shows you the name of the source module.

6. In the Target module box enter the name of the target module (specify the path from its nearest ancestor project), or use Browse to locate it.

7. Use the Copy drop-down list to select what you want to copy

   • Select Current object only to copy only the current object
   • Select Current object with children to copy the current object and all objects in the tree below it
   • Select Current display set to copy all objects in the current view
   • Select All objects to copy all objects in the module.

8. Use the New position radio buttons to specify where you want to create the copies in the target module:

   • Select After to create the copies at the same level as, and immediately after, the current object
   • Select One level below to create the copies one level below the current object
   • Select the attributes you want to copy
Merging object text

You can create an object whose Object Text consists of the Object Text of one or more objects in the same or another module.

**To merge object text:**

1. Open the module that contains the objects whose Object Text you want to merge.

2. Click Tools > Functions > Merge Objects.

3. A list of all the objects in the current module is displayed. Select the ones whose Object Text you want to merge.

4. Specify where you want to create the object:
   - In the **Target module** box, type the name of the target module, or use **Browse** to locate it. You must specify the path to the module from its nearest ancestor project.
   - Open the target module and select the object you want to create the object below or after.
   - In the **Merge Objects** window, use the **New position** radio buttons to specify where you want to create the object in the target module:
     - Click **After** to create the object at the same level as, and immediately after, the current object.
     - Click **Below** to create the object one level below the current object.

5. If you want to create links between each of the source objects and the new object:
   - Select the **Create links** check box.
   - Use the drop-down list to select the direction of the links.

6. Click **OK**.
Editing using forms

Forms

You can create forms for viewing and editing data in modules. You select the attributes you want to display in the form and optionally create a view of those attributes in the module. Forms can be saved and accessed from the module at any time.

Creating a new form

1. In the module window, click Tools > Forms > New Form.

   The Form Generator dialog box is displayed. The following table describes the options that are available:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Form name</td>
<td>The name you want to give the form.</td>
</tr>
<tr>
<td>Object attributes</td>
<td>The attributes in the module that are available to display in the form.</td>
</tr>
<tr>
<td>Form attributes</td>
<td>The attributes that will be displayed in the form.</td>
</tr>
<tr>
<td>Add</td>
<td>Adds the attributes selected in the Object attributes list to the Form attributes list.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the attributes selected in the Form attributes list.</td>
</tr>
<tr>
<td>Move Up</td>
<td>Moves the attribute up the Forms attribute list.</td>
</tr>
<tr>
<td></td>
<td>The attributes are displayed on the form in the order they appear in the Form attributes list.</td>
</tr>
</tbody>
</table>
2. Select the attributes you want to display on the form from the **Object Attributes** list and click **Add**.

3. Select the check box in the ☑ column of the **Form attributes** panel for any attributes that you want to display on the form, but that you do not want to be editable. This does not change the access rights to the attribute, it just makes it read-only on the form.

4. If you want to preview the form before you create it, click **Preview**.

5. If you want to create a module view that displays the attributes you have added to the form:
   a. Click **Create View**.
      The **Save View** dialog box is displayed.
   b. Type a name for the view and click **OK**.
If a view with that name already exists, you will be prompted to overwrite the view.

6. Click **OK** to create the form.

**Editing forms**

You can edit forms that you have created previously.

**To edit a form:**

1. In the module window, click **Tools > Forms > Edit Forms.**
2. Select the form you want to edit from the list and click **OK.**
3. You can change the attributes that you want to display on the form, and the options that apply to the form, but not the name of the form.
4. Click **OK** when you are finished.

The form is updated.

**Running forms**

When you have created a form, you can use it to view and edit the attributes that are included in the form. You can only edit attribute values if you have modify access to them and if they have not been set to display as read-only on the form.

**To view and edit attributes using a form:**

1. In the module window, click **Tools > Forms > Run Forms.**
2. Select the form you want to view and click **OK.**

The form opens. The attributes are those that were selected to be displayed on the form when it was created or last edited. The attribute values displayed are those of the currently selected object. Some or all attribute values might be read-only, depending on your access rights, and whether they were set to be read-only when the form was created or last edited.

3. Select **Automatically copy changes to module** if you do not want to be prompted to save your changes each time you move to a different object.
4. Use the form to edit different objects in the module by clicking the **Previous, Next** and **Go To** buttons. If you have not selected to automatically write changes to the module, you will be prompted to save any changes you have made.
5. Click **OK** to save changes and close the form.
Deleting forms

To delete a form:

1. In the module window, click **Tools > Forms > Delete Form**.
   
   A list of the available forms is displayed.

2. Select the form you want to delete and click **OK**.
   
   The form is deleted.
Using views

This chapter contains the following topics:

- Views
- Saving your current view
- Inheritance in views
- Setting default views
- Editing a view
- Controlling access to a view
- Deleting a view

Views

When you create a formal module, the default view of the module is the Standard view. This displays the Module Explorer, the ID column, and the main column.

You can edit the Standard view and save it with a different name, but you cannot save a view and name it Standard view.

When you work with modules, your current view is what is currently displayed on your screen. It is a combination of the columns that you can see, the sort or filter you are currently using, and so on.

You can save your current view, so you can use it again later, for example in your next Rational DOORS session. This saves you having to set up all the display options again.

The names of all the views that have been created for a module are shown in the Views drop-down list on the View toolbar. The full name of the view that is currently selected and its description are displayed when you roll over the list box.

To load a different view, select it from the drop-down list. Click away from the drop down list to cancel a selection.

To reload the current view, click View > Reload.

Note A warning is displayed if you make changes to the display that will be lost when you select a different view or close the module. You can stop this message being displayed by
changing your user options. For more information see “Showing your user options,” on page 403.

**Saving your current view**

To save your current view:

1. In the module window, click **View > Save As**.
2. In the **Name** box, type the name you want. If you want to overwrite an existing view, type the name of the view you want to overwrite.
   
   **Note** View names are case sensitive, so if you want to overwrite an existing view, you must type the name exactly as it appears in the **Views** list.

3. If you want to enter additional information about the view, type it in the **Description** box.
4. Select the display settings you want to save with the view.

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current object</td>
<td>Select this check box if you want the view to remember the settings for the current object.</td>
</tr>
<tr>
<td>Window size and position</td>
<td>Select this check box if you want the view to remember the current window size and position.</td>
</tr>
<tr>
<td>Filtering</td>
<td>Select this check box if you want the view to remember the current filtering settings (whether filtering is turned on and what the current filter is).</td>
</tr>
<tr>
<td>Sorting</td>
<td>Select this check box if you want the view to remember the current sorting settings (whether sorting is turned on and what the current sort is).</td>
</tr>
<tr>
<td>Inherit undefined settings from</td>
<td>Select a view from which “remember” settings are inherited if they are not defined in the current view. For more information, see “Inheritance in views,” on page 98.</td>
</tr>
</tbody>
</table>

The saved settings are automatically applied whenever you load the view. If a check box is not selected, loading the view does not change the associated display setting.
For example:

- If the **Filtering** check box is not selected, loading the saved view does not change the current filtering settings.
- If the **Filtering** check box is selected, when you subsequently load the saved view, the filtering settings are changed to be the same as they are now. If filtering is off now, filtering is off when you load the saved view. If filtering is on now, filtering is on when you load the saved view.

5. Use the **Default** check boxes if you want the saved view to be a default view for the module:
   - Select **For module** if you want it to be the module default view. You must have modify access to the module to be able to select or clear this check box. This option is disabled if **Private** is selected in the **Access to this view** pane.
   - Select **For current user** if you want it to be your own user default view.

6. Use the **Access to this view** section to define the access rights for the view.

<table>
<thead>
<tr>
<th>If you select</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Private</td>
<td>You will have full access to the view, and everyone else will have no access. You cannot make the view private if the <strong>For Module</strong> check box is selected in the <strong>Default</strong> pane of this dialog box.</td>
</tr>
<tr>
<td>Public</td>
<td>You will have full access to the view, and everyone else will have read access.</td>
</tr>
<tr>
<td>Custom</td>
<td>You will have full access to the new view. The custom access rights for all other users and groups that are defined in the view that is currently displayed in the module are inherited by the new view. If you are overwriting an existing view, the access rights for the existing view are overwritten with the access rights of the view that is currently displayed in the module. If the view that is displayed in the module when you save a new view is the Standard view, you cannot select <strong>Custom</strong> for the <strong>Access to this view</strong>. This is because the Standard view cannot have custom access rights, so there are no custom access rights for your new view to copy.</td>
</tr>
</tbody>
</table>
You can edit the access rights for a view using the Manage views dialog box. For example, you might have created a private view, but want to allow specific Rational DOORS users access to it. See “Controlling access to a view,” on page 104 for details.

7. Use the Advanced tab if you do not want to save other display options with the view. For more information, see “Editing a view,” on page 100.

8. Click OK.

Inheritance in views

When you create a view you can make it inherit undefined settings from a different view in the module. Undefined settings mean any of the options that are not selected in the Remember settings for frames on the General and Advanced tabs when you save a view. This is useful if you want to save a new view of a module, but use a setting that has been saved with an existing view.

For example if you already have a filter saved with View X and you want to use that filter again in View Y, you can select View X in the Inherit undefined settings from list when you create View Y. As long as you make sure that Filtering is not selected in the Remember settings for pane of View Y, it will inherit the filter from View X.

When you select View Y, View X is pre-loaded:

- Settings that are selected in View X are applied to the view.
- When View Y is loaded, any settings that are selected in View Y overwrite settings in View X.
- Any settings that are not selected in View Y are inherited from View X. If a setting is not selected in either View Y or View X, the module default is used.

So, you could create a sort in the current view and inherit a filter from an existing view. As long as the Sorting check box is selected and the Filtering check box is cleared in the Remember settings for pane of the current view, both the sort and the filter will be applied when you select the view.

Views inheritance and access controls

When you set a view to inherit settings from another view, all the users that have read access to the current view must also have read access to the view from which it inherits settings. When you save a new view, only the existing views that allow the same users read access as the new view are displayed in the Inherit undefined settings from list.
A view that inherits access controls from the module cannot inherit settings from a view which does not, and to which any users might not have Read access.

If you change the access rights on an existing view that is inheriting settings, so that you give read access to users who do not have read access to the view from which it inherits settings, the inheritance is invalid. You are prompted to either confirm the change in access and remove the inheritance, or cancel the change in access.

If you remove read access from a view that has its settings inherited by other views, so that users who have read access to inheriting views do not have read access to this view, the inheritance is invalid. You are prompted to either confirm the change in access and remove the inheritance from views which are affected, or cancel the change in access.

Setting default views

A module has two different types of default view:

• **User default view**

  Each user can set their own default view for the module. If you have defined a user default view for a module, that view is displayed when you open the module.

• **Module default view**

  This is the view that a user sees when they open a module and they have not defined a user default view for the module.

  **Note**  If you make the module default view read-only, other users cannot change the settings within the view. However, a user with modify access to the module can overwrite the module default view with a different view.

To set the default views for a module:

1. In the module window, click **View > Manage Views**.
2. On the left of the screen, select the view that you want to be the default.
3. On the **General** tab on the right:
   a. Select the **For module** check box to make the view the module default.
      You must have modify access to the module to be able to select or clear this check box.
   b. Select the **For current user** check box to make the view your personal user default.
Using views

4. Click **OK**.

**Editing a view**

**To edit a view:**
1. In the module window, click **View > Manage Views**.
2. On the left of the screen, select the view you want to edit.
   You must have modify access to the view.
3. Select the **General** tab.
4. In the **Name** box, edit the name if you want.
   **Note** View names are case sensitive.
5. In the **Description** box, edit the description if you want.
6. Edit the display settings:

<table>
<thead>
<tr>
<th><strong>Check box</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Current object</td>
<td>Clear this check box if you do not want the view to remember the settings for the current object.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If this check box was cleared when the view was created, you cannot select it. If you want to select this check box, you will need to use View &gt; Save As.</td>
</tr>
<tr>
<td>Window size and position</td>
<td>Clear this check box if you do not want the view to remember the settings for the current window size and position.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If this check box was cleared when the view was created, you cannot select it. If you want to select this check box, you will need to use View &gt; Save As.</td>
</tr>
<tr>
<td>Filtering</td>
<td>Clear this check box if you do not want the view to remember the current filtering settings (whether filtering is turned on and what the current filter is).</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If this check box was cleared when the view was created, you cannot select it. If you want to select this check box, you will need to use View &gt; Save As.</td>
</tr>
</tbody>
</table>
Editing a view

The saved settings are automatically applied whenever you load the view. If a check box is not selected, loading the view does not change the associated display setting.

For example:

- If the **Filtering** check box is not selected, loading the saved view does not change the current filtering settings.
- If the **Filtering** check box is selected, when you subsequently load the saved view, the filtering settings are changed to be the same as they are now. If filtering is off now, filtering is off when you load the saved view. If filtering is on now, filtering is on when you load the saved view.

7. Edit the default settings:
   - Select **For module** to make the view the module default.
     You must have modify access to the module to be able to select or clear this check box.
     You can only select this check box if the view is a **Public** view.
   - Select **For current user** to make the view your personal user default.

8. Edit the access rights for the view.
   Click the **Access** tab.
   For more information, see “Controlling access to a view,” on page 104.

9. Edit the advanced properties of the view.

<table>
<thead>
<tr>
<th>Check box</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sorting</td>
<td>Clear this check box if you do not want the view to remember the current sorting settings (whether sorting is turned on and what the current sort is).</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> If this check box was cleared when the view was created, you cannot select it. If you want to select this check box, you will need to use View &gt; Save As.</td>
</tr>
<tr>
<td>Inherit undefined settings from</td>
<td>Select a view from which “remember” settings are inherited if they are not defined in the current view. For more information see “Inheritance in views,” on page 98.</td>
</tr>
</tbody>
</table>
Click the **Advanced** tab, and select the display settings you want to save with the view. The saved settings are automatically applied whenever you load the view.

<table>
<thead>
<tr>
<th><strong>Select</strong></th>
<th><strong>To</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Outlining</td>
<td>Save the outlining setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Compression</td>
<td>Save compression settings with the view.</td>
</tr>
<tr>
<td>Graphics mode</td>
<td>Save the display mode setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Graphics links</td>
<td>Save the <strong>Show Graphics Links</strong> setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Module Explorer</td>
<td>Save the <strong>Module Explorer</strong> setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Apply Filtering to Explorer</td>
<td>Save the <strong>Apply Filtering to Explorer</strong> setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Link arrows</td>
<td>Save the <strong>Show Link Arrows</strong> setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Deleted objects</td>
<td>Save the <strong>Show Deletions</strong> setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Table cells</td>
<td>Save the <strong>Show Table Cells</strong> setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Filter table contents</td>
<td>Save the <strong>advanced filter</strong> option for hiding non-matching table cells (see “Using an advanced filter,” on page 117) with the view.</td>
</tr>
<tr>
<td>Default table cell attribute</td>
<td>Save the <strong>Table Attribute</strong> setting (see “Controlling table attribute display,” on page 161) with the view.</td>
</tr>
<tr>
<td>Pictures</td>
<td>Save the <strong>Show Pictures</strong> setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Display level</td>
<td>Save the <strong>display level</strong> setting (shown on the <strong>View</strong> menu) with the view.</td>
</tr>
<tr>
<td>Columns</td>
<td>Save information about columns with the view.</td>
</tr>
</tbody>
</table>
Controlling access to a view

10. Click OK.

### Controlling access to a view

To change the access rights for a view, you must have admin access to it.

**To change the access rights for a view:**

1. Open the module that contains the view you want to change.
2. Click View > Manage Views.
3. Select the view, and then click the Access tab.

   The current access rights for the view are displayed.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>See the view.</td>
</tr>
<tr>
<td></td>
<td>Make it your user default view.</td>
</tr>
</tbody>
</table>
If the module is partitioned in, the access rights associated with the partition are displayed. These describe the maximum access that any user has. They override the RCMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RMDA), but the view is partitioned in read-only, in practice the user has only read (R) access.

4. Make the changes you want.

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
</table>
| Inherit from parent | Select this check box if you want the view to inherit its access rights from the module.  
When this check box is selected, the list of access rights is unavailable, and shows what access rights the view is inheriting. |
| Add              | To add a new entry to the list of access rights:  
  a. Click Add.  
The Add Access window is displayed.  
b. In the Name box, select the name of the user or group that you want to add an entry for.  
c. Select the access rights you want to give them, and then click OK. |
| Remove           | To remove an entry from the list of access rights, select the entry, and then click Remove. |
| Edit             | To edit an entry in the list of access rights:  
  a. Select the entry then click Edit.  
The Edit Access window is displayed.  
b. Select the access rights you want to give them, and then click OK. |

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Modify (M)</td>
<td>Change the view in any way.</td>
</tr>
<tr>
<td>Delete (D)</td>
<td>Delete the view.</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Change the access rights for the view.</td>
</tr>
</tbody>
</table>
5. Click **OK**.

If you change the access rights on a view that is inheriting settings, so that you give read access to users who do not have read access to the view from which it inherits settings, the inheritance is invalid. You are prompted to either confirm the change in access and remove the inheritance, or cancel the change in access.

If you remove read access from a view that has its settings inherited by other views, so that users who have read access to inheriting views do not have read access to this view, the inheritance is invalid. You are prompted to either confirm the change in access and remove the inheritance from views which are affected, or cancel the change in access.

### Deleting a view

**Note** You cannot undelete a view once you have deleted it.

**To delete a view:**

1. In the module window, click **View > Manage Views**.
2. On the left of the screen, select the view you want to delete, and then click **Delete**.

   You must have delete access to both the module and the view.

3. A message is displayed asking if you really want to delete the view.

   Click **Yes**.

4. Click **OK**.
This chapter contains the following topics:

- Searching the database
- Finding text in a module
- Finding and replacing text
- Going to a particular object
- Filters
- Using a simple filter
- Using an advanced filter
- Applying filtering to the Module Explorer
- Turning filtering on and off
- Sorts
- Sorting
- Turning sorting on and off
- Searching with regular expressions

### Searching the database

You can:

- Search by name for projects, folders and modules
- Search for occurrences of specified text in modules. Only the **Object Heading** attribute and the **Object Text** attribute are searched.

**To search the database:**

1. In the Database Explorer, select the project, folder or module that you want to search.
2. Click **Tools > Find**.
3. If you want to search for projects, folders or modules with a particular name:
   a. Type the name in the **Named** box.
      
      The name can include asterisk (*) and question mark (?) wildcard characters.
b. Select **Search description** to search the project, folder and module descriptions.

c. Select the **Match case** check box if you want a case-sensitive search.

4. The **Look in** box shows the project or folder to be searched.

By default, the search includes all the projects and folders under this project or folder. Clear the **Include Subfolders** check box if you only want to search the modules in this project or folder.

If you selected a module in Step 1, the **Look in** box contains the name of the folder or project that it is in.

5. If you want to search for modules that contain specific text in their **Object Heading** or **Object Text** attribute:

   a. Type the text you want to search for in the **Containing text** box.
   
   b. Select the **Use Wildcards** check box if the text you typed in the **Containing text** box includes asterisk (*) or question mark (?) wildcard characters.
   
   c. Select the **Match case** check box if you want a case-sensitive search.

6. Click **Find Now** to start the search.

   A list of all the items that matched your search is displayed.

   Double-click an item to open it.

### Finding text in a module

This topic describes how to search a formal module for all the objects that contain specific text. For example, you can search for objects that contain the word **accelerate**.

**To search a module for objects that contain specific text:**

1. Open the module you want to search.

2. In the module window, click **Edit > Find**.

   The **Find and Replace** dialog box is displayed.

   Any search options that have already been set are displayed.

   **Note** You cannot search using standard Windows wildcards.

3. In the **Find what** box, type the text you want to search for.

4. If you want to change the search options, select **Advanced** and select or clear the appropriate check boxes:
Finding and replacing text

You can search for and replace text within a formal module. For example, you can search for the word **petrol** and replace it with **gas**.

**To find and replace text within a formal module:**

1. In the module window, click **Edit > Replace**.
The **Find and Replace** dialog box is displayed.

Any search options that have already been set are displayed.

2. In the **Find what** box, type the text you want to search for, and in the **Replace with** box, type the text you want to replace it with.

3. If you to change the search options, select **Advanced** and select or clear the appropriate check boxes:
   - Select **Match case** if you want to perform a case-sensitive search.
   - Select **Use regular expression** if you want to use a regular expression in the **Find what** box.

   For information about regular expressions, see “Searching with regular expressions,” on page 123.

4. In the **Replace in** box, select the attributes you want to search. By default, only **Object Heading** and **Object Text** are selected.
   - Click **All in View** to select all the attributes displayed in your current view.
   - Click **All** to select all the attributes in the list.

   **Note** You can only use the **Replace** function if you have modify access to the attributes being searched.

5. Click **Find Next** to find the next object that contains the specified text, or click **Find Previous** to search backwards.
   - Click **Replace** to replace every occurrence of the specified text in the current object
   - Click **Replace All** to replace every occurrence of the specified text throughout the module

6. When you have finished, click **Close**.

**Going to a particular object**

When you have a module open, you can go directly to a particular object in the module if you know its absolute number or its section number.

**Note** You can only go to an object in the current view.

**To go directly to a particular object:**

1. In the module window:
   - Click **Edit > Go To**.
2. Type in the section number or absolute number of the object you want to go to, or select a number that you previously entered from the list.
   • If you enter a number containing a decimal point, for example 5.2 or 6., Rational DOORS goes to the object with that section number.
   • If you enter a whole number, for example 5, Rational DOORS goes to the object with that absolute number.
   • If you enter a valid module prefix followed by valid object number, Rational DOORS goes to the object with that Object Identifier.

3. Click Go To.
   If the object with the specified absolute number or section number is in your current view, it becomes the current object.
   The last seven numbers that you have typed are stored in the list until you close the module. They can be accessed by clicking the down arrow.

4. Click Close.

Filters

Filters let you control what data is displayed in a module. You can use them to filter out data you do not want to see.
For example, you can filter out all objects except those that contain the word steering. Or you can filter out all objects except those that have links.
There are two types of filter, simple and advanced.

Simple filters

With a simple filter, you can either:
• Filter on the contents of every attribute of type Text or String.
• Filter on the Object Heading number.
• Filter on the contents of any column, whether it is a traceability column or any other custom column created by DXL.
• Filter on the value of a single attribute of any type.
• Filter on the basis of whether the object has links.
• Filter on the basis of whether the object is either the current object or a leaf object.
An object is a leaf object if it does not have any children.
Advanced filters

With an advanced filter, you can:

- Combine together simple filters to create a complex filter.
  For example, you can display objects that contain the word `steering` and that also have links.

- Specify filter options that control what is displayed.
  For example, you can control whether only the objects that match your filter are displayed, or whether their ancestors or descendants are displayed too.

By default, the filter only affects what is displayed in the module window. If you want the filter to affect the Module Explorer, you can use either the **Apply Filtering to Explorer** menu option on the **View** menu or the **Apply Filtering to Explorer** button on the **Display** toolbar to set the Module Explorer to display only the results of the filter. Objects that are excluded from the filter are disabled in the Module Explorer.

Using a simple filter

For information about filters, see “Filters,” on page 113.

For information about using advanced filters, see “Using an advanced filter,” on page 117.

**To use a simple filter:**

1. In the module window, click **Tools > Filter > Define**, or click **Filter properties** on the **Display** toolbar.
2. Use the **Attributes** tab if you want to filter on an attribute.
   Specify the attribute you want to use for your filter. For example, if you want to only display objects that contains the word `steering`:
   a. Select **Any string or text attribute** in the **Attribute** box.
   b. Select **contains** in the **Condition** box.
   c. Type `steering` in the **Value** box.
3. If the value in the **Condition** box is **contains**:
   a. Select the **Match case** check box if you want to set up a case-sensitive filter.
   b. Select the **Regular Expression** check box if you want to use a regular expression. For information about regular expressions, see “Searching with regular expressions,” on page 123.
4. If you want to filter objects on the basis of what links they have, click the **Links** tab, and then define your link criteria.

For example, if you only want to display objects that have in-links, select **have** and **in-links** in the top two boxes. To show:

- All the objects in the module that have inlinks select **going through any link module**.
- Only in-links contained in a specific link module, select **going through link module**, and then browse to the link module.

5. If you want to filter objects on the basis of whether they are either the current object or leaf objects, click the **Objects** tab, and then click the appropriate radio button.

An object is a **leaf** if it does not have any children.

6. Alternatively, if you want to filter the contents of columns, click the **Columns** tab.

   a. Select the column you want to filter in the **Column** box.
   
   b. Type what you want to filter for in the **Contains** box.
   
   c. Select the **Match case** check box if you want to set up a case-sensitive filter.
   
   d. Select the **Regular Expression** check box if you want to use a regular expression. For information about regular expressions, see “Searching with regular expressions,” on page 123.

7. Use the following filter options to control what is displayed on your screen.

<table>
<thead>
<tr>
<th>Select</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show ancestors</td>
<td>Display all the ancestors of the objects that match the filter, as well as the objects themselves. For each object that matches the filter, Rational DOORS displays its parent, grandparent, and so on. This lets you see where the objects that match the filter fit in the object hierarchy.</td>
</tr>
<tr>
<td>Show descendants</td>
<td>Display all the descendants of the objects that match the filter criteria, as well as the objects themselves. For each object that matches the criteria, Rational DOORS displays the tree of objects below it.</td>
</tr>
</tbody>
</table>
Finding, filtering and sorting

8. Click **Apply** or **OK**.

The module background color changes to show that a filter is being applied to the data. The color depends on the display scheme you are using. For example, in the modern display scheme the background changes to gray, and in the classic display scheme it changes to green.

If a simple filter is currently applied to the module, the filter settings are displayed in the filter dialog when it is opened.

By default, the filter only affects what is displayed in the module window. If you want the filter to affect the Module Explorer, you can use either the **Apply Filtering to Explorer** menu option on the **View** menu or the **Apply Filtering to Explorer** button on the **Display** toolbar to set the Module Explorer to display only the results of the filter. Objects that are excluded from the filter are disabled in the Module Explorer.

**Statistics**

If you click **Apply** after defining your filter, the statistics box will display the following information:

<table>
<thead>
<tr>
<th>Select</th>
<th>To</th>
</tr>
</thead>
</table>
| Show all table cells | To display all table cells and their contents regardless of whether they match the filter definition.  
If you wish to retain the structure of tables in the module when filtering, ensure this check box is selected. |

**Using an advanced filter**

For information about filters, see “Filters,” on page 113.

For information about using simple filters, see “Using a simple filter,” on page 115.

**To use an advanced filter:**

1. In the module window, click **Tools > Filter > Define**.
2. Click Advanced.

3. There are four tabs at the top of the screen: Attributes, Links, Objects, and Columns.

4. Use these tabs and check boxes to define simple filtering criteria, and then click Add to add it to the list of rules. For information about these tabs, see “Using a simple filter,” on page 115.

5. Use the And, Or and Not buttons to define complex filtering criteria.

The following table describes the buttons on the Advanced Filter window.

<table>
<thead>
<tr>
<th>Use</th>
<th>If you want to</th>
</tr>
</thead>
<tbody>
<tr>
<td>And</td>
<td>Include all the objects that match two or more filtering criteria. For example, you want to include all objects that have a priority greater than 3 and that contain the word steering. Select the rules you want to and together, and then click And.</td>
</tr>
<tr>
<td>Or</td>
<td>Include all the objects that match one or more filtering criteria. For example, you want to include all objects that either have a priority greater than 3 or contain the word steering, or both. Select the rules you want to or together, and then click Or.</td>
</tr>
<tr>
<td>Not</td>
<td>Include all the objects that do not match a particular filtering criterion. For example, you want to include all objects that do not contain the word steering. Select the rule, and then click Not.</td>
</tr>
</tbody>
</table>

And, Or, and Not add a new rule to the list.

To delete one or more filter rules from the list, select the rule then click Delete. If you delete a filter rule that has been applied to the module, the rule is displayed again the next time you open the Advanced Filter dialog box.

6. Select the rule you want to apply to your current view.

If you have created a complex and lengthy rule, it might be difficult to view the complete definition in the Filter Definition window. If you want to view the complete definition, select it in the filter definition pane and click
the **Description** button. A dialog box containing the complete filter definition is displayed.

Use the following filter options to control what is displayed on your screen.

<table>
<thead>
<tr>
<th>Select</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show ancestors</td>
<td>Display all the ancestors of the objects that match the filter, as well as the objects themselves. For each object that matches the filter, Rational DOORS displays its parent, grandparent, and so on. This lets you see where the objects that match the filter fit in the object hierarchy.</td>
</tr>
<tr>
<td>Show descendants</td>
<td>Display all the descendents of the objects that match the filter criteria, as well as the objects themselves. For each object that matches the criteria, Rational DOORS displays the tree of objects below it.</td>
</tr>
<tr>
<td>Show all table cells</td>
<td>To display all table cells and their contents regardless of whether they match the filter definition. If you wish to retain the structure of tables in the module when filtering, ensure this check box is selected.</td>
</tr>
</tbody>
</table>

7. When you have finished, click **Apply** or **OK**

The module background color changes to show that a filter is being applied to the data. The color depends on the display scheme you are using. For example, in the modern display scheme the background changes to gray, and in the classic display scheme it changes to green.

**Statistics**

If you click **Apply** after defining your filter, the statistics box will display the following information:

<table>
<thead>
<tr>
<th>Total Objects</th>
<th>The total number of objects in the current module</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accepted</td>
<td>The number of objects that fulfill the filter criteria</td>
</tr>
<tr>
<td>Rejected</td>
<td>The number of objects that do not fulfill the filter criteria</td>
</tr>
</tbody>
</table>
Applying filtering to the Module Explorer

When you set a filter you can determine whether the Module Explorer displays all the objects in the module, or only those objects that are displayed by the filter. Objects that are excluded from the filter are disabled.

To apply filtering to the Module Explorer:
- Click View > Apply Filtering to Explorer.

Turning the Module Explorer filter off and on again shows the results of the last filter. It does not reapply the filter.

For example, you filter a module to show only the objects that have a high priority and apply the filter to the Module Explorer. Object 13 has a high priority, so it is displayed on your screen. You turn filtering off, and then edit object 13 and change its priority to medium. When you turn the filter back on, you still see object 13 because it matched the filter when you first applied the filter. To filter the data using the current values, you must reapply the filter.

To reapply your filter, click Tools > Filter > Reapply or click Reapply filter on the Display toolbar.

Turning filtering on and off

To turn filtering on and off:
- Click View > Show > Filter.

Turning the filter off and on again shows the results of the last filter. It does not reapply the filter.

For example, you filter a module to show only the objects that have a high priority. Object 13 has a high priority, so it is displayed on your screen. You turn filtering off, and then edit object 13 and change its priority to medium. When you turn the filter back on, you still see object 13 because it matched the filter when you first applied the filter. To filter the data using the current values, you must reapply the filter.

To reapply your filter, click Tools > Filter > Reapply or click Reapply filter on the Display toolbar.

Sorts

Sorting lets you control the order in which objects are displayed on your screen.
By default, objects are displayed in an order that shows their structure in the tree, like sections in a book. First there is section 1, and then section 2, and so on. Section 1 is subdivided first into section 1.1, and then section 1.2, and so on.

Use a sort if you want to use the value of one or more attributes to sort your data. For example, sort on the **Priority** attribute to display objects in order of either ascending or descending priority, or sort first on the **Priority** attribute, and then on the **Risk** attribute. When two objects have the same priority, they are sorted in risk order.

**Note** Tables are ignored when you sort. >> Table is displayed instead of a table whenever sorting is turned on. Sorting only affects what is displayed in the module window. The Module Explorer always shows the data in the standard order.

### Sorting

For information about sorting, see “Sorts,” on page 121.

**To sort:**

1. In the module window, click **Tools > Sort**.
2. Define each sort you want to use:
   a. In the **Sort on** box, select the attribute you want to sort on.
   b. In the **Order** box, select the order you want to sort in, **Ascending** or **Descending**.
   c. Click **Add** to add it to the Sort List.
3. The sorts are applied in the order in which they are listed in the **Sort List**.
   To change the order of the items in the list, select an item then click **Up** or **Down**.
4. To remove an item from the list, select it then click **Remove**.
5. Click **Apply** if you want to keep the Sort dialog box open when the sort is applied, or **OK** to apply the sort and close the Sort dialog box.
   If you change the current sort and click **Apply**, you can revert to the original sort by clicking the **Revert** button.

The objects are sorted. An arrow is displayed in the column title bar, showing whether the sort is ascending (up arrow) or descending (down arrow). The number to the right of the arrow shows the sort order.
Note Sorting only affects what is displayed in the module window. The Module Explorer always shows the data in the standard order.

To sort on an attribute that is displayed in a column in your current view:
Right-click on the column heading and click Sort > Ascending or Sort > Descending. The module is sorted according to the contents of the column, and an arrow and the number 1 (one) is displayed in the column title bar to show that a sort has been applied. Any other sort that was applied to the module is removed.
If you open the Sort dialog box, the sort is displayed in the Sort List box.

Note Sorting only affects what is displayed in the module window. The Module Explorer always shows the data in the standard order.

Turning sorting on and off

To turn sorting on and off:
• Click View > Show > Sort.
Turning the sort off and on again shows the results of the last sort. It does not reapply the sort.
For example, you apply a sort, and then you turn sorting off and edit the values of the attribute you sorted on. If you turn sorting on again, the objects are displayed in exactly the same order as when you applied the sort, based on the values of the attribute at that time. To sort the data on the current values of the attribute, you must reapply the sort.

To reapply your sort:
1. In the module window, click Tools > Sort.
   Your current sort is displayed in the Current sort box.
2. Click Apply or OK to reapply the sort.

Searching with regular expressions

You can use regular expressions when you are searching for text in module windows. For example:
• Use c.t to search for all three letter words that start with c and end in t.
• Use 200[7 | 8 | 9] if you want to search for either 2007, 2008 or 2009.
**Note** In the Database Explorer, the Find tool uses both standard Windows wildcards and regular expressions. In module windows, the Find tool uses regular expressions, not wildcards.

The following table shows the characters you can use to build regular expressions:

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Example</th>
<th>Matches</th>
</tr>
</thead>
<tbody>
<tr>
<td>*</td>
<td>a*</td>
<td>zero or more a characters (every string matches this expression)</td>
</tr>
<tr>
<td>+</td>
<td>a+</td>
<td>one or more a characters</td>
</tr>
<tr>
<td>.</td>
<td>*</td>
<td>any number of any characters except for newline characters (in other words, any string)</td>
</tr>
<tr>
<td>\</td>
<td>.</td>
<td>a period (.) character</td>
</tr>
<tr>
<td>^</td>
<td>^The.*</td>
<td>any line that starts with the string The</td>
</tr>
<tr>
<td>$</td>
<td>Monday.$</td>
<td>any line that ends with the string Monday followed by a period (.)</td>
</tr>
<tr>
<td>( )</td>
<td>(ref)+ (bind)*</td>
<td>at least one ref string then zero or more bind strings</td>
</tr>
<tr>
<td>[ ]</td>
<td>[sS]hall.*.$</td>
<td>any line that contains either shall or Shall and that ends with a period (.)</td>
</tr>
<tr>
<td></td>
<td>[^abc]</td>
<td>any character except a, b, or c</td>
</tr>
<tr>
<td></td>
<td>[a-zA-Z]</td>
<td>any alphabetic character (upper or lower case)</td>
</tr>
</tbody>
</table>
Searching with regular expressions

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Example</th>
<th>Matches</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>[0–9]</td>
<td>any numeric character (number between 0 and 9)</td>
</tr>
<tr>
<td></td>
<td>alternative</td>
<td>(dat</td>
</tr>
</tbody>
</table>
Finding, filtering and sorting
This chapter contains the following topics:

- System attributes
- Attribute types
- Showing attribute types
- Creating an attribute type
- Controlling access to an attribute type
- Editing an attribute type
- Deleting an attribute type
- Showing attribute definitions
- Creating an attribute definition
- Controlling access to an attribute definition
- Controlling access to an attribute value
- Editing an attribute definition
- Sharing attribute and type definitions
- Deleting an attribute definition
- DXL attributes and layout DXL columns
- Copying attribute values
- Measuring the frequency of attribute values

**System attributes**

*System attributes* are attributes that are automatically created by Rational DOORS.

For example, when you create a module, Rational DOORS automatically creates a system attribute, called **Created On**, that contains the date when the module was created.
The following table lists the system attributes for modules. You cannot edit the ones that are read-only:

<table>
<thead>
<tr>
<th>System attributes for modules</th>
<th>Description</th>
<th>Read-only</th>
</tr>
</thead>
<tbody>
<tr>
<td>Created By</td>
<td>The user name of the person who created the module.</td>
<td>Yes</td>
</tr>
<tr>
<td>Created On</td>
<td>The date when the module was created.</td>
<td>Yes</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the module.</td>
<td>No</td>
</tr>
<tr>
<td>Last Modified By</td>
<td>The user name of the person who last modified the module.</td>
<td>Yes</td>
</tr>
<tr>
<td>Last Modified On</td>
<td>The date when the module was last modified.</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>This attribute value can be used together with the module history to provide information about changes to the module.</td>
<td></td>
</tr>
<tr>
<td>Mapping</td>
<td>The type of link mapping, for example one-to-one or many-to-many (link modules only).</td>
<td>Yes</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the module.</td>
<td>No</td>
</tr>
<tr>
<td>Prefix</td>
<td>The prefix part of the object identifiers. An object identifier consists of an optional prefix, followed by an absolute number that is automatically generated by Rational DOORS.</td>
<td>No</td>
</tr>
<tr>
<td>Remote Created By</td>
<td>The user name of the person who created the rejoined module (module that is part of a partition that has been rejoined).</td>
<td>Yes</td>
</tr>
<tr>
<td>Remote Created On</td>
<td>The date when the rejoined module was created (module that is part of a partition that has been rejoined).</td>
<td>Yes</td>
</tr>
</tbody>
</table>
## System attributes

The following table lists the system attributes for objects. You cannot edit the ones that are read-only:

<table>
<thead>
<tr>
<th>System attributes for objects</th>
<th>Description</th>
<th>Read-only</th>
</tr>
</thead>
<tbody>
<tr>
<td>Absolute Number</td>
<td>The unique number that was automatically generated by Rational DOORS when you created the object.</td>
<td>Yes</td>
</tr>
<tr>
<td>Created By</td>
<td>The user name of the person who created the object.</td>
<td>Yes</td>
</tr>
<tr>
<td>Created On</td>
<td>The date when the object was created.</td>
<td>Yes</td>
</tr>
<tr>
<td>Created Thru</td>
<td>Whether the object was created by copying, extraction, or manual input (formal modules only).</td>
<td>Yes</td>
</tr>
<tr>
<td>Last Modified By</td>
<td>The user name of the person who last modified the object.</td>
<td>Yes</td>
</tr>
<tr>
<td>Last Modified On</td>
<td>The date when the object was last modified.</td>
<td>Yes</td>
</tr>
<tr>
<td>Object Heading</td>
<td>The object heading (formal modules only).</td>
<td>No</td>
</tr>
<tr>
<td>Object Short Text</td>
<td>The text that is used by default in Graphics mode in object boxes (formal modules only).</td>
<td>No</td>
</tr>
</tbody>
</table>
### Using attributes

<table>
<thead>
<tr>
<th>System attributes for objects</th>
<th>Description</th>
<th>Read-only</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object Text</td>
<td>The object text (formal and link modules only).</td>
<td>No</td>
</tr>
</tbody>
</table>
| OLE                           | Advanced system attributes that show status information (formal modules only). For example, **Picture** is a boolean attribute that has the value **True** if the object contains a picture. These attributes are normally hidden. To display them:  
  a. Click **Tools > Options**.  
  b. Click the **Settings** tab.  
  c. Select the **Show advanced system attributes** check box.  
  d. Click **OK**. | Yes |
| OLEIconic                     |                   |           |
| Picture                       |                   |           |
| PictureName                   |                   |           |
| PictureNum                    |                   |           |
| TableBottomBorder             | Advanced system attributes that show status information (formal modules only). To display them:  
  a. Click **Tools > Options**.  
  b. Click the **Settings** tab.  
  c. Select the **Show advanced system attributes** check box.  
  d. Click **OK**. | No |
| TableCellAlign                |                   |           |
| TableCellWidth                |                   |           |
| TableChangeBars               |                   |           |
| TableLeftBorder               |                   |           |
| TableLinkIndicators           |                   |           |
| TableRightBorder              |                   |           |
| TableShowAttrs                |                   |           |
| TableShowBookform             |                   |           |
| TableShowWide                 |                   |           |
| TableShowWide                 |                   |           |
| TableType                     |                   |           |
| TableTopBorder                |                   |           |
| TableType                     |                   |           |

### Attribute types

Each attribute has a type, which controls the type and range of values that you can store in it. For example, you can only store integer values in attributes of type **Integer**, and dates in attributes of type **Date**.
Rational DOORS provides the base types shown in the following table:

<table>
<thead>
<tr>
<th>This base type</th>
<th>Can store this type of value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Text. A Text attribute type can include paragraphs (newline characters), and there is no restriction on the number of characters that can be entered.</td>
</tr>
<tr>
<td>String</td>
<td>Text. A String attribute type cannot include paragraphs (newline characters), and there is an upper limit of 968 on the number of characters that can be entered. The upper limit of 968 includes hidden characters and not just visible characters. For example, rich text contains hidden characters and these are included as part of the 968 characters; unicode and upper ASCII characters take up more internal storage space than plain ASCII characters. If you try to enter a value that contains more than 968 characters, an error will be reported, and the value will be truncated. If you need to enter a large number of characters, use a Text attribute as there is no restriction on the number of characters that can be stored in a Text attribute.</td>
</tr>
<tr>
<td>Integer</td>
<td>An integer (a whole number, such as 4 or 57). It can be positive or negative.</td>
</tr>
<tr>
<td>Real</td>
<td>A decimal value (for example, 5.619). It can be positive or negative.</td>
</tr>
<tr>
<td>Date</td>
<td>A date, for example, 15 May 2010. For more information, see the section on understanding how dates and times are recorded in Managing Rational DOORS.</td>
</tr>
</tbody>
</table>
| Enumeration    | One of a predefined list of values. For example, you can define an attribute called Priority whose:  
  • Base type is Enumeration.  
  • Values are High, Medium, and Low. |
| Username       | A Rational DOORS user name. |
You can construct your own types from these base types. For example, you create a type called Percentage that has a base type of Integer and that can have values in the range 0 to 100. You then create various attributes of type **Percentage**. You know that users can only assign integer values between 0 and 100 to those attributes. Rational DOORS automatically rejects any other values as invalid.

You can also use types as a way of letting users know what units of measurement an attribute’s values should use. For example, you create a type called **Kg** that has a base type of **Integer**, and then create an attribute called **Weight** of type **Kg**. If an experienced Rational DOORS user is looking at your **Weight** values, and is not sure what units the weight is measured in, they can check the attribute type and see that the units are Kg.

The following table shows examples of attribute types you might want to create:

<table>
<thead>
<tr>
<th>Example type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Kg</td>
<td>A type of base type <strong>Integer</strong>, used for storing weights.</td>
</tr>
<tr>
<td>Dollar</td>
<td>A type of base type <strong>Integer</strong>, used for storing costs.</td>
</tr>
<tr>
<td>Percentage</td>
<td>A type of base type <strong>Integer</strong>, with a minimum value of 0 and a maximum value of 100.</td>
</tr>
<tr>
<td>Deviation</td>
<td>A type of base type <strong>Real</strong>, with a minimum value of 0.5 and a maximum value of 1.5.</td>
</tr>
<tr>
<td>Priority</td>
<td>A type of base type <strong>Enumeration</strong>, with the values Mandatory, Desirable and Luxury.</td>
</tr>
<tr>
<td>Project Span</td>
<td>A type of base type <strong>Date</strong>, with a minimum value of 1 December 2009 and maximum value of 31 May 2010.</td>
</tr>
</tbody>
</table>

### Showing attribute types

To show attribute types:

1. In the module window, click **Edit > Types**.
2. A list of all the attribute types for the module is displayed.
Creating an attribute type

To create an attribute type, you must have create and modify access to the module.

To create an attribute type:

1. Make sure you are in exclusive edit mode.
   
   The edit mode is shown on the status bar at the bottom of the module window. To change your edit mode, click Edit > Edit Mode > Exclusive Edit.

2. Click Edit > Types.

3. Either click New to create a type from scratch, or select the type you want to copy, and then click Copy.

4. Type the name of the new attribute type in the Type name box.

5. Select the base type in the Base type box.

6. If the base type allows a range of values to be defined, you can type minimum and maximum values in the Minimum value and Maximum value boxes.

7. If the base type is Enumeration, click the Enumerations tab, and then define the values that attributes of this type can have.

<table>
<thead>
<tr>
<th>Enumerations tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value</td>
<td>Enter a value for the attribute in the Value box, and then click Add.</td>
</tr>
<tr>
<td>Related number</td>
<td>If you want, you can enter a number that you want to assign to the value. This number is used when you sort or filter using an operator that uses a numeric value. For example, you can filter on values greater than 5.</td>
</tr>
<tr>
<td>Default</td>
<td>Click this radio button if you want to use the default color for the attribute value.</td>
</tr>
<tr>
<td>Specified</td>
<td>Click this radio button if you do not want to use the default color for the value, and then select the color you want from the drop-down list.</td>
</tr>
</tbody>
</table>
Using attributes

<table>
<thead>
<tr>
<th>Enumerations tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Adds the value in the Value box (and optionally also the number in the Related number box) to the list of attribute values in the right box.</td>
</tr>
<tr>
<td>Replace</td>
<td>Replaces the entry in the list of attribute values in the right box, with the contents of the Value and Related number boxes on the left.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the entry from the list of attribute values in the right box.</td>
</tr>
<tr>
<td></td>
<td>Changes the order of the entries in the list of attribute values in the right box.</td>
</tr>
</tbody>
</table>

8. By default, the new attribute type inherits its access rights from the module. If you want to change its access rights use the Access tab. For more information see “Controlling access to an attribute type,” on page 133.

9. Click OK.

10. Click Close.

Controlling access to an attribute type

Use access rights to control who can edit an attribute type.

For example, the delivery dates for a project must fall within fixed dates. The Project Manager creates an attribute type called Delivery, that can have a range of date values. She gives other users read-only access to the attribute type, so that they cannot change the date ranges.

To change the access rights for an attribute type, you must have admin access to it.

To change the access rights for an attribute type:

1. Open the module that contains the attribute type you want to change.
2. Click Edit > Types.
3. Select the attribute type, and then click Edit.
4. Click the Access tab.
Controlling access to an attribute type

The current access rights for the attribute type are displayed.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>See the attribute type.</td>
</tr>
<tr>
<td>Modify (M)</td>
<td>Change the attribute type in any way.</td>
</tr>
<tr>
<td>Delete (D)</td>
<td>Delete the attribute type.</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Change the access rights for the attribute type.</td>
</tr>
</tbody>
</table>

If the module is partitioned in, the access rights associated with the partition are displayed. These describe the maximum access that any user has. They override the RMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RMDA), but the module is partitioned in read-only, in practice the user has only read (R) access to the attribute type.

5. Make the changes you want.

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit from parent</td>
<td>Select this check box if you want the attribute type to inherit its access rights from the module. When this check box is selected, the list of access rights is unavailable, and shows what access rights the attribute type is inheriting.</td>
</tr>
</tbody>
</table>
| Add            | To add a new entry to the list of access rights:  
  a. Click **Add**.  
  The **Add Access** window is displayed.  
  b. In the **Name** box, select the name of the user or group that you want to add an entry for.  
  c. Select the access rights you want to give them, and then click **OK**. |
| Remove         | To remove an entry from the list of access rights, select the entry, and then click **Remove**. |
Using attributes

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
</table>
| Edit       | To edit an entry in the list of access rights:  
  a. Select the entry then click **Edit**.  
  The **Edit Access** window is displayed.  
  b. Select the access rights you want to give them, and then click **OK**. |

6. Click **OK**.
7. Click **Close**.

Save the module to make the changes permanent (click **File > Save**).

Editing an attribute type

To edit an attribute type, you must have modify access to both the attribute type and the module.

**To edit an attribute type:**

1. Make sure you are in exclusive edit mode.

   The edit mode is shown on the status bar at the bottom of the module window. To change your edit mode, click **Edit > Edit Mode > Exclusive Edit**.

2. Click **Edit > Types**.

3. Select the type you want to edit, and then click **Edit**. Base types are read-only.

4. Make the changes you want. For information about the boxes and tabs on the screen, see “Creating an attribute type,” on page 131.

5. Click **OK**.

   If you made the range of values more restrictive for an attribute type, any values in the module that are now out of range are unchanged until the object containing them is edited. At that point the user is forced to change the value so it falls within the new range.

6. If you edited the values of an enumerated attribute type:

   • If you replaced a value, Rational DOORS automatically updates the value of any attribute that had that enumerated value.
   • If you delete a value:
Deleting an attribute type

You cannot delete an attribute type that is being used in an attribute definition. To delete an attribute type, you must have delete access to the attribute type and modify access to the module.

To delete an attribute type:

1. Make sure you are in exclusive edit mode.
   
   The edit mode is shown on the status bar at the bottom of the module window. To change your edit mode, click Edit > Edit Mode > Exclusive Edit.

2. Click Edit > Types.

3. Select the type you want to delete, and then click Delete.
   
   A message is displayed asking if you really want to delete the attribute type.

4. Click Yes.

5. Click Close.

Showing attribute definitions

To show attribute definitions:

1. In the module window, click Edit > Attributes.

2. A list of attribute definitions is displayed:

   - The Name column shows the name of the attribute definition.
   - The Description column displays whether the attribute is a system attribute.
   - The Type column shows the attribute type.

7. Click Close.
• The **Default value** column shows its default value.
• The **Inherits value** column shows whether it inherits its value.
• The **Exists for** column shows whether it is an object attribute a module attribute, or both.
• If it is an enumerated attribute, the **Multi-valued** column tells you whether it can have multiple values.

**Creating an attribute definition**

To create an attribute definition, you must have create and modify access to the module.

**To create an attribute definition:**

1. Make sure you are in exclusive edit mode.
   
   The edit mode is shown on the status bar at the bottom of the module window. To change your edit mode, click **Edit > Edit Mode > Exclusive Edit**.

2. Click **Edit > Attributes**.
   
   On the **Attributes** tab, a list of attributes is displayed.

3. If you want the new attribute to have a type that does not already exist, click the **Types** tab and create the type (see “Creating an attribute type,” on page 131).

4. On the **Attributes** tab, either click **New** to create an attribute from scratch, or select the attribute you want to copy, and then click **Copy**.

5. Type the name of the new attribute in the **Name** box, and type a description in the **Description** box.

6. Select the other options on the **General** tab.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>The name you want to give the new attribute. The name must be unique within the module.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Additional information about the new attribute.</td>
</tr>
<tr>
<td><strong>Type</strong></td>
<td>The type of the new attribute. The options in the dialog box change depending on what type you select.</td>
</tr>
</tbody>
</table>
Creating an attribute definition

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Locale</strong></td>
<td>This option is displayed when either <strong>Text</strong> or <strong>String</strong> attribute types are selected. Select a locale for the attribute. By default this is the current locale on the client machine. For more information, see the section on understanding locales in <em>Managing Rational DOORS</em>, which is part of the DOORS documentation set.</td>
</tr>
<tr>
<td><strong>DXL attribute</strong></td>
<td>Select this check box if you want to use a DXL program to assign values to the attribute. Click <strong>Browse</strong> to select the DXL program you want to use, or <strong>Wizard</strong> to create a DXL attribute using the DXL Attribute Wizard. For information about the DXL Attribute Wizard, see “Creating a new DXL attribute,” on page 140</td>
</tr>
</tbody>
</table>
| **Browse** | If you selected the **DXL attribute** check box:  
  a. Click **Browse** to select the DXL program.  
     A list of all predefined DXL programs that can be used to set attribute values is displayed.  
  b. Select the program you want to use, and then click **Apply**. Alternatively, if you want to define a new program, click **New**. |
| **Multi-valued** | Select this check box if the attribute type has a base type of Enumeration, and you want to be able to store more than one value in the attribute. |
| **Default value** | If you want the new attribute to have a default value, select the **Default value** check box, and then type the value in the box.  
If the new attribute has an attribute type of **Date**, you can type the default value, or select a date from the drop down calendar.  
If the default value is greater than 988 characters, a message is displayed, informing you the value may be truncated. |
7. By default, the attribute inherits its access rights from the module.

   If you want to change its access rights use the Access (Definition) and Access (Value) tabs. For more information see “Controlling access to an attribute definition,” on page 141 and “Controlling access to an attribute value,” on page 143.

8. Click OK.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include time of day</td>
<td>This option is available when date attribute types are selected. If you select this box, date and time values are displayed using the default short date format for your current locale, and a 24-hour clock. If you clear this box, date values are displayed using the default long date format for your current locale.</td>
</tr>
<tr>
<td>Objects</td>
<td>Select this check box if you want the attribute to apply to the objects in the module.</td>
</tr>
<tr>
<td>Module</td>
<td>Select this check box if you want the attribute to apply to the module.</td>
</tr>
<tr>
<td>Inherit value</td>
<td>Select this check box if the attribute applies to objects, and if you want objects to be able to inherit the attribute value from their parent objects. Note that if the attribute applies to both the module and objects in it, top-level objects do not inherit the value from the module.</td>
</tr>
<tr>
<td>Affect change bars</td>
<td>Select this check box if you want Rational DOORS to update an object’s change bar when anyone edits the attribute values.</td>
</tr>
<tr>
<td>Affect change dates</td>
<td>Select this check box if you want Rational DOORS to update an object’s last modified date when anyone edits the attribute values.</td>
</tr>
<tr>
<td>Generate history</td>
<td>Select this check box if you want Rational DOORS to update the database history when anyone edits the attribute values.</td>
</tr>
<tr>
<td>Add new attribute to current view</td>
<td>Select this check box if you want to add a column for the new attribute to your current view.</td>
</tr>
</tbody>
</table>
Creating an attribute definition

9. Click Close.

10. Save the module to make the change permanent (click File > Save).

Creating a new DXL attribute

You can use the DXL Attribute Wizard to create a DXL attribute that contains the values of other attributes in the module. This is particularly useful for displaying the values of more than one attribute in table cells.

1. Click Edit > Attributes, and click New.

2. Type a name for the attribute in the Name box.

3. Select Text in the Type box.

4. Select DXL attribute and click Wizard.

   The DXL Attribute Wizard opens.

5. Click Next.

   The DXL Attribute Wizard Step 2 is displayed.

6. Select the attributes you want to include in the DXL attribute and click Next.

   The DXL Attribute Wizard Step 3 is displayed.

7. Move the attributes up or down the list by selecting the attribute name and clicking the up or down arrow. Click Next.

   The DXL Attribute Wizard Step 4 is displayed.

8. The following options are available:

   • One attribute per line
   • Show attribute names
   • Include OLE objects in text.

   Select or clear the options as required and click Next.

   The DXL Attribute Wizard Step 5 is displayed.

9. Click Finish.

   The new attribute is created. If you do not want the attribute displayed in a column in the module, clear the Add new attribute to current view check box on the New attribute dialog box.

10. Click OK.
Controlling access to an attribute definition

Use access rights to control who can edit an attribute definition.

For example, you might want to lock Generate history on for an attribute definition. If users can edit the attribute definition, a dishonest user could conceal a change to an attribute value by temporarily turning Generate history off, changing the attribute value, and then turning Generate history on again. Although the modification of the attribute definition would be recorded in the module’s history, you would miss the change to the attribute value. By setting strict access rights, this unlikely event becomes impossible.

To change the access rights for an attribute definition, you must have admin access to it.

To change the access rights for an attribute definition:
1. Open the module that contains the attribute definition you want to change.
2. Click Edit > Attributes.
3. Select the attribute, and then click Edit.
4. Click the Access (Definition) tab.

The current access rights for the attribute definition are displayed.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>See the attribute definition</td>
</tr>
<tr>
<td>Modify (M)</td>
<td>Change the attribute definition in any way</td>
</tr>
<tr>
<td>Delete (D)</td>
<td>Delete the attribute definition</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Change the access rights for the attribute definition</td>
</tr>
</tbody>
</table>

If the module is partitioned in, the access rights associated with the partition are displayed. These describe the maximum access that any user has. They override the RMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RMDA), but the attribute is partitioned in read-only, in practice the user has only read (R) access.
5. Make the changes you want.

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit from parent</td>
<td>Select this check box if you want the attribute definition to inherit its access rights from the module. When this check box is selected, the list of access rights is unavailable, and shows what access rights the attribute definition is inheriting.</td>
</tr>
<tr>
<td>Add</td>
<td>To add a new entry to the list of access rights:</td>
</tr>
<tr>
<td></td>
<td>a. Click Add.</td>
</tr>
<tr>
<td></td>
<td>The Add Access window is displayed.</td>
</tr>
<tr>
<td></td>
<td>b. In the Name box, select the name of the user or group that you want to add an entry for.</td>
</tr>
<tr>
<td></td>
<td>c. Select the access rights you want to give them, and then click OK.</td>
</tr>
<tr>
<td>Remove</td>
<td>To remove an entry from the list of access rights, select the entry, and then click Remove.</td>
</tr>
<tr>
<td>Edit</td>
<td>To edit an entry in the list of access rights:</td>
</tr>
<tr>
<td></td>
<td>a. Select the entry then click Edit.</td>
</tr>
<tr>
<td></td>
<td>The Edit Access window is displayed.</td>
</tr>
<tr>
<td></td>
<td>b. Select the access rights you want to give them, and then click OK.</td>
</tr>
</tbody>
</table>

6. Click OK.

7. Click Close.

8. Save the module to make the changes permanent (click File > Save).

**Controlling access to an attribute value**

Use access rights on an attribute’s values to control who can edit the values. To edit the value of an attribute for a particular object, you need modify access to both the object and the attribute’s values.

For example, you give everyone read-only access to the **Priority** attribute’s values. This lets everyone see the priority of each object, but they cannot change the priority even if they have modify access to the object.
To change the access rights for an attribute value, you must have admin access to it.

**To change the access rights for an attribute value:**

1. Open the module that contains the attribute value you want to change.
2. Click *Edit > Attributes*.
3. Select the attribute, and then click *Edit*.
4. Click the **Access (Value)** tab.

The current access rights for the attribute values are displayed.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>See the value of the attribute for any object.</td>
</tr>
<tr>
<td>Modify (M)</td>
<td>Change the value of the attribute for any object.</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Change the access rights for the attribute value.</td>
</tr>
</tbody>
</table>

If the module is partitioned in, the access rights associated with the partition are displayed. These describe the maximum access that any user has. They override the RM access rights displayed for users and groups.

For example, if a user’s entry says full access (RMA), but the attribute is partitioned in read-only, in practice the user has only read (R) access.

5. Make the changes you want.

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit from parent</td>
<td>Select this check box if you want the attribute value to inherit its access rights from the module. When this check box is selected, the list of access rights is dimmed, and shows what access rights the attribute value is inheriting.</td>
</tr>
</tbody>
</table>
Editing an attribute definition

To edit an attribute definition, you must have modify access to both the attribute definition and the module it is in.

To edit an attribute definition:

1. Make sure you are in exclusive edit mode.

   The edit mode is shown on the status bar at the bottom of the module window. To change your edit mode, click Edit > Edit Mode > Exclusive Edit.

2. Click Edit > Attributes.

3. Select the attribute you want to edit, and then click Edit.

6. Click OK.

7. Save the module to make the changes permanent (click File > Save).

---

**Access tab**  | **Description**
---|---
Add | To add a new entry to the list of access rights:
   a. Click Add.
   The Add Access window is displayed.
   b. In the Name box, select the name of the user or group that you want to add an entry for.
   c. Select the access rights you want to give them, and then click OK.
Remove | To remove an entry from the list of access rights, select the entry, and then click Remove.
Edit | To edit an entry in the list of access rights:
   a. Select the entry then click Edit.
   The Edit Access window is displayed.
   b. Select the access rights you want to give them, and then click OK.
4. On the **General** tab, make the changes you want.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the attribute definition.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>When you change the name of an attribute definition, it is no longer recognized by any of the views it is in. Update each view to add a column for the attribute, and then save the view.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the attribute definition.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of the attribute. Once an attribute has been created, you cannot change its type, so this field is always unavailable.</td>
</tr>
<tr>
<td>Locale</td>
<td>This option is displayed when either <strong>Text</strong> or <strong>String</strong> attribute types are selected. Select a locale for the attribute. By default this is the current locale on the client machine. For more information, see the section on understanding locales in <em>Managing Rational DOORS</em>, which is part of the DOORS documentation set.</td>
</tr>
<tr>
<td>Locale</td>
<td>This option is displayed when either <strong>Text</strong> or <strong>String</strong> attribute types are selected. Select a locale for the attribute. By default this is the current locale on the client machine.</td>
</tr>
<tr>
<td>DXL attribute</td>
<td>Select this check box if you want to use a DXL program to assign values to a text attribute. Click <strong>Browse</strong> to select the DXL program you want to use, or <strong>Wizard</strong> to create a DXL attribute using the DXL Attribute Wizard. If you are editing an existing DXL attribute, see “Editing a DXL attribute definition,” on page 147.</td>
</tr>
<tr>
<td>Browse</td>
<td>If the <strong>DXL attribute</strong> check box is selected:</td>
</tr>
<tr>
<td></td>
<td><strong>a.</strong> Click <strong>Browse</strong>.</td>
</tr>
<tr>
<td></td>
<td>A list of all the predefined DXL programs that can be used to set attribute values is displayed.</td>
</tr>
<tr>
<td></td>
<td><strong>b.</strong> Select the program you want to use, and then click <strong>OK</strong>.</td>
</tr>
<tr>
<td></td>
<td>Alternatively, if you want to define a new program, click <strong>New</strong>.</td>
</tr>
</tbody>
</table>
Editing an attribute definition

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wizard</td>
<td>If the DXL attribute check box is selected:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Wizard</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. Step through the DXL Attribute Wizard, selecting the attributes that you want to display in the DXL attribute, the order in which you want them displayed, and how you want the information to be displayed.</td>
</tr>
<tr>
<td></td>
<td>c. Click <strong>Finish</strong> to create the DXL attribute.</td>
</tr>
<tr>
<td>Multi-valued</td>
<td>Select this check box if the attribute type has a base type of Enumeration, and you want to be able to store more than one value in the attribute.</td>
</tr>
<tr>
<td>Default value</td>
<td>If you want the attribute to have a default value, select the <strong>Default value</strong> check box, and then type the value in the box.</td>
</tr>
<tr>
<td></td>
<td>If the attribute has an attribute type of <strong>Date</strong>, you can type the default value, or select a date from the drop down calendar.</td>
</tr>
<tr>
<td></td>
<td>When you change the default value of an attribute definition, the values of any attributes that have been assigned the previous default value are updated.</td>
</tr>
<tr>
<td>Include time of day</td>
<td>This option is available when date attribute types are selected.</td>
</tr>
<tr>
<td></td>
<td>If you select this box, date and time values are displayed using the default short date format for your current locale, and a 24-hour clock.</td>
</tr>
<tr>
<td></td>
<td>If you clear this box, date values are displayed using the default long date format for your current locale.</td>
</tr>
<tr>
<td>Objects</td>
<td>Select this check box if you want the attribute to apply to the objects in the module.</td>
</tr>
<tr>
<td>Module</td>
<td>Select this check box if you want the attribute to apply to the module.</td>
</tr>
<tr>
<td>Inherit value</td>
<td>Select this check box if the attribute applies to objects, and if you want the objects to be able to inherit the attribute value from their parent objects.</td>
</tr>
<tr>
<td></td>
<td>Note that if the attribute applies to both the module and objects in it, top-level objects do not inherit the value from the module.</td>
</tr>
</tbody>
</table>
5. Use the **Access (Definition)** tab if you want to change who can see or modify the definition of the attribute. For more information, see “Controlling access to an attribute definition,” on page 141.

6. Use the **Access (Values)** tab if you want to change who can read or modify the attribute’s values. For more information, see “Controlling access to an attribute value,” on page 143.

7. Click **OK**.

8. Click **Close**.

9. Save the module to make the changes permanent (click **File > Save**).

### Editing a DXL attribute definition

If the DXL attribute you are editing was created using the DXL Attribute Wizard, edit it using the wizard. Edit any other DXL attributes by clicking the **Browse** button.

**If the DXL attribute was created using the DXL Attribute Wizard:**

1. Select the DXL attribute you want to edit.

2. Click **Wizard**.

   The **DXL Attribute Wizard** is displayed.

3. Click **Next**.

   The **DXL Attribute Wizard Step 2** is displayed. The attributes that are currently included in the DXL attribute definition are selected.

**Note** If no attributes are selected on this screen, the DXL attribute was probably not created using the wizard. If you continue, any DXL that is currently associated with the attribute will be overwritten. If you do not want to

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Affect change bars</td>
<td>Select this check box if you want change bars to be updated when you edit the attribute values.</td>
</tr>
<tr>
<td>Affect change dates</td>
<td>Select this check box if you want last modified dates to be updated when you edit the attribute values.</td>
</tr>
<tr>
<td>Generate history</td>
<td>Select this check box if you want changes to the attribute’s values to be recorded in the database history.</td>
</tr>
</tbody>
</table>
overwrite the existing DXL, click **Cancel** and use the **Browse** button to edit the DXL attribute.

4. Select the attributes you want to add to the DXL attribute definition, and clear the attributes that you want to remove from the attribute definition.

5. Click **Next**.
   
   The **DXL Attribute Wizard Step 3** is displayed.

6. Move the attributes up or down the list by selecting the attribute name and clicking the up or down arrow.

7. Click **Next**.
   
   The **DXL Attribute Wizard Step 4** is displayed.

8. The following options are available:
   
   • One attribute per line
   • Show attribute names
   • Include OLE objects in text

   Select or clear the options as required and click **Next**.

   The **DXL Attribute Wizard Step 5** is displayed.

9. Click **Finish**.
   
   The DXL attribute definition is updated.

If the DXL attribute definition was not created using the DXL Attribute Wizard:

1. Select the DXL Attribute you want to edit.

2. Click **Browse**.
   
   The **Browse DXL** dialog box is displayed.

3. Click **Current**.
   
   The **Edit Attribute DXL** window opens, and the DXL associated with the attribute is displayed for editing and checking.

**Note** If the DXL was created by the DXL Attribute Wizard, this is indicated in the first line of the code. If you make manual changes to code that was generated by the wizard, and you subsequently edit the attribute using the wizard, the manual changes will not be recognized, and will be overwritten.
Sharing attribute and type definitions

Rational DOORS allows you import attribute types or attribute definitions into your current module from any module in the Rational DOORS database that you have read access to.

To import attribute definitions into an open module:

1. Click **Edit > Attributes**.
   
The **Columns and Attributes** window is displayed.

2. Select the **Attributes** tab.
   
The attributes that are available in the module are listed.

3. Click **Import**.
   
The **Import Attribute** dialog box is displayed.

4. Click **Browse**.
   
A Mini-Explorer window opens.

5. Browse to the source module containing the attribute definitions you want to import, and then click **OK**.
   
The source module’s attributes are listed in the **Import Attribute** dialog box.

6. Select the attribute definition or definitions that you want to import, and then click **OK**.
   
The dialog box closes. The attribute definitions are added to your open module and the display returns to the **Columns and Attributes** window.

7. Click **Close**.

To import type definitions into an open module:

1. Click **Edit > Types**.
   
The **Columns and Attributes** window is displayed.

2. Select the **Types** tab.
   
The types that are available in the module are listed.

3. Click **Import**.
   
The **Import Type** dialog box is displayed.

4. Click **Browse**
   
A Mini-Explorer window opens.
5. Browse to the source module containing the type definitions you want to import, and then click OK.

The source module’s types are listed in the Import Types dialog box.

6. Select the type definition(s) you want to import, and then click OK.

The window closes. The type definitions are added to your open module and the display returns to the Columns and Attributes window.

7. Click Close.

Deleting an attribute definition

To delete an attribute definition, you must have delete access to the attribute definition, and modify access to the module.

Note You cannot undelete an attribute definition once you have deleted it.

To delete an attribute definition:

1. Make sure you are in exclusive edit mode.

The edit mode is shown on the status bar at the bottom of the module window. To change your edit mode, click Edit > Edit Mode > Exclusive Edit.

2. Click Edit > Attributes.

3. Select the attribute you want to delete, and then click Delete.

4. A message is displayed asking if you really want to delete the attribute. Click Yes.

5. Click Close.

6. Save the module to make the change permanent (click File > Save).

DXL attributes and layout DXL columns

Both DXL attributes and layout DXL columns use DXL programs to calculate values displayed on your screen. For example, Rational DOORS provides DXL programs that calculate the number of days since an object was last modified, and the number of in-links and out-links for an object.

The differences between DXL attributes and layout DXL columns are subtle. With a DXL attribute, the DXL program is associated with an attribute definition. You can use the attribute in multiple columns and in multiple views.
With a layout DXL column, the DXL program is associated with a single column, but not with any attribute. A layout DXL column is a column that does not contain an attribute. Instead, it uses the DXL program to calculate what to display on your screen.

**Note**  Layout DXL does not process table objects.

The values of an object’s DXL attributes are automatically calculated only when the object is first displayed on your screen. To make Rational DOORS recalculate the values, click **Tools > Refresh DXL Attributes**. This updates the values of all the DXL attributes in the module by re-running the DXL programs associated with them in the background.

The values displayed in a layout DXL column are automatically recalculated whenever Rational DOORS refreshes your screen. If the DXL program associated with the column is compute intensive, the constant recalculation of the values can lead to poor performance. In this case you should consider using a DXL attribute instead of a layout DXL column.

You should also use attribute DXL, or convert your layout DXL column to attribute DXL, if a large amount of data is displayed in the column. This is because you cannot scroll layout DXL if the object contains more data than can be displayed on the screen, but you can scroll attribute DXL.

For more information, see the DXL attributes section of the *DXL Reference Manual*. This manual is available as a PDF and from the Help menu in Rational DOORS.

### Copying attribute values

To copy values from one attribute to another, within the same module:

1. In the module window, click **Tools > Functions > Copy Attributes**.
2. In the **Source attribute** box, select the attribute that contains the values you want to copy.
3. In the **Destination attribute** box, select the attribute whose values you want to overwrite.
4. Click **OK**.
5. Save the module to make the changes permanent (click **File > Save**).
Measuring the frequency of attribute values

You can display a graph that shows the frequency of attribute values for all the objects in the current view.

This function is useful for monitoring attributes that have a small number of finite values, for example priority or pass/fail attributes. If you use it to monitor attributes that have a large number of values, for example Object Text, the resulting graph will not provide any useful information.

To display a graph of an attribute:

1. In the module window, click Tools > Functions > Statistics.
2. In the Attribute box, select the attribute you want to look at.
   The frequency of the attribute’s values for all objects in the current view are displayed graphically.
3. If you want to print the information or export it to a file, click Publish.
   If you want to print the page, you can control:
   • The page orientation
   • The horizontal and vertical scale
   • The top and left margins
Using attributes
Viewing data in formal modules

This chapter contains the following topics:

- Navigating using the keyboard
- The view menu
- The Module Explorer
- Display modes
- Changing the display mode
- Controlling display levels
- Controlling table attribute display
- Outlining
- Compression
- Working with columns
- Showing column information
- Adding a column
- Editing column information
- Color-coding your data
- Adding a graph column
- Adding an icon column

Navigating using the keyboard

The following table shows the keys you can use on your keyboard to navigate formal modules:

<table>
<thead>
<tr>
<th>Press</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>HOME</td>
<td>Go to the first object in the module.</td>
</tr>
<tr>
<td>END</td>
<td>Go to the last object in the module.</td>
</tr>
<tr>
<td>PAGE UP</td>
<td>Scroll up one screen in Document mode.</td>
</tr>
<tr>
<td></td>
<td>Rotate the tree clockwise through 90 degrees in Graphics mode.</td>
</tr>
</tbody>
</table>
Viewing data in formal modules

In a module window, use the following options on the View menu to change the way your screen looks and control what data is displayed:

<table>
<thead>
<tr>
<th>Press</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAGE DOWN</td>
<td>Scroll down one screen in Document mode.</td>
</tr>
<tr>
<td></td>
<td>Rotate the objects clockwise in Graphics mode.</td>
</tr>
<tr>
<td>UP ARROW DOWN ARROW</td>
<td>Go to the next or previous object in Document mode.</td>
</tr>
<tr>
<td></td>
<td>Move up or down the tree hierarchy in Graphics mode.</td>
</tr>
<tr>
<td>CTRL+UP ARROW</td>
<td>Move from the current object to the sibling above or below it.</td>
</tr>
<tr>
<td>CTRL+DOWN ARROW</td>
<td>Scroll, if the focus is on the left pane of the Module Explorer.</td>
</tr>
<tr>
<td>CTRL+LEFT ARROW</td>
<td>Go to the current object’s parent (left arrow) or first child (right arrow).</td>
</tr>
<tr>
<td>CTRL+RIGHT ARROW</td>
<td>Scroll if the focus is on the left pane of the Module Explorer.</td>
</tr>
<tr>
<td>SHIFT+RETURN</td>
<td>Edit the current object in-place in Document mode.</td>
</tr>
<tr>
<td></td>
<td>Go to the next object if you are already editing in-place.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> It does nothing if you are in Graphics mode, or if the focus is on the left pane of the Module Explorer.</td>
</tr>
</tbody>
</table>

The view menu

In a module window, use the following options on the View menu to change the way your screen looks and control what data is displayed:

<table>
<thead>
<tr>
<th>View menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Module Explorer</td>
<td>Turns the Module Explorer on or off. For more information, see “The Module Explorer,” on page 158.</td>
</tr>
<tr>
<td>Graphics Mode</td>
<td>Turns Graphics mode on or off. For more information, see “Display modes,” on page 159 and “Changing the display mode,” on page 160.</td>
</tr>
<tr>
<td>Outline</td>
<td>Turns outlining on or off. For more information, see “Outlining,” on page 162.</td>
</tr>
</tbody>
</table>
The view menu

<table>
<thead>
<tr>
<th>View menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compress</td>
<td>Compresses (or hides) parts of the data hierarchy when outlining is turned on. For more information, see “Compression,” on page 162.</td>
</tr>
<tr>
<td>Level</td>
<td>Controls how many levels of the hierarchy are displayed. For more information, see “Controlling display levels,” on page 161.</td>
</tr>
<tr>
<td>Tables</td>
<td>Controls the default attribute that is displayed in all tables in the module. For more information, see “Controlling table attribute display,” on page 161.</td>
</tr>
</tbody>
</table>
Viewing data in formal modules

<table>
<thead>
<tr>
<th>View menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show</td>
<td>Controls what is shown on your screen:</td>
</tr>
<tr>
<td></td>
<td>• Use Sort to control whether the display reflects the current sort criteria. It turns sorting on and off.</td>
</tr>
<tr>
<td></td>
<td>• Use Filter to control whether the display reflects the current filter criteria. It turns filtering on and off.</td>
</tr>
<tr>
<td></td>
<td>• Use Deletions to control whether deleted objects are displayed. Deleted objects are colored red and have black change bars.</td>
</tr>
<tr>
<td></td>
<td>• Use Pictures to control whether pictures are displayed.</td>
</tr>
<tr>
<td></td>
<td>• Use Table Cells to control whether tables are displayed. When a table is hidden, a table marker object (Table) is displayed instead of the table. Tables are automatically hidden when sorting is turned on. The left pane of the Module Explorer always displays table marker objects.</td>
</tr>
<tr>
<td></td>
<td>• Use Link Arrows to control whether link arrows are displayed. These are triangular arrows like this: . Note that you cannot use this option to show hidden link arrows in table cells, but you can use it to hide shown link arrows in table cells.</td>
</tr>
<tr>
<td></td>
<td>• Use Change Bars to control whether change bars are displayed.</td>
</tr>
<tr>
<td></td>
<td>• Use Graphics Links to control whether lines between linked objects in Graphics mode are displayed. You can click these lines to go to the source or target object.</td>
</tr>
<tr>
<td></td>
<td>• Use Graphics Datatips to control whether datatips are displayed in Graphics mode.</td>
</tr>
<tr>
<td>Refresh Explorer</td>
<td>Updates the left pane of the Module Explorer, so that it displays the current object.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refreshes the screen display.</td>
</tr>
</tbody>
</table>

The Module Explorer

To turn on the Module Explorer, do one of the following:

• Click View > Module Explorer.
• Click Module Explorer on the Display toolbar.
When you turn the Module Explorer on, two panes are displayed:

- The left pane has a Windows Explorer style display that lets you quickly navigate the object tree within the module.
- What is displayed in the right pane depends on whether you are in Document or Graphics mode and what display options, such as outlining, you are using.

When you turn the Module Explorer off, the left pane disappears and the right pane fills your screen.

**Display modes**

You can use the following display modes:

- Document mode
- Graphics mode

Document mode is the default. It displays the module data as a table, with rows and columns.

In Graphics mode each object is displayed as a box that contains one attribute:

You can choose which attribute is displayed in the box (see “Changing the display mode,” on page 160). By default, it is the **Object Short Text** attribute. If the object does not have an **Object Short Text**, one of the following is used, in order of priority: **Object Heading**, and then **Object Text**, and then Object Identifier.

The box on the left shows the title of the main column.

In Graphics mode:

- The current object has a pink border, and is always visible on your screen.
  
  As you navigate around the module, the display changes to keep the current object near the center of your screen. On a large screen, it magnifies the objects in the center and makes the objects at the edge smaller, as if you were looking through a fish-eye lens.

- If you roll your mouse over an object, a datatip is displayed.

  By default, the datatip shows the **Object Heading** and **Object Text** attributes. You can choose to display another attribute in the datatip (see “Changing the display mode,” on page 160).

- A red square or triangle is displayed if there are child objects that are hidden because they do not fit on your screen. Click the red square or triangle to display the hidden objects.
**Viewing data in formal modules**

**Note**  A red square means a single object tree is hidden. A red triangle means two or more object trees are hidden.

**Changing the display mode**

For information about display modes, see “Display modes,” on page 159.

**To turn Graphics mode on or off:**

- Click **View > Graphics Mode**.

This switches between Graphics mode and Document mode. When Graphics mode is off, you get the default mode, which is Document mode.

**Selecting the attributes shown in graphics mode**

**To change the attribute shown in the object boxes in Graphics mode:**

1. Turn Graphics mode off.
2. Select the title of the column that contains the data you want to display in the object boxes in Graphics mode, and then right-click **Use in Graphics mode boxes**.

   A white marker is displayed at the top right edge of the column’s title bar, as shown in the next screenshot.

**To change the attribute shown in the datatips in Graphics mode:**

1. Turn Graphics mode off.
2. Select the title of the column that contains the data you want to use, and then right-click **Use in Graphics mode datatips**.

   An orange marker is displayed at the bottom right edge of the column’s title bar.

**Controlling display levels**

The object hierarchy in a module is often too complex to see at once.

You can specify how many levels of the hierarchy you want to see. For example, you might only want to see level 1 and level 2 objects.

**To change the display level either:**

- Click **View > Level**, and then select the level you want.
- Select the display level from the **Display to level** drop-down list on the **View** toolbar.
Objects lower than the selected level are hidden. For example, if you select level 2, you only see level 1 and 2 objects.

Notice that an object is marked with a \( > \) symbol if it has children that are hidden because they are at a lower level than the selected display level.

**Note** The display level only affects what is shown in the module window. The Module Explorer always shows all the objects in the current view.

---

**Controlling table attribute display**

By default, table cells display the main column attributes: **Object Heading** and **Object Text**. If you want to display a different attribute in table cells, either:

- Use the table properties to specify which attribute you want to display in that table’s cells. This allows you to display a different attribute in each table in the module. For more information about this option, see “Changing table properties,” on page 186.

- Use the **Table Attributes** option under the **View** menu to set an attribute other than the main column attributes to be the default displayed in tables in the module. You can choose to make this setting override table settings for individual tables in the module.

**To change the default attribute displayed in table cells:**

1. In the formal module, click **View > Table Attributes**.

   The **Table Attributes** dialog box is displayed.

2. Select **Enable default table attribute**, and select the attribute that you want to display from the list.

3. If you want this setting to override any attribute settings that have been made in the table properties of individual tables, select the **Default attribute overrides table settings** check box.

4. Click **OK**.

   If you want this setting to persist through different sessions, you must save the view. For more information, see “Saving your current view,” on page 96.

---

**Outlining**

Outlining reduces the amount of information displayed on your screen.

When outlining is turned on:

- Only objects that have a heading are displayed.
• Only the **Object Heading** of those objects is displayed. Their **Object Text** attribute is hidden.

You can use outlining in Document or Graphics mode.

**Note** Outlining only affects what is shown in the module window. The Module Explorer always shows all the objects in the current view.

**To turn outlining on or off, do one of the following:**

- Click **View > Outline**
- Click **Turn outlining on or off** on the **Display** toolbar

**Note** Tables are always hidden when outlining is turned on.

**Compression**

When outlining is turned on, you can **compress** or hide parts of the hierarchy. If a section is compressed, it has a plus sign to show that its objects are hidden.

To turn compression on or off for the current object, click **View > Compress**.

**Working with columns**

When you are in Document mode, module data is displayed in rows and columns.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move a column</td>
<td>Drag the column’s title to the new position.</td>
</tr>
<tr>
<td>Change the width of a column</td>
<td>Drag the column separator at the edge of the column’s title bar.</td>
</tr>
<tr>
<td>Select a column</td>
<td>Click the column’s title.</td>
</tr>
<tr>
<td>De-select a column</td>
<td>Click its title again.</td>
</tr>
<tr>
<td>Change the alignment of the</td>
<td>Select the column, and then right-click <strong>Left, Right, Center</strong> or <strong>Justify</strong>.</td>
</tr>
<tr>
<td>contents of a column</td>
<td></td>
</tr>
</tbody>
</table>
Showing column information

When you are in Document mode, you can control what columns are displayed on your screen, what is displayed in each column, what the column titles are, and so on.

To show column information:

1. In the module window, click **Edit > Columns**.

2. On the **Columns** tab, a list is displayed of all the columns currently displayed on your screen:
   - The **Title** column shows the title of the column.
   - The **Attribute** column shows the name of the attribute. If the column does not contain an attribute, words in angle brackets are displayed. For example, if it contains layout DXL, `<Layout DXL>` is displayed.
   - The **Type** column shows the type of the attribute. It is empty if the column does not contain an attribute.

3. To remove a column, select it, and then click **Remove**.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto-indent the main column</td>
<td>Select the column, and then right-click <strong>Auto Indent</strong>. The contents of the main column are indented according to the object’s position in the hierarchy: the lower down the hierarchy the object is, the further it is indented. This allows users to see at a glance the structure of the module.</td>
</tr>
<tr>
<td>Sort the module on the contents of a column</td>
<td>Right-click on the column heading and click <strong>Sort &gt; Ascending</strong> or <strong>Sort &gt; Descending</strong>. The module is sorted according to the contents of the module. For more information about using sorting, see “Sorts,” on page 121.</td>
</tr>
<tr>
<td>Remove a column</td>
<td>Select the column’s title, and then right-click <strong>Remove</strong>.</td>
</tr>
<tr>
<td>Add a column</td>
<td>Follow the instructions in “Adding a column,” on page 164.</td>
</tr>
<tr>
<td>Use a column in Graphics mode</td>
<td>Select the column, and then right-click <strong>Use in Graphics mode object boxes</strong>.</td>
</tr>
</tbody>
</table>
Adding a column

When you are in Document mode, you can control what columns are displayed on your screen.

**Note** The maximum number of columns you can display in a view is 32.

**To add a column:**

1. In the module window, click **Insert > Column**.
   
   **Note** You can also click **Edit > Columns**, which displays the **Columns and Attributes** window, with the **Columns** tab selected. This shows a list of all the columns currently displayed on your screen, in the order in which they are displayed. Select the column that you want to insert the new column before, and then click **New** or **Copy**. If you do not select a column, the new column is added to the bottom of the list and is displayed at the extreme right of the module window.

2. In the **New Column** window, use the **Contents** radio buttons to specify what you want to display in the column:
   
   - To display an attribute in the column, click **Attribute**, and then select the attribute from the drop-down list.
   - To display layout DXL in the column:
     
     i. Click **Layout DXL**
     
     ii. Click **Browse** to specify the DXL. A list of all the predefined DXL programs you can use is displayed.
     
     iii. Select the program you want to use, and then click **Apply**. Alternatively, if you want to define a new program, click **New** and define the program.

     **Note** Layout DXL columns do not display information about table objects.

   - To display the **Object Heading** and **Object Text** attributes in the column (like a main column), click **Object Heading and Object Text**.
   - To display a discussion in the column:
     
     i. Click **Discussion**.
ii. Click **Browse** to specify the type of discussion. A list of all the available discussion types is displayed.

iii. Select the discussion type you want to use, and then click **OK**.

**Note** Discussion columns do not display discussions about table objects.

3. If you want to color-code the data that is displayed in the column, click **By attribute** in the **Text Color** box, and then select the attribute from the drop-down list.

Only attributes that have a color defined as part of their definition are included in the drop-down list.

For information about color-coding, see “Color-coding your data,” on page 167.

4. In the **Column Title** box, type the title you want the column to have.

You can leave this box blank if you are displaying an attribute in the column. By default, the title of the column is the same as the name of the attribute.

5. Click **Insert**.

6. If you want to add more columns to the view, add them and click **Insert**.

7. When you have finished adding columns, click **Close**.

If you want to permanently add the new column to your view, follow the instructions in “Saving your current view,” on page 96.

---

**Editing column information**

See also “Working with columns,” on page 163.

**To edit column information:**

1. In the module window, click **Edit > Columns**.

2. A list of all the columns currently displayed on your screen is displayed. Select the column you want to edit, and then click **Edit**.

The following table describes the options on the **Edit Column** dialog box.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>The title of the column.</td>
</tr>
</tbody>
</table>
Viewing data in formal modules

Color-coding your data

For enumerated attribute types you can define the color associated with each value that the attribute can have.

For example, you have an enumerated attribute type called Yes or No, and you define its values and their colors like this:

<table>
<thead>
<tr>
<th>Value</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>Green</td>
</tr>
<tr>
<td>No</td>
<td>Red</td>
</tr>
</tbody>
</table>

You create an attribute called Approved that has the type Yes or No. You can then edit the properties of any of the columns in the view so that the data in the column is color-coded according to the value of the Approved attribute. For
example, right-click on the main column title bar and select Properties. In the Color pane, select By attribute and select Approved from the list.

The main column is color-coded using the Approved attribute. Items that are approved are green, and items that are not approved are red.

In this case, you do not need to display the Approved attribute in its own column, because you can see at a glance which items are approved from their color in the main column.

If you want this setting to persist through different sessions, you must save the view. For more information, see “Saving your current view,” on page 96.

Adding a graph column

A graph column is a column that contains one or more bar charts. Each bar chart displays the values of an attribute. The attribute must have numeric values; it must be of base type integer or real.

Graph columns are layout DXL columns. If you edit the values of the attributes shown in the columns, the bar charts are immediately updated to show the new values.

To add a graph column to your current view:

1. Click Tools > Wizards > Graph.

   The Graph Wizard’s Welcome screen is displayed.

2. Click Next.

3. Select the attributes that you want to display as bar charts in the column.

   The available attributes are listed in the Existing attributes box. You can add and remove attributes from the Attributes to graph list by selecting an attribute and clicking Add, Insert or Delete. The buttons are described in the following table.

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Put the attribute after the selected entry in the Attributes to graph box</td>
</tr>
<tr>
<td>Insert</td>
<td>Put the attribute before the selected entry in the Attributes to graph box</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete the attribute from the Attributes to graph box</td>
</tr>
<tr>
<td>Save</td>
<td>Save the list of attributes to a file</td>
</tr>
</tbody>
</table>
Click the Next button.

You can change the scaling factor for your bar charts. The Preview box shows what your bar charts look like for the current object.

The following table describes the options on the Preview box.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load</td>
<td>Load a list of previously saved attributes from a file</td>
</tr>
<tr>
<td>4. Click <strong>Next</strong>.</td>
<td></td>
</tr>
<tr>
<td>5. You can change the scaling factor for your bar charts. The Preview box shows what your bar charts look like for the current object.</td>
<td></td>
</tr>
<tr>
<td>Load a list of previously saved attributes from a file</td>
<td></td>
</tr>
<tr>
<td>5. You can change the scaling factor for your bar charts. The Preview box shows what your bar charts look like for the current object.</td>
<td></td>
</tr>
<tr>
<td>Load</td>
<td>Load a list of previously saved attributes from a file</td>
</tr>
<tr>
<td><strong>Minimum value</strong></td>
<td>You cannot edit these boxes.</td>
</tr>
<tr>
<td><strong>Maximum value</strong></td>
<td>Initially they show the value for the current object (the minimum value is 0, and the maximum is the value for the current object).</td>
</tr>
<tr>
<td><strong>Clicking Rescale for all objects</strong></td>
<td>shows the minimum and maximum values for all the attributes selected in the previous screen.</td>
</tr>
<tr>
<td><strong>Minimum scale</strong></td>
<td>These show the minimum and maximum values that are shown in the bar charts.</td>
</tr>
<tr>
<td><strong>Maximum scale</strong></td>
<td>Initially the minimum is 0, and the maximum is the value for the current object.</td>
</tr>
<tr>
<td><strong>To change the values, type new numbers, and then click Rescale.</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Percentage values</strong></td>
<td>Changes the Minimum scale and Maximum scale values to 0 and 100 respectively, and then rescales the bar charts using the new numbers.</td>
</tr>
<tr>
<td><strong>Rescale</strong></td>
<td>Use this when you have typed new numbers in the Minimum scale or Maximum scale boxes. It rescales the bar charts using the new numbers.</td>
</tr>
<tr>
<td><strong>Percentage values</strong></td>
<td>Changes the Minimum scale and Maximum scale values to 0 and 100 respectively, and then rescales the bar charts using the new numbers.</td>
</tr>
</tbody>
</table>
Adding a graph column

**Option** | **Description**
--- | ---
Rescale for all objects | Changes the **Minimum scale** and **Maximum scale** values to the minimum and maximum values for all the attributes selected in the previous screen, and then rescales the bar charts using the new numbers. It also changes the **Minimum value** and **Maximum value** to the minimum and maximum values for all the attributes selected in the previous screen.

6. Click **Next**.

7. Select the type of bar charts you want and the width and height of each bar chart. The Preview box shows what they look like.

The following table describes the options on the wizard screen.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Graph type</strong></td>
<td>Select either Vertical 3D bar chart, Horizontal 3D bar chart, Vertical bar chart, or Horizontal bar chart.</td>
</tr>
<tr>
<td><strong>Width</strong></td>
<td>Type the width in pixels, and then click <strong>Resize</strong>. <strong>Note</strong> Pixels are used to measure distances on computer screens. Open <strong>Display</strong> in the <strong>Control Panel</strong>, and then the <strong>Settings</strong> tab to find out how big your screen is in pixels.</td>
</tr>
<tr>
<td><strong>Height</strong></td>
<td>Type the height in pixels, and then click <strong>Resize</strong>.</td>
</tr>
<tr>
<td><strong>Resize</strong></td>
<td>Changes the size of the bar charts, using the values shown in the <strong>Width</strong> and <strong>Height</strong> boxes.</td>
</tr>
</tbody>
</table>

8. Click **Next**.

9. If you want labels on your bar charts, select the **Labels** box, and then specify what labels you want. The Preview box shows what your bar charts look like.
The following table describes the options on the wizard screen.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Labels</td>
<td>Select this check box if you want labels on the bar charts. The default label is the name of the attribute.</td>
</tr>
<tr>
<td>Include values</td>
<td>Select this check box to display the value, in parentheses, after the label.</td>
</tr>
<tr>
<td>Position</td>
<td>Specify whether you want the labels below the bars of the charts (out of bars) or inside them (in bars).</td>
</tr>
<tr>
<td>Alignment</td>
<td>If you select the in bars position, specify whether you want the label at the top, bottom or center of the bars.</td>
</tr>
<tr>
<td>Attribute</td>
<td>Lists the attributes that are shown in the bar charts.</td>
</tr>
<tr>
<td>Label</td>
<td>Shows the label for the attribute selected in the Attribute drop-down list. By default, the label is the name of the attribute. To change the label, type a new label, and then click Apply label.</td>
</tr>
<tr>
<td>Apply label</td>
<td>Use this when you have typed a new label in the Label box. It changes the label of the attribute selected in the Attribute drop-down list to the value shown in the Label box.</td>
</tr>
</tbody>
</table>

10. Click Next.

11. Specify the colors you want in your bar charts. The Preview box shows what they look like.

You can specify the color of the label text, the background color, and the color of the bars. For a 3D bar chart, you can specify the colors of the front, top, and sides of each bar.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change the color of Side</td>
<td>Select either Text, Background, or one of the attributes in the bar chart. For a 3D bar chart, select Front, Top, or Side.</td>
</tr>
<tr>
<td>List of colors</td>
<td>Click the color you want.</td>
</tr>
</tbody>
</table>
Adding an icon column

An icon column uses an icon to display the value of an attribute. You can use an icon to display either:

- An attribute whose values are numbers (attributes of type Integer or Real).
- An enumerated attribute.

**Note** You can only display one attribute in an icon column, unlike a graph column that can display multiple attributes.

Icon columns are layout DXL columns. If you edit the values of the attributes shown in the columns, the icons are immediately updated to show the new values.

**To add an icon column to your current view:**

1. Click Tools > Wizards > Icon.
   
The Iconizer Wizard's Welcome screen is displayed.
2. Click Next.
3. Select the attribute you want to show in the icon column.
4. Click Next.
5. Select the style of icon you want to use.
   
   You can only select styles that have a pink background. Click a style to select it.
6. If the Use color check box is available, you can clear it if you only want to use one color in the icon.
7. If the Horizontal check box is available, select it to rotate the icon through 90 degrees.
8. Click Next to display the next wizard screen.
9. In the **Column title** box, type a title for the icon column.

10. Use the **Insert** radio buttons and the **Column** box to specify where you want to insert the column.

11. Click **Finish** to add the column to your current view.

If you want to permanently add the new column to your view, follow the instructions in “Saving your current view,” on page 96.
The Module Comparison Wizard

This chapter contains the following topics:

• What is the Module Comparison Wizard used for?
• How does the Module Comparison Wizard work?
• Running the Module Comparison Wizard
• The redline markup column

What is the Module Comparison Wizard used for?

You can use the Module Comparison Wizard to compare two modules and identify objects that have been inserted, deleted, moved or edited. For example, a set of requirements for a project might be updated several times by the customer. You can import the updated requirements into a new Rational DOORS module, and then compare the new module to the original module. Identical and almost identical objects are matched, and any changes that have been made are displayed in a column in the new module with redline markup.

The wizard only compares plain text. Rich text formatting, pictures and OLE objects cannot be compared. OLE objects embedded in text are also ignored when the text is compared.

How does the Module Comparison Wizard work?

The Module Comparison Wizard uses approximate matching techniques that work best when about 75% of the heading structure of the modules being compared is identical.

The Module Comparison Wizard creates links between the objects that it matches. When the module comparison is complete, the wizard can apply a filter to both modules so that only objects that have not been matched are displayed.

Note You must run the Module Comparison Wizard from the current version of the newer of the two modules that you are comparing. If you run the wizard from the older module, the redline markup will be incorrect because the wizard treats the module from which it is being run as the most recent, and marks up the text accordingly.
The module comparison is performed in four stages. Stages one and three are compulsory; stages two and four are optional. You can select the attributes that the wizard will compare.

<table>
<thead>
<tr>
<th>Stage</th>
<th>The wizard...</th>
</tr>
</thead>
<tbody>
<tr>
<td>One</td>
<td>Matches objects that are identical. In this stage, only identical objects that appear in the same order in both modules are matched. Objects that have been moved are not matched during this stage. If a large proportion of objects remain unmatched after this stage is complete, the remaining phases will be slow.</td>
</tr>
<tr>
<td>Two</td>
<td>Matches objects that have been edited. Objects are matched if they appear in the same order in both modules, and if a percentage of the words being compared are identical. Objects that have been moved are not matched during this stage. You can define what percentage of the text must be identical for objects to be matched. The percentage is calculated by the number of identical words in the object, and is approximate.</td>
</tr>
<tr>
<td>Three</td>
<td>Compares the remaining objects and matches identical objects, regardless of their position in the module. Objects that have not been edited, but have been moved are matched during this stage.</td>
</tr>
<tr>
<td>Four</td>
<td>Compares any objects that have not yet been matched and matches them if a percentage of the text being compared is identical. Objects that have been edited and moved are matched during this stage. You can define what percentage of the text must be identical for objects to be matched. The percentage is calculated by the number of identical words in the object, and is approximate.</td>
</tr>
</tbody>
</table>

When the comparison is complete the results can be displayed in a column in the newer module. Changes to the attributes that are compared by the wizard are displayed with redline markup. A filter can also be applied to both modules to display objects that have not been matched by the wizard.

**Running the Module Comparison Wizard**

To run the Module Comparison Wizard:
1. Open the current version of the newer module in exclusive edit mode.

2. Create a view to which the comparison wizard can add a column. This column is used to display the changes with redline markup. The view must contain the main column. The comparison column is added to the right of the main column.

3. Click **Tools > Compare Modules**.

   The **Welcome** screen is displayed. The name of the current module is displayed in the **Newer Module** box.

4. Click **Next**.

   The module selection screen is displayed.

5. In the **Older Module** box, type the name of the module you want to compare, including the path from its nearest parent project, or click **Browse** to locate it.

   **Note** When the module selection screen is displayed, the name of the current module is displayed in the **Older module** box, and any baselines of the current module are displayed in the **Baseline of older module** box. If you want to compare the module to one of its baselines, select the baseline version and click **Next**.

6. Select the version of the older module you want to compare from the **Baseline of Older Module** list.

7. Click **Next**.

   The attribute selection screen is displayed.

   The list in the **Attributes to Compare** box includes all the attributes in both modules.

   The **Absolute Number**, **Object Heading** and **Object Text** attributes are always compared. Select any additional attributes that you want to compare. Changes to attributes that are not selected are ignored. If you select an attribute that only exists in one of the modules, the Module Comparison Wizard treats it as being empty.

8. Click **Next**.

   The performance parameters screen is displayed.

   There are three limits that you can set on the module comparison to improve its performance:
   
   - Limit on size of similar objects to compare
If an object’s text contains more characters than you specify here, and if the text is not identical, the wizard does not attempt to match the object. It is useful to set a limit here if objects contain large amounts of text that are substantially different.

- Limit on number of similar object comparisons
  If the number of object comparisons required in stage four exceeds the limit you specify here, you will be prompted to confirm whether you want to run stage four of the comparison. The number of comparisons is calculated by multiplying the number of unmatched objects that remain in the two modules after stage three.

  For information about the matches that are made during stage four of the wizard, see “How does the Module Comparison Wizard work?,” on page 175.

- Maximum difference in similar objects
  If objects that are compared have more unmatched text than you specify here, they are not matched. For example, if you specify the maximum percentage difference to be 40%, at least 60% of the object’s text must be identical for the objects to be matched.

  **Note**  The percentage is approximate, and is based on the number of matching words in each object.

9. Click **Next**.

The links screen is displayed.

**Note**  If the module’s default linkset pairings define the link module in which links from this module are stored, the link module selection box is unavailable, and links will be created in the default linkset for the module.

Type the name of the link module you want to use for the links, including the path from the nearest parent project, or click **Browse** to locate it.

If you want to create a link module for the comparison links:

a. Click **Create link module**.

b. In the **Link module path** box, type the path from the nearest parent project to the project or folder where you want to create the link module, or click **Browse** to locate it.

c. In the **Link module name** box, type a name for the new link module.
d. In the **Link module description** box, type a description for the new link module, if required.

e. Click **Create**.

The link module is created in the folder you specified.

10. Click **Next**.

The display options screen is displayed.

The following options are available for displaying the results of the module comparison:

- **Filter modules to show unmatched objects**

  Select this option to apply a filter to both modules when the module comparison is complete. The objects that are displayed in this filter are those that have not been matched by the wizard.

- **Always treat OLE objects and pictures as different**

  The wizard cannot compare OLE objects and pictures. If you select this option, objects containing OLE objects and pictures will not be matched. If you select **Filter modules to show unmatched objects**, objects containing OLE objects and pictures will be displayed in the filter. You can then manually compare them for changes.

- **Show differences in a view in the newer module**

  Select this option to insert a column in the newer module. Changes to the attributes that are compared by the wizard are displayed with redline markup.

11. Click **Next**.

The **Finish** screen is displayed.

Select the matching stages that you want the wizard to perform. Stages one and three are mandatory; stages two and four are optional.

**Note** If you select to perform stage four, stage two is selected and made unavailable. When it performs stage four, the wizard automatically performs stage two.

For information about the comparisons that are made during each stage, see “How does the Module Comparison Wizard work?,” on page 175.

12. Click **Finish**.
The Module Comparison Wizard starts, and a progress bar indicates the progress of each stage. When the comparison is complete, a dialog box is displayed, providing information about the module comparison.

13. Click **OK**.

The dialog box is closed.

If you selected to filter the modules to show unmatched objects, those objects are displayed. If you ran all four stages of the wizard:

- The objects that are displayed in the filter in the newer module have probably been inserted since the creation of the older module.
- The objects that are displayed in the older module have probably been deleted from the newer module.

**Note**  Objects that have more unmatched text than you specified in the **Maximum percentage difference in matched objects** box are also displayed.

14. Adjust the linking if necessary. You can manually link any objects that have not been matched by the wizard, or delete any links that you do not want.

### The redline markup column

If you selected to show differences in a view in the newer module, a column has been added to that module. Switch off the filter to see the changes with redline markup. The changes are marked up as follows:

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>An object has been inserted</td>
<td>The object heading and/or object text of the inserted object is displayed in the comparison column in blue, underlined text.</td>
</tr>
</tbody>
</table>
| An object has been deleted      | The object immediately above the deleted object contains red, italicized text similar to the following:  
**Deleted object <object ID> follows here**  
This is followed by the object heading and/or object text of the deleted object, in red text with strikethrough. |
### The redline markup column

<table>
<thead>
<tr>
<th>If</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>An object has been moved</td>
<td>Text such as <em>(Parent object differs)</em>, <em>(Preceding object differs)</em> or <em>(Following object differs)</em> is displayed in blue italics in the comparison column of the object that appears to have moved. The old heading number, which changed when the object was moved to its new location, is displayed with strikethrough to show the old number, and underlined to show the new number.</td>
</tr>
<tr>
<td>An object’s heading number has changed as a result of changes to the module structure</td>
<td>The old heading number is displayed in red with strikethrough, and the new heading number is blue and underlined.</td>
</tr>
<tr>
<td>An object has been edited</td>
<td>Deletions within text are shown in red with strikethrough, and additional text is blue and underlined.</td>
</tr>
</tbody>
</table>

For a description of how redline markup is implemented in Rational DOORS see “Redlining,” on page 281.

The new column is a layout DXL column. Layout DXL can be memory intensive, as the associated DXL is recalculated each time Rational DOORS refreshes the display. If you do not want to the DXL to be recalculated on each refresh, you can convert the layout DXL column to attribute DXL. The DXL is then associated with an attribute, and is recalculated each time the module is opened. You can refresh attribute DXL during a session by selecting **Tools > Refresh DXL Attributes** in the module window.

To convert the column to attribute DXL, click **Tools > Support Tools > Convert Layout DXL to Attribute DXL**. In the **Convert Layout DXL** dialog box, select the comparison column and click **Convert**. A message is displayed stating that the DXL has been successfully converted, and the new Attribute DXL column is added to the view.

**Note** The attribute DXL column does not contain redline markup, and only provides information about changes to the structure of the module. Changes to text within objects are not recorded.
This chapter contains the following topics:

- Tables
- Creating a table
- Inserting a module as a table
- Inserting rows
- Inserting columns
- Changing table properties
- Deleting, undeleting and purging tables

**Tables**

When you insert a table in a module, Rational DOORS creates an object for each cell in the table. It also creates a table marker object, which contains the table cell objects.

You can see the table marker object in the left pane of the Module Explorer. It has **>> Table** as its text.

In the right pane, the table marker object is hidden by default. Instead the table cells is displayed are displayed.

You can turn the display of table cells on and off in the right pane by clicking **View > Show > Table Cells**. When it is off, **>> Table** is displayed in the right pane as well as the left.

**Note** If you want to copy a table, turn the display of table cells off.

When it is turned on, the Copy option is unavailable when you select a table.

By default, the whole table is displayed in the main column of the module. It is truncated if it is too wide to fit in the main column. Use the table properties sheet to override the default behavior and use the full screen width to display the table (see “Changing table properties,” on page 186).

**Note** You cannot create a table within an existing table cell.
You can use drag-and-drop to copy tables between modules. Select all the cells in the table (click the first cell, and then $\text{SHIFT+Click}$ the last cell) then drag them to the target module.

**Creating a table**

This topic describes how to create an empty table. You can also create a table from another module (see “Inserting a module as a table,” on page 184).

**To create a table:**

1. In the module window, select the object where you want to create the table. You can create a table at either the same level as the current object or one level below the current object. You must have create access to the current object to create a table one level below it. You must have create access to the parent of the current object to create a table at the same level as the current object.

2. Click Table > Insert then either After or Below.

3. Optionally type the number of rows and columns you want in your table.

4. Optionally type the column width, in pixels.

   Pixels are used to measure distances on computer screens. Open Display in the Control Panel, and then the Settings tab to find out how big your screen is in pixels.

5. Click OK.

6. Save the module to make the changes permanent (click File > Save).

**Inserting a module as a table**

This topic describes how to insert a whole module as a table in another module. The inserted module must not contain any tables.

To insert an empty table, see “Creating a table,” on page 184.

**To insert a module as a table in the current module:**

1. Select the object that you want to insert the module below.

2. Click Table > Insert > Module as Table.

   The Insert Module as Table dialog box is displayed.

3. In the Source module box, click Browse and select the module you want to insert.
Inserting rows

Note The module you want to insert must not contain any tables.

4. In the Views box, select the view you want to insert.

5. Select the Object Identifiers check box if you want the inserted table to include a column that contains the object identifiers for the objects in the source module.

6. Select the Borders check box if you want the inserted table to have borders around its cells.

7. Click OK.

Inserting rows

To insert a new row in a table:

1. In the module window, select the row where you want to insert a new row.
   
   Note You must have create access to the table marker object.

   You can insert a row above or below the current row.

   The inserted row has the same number of cells and the same settings as the current row. For example, it has the same width and alignment as the current row.

2. Click Table > Insert > Row, and then either Above or Below.

3. Save the module to make the changes permanent (click File > Save).

Inserting columns

To insert a new column in a table:

1. In the module window, select the cell where you want to insert a new column.
   
   Note You must have create access to the table marker object.

   You can insert a column to the left of the current cell, or to the right of the current cell.

   The inserted column has the same number of cells and the same settings as the current column. For example, it has the same width and alignment as the current column.
2. Click **Table > Insert > Column**, and then either **To the Left** or **To the Right**.

3. Save the module to make the changes permanent (click **File**, and then **Save**).

**Note** In a table with unequal row lengths, cells in the inserted column might not be horizontally aligned. Each cell in the new column is positioned relative to the start of the row that it is in. For example, if the current cell is the third cell in the row and you insert a column to the left of it, a new cell is added to the left of the third cell in each row.

### Changing table properties

**To change the properties of a table:**

1. Click in a table cell:
   - If you want to change the properties of the whole table, click any table cell.
   - If you want to change the properties of a particular row or column, click any cell in that row or column.
   - If you want to change the properties of a particular cell, click that cell.

2. Click **Table > Properties**.

3. To change the settings for every cell in the entire table, click the **Table** tab and select the settings you want.

<table>
<thead>
<tr>
<th>Table tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display in module main column only</td>
<td>Clear this check box to display the table across all the columns in the module, not just in its main column.</td>
</tr>
<tr>
<td>Preferred Width</td>
<td>If you want to specify a cell width, select the <strong>Preferred Width</strong> check box, and then enter the cell width in pixels, or use the slider bar to change the width of all the cells in the table graphically. <strong>Note</strong> Pixels are used to measure distances on computer screens. Open <strong>Display</strong> in the <strong>Control Panel</strong>, and then the <strong>Settings</strong> tab to find out how big your screen is in pixels.</td>
</tr>
<tr>
<td>Alignment</td>
<td>Select the alignment of text within the cells.</td>
</tr>
</tbody>
</table>
Changing table properties

<table>
<thead>
<tr>
<th>Table tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change bars</td>
<td>Show or hide change bars for the cells.</td>
</tr>
<tr>
<td>Link arrows</td>
<td>Show or hide link arrows in the cells.</td>
</tr>
</tbody>
</table>

4. To change the settings for every cell in the current row, click the **Row** tab and select the settings you want.

<table>
<thead>
<tr>
<th>Row tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preferred Width</td>
<td>If you want to specify a cell width, select the <strong>Preferred Width</strong> check box, and then enter the cell width in pixels, or use the slider bar to change the width of the cells in the selected row graphically.</td>
</tr>
<tr>
<td>Note</td>
<td>Pixels are used to measure distances on computer screens. Open <strong>Display</strong> in the <strong>Control Panel</strong>, and then the <strong>Settings</strong> tab to find out how big your screen is in pixels.</td>
</tr>
<tr>
<td>Alignment</td>
<td>Select the alignment of text within the cells.</td>
</tr>
<tr>
<td>Change bars</td>
<td>Show or hide change bars for the cells.</td>
</tr>
<tr>
<td>Link arrows</td>
<td>Show or hide link arrows in the cells.</td>
</tr>
</tbody>
</table>

5. To change the settings for every cell in the current column, click the **Column** tab and select the settings you want.

<table>
<thead>
<tr>
<th>Column tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preferred Width</td>
<td>If you want to specify a cell width, select the <strong>Preferred Width</strong> check box, and then enter the cell width in pixels, or use the slider bar to change the width of the cells in the selected row graphically.</td>
</tr>
<tr>
<td>Note</td>
<td>Pixels are used to measure distances on computer screens. Open <strong>Display</strong> in the <strong>Control Panel</strong>, and then the <strong>Settings</strong> tab to find out how big your screen is in pixels.</td>
</tr>
<tr>
<td>Alignment</td>
<td>Select the alignment of text within the cells.</td>
</tr>
</tbody>
</table>
6. To change the settings for the current cell only, click the **Cell** tab and select the settings you want.

<table>
<thead>
<tr>
<th>Cell tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Preferred Width</td>
<td>If you want to specify a cell width, select the <strong>Preferred Width</strong> check box, and then enter the cell width in pixels, or use the slider bar to change the width of the selected cell graphically. Pixels are used to measure distances on computer screens. Open Display in the <strong>Control Panel</strong>, and then the <strong>Settings</strong> tab to find out how big your screen is in pixels.</td>
</tr>
<tr>
<td>Alignment</td>
<td>Select the alignment of text within the cell.</td>
</tr>
<tr>
<td>Change bars</td>
<td>Show or hide change bars for the cell.</td>
</tr>
<tr>
<td>Link arrows</td>
<td>Show or hide link arrows in the cell.</td>
</tr>
</tbody>
</table>

7. To change the borders of the table, click the **Borders** tab and select the settings you want.

<table>
<thead>
<tr>
<th>Borders tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Click <strong>None</strong> if you do not want any borders.</td>
</tr>
<tr>
<td>Box</td>
<td>Click <strong>Box</strong> if you want a border around the outside edge only.</td>
</tr>
<tr>
<td>All</td>
<td>Click <strong>All</strong> if you want border around all edges, including internal cells.</td>
</tr>
<tr>
<td>Custom</td>
<td>Click <strong>Custom</strong> to set up custom borders, and then in the <strong>Preview</strong> box, click the buttons to specify where you want borders.</td>
</tr>
</tbody>
</table>
Deleting, undeleting and purging tables

8. To change the attribute that is displayed in the table cell, click the Attributes tab and select the attribute you want to display from the list, or click Object Heading and Object Text to display those attributes. By default, Object Heading and Object Text are displayed in table cells.

   **Note** If an attribute to display in table cells has been specified using the View > Tables Attributes option, that setting might have been set to override individual table settings.

   If you want to display more than one attribute in table cells, you can use the DXL Attribute Wizard to create a DXL attribute that contains all the attributes you want to display. For more information about the DXL Attribute Wizard, see “Creating a new DXL attribute,” on page 140.

   If you select a DXL attribute from the drop down list, the Edit using Wizard button becomes available. If the DXL attribute was created using the DXL Attribute Wizard, you can view and edit it by clicking this button to open the wizard.

9. Click OK.

10. Save the module to make the changes permanent (click File > Save).

---

### Deleting, undeleting and purging tables

You can delete an entire table, or just a row, column or cell within the table.

Deleting a table cell does not destroy any of it data. It simply marks the cell as deleted, and stops users from being able to access it. To destroy the table cell, you must purge it once you have deleted it.

Purging deleted table cells removes them permanently from the database.

When you delete a table cell that has an in-link, the source object is automatically modified to remove the link, so you must have modify access to the source object.

You cannot delete the table cell if you do not have modify access to the source object. This ensures that you do not end up with a dangling link at the source object.
object that goes nowhere. The link between the object and the table cell means there is some kind of dependency between them. You must resolve this dependency before you delete the table cell and lose the dependency.

To delete, undelete or purge a table cell, you must have delete access to the table marker object.

To delete all or part of a table:
1. Click the table cells:
   • If you want to delete the entire table, click any cell in the table.
   • If you want to delete a particular row or column, click any cell in that row or column.
   • If you want to delete a particular cell, click that cell.
2. Click Table > Delete, and then either Table or Row or Column or Cell.
3. Save the module to make the change permanent (click File > Save).

Note  Cells to the right of the deleted cells are shifted left.

To undelete all or part of a table:
1. In the module window, make sure that deleted items are being displayed.
   If necessary, click View > Show > Deletions.
   Deleted cells have red text, and their change bars are black.
2. Select the table cells you want to undelete:
   • If you want to undelete the entire table, click any cell in the table.
   • If you want to undelete a particular row or column, click any cell in that row or column.
   • If you want to undelete a particular cell, click that cell.
3. Click Table > Undelete, and then either Table or Row or Column or Cell.
4. Save the module to make the change permanent (click File > Save).

To purge all or part of a table:
1. In the module window, make sure that deleted items are being displayed.
   If necessary, click View > Show > Deletions.
   Deleted cells have red text, and their change bars are black.
2. Select the deleted table cells you want to purge:
   • If you want to purge the entire table, click any cell in the table.
Deleting, undeleting and purging tables

- If you want to purge a particular row or column, click any cell in that row or column.
- If you want to purge a particular cell, click that cell.

3. Click **Table > Purge**, and then either **Table** or **Row** or **Column** or **Cell**.
   A message is displayed asking you to confirm that you want to purge the cells.

4. Click **Confirm**.

5. Save the module to make the change permanent (click **File > Save**).
   The cells are permanently removed from the database.
This chapter contains the following topics:

- Working with pictures
- OLE objects
- Activating and deactivating an OLE object
- Inserting a new OLE object
- Inserting an existing file as an OLE object
- Resizing OLE objects
- Cutting, copying and pasting OLE objects
- Editing OLE object properties
- Deleting OLE objects
- OLE objects and history
- Setting the OLE open limit
- Registered and Unregistered OLE Objects
- Actions affected by changes to the handling of OLE objects
- Actions unaffected by changes to the handling of OLE objects

**Working with pictures**

You can insert the following picture formats into Rational DOORS objects:

- bmp
- wmf
- jpg, jpeg, jif, jpe
- png
- gif
- tif, tiff
- dib, rle, bmz
- emz
- wmz
To insert a picture:
1. In the module window, select the object.
2. Click **Insert > Picture**.
3. In the **File name** box, type the name of the file that contains the picture, or use **Browse** to locate it.
4. If you are creating a new object, specify where you want to create it:
   - Click **Same level** to create it at the same level as, and immediately after, the current object. You need create access to the current object’s parent to do this.
   - Click **One level below** to create it one level below the current object. You need create access to the current object to do this.

If the current object already contains a picture, you will see a **Replace current picture** option on the **Insert Picture** dialog box.

5. If you want to replace your picture, select the **Replace current picture** option.
6. Click **OK**.

**OLE objects**

You can insert OLE objects into any text attribute in Rational DOORS. There is no limit to the number of OLE objects that can be inserted into a text attribute. Use OLE objects carefully, however. They can diminish the performance of your application.

If an attribute is displayed in a traceability column in another module, any OLE objects that have been inserted in the attribute are also displayed.

**Note** You cannot insert an OLE object into the **Object Heading** attribute.

You have several options when inserting an OLE object:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert as an icon</td>
<td>The icon that is associated with the program is inserted. For example, if you insert a Word document as an icon, a Word icon is inserted in the attribute. You double-click the icon to activate the OLE object.</td>
</tr>
</tbody>
</table>
Activating and deactivating an OLE object

When you activate an OLE object, the application with which it is associated is opened. You can either edit the OLE object in a new window, or in-place in the formal module.

To activate an OLE object:

1. Double-click the attribute in which the OLE object has been inserted to enter in-place edit mode.
2. Select the OLE object.
   
   The Edit menu now contains an additional option for the OLE object that you have selected. For example, if you select a Microsoft Visio OLE object, the last item on the Edit menu is VISIO object.
3. Click the OLE object name on the Edit menu, and then either:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert as a picture</td>
<td>The OLE object is displayed as it appeared when it was last saved. For example, if you insert an Excel chart as a picture, the chart is displayed in the attribute. You double-click the picture to activate the OLE object.</td>
</tr>
<tr>
<td>Create New</td>
<td>This inserts a blank OLE object of the type you select into the attribute. You can then double-click the OLE object to activate and edit it.</td>
</tr>
<tr>
<td>Create from File</td>
<td>This lets you browse to and insert a file that already exists on your system.</td>
</tr>
<tr>
<td>Link or Embed</td>
<td>If you create the OLE object from file you can either link it to the file on your system, or embed it. If you link an OLE object, the path to the file on your system is stored with the OLE object, so you have a hot-link between the file and the OLE object in Rational DOORS. If someone subsequently updates the file, the change is reflected in Rational DOORS. If you embed an OLE object, you copy the file to the Rational DOORS attribute. If someone subsequently updates the original file, the change is not reflected in the copy of it in Rational DOORS.</td>
</tr>
</tbody>
</table>
• Click **Edit** to edit the OLE object in the formal module window. The menus and toolbars of the application associated with the OLE object replace the Rational DOORS menus and toolbars. To deactivate the OLE object, click on another Rational DOORS object.

• Click **Open** to open the application associated with the OLE object in a new window, and edit the OLE object in that window. When you have finished editing, save and close the file. The OLE object in Rational DOORS is updated with your changes.

**Note** Menu items might vary depending on the type of OLE object that is selected. For example, if you select a PowerPoint Presentation, the additional option **Show** is displayed. Select this option to show the presentation.

You can also double-click the OLE object in-place to activate it:

• If the OLE object is displayed as an icon, the application associated with the OLE object is opened in a new window. When you have finished editing, save and close the file. The OLE object in Rational DOORS is updated with your changes.

• If the OLE object is not displayed as an icon, it becomes editable in the module window. The menus and toolbars of the application associated with the OLE object replace the Rational DOORS menus and toolbars. To deactivate the OLE object, click on another Rational DOORS object.

**Note** Double-clicking on a PowerPoint presentation OLE object runs the presentation slide show. If you want to edit a PowerPoint presentation OLE object, you must use the **Edit** menu to activate it.

### Inserting a new OLE object

If you want to insert an OLE object into an attribute, you must have modify access to the attribute.

**To insert a new OLE object into a Rational DOORS attribute:**

1. In the module window, select the Rational DOORS object into which you want to insert the OLE object.

2. Double-click the attribute into which you want the OLE object inserted, and position the cursor where you want the OLE object to appear.

3. Click **Insert > OLE Object**.
4. Select the type of OLE object you want to insert from the Object Type list. Information about the type that is currently selected is displayed in the Result pane.

5. Select the Display as Icon check box if you want the OLE object to be displayed as an icon in Rational DOORS. The icon that is currently associated with the selected object type is displayed below the check box. If you want Rational DOORS to use a different icon and title, click Change Icon, and specify a new icon and title.

If you want the OLE object to display as editable information, leave the Display as Icon check box clear.

6. Click OK.

Rational DOORS creates an empty OLE object of the specified type, embeds it in the current object, and then runs the appropriate program to let you edit the OLE object.

Inserting an existing file as an OLE object

You can use any of the following methods to insert an existing file into a Rational DOORS attribute as an OLE object.

• Click Insert > OLE object on the formal module menu bar.
• Copy and paste, using the Paste Special option in Rational DOORS.
• Drag and drop. You cannot link the OLE object if it is inserted using drag and drop.

To insert an existing OLE object using the Insert > OLE object menu option:

1. In the module window, select the Rational DOORS object into which you want to insert the OLE object.

2. Double-click the attribute into which you want the OLE object inserted, and position the cursor where you want the OLE object to appear.

3. Click Insert > OLE Object, and select the Create from File radio button.

4. Enter the path to the file you want to insert, or click Browse to select it.

5. Select the Link check box to link the OLE object to the source file, or clear it to embed the OLE object in the Rational DOORS module. For information about linking and embedding files see “OLE objects,” on page 194.
6. If you want the OLE object to be displayed as an icon in Rational DOORS, select the **Display as Icon** check box. The icon that is currently associated with the selected object type is displayed below the check box. If you want Rational DOORS to use a different icon and title, click **Change Icon**, and specify a new icon and title.

If you want the OLE object to display as editable information, leave the **Display as Icon** check box clear.

7. Click **OK**.

The file is inserted into the current object as an OLE object.

**To insert an existing OLE object using copy and paste:**

1. You can either:
   - In the Windows Explorer, select the file you want to insert and copy it
   - Open the file and select the contents that you want to insert and copy them

2. In the module window, select the Rational DOORS object into which you want to insert the OLE object.

3. Double-click the attribute into which you want the OLE object inserted, and position the cursor where you want the OLE object to appear.

4. Click **Edit > Paste Special**.

5. Select **Paste** to embed the OLE object in the Rational DOORS module, or **Paste Link** to link the OLE object to the source file. For information about linking and embedding files see “OLE objects,” on page 194.

6. If you want the OLE object to be displayed as an icon in Rational DOORS, select the **Display as Icon** check box. The icon that is currently associated with the selected object type is displayed below the check box. If you want Rational DOORS to use a different icon and title, click **Change Icon**, and specify a new icon and title.

If you want the OLE object to display as editable information, leave the **Display as Icon** check box clear.

7. Click **OK**.

The contents of the clipboard are pasted into the attribute as an OLE object.

**Note** Some OLE objects can be pasted but not activated. For example, if you copy a picture from a browser window and paste it into Rational DOORS, it is displayed but it cannot be activated. These metafiles are static OLE objects.
To insert an existing OLE object using drag and drop:

1. In the module window, select the Rational DOORS object into which you want to insert the OLE object.

2. Double-click the attribute into which you want the OLE object inserted, and position the cursor where you want the OLE object to appear.

3. Using the Windows Explorer, navigate to the file you want to embed, select it, and then drag it onto the target object in Rational DOORS.

   The file is embedded in the current object as an OLE object.

   **Note** You cannot link the OLE object if it is inserted using drag and drop.

---

**Resizing OLE objects**

If an inserted OLE object is too large to fit in the column into which it has been inserted, you can resize it to fit the column. The object will resize itself proportionally, taking its width from the width of the column.

You can choose to change either:

- The size of an OLE object or objects in a single object
- The size of all the OLE objects in the module

**To resize an OLE object or objects in a single object:**

1. Select the object containing the OLE object or objects you want to resize.

2. Click **Tools > Support Tools > Set OLE Size For Current Object**.

   The OLE object or objects are resized to fit in the column.

   To reset the OLE object or objects to their original size, select the object containing the OLE object or objects, and then click **Tools > Support Tools > Reset OLE Size In Current Object**.

**To resize all the OLE object in a module:**

1. Select any object in the module.

2. Click **Tools > Support Tools > Set OLE Size In All Objects**.

   All the OLE objects in the module are resized to fit in the column.

   To reset the OLE objects to their original size, select any object in the module, and then click **Tools > Support Tools > Reset OLE Size In All Objects**.
Cutting, copying and pasting OLE objects

You can cut and paste or copy and paste OLE objects.

The following steps describe how to do this:

1. In the module window, select the Rational DOORS object containing the OLE object you want to cut or copy.
2. Double-click the attribute containing the OLE object to enter edit mode, and select the OLE object.
3. Select Cut or Copy.
4. Double-click the attribute you want to paste to and right-click Paste to insert the OLE object.

You can also use cut or copy if you want to paste OLE objects from Rational DOORS to external applications.

Note You need to be in in-place edit mode to insert an OLE object. Consequently, you cannot cut and paste OLE objects between different attributes. You can, however, cut and paste within the same attribute.

Editing OLE object properties

You can change the properties of an OLE object using the OLE Object Properties. The options that are available depend on whether the OLE object is embedded or linked.

Editing the properties of an OLE object:

1. In the module window, select the Rational DOORS object containing the OLE object whose properties you want to edit, and double-click to enter in-place edit mode.
2. Select the OLE object, and then click Edit > OLE Object Properties.
3. The General tab displays the file information for the OLE object.
   The Convert button is unavailable.
4. Use the **View** tab to change the appearance of the OLE object in the module.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display as editable information</td>
<td>If the OLE object is currently displayed in the module as an icon, select this button to display it as editable information. This allows you to see the contents of the file displayed in the module. You double-click in the contents of the file to activate the OLE object.</td>
</tr>
<tr>
<td>Display as icon</td>
<td>If the OLE object is currently displayed in the module as editable information, select this button to display it as an icon. You double-click the icon to edit the OLE object.</td>
</tr>
<tr>
<td>Change icon</td>
<td>If the OLE object is displayed as an icon, click this button to change the icon or the icon's label.</td>
</tr>
<tr>
<td>Scale</td>
<td>This field is unavailable. If you want to resize an OLE object, select the OLE object and drag the sizing handles.</td>
</tr>
<tr>
<td>Relative to original size</td>
<td>This field is unavailable.</td>
</tr>
</tbody>
</table>

5. Use the **Link** tab to edit the link properties of the OLE object.

**Note** This tab is not displayed if the OLE object is embedded in the module. For information about embedding and linking OLE objects see “OLE objects,” on page 194.

The link tab displays:
- The path to the linked file on your system
- The date and time that the file was last updated

The following options are also available:

<table>
<thead>
<tr>
<th>Use</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatically or Manually</td>
<td>This functionality is not supported in Rational DOORS. Linked OLE objects in Rational DOORS are automatically updated regardless of this setting.</td>
</tr>
</tbody>
</table>
There are two ways to delete an OLE object. You can:

- Delete an OLE object as well as the Rational DOORS object that contains it.
  
  Select the object, and then click File > Delete.
  
  You must have delete access to the object to do this.

- Delete an OLE object but not the Rational DOORS object that contains it.
  
  a. Select the object then double-click the attribute where the OLE object has been placed to enter edit mode.
  
  b. Select the OLE object you want to delete. It will become highlighted.
  
  c. Press DELETE.
  
  You must have modify access to the object to do this.

**OLE objects and history**

OLE objects can now be saved as part of a history record. This allows users to compare a current OLE object (or set of OLE objects) with that which preceded it.

Using this setting can have a major effect on performance and disk space requirements, so by default it is switched off.

<table>
<thead>
<tr>
<th>Use</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change Source</td>
<td>Manually update the path to a file that has been moved. You can also use this button if you want to replace the existing OLE object. Click the button, navigate to the new file location, select the file and click <strong>OK</strong>. The path is updated.</td>
</tr>
<tr>
<td>Open Source</td>
<td>Open the source file.</td>
</tr>
<tr>
<td>Update Now</td>
<td>Redraw the OLE object.</td>
</tr>
<tr>
<td>Break Link</td>
<td>This functionality is not supported in Rational DOORS. Clicking Break Link does not remove the link between the OLE object and the source object. If you want to remove the link from the OLE object, delete it and insert it again without linking.</td>
</tr>
</tbody>
</table>
To enable it:
1. Right-click on Database, and select Properties.
2. In the OLE in history section, select the Save OLE objects in attribute history option.

Now when you view the history of a particular object, you can determine how an OLE object has changed over time.

Setting the OLE open limit

When you open a module, the OLE objects in the module are pre-loaded from the database into memory. By default, up to five OLE objects can be pre-loaded into memory at any one time.

The demands of these OLE objects on memory can result in poor performance. To improve performance, you can reduce the number of OLE objects that are pre-loaded.

To do this:
• Edit the oleopenlimit entry in your registry.

The default value of oleopenlimit is 5. A value of 0 means there is no limit.

Registered and Unregistered OLE Objects

There have been problems with data loss related to OLE objects in previous versions of Rational DOORS.

The following sections describe how Rational DOORS now behaves when it encounters OLE objects. The terminology used is explained in the table below.

<table>
<thead>
<tr>
<th>OLE Type</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Registered OLE objects</td>
<td>If the application associated with an OLE object in Rational DOORS is installed on the Rational DOORS client, the OLE object is registered. It can be opened from Rational DOORS and edited. For example, if a Rational DOORS module you are working on contains a Word document, and you have Microsoft Word installed on your machine, that Word document is a registered OLE object.</td>
</tr>
</tbody>
</table>
Working with pictures and OLE objects

<table>
<thead>
<tr>
<th>OLE Type</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unregistered OLE objects</td>
<td>If the application associated with an OLE object in Rational DOORS is not installed on the Rational DOORS client, the OLE object is <strong>unregistered</strong>. It cannot be opened from Rational DOORS and edited. For example, if a Rational DOORS module you are working on contains a Word document and you do not have Microsoft Word installed on your machine, the Word document is an unregistered OLE object.</td>
</tr>
<tr>
<td>Static OLE objects</td>
<td>A <strong>static</strong> OLE object is a picture which cannot be edited regardless of what applications you have installed on your machine. For example, if you take a screenshot and paste it into a Rational DOORS object, it is a static OLE object.</td>
</tr>
</tbody>
</table>

**Actions affected by changes to the handling of OLE objects**

Rational DOORS now displays warnings if objects containing unregistered OLE objects are accessed. The warnings and behavior for each action that is affected are listed below.

**Edit in-place or using the object properties sheet.**

<table>
<thead>
<tr>
<th>Action</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Double-click on an unregistered OLE object</td>
<td>A message stating that the OLE object cannot be activated because its associated application is not available is displayed. Attempting to activate an unregistered OLE object does not cause any data loss.</td>
</tr>
<tr>
<td>Edit text surrounding an unregistered OLE object</td>
<td>If you edit text contained in the same attribute as an unregistered OLE object, the OLE object is unaffected. It remains unregistered on your machine, but can be accessed on machines that have the associated application installed.</td>
</tr>
</tbody>
</table>

**Caution** If you edit an object that contains an unregistered OLE object using the Change Proposal System, and that
Actions affected by changes to the handling of OLE objects

change is approved and applied, the unregistered OLE object is converted to a static OLE object and data contained in that OLE object is lost. See “Change Proposal System,” on page 208 for more information.
### Copy and paste in-place or using the object properties sheet

<table>
<thead>
<tr>
<th>Action</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy an unregistered OLE object on its own</td>
<td>The original OLE and the copied OLE remain unregistered and can be accessed on machines that have the associated application installed.</td>
</tr>
<tr>
<td>Copy an unregistered OLE object and some surrounding text</td>
<td>A warning is displayed, which states that the copied selection includes an object from an uninstalled application. When you click OK the copy operation is reversed and the data is unaffected.</td>
</tr>
<tr>
<td>Copy a selection of OLE objects, where one or more of them are unregistered.</td>
<td>A warning is displayed, which states that the copied selection includes an object from an uninstalled application. When you click OK the copy operation is reversed and the data is unaffected.</td>
</tr>
</tbody>
</table>

### Cut and paste in-place or using the Object properties sheet

<table>
<thead>
<tr>
<th>Action</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut an unregistered OLE object on its own</td>
<td>When you paste the OLE object, it remains unregistered and can be accessed on machines that have the associated application installed.</td>
</tr>
<tr>
<td>Cut an unregistered OLE object and some surrounding text</td>
<td>A warning is displayed, which states that the selection includes an object from an uninstalled application. If you click Yes to continue with the operation, the unregistered OLE object is converted to a static object when it is pasted, and information held in the OLE object is lost. If you click No, the cut operation is reversed and the data is not affected.</td>
</tr>
</tbody>
</table>
Actions affected by changes to the handling of OLE objects

<table>
<thead>
<tr>
<th>Action</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut a selection of OLE objects, where one or more of them are unregistered.</td>
<td>A warning is displayed, which states that the selection includes an object from an uninstalled application. If you click Yes to continue with the operation, any unregistered OLE objects are converted to static OLE objects when they are pasted, and information held in the OLE objects is lost. If you click No, the cut operation is reversed and the data is not affected.</td>
</tr>
</tbody>
</table>

**Copy or cut a Rational DOORS object containing an unregistered OLE object in an attribute**

**Note**  This is the case for all methods of copying and cutting objects within a module, i.e using keyboard shortcuts, drag and drop or the menu items.

<table>
<thead>
<tr>
<th>Action</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy or cut and paste an object containing an unregistered OLE object</td>
<td>The OLE in the original object, and in the copied or moved object remains unregistered and can be accessed on machines that have the associated application installed</td>
</tr>
</tbody>
</table>

**Copy objects using the Object Copier**

If you copy an object that contains one or more unregistered OLE objects to another module using the Object Copier (Tools > Functions > Copy Objects), the object and OLE objects are copied successfully and no data is lost.

**Change Proposal System**

**Submit a change proposal**

If you select an object that contains an unregistered OLE object and click Tools > Change Proposal System > Submit Change Proposal, a message is displayed stating that you are about to raise a proposal against an object that contains unregistered OLE data in at least one of its attributes.
You can continue, and submit a change proposal. However, if your change proposal is approved and applied, any unregistered OLE objects that are held in the object are changed to static OLE objects and data stored in them is lost.

**Review change proposals**

If you change the status of a change proposal made against an object that contains an unregistered OLE object in one of its attributes, a message is displayed.

You can continue, but if you approve a change proposal and that change proposal is then applied, any unregistered OLE objects that are held in the object are changed to static OLE objects and data stored in them is lost.

**Apply change proposals**

If you apply a change proposal that has been made against an object that contains an unregistered OLE object in one of its attributes, a message is displayed.

Applying change proposals for objects that contain one or more unregistered OLE objects in any of their attributes results in the OLE object being converted to a static OLE object. All data held in the OLE object is lost.

**DXL**

You cannot manipulate unregistered OLE objects using DXL.

**History**

If you double-click an unregistered OLE object in the History window a message is displayed stating that the object is a static OLE object. This message is incorrect - if an OLE object was unregistered when it was current, it remains unregistered in the history. If you restore the history entry containing that OLE object, it is restored as an unregistered OLE object and no data is lost.

**Split Object**

If you attempt to split an object that contains an unregistered OLE object, an error is displayed.

If you click **Confirm**, the object is split, and the unregistered OLE object is converted to a static OLE object. Data held in the OLE object is lost.

If you click **Cancel**, the data is unaffected, and the OLE object can be accessed by machines that have the associated application installed.
Actions unaffected by changes to the handling of OLE objects

Export data from Rational DOORS

If you export a module from Rational DOORS to any other application, unregistered OLE objects are exported as pictures. The unregistered OLE objects in the Rational DOORS module are unaffected by the export and no data is lost in Rational DOORS.

If Rational DOORS encounters unregistered OLE objects during an export to another application, a message is displayed to inform the user that the exported OLE objects will be converted to pictures.

If the application to which you want to export the module supports OLE, a new check box is displayed on the Export dialog box.

The Issue a warning when an unregistered OLE Object is exported as a picture check box is selected by default. Clear the check box if you do not want to receive warnings during export.

Paste unregistered OLE objects into other applications

If you cut or copy an unregistered OLE object to the clipboard, and then paste it into another application, the OLE Object is pasted as a picture, and data contained in the OLE object is lost. If the OLE object is copied, the original remains unregistered and no data is lost in Rational DOORS.

Spelling checker

You cannot edit text in the Check Spelling window if the object contains an unregistered or static OLE object. A message is displayed on the Check Spelling window if this is the case.

You can use Replace to correct spelling mistakes, and the unregistered OLE object is unaffected.

Actions unaffected by changes to the handling of OLE objects

The following areas of functionality were unaffected in previous versions of Rational DOORS by the data loss problem related to OLE objects. They remain unchanged.

Merge Objects

When you merge objects in Rational DOORS, OLE objects are not included in the resulting object. This is the case whether the OLE objects are registered, unregistered or static.
When you merge objects, the OLE objects in the original objects are unaffected, and no data is lost.

Create a Baseline

Baselining a module that contains unregistered OLE objects does not affect the OLE objects. They remain unregistered in both the baseline and the current version of the module. No data is lost.

Copy a baseline

When you copy a baseline of a module that contains unregistered OLE objects, the new module contains the unregistered OLE objects, and no data is lost. The data can be accessed on machines that have the associated application installed.

Clone a module

The clone module functionality is not designed to clone OLE objects, so any unregistered OLE objects in the original module are unaffected and no data is lost. This is the case in all previous versions of Rational DOORS and there is no change in functionality in this patch.

Cut or Copy modules in the Database Explorer

When you copy and paste a module that contains unregistered OLE objects in the Database Explorer, the OLE objects are copied successfully and no data is lost.

Import data to Rational DOORS

You cannot import an unregistered OLE object to Rational DOORS. This is the case in all previous versions of Rational DOORS and there is no change in functionality in this patch.

Archive and restore

Unregistered OLE objects are unaffected by archive and restore operations, and no data is lost.

Partition/Rejoin

Unregistered OLE objects are unaffected by partition/rejoin operations, and no data is lost.
Actions unaffected by changes to the handling of OLE objects

**Find and Replace**

Edits made to text contained in the same attribute as unregistered OLE objects during Find and Replace operations have no affect on unregistered OLE objects and no data is lost.

**Linking**

Creating, editing and navigating links does not affect unregistered OLE objects.
This chapter contains the following topics:

- About access rights
- About groups
- How group rights and user rights interact
- About inheritance
- Inheritance example
- Propagating extra access rights with create

Note You can skip this chapter if you’re only going to use Rational DOORS to look at data, and you don’t want to create or edit data. You can also ignore this chapter if your site isn’t using access controls; that is, if your database is set up to allow everyone full access to all data.

About access rights

Access rights control who can do what to each item of data in your Rational DOORS database. Rational DOORS provides five access rights.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>Read (look at) data.</td>
</tr>
<tr>
<td>Create (C)</td>
<td>Create new data.</td>
</tr>
<tr>
<td>Modify (M)</td>
<td>Edit existing data.</td>
</tr>
<tr>
<td>Delete (D)</td>
<td>Delete data.</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Change the access rights for data.</td>
</tr>
</tbody>
</table>

For example, to be able to see a folder, you need read access to it.

You have read access to everything you can see in the Database Explorer. If you can see a project, folder or module in the Database Explorer, you have read access to it.

Create access lets you create new things one level down in the database tree:
• If you have create access to a project or folder, you can create new projects, folders, and modules in the project or folder.

• If you have create access to a module, you can create new top-level objects in the module.

• If you have create access to an object, you can create new objects one level below the object.

Modify access lets you edit existing data. For example, if you have modify access to an object, you can edit the object and change the values of its attributes. To be able to delete something, you need delete access to it. And to be able to change the access rights for something, you need admin access to it.

**Full access and no access**

If you have full access to something, it means that you have all five access rights to it. Full access is just a shorthand for the five access rights.

If you have no access to a project, folder or module, you cannot see the project, folder, or module, so you do not even know it exists.

If you have read access to a module, it does not mean that you can see all the data in the module. You might have no access to some of the objects or attributes in the module. When you have no access to an object or attribute, you see **Read Locked Data** instead of the object or attribute.

**About groups**

Often you need to allow a group of users the same access to a particular piece of data. For example, you might want all the engineers in your company to have full access to a particular module.

The Database Manager creates the Engineering group, which contains all the engineers in your company. Then you can quickly set up the access rights for the module. Instead of having to set up the access rights for each user individually, you set up the access rights for the whole Engineering group.

And when a new engineer joins your company, the Database Manager just adds them to the Engineering group, and they automatically get access to your module.

Each user can be in lots of different groups.
How group rights and user rights interact

The following picture shows how the different types of entry for individual users, groups, and everyone else interact. It shows how to figure out what access rights you have to a piece of data. It assumes that you have read access to the data, otherwise you cannot see it and so you cannot click its Access tab.

For example, if a user is part of a group that has been given access rights to a project, and that user also has an individual entry, the user has the access defined in the individual entry, and not the access rights that are defined for the group.

When you are in several groups

If you do not have your own entry and you are in two or more groups that have entries, you get the access rights for all your group entries combined.

For example, if one of your groups has read and modify access, and another has read and create access, you get read, modify, and create access.

About inheritance

To make it easy to set up access rights, Rational DOORS provides a powerful inheritance mechanism.
Whenever you create anything, by default it automatically inherits its access rights from its parent.

For example, when you create a top-level object in a module, by default the new object inherits the same access rights as its parent, the module. If you click the Access tab on the object properties sheet, you see that it has the same access rights as the module.

The Inherit from parent check box is selected, and the entries in the list of access rights are unavailable. You can see what access rights the object is inheriting from the module, but you cannot edit them.

To turn off inheritance, clear the Inherit from parent check box. Now the access rights are available—you can edit them and set up whatever access rights you want the object to have.

Although the object is no longer inheriting access rights from its parent, whenever you create new objects under it, the new objects initially have inheritance turned on. By default, children automatically inherit the access rights you set up for their parent.

If you change the access rights for the parent, this change automatically applies to all its children, grandchildren, and so on, who are inheriting their access rights from the parent.
The change ripples all the way down through the database tree, but it does not affect any items that have inheritance turned off, or their direct descendants.

In this picture a tree of items have a common ancestor A. The **Inherit from parent** check box shows which items have inheritance turned on. All the items have inheritance turned on except A and D.

The red items inherit their access rights from A. The green items inherit access rights from D.

If you change A’s access rights, the change automatically applies to the other red items (B, C, E, and H). The change ripples down through the tree to all items that inherit their access rights from A.

Similarly, if you change D’s access rights, the change automatically applies to the other green items (F and G).

**Inheritance example**

You are managing a car project and have created an Engineering group. You want everyone in the Engineering group to have full access to all the data in the car project:

- You set up the access rights for the car project. You add an entry to give the Engineering group full access to the project.
Inheritance is turned on whenever you create new data in the project. So the new data inherits the access rights for the Engineering group, which gives the group full access to the data.

Later, you change your mind and decide that you want John to have full access to the data in the car project, and the rest of the group to have only read access.

So you change the access rights for the car project:

- You change the Engineering group entry to read access.
- You add an entry for John, giving him full access.

These changes automatically apply to all the data in car project because all the data has inheritance turned on.

But Sue and Mark are writing the Design module, so you want to give them full access to that one module. Easy. Turn inheritance off for the Design module, and add an access entry for Sue that gives her full access to the module, and an access entry for Mark that gives him full access to the module.

**Propagating extra access rights with create**

In some scenarios, standard inheritance does not provide the flexibility you might need. For example:

- You want to let Mark create modules in a folder. So Mark needs create access to the folder.
- You also want Mark to be able to delete the modules he creates in the folder, but you do not want him to be able to delete the folder itself.

You cannot do this using standard inheritance.

One way around this would be to turn off inheritance for every module that Mark creates in the folder, and then set up the access rights for these modules to give Mark delete access to them. That would be very time consuming.

So Rational DOORS lets you treat create access in a special way. You can choose to propagate extra access rights with create access.

This option is only available if the item has inheritance turned off. In our example, the folder must have inheritance turned off.

You can choose which extra access rights to propagate with create access:

- Modify (M)
- Modify and delete (MD)
- Modify, delete, and admin (MDA)
Propagating extra access rights with create

The extra access rights are not specific to a particular user or group. They are propagated with every access rights entry that includes the create access right.

For example, item X has four access rights entries, two of which (for Anne and Engineering) include the create access right.

<table>
<thead>
<tr>
<th>Name</th>
<th>Access rights</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anne</td>
<td>RC</td>
</tr>
<tr>
<td>John</td>
<td>R</td>
</tr>
<tr>
<td>Engineering</td>
<td>RCMD</td>
</tr>
<tr>
<td>Everyone else</td>
<td>RM</td>
</tr>
</tbody>
</table>

You decide to propagate modify, delete and admin (MDA) access with create. This means that the access rights entries for items that inherit their access rights from X look like this:

<table>
<thead>
<tr>
<th>Name</th>
<th>Access rights</th>
</tr>
</thead>
<tbody>
<tr>
<td>Anne</td>
<td>RCMDA</td>
</tr>
<tr>
<td>John</td>
<td>R</td>
</tr>
<tr>
<td>Engineering</td>
<td>RCMDA</td>
</tr>
<tr>
<td>Everyone else</td>
<td>RM</td>
</tr>
</tbody>
</table>

The only entries affected are the ones that included the create access. They gain modify, delete, and admin (MDA) if they do not already have them:

- The entry for Anne gains MDA.
- The entry for Engineering gains A.

As always with access rights, the extra access rights are only propagated to descendants (folders, projects, modules, or objects) that have inheritance turned on.
Managing folders

This chapter contains the following topics:

- Creating a folder
- Controlling access to a folder
- Editing folder properties
- Deleting, undeleting and purging a folder
- Managing locks

For information on how to convert a folder to a project, and vice versa, see the Rational DOORS online help or Managing Rational DOORS.

Creating a folder

To create a folder:

1. In the left pane of the Database Explorer, select the folder or project in which you want to create the new folder. This is the new folder's parent. You must have create access to the parent.

2. Click File > New > Folder.

3. In the Name box, type the name of the new folder.

   The name is case-sensitive. For example, the names Myfolder and MyFOLDER are different.

   The name must be unique within the parent project or folder. All the projects, folders and modules in the parent must have different names.

   The name can contain the following characters:

   - Alphanumeric characters (letters of the alphabet and numbers)
   - Space characters
   - Periods (.)
   - Underscores (_)
   - Hyphens (-)

4. If you want to enter additional information about the new folder, type it in the Description box.

5. Click OK.
Managing folders

The folder is created. It inherits its access rights from its parent.

Note If you receive the error Cannot create this Folder: Lock request timed out when you try to create the folder, wait a moment, and then try again. This error is generated if another Rational DOORS user is performing a paste operation when you click OK to create the folder.

Controlling access to a folder

To change the access rights for a folder, you must have admin access to the folder.

To change the access rights for a folder:

1. Select the folder in the Database Explorer, and then click File > Properties.
2. Click the Access tab.

The current access rights for the folder are displayed.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>See the folder. If you do not have read access, the folder is not displayed in your Database Explorer.</td>
</tr>
<tr>
<td>Create (C)</td>
<td>Create new modules, folders and projects in the folder. Paste existing modules, folders and projects into the folder.</td>
</tr>
<tr>
<td>Modify (M)</td>
<td>Change the name or description of the folder.</td>
</tr>
<tr>
<td>Delete (D)</td>
<td>Delete, undelete and purge the folder. Cut the folder to the Database Explorer clipboard.</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Change the access rights for the folder. Change the default linkset pairings for links from top-level modules within the folder.</td>
</tr>
</tbody>
</table>
Controlling access to a folder

3. Make the changes you want.

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit from parent</td>
<td>Select this check box if you want the folder to inherit its access rights from the project or folder that it is in. If it is a top-level folder, it inherits its access rights from the database root. When this check box is selected, the list of access rights is unavailable, and shows what access rights the folder is inheriting.</td>
</tr>
<tr>
<td>Add</td>
<td>To a new entry to the list of access rights:</td>
</tr>
<tr>
<td></td>
<td>a. Click Add.</td>
</tr>
<tr>
<td></td>
<td>The Add Access window is displayed.</td>
</tr>
<tr>
<td></td>
<td>b. In the Name box, select the name of the user or group that you want to add an entry for.</td>
</tr>
<tr>
<td></td>
<td>c. Select the access rights you want to give them, and then click OK.</td>
</tr>
<tr>
<td>Remove</td>
<td>To remove an entry from the list of access rights, select the entry, and then click Remove.</td>
</tr>
<tr>
<td>Edit</td>
<td>To edit an entry in the list of access rights:</td>
</tr>
<tr>
<td></td>
<td>a. Select the entry then click Edit.</td>
</tr>
<tr>
<td></td>
<td>The Edit Access window is displayed.</td>
</tr>
<tr>
<td></td>
<td>b. Select the access rights you want to give them, and then click OK.</td>
</tr>
<tr>
<td>Additional access</td>
<td>Select the additional access rights that you want to propagate with create access. The additional rights are propagated to the items in the tree below the folder that inherit their access rights from it. For more information, see “Propagating extra access rights with create,” on page 218.</td>
</tr>
</tbody>
</table>

4. Click OK.
Editing folder properties

To edit the properties of a folder, you must have modify access to the folder.

**To edit the properties of a folder:**

1. Select the folder in the right pane of the Database Explorer, and then click **File > Properties**.
2. Select the options you want.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the folder. You cannot change the name of a folder if any of the folders, projects or modules in the tree below it are open. If the folder contains a link module, and the link module is named in any formal module filter that has been saved as a view, no objects will be displayed in the view if the folder name is changed.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the folder.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of item whose properties are being displayed. In this case the type is Folder and it cannot be edited.</td>
</tr>
<tr>
<td>URL</td>
<td>The URL of the folder.</td>
</tr>
<tr>
<td>Copy URL</td>
<td>Copies the URL to the system clipboard. For more information about Rational DOORS URLs see “Rational DOORS URLs,” on page 32.</td>
</tr>
</tbody>
</table>

For information about the options on the Access tab, see either:

- The help for the Access tab (click the **Access** tab, then click **Help**).
- “Controlling access to a folder,” on page 192.

3. Click **OK**.

Deleting, undeleting and purging a folder

Deleting a folder does not destroy any of the data in the folder. It simply marks the folder as deleted, and stops users from being able to access its data. To destroy the data, you must purge the folder once you have deleted it.

Purging deleted folders removes them permanently from the database.
You cannot delete a folder if the folder or anything in it is open.

In the Database Explorer, the folder or project selected in the left pane is open and has an open folder icon or an open project icon. Its parent folder or project is also open, and so are all the folders and projects above it in the database tree, although they do not have open folder or open project icons.

When a module is open, all the folders and projects above it in the database tree are also open.

To delete, undelete or purge a folder, you must have delete access to the folder and to all the folders, projects and modules in it.

**To delete a folder:**
- In the right pane of the Database Explorer, select the folder you want to delete, and then click File > Delete.

**To undelete a deleted folder:**
1. In the Database Explorer, make sure that deleted items are being displayed. If necessary, click View > Show Deleted.
2. Select the folder you want to undelete, and click File > Undelete.

**To purge a folder:**
1. In the Database Explorer, make sure that deleted items are being displayed. If necessary, click View > Show Deleted.
2. Select the folder you want to purge, and then click File > Purge.
   A message is displayed asking if you really want to purge the folder.
3. Click Yes.
   The folder and all the data in it are permanently removed from the database.

**Managing locks**

If an error message is displayed saying that an object is locked, it is because either you or another user have the object open.

You may have the object open if a previous Rational DOORS session ended abnormally, for example if your computer crashed.

If a session ends abnormally:
- Any modules that you were editing are locked.
  No-one can edit these modules until they are unlocked. They can open them in read-only mode, but not in shareable or exclusive edit mode.
• Projects and folders you had open are locked.
  No-one can move, rename or delete these projects or folders until they are unlocked.

To unlock projects, folders and modules:

1. In the Database Explorer, click **Tools > Manage Locks**.
   A list of the items that are currently locked is displayed.

   The list does not include the locks associated with your current Rational DOORS session, because you must not delete these locks. If you deleted them you would corrupt your data.

   If you are a Standard user, you only see the items that you locked in previous Rational DOORS sessions. If you are a Database Manager or a Custom user with the power to manage the database, items locked by all database users are displayed.

   If you are a Standard user, and you cannot see the locked item in the list, another user must have it locked. Contact your Database Manager to find out who has it locked.

   If you have a chain of locks from the root of the database, you only see the lock at the end of the chain.

   **Note** By default, the **Current folder only** check box is selected. This shows locks in the current folder that have been partially removed, and that are not displayed otherwise. If you want to see all the locks in the database, clear this check box.

2. Click **Refresh** to refresh the display.

3. Select the items you want to unlock, and then click **Unlock**.

   **Note** When you open a module, you lock all the folders and projects above the module in the database tree. But on this screen, you only see the lock for the module, not the associated locks in the tree above it. When you unlock the module, you also remove any associated locks that are not needed by other data that is locked elsewhere in the database tree.

   A message is displayed asking if you really want to unlock the items.

4. Click **Yes**.

5. Click **Close**.
Managing locks
Managing folders
This chapter contains the following topics:

- Links
- External links
- Link arrows
- Creating links
- Creating and editing external links
- Clearing the link start
- Link modules and linksets
- Controlling access to a link module
- How copy and move affect links
- Editing links
- Creating link attributes
- Deleting links
- Creating links in bulk
- Linking by attribute
- Link module defaults
- Creating default linkset pairings
- Control on links for process management
- Showing link module information
- Creating a link module
- Creating a linkset
- Deleting a linkset

**Links**

Rational DOORS lets you **link** together related information. You can follow links by simply clicking them.
For example, you can link a user requirement to the design features that fulfill that requirement. And you can link the design features to the tests that are carried out to verify the design features.

Links give you traceability. You can check that what you are building satisfies your user requirements.

You can follow links in both directions. For example, if a test fails, you can find out which requirements are affected by tracing the links from the test back to the design features, and from the design features back to the requirements.

Links allow you to effectively manage change. You can quickly trace the impact of a change to a single piece of data on the rest of your system.

For example, the engineering department tell you that they cannot deliver the solar-powered battery you were expecting. You can trace the links from the battery object back to the requirements that depend on it, and forward to the other features of the car that depend on having a solar-powered battery. You can quickly see the full impact of not having a solar-powered battery. You can make an informed decision about whether to just use a conventional battery or whether to invest more money and resources to help deliver a solar-powered battery.

**External links**

You use external links to create a link from a Rational DOORS object to an entity or resource that is outside the current Rational DOORS database. For example, you might create an external link to a website, or to a different Rational DOORS database.

External links can be marked as URLs. Where an external link is a URL, it is treated like a hyperlink and is opened by the default browser.

If an external link is not marked as a URL, nothing happens when the external link is selected.

**Note** If you are running Rational DOORS through Citrix, the application referenced by the external link must also be running through Citrix or the external link will not work.

An external link is a one way link to the resource it references. No corresponding link is created in the linked resource, although you can create a link in the resource back to the Rational DOORS object by inserting the Rational DOORS URL in the resource. For information about Rational DOORS URLs see “Rational DOORS URLs,” on page 32.
External links do not use link modules. All the information about the link is stored with the external link. External links are not a property of the object to which they are attached. They behave as separate objects, and can have different attribute values than the objects to which they are attached.

**Link arrows**

Linked objects have **link arrows** in the main column:

- **Out-links** have red link arrows
- **In-links** have yellow link arrows

Some module baselines may display link arrows that look like this: ![link arrow]. These arrows signify links to and from modules that are not in the same baseline set definition, and are called **echoed links**. For more information on links in baseline sets, see Managing incremental development using Intelligent Traceability in the online help and in *Managing Rational DOORS*.

**Note** You can turn off link arrows. If you cannot see any link arrows, select the module’s view settings. Click **View > Show > Link Arrows**.

Roll over the link arrow to see how many in-links, out-links and external links the object has. Only information about modules that you have read access to is displayed.

Right-click the link arrow to see a pop-up menu that shows the names of the modules that contain the objects at the other end of the links. If the module containing the links is not open, ![unloaded] is displayed, where *n* is the object number. If the object has external links, they are listed in alphabetical order in the **External Links** submenu.

If you roll over the **External Links** menu item, the description of each external link is displayed. External links are displayed in alphabetical order.

To follow a link, select it from the pop-up menu:

- If the link is to a Rational DOORS object, the module that it is in is automatically opened if it is not already open and the linked object is selected.
- If the link is an external link and the external link is a URL, the linked resource is opened by your default browser. If the external link is not a URL it cannot be opened, and a message is displayed.

**Note** There is a limitation in the Microsoft rich edit control which results in double-byte characters not being automatically
highlighted when they are part of a URL. This affects external links in Rational DOORS, so that if an external link URL contains double-byte characters it cannot be followed from Rational DOORS by clicking the external link. You can copy and paste the URL into a browser window and the item referred to by the link will open as expected.

Creating links

You can only create a link if you have modify access to the source object and read access to the target object.

This topic describes two ways to create a link:

- Using drag-and-drop
- By explicitly defining the link start

Using drag-and-drop

You can use drag-and-drop to create links from multiple objects to a single object. You cannot use it to create links to multiple objects.

To create a link using drag-and-drop:

1. If the objects you are creating links between are in different modules, open both modules and re-size their windows so that you can see both modules on your screen at the same time.

2. Select the objects that you want to link to or from and then, without releasing the mouse button, drag your cursor to the object you want to link. If you want to link from multiple objects, do not release the mouse button after making the multiple object selection. You lose your selection if you release the mouse button between selecting the objects and dragging the mouse.

3. Release the mouse button.

A pop-up menu is displayed.

- Click Make Link from Start to create links from the objects you selected
- Click Link > Make Link to Start to create links to the objects you selected

While you are dragging the mouse, the objects you selected in step 2 are highlighted with a pink background, showing that they are the link start.
Creating links

If you select **Cancel** on the pop-up menu, the source objects stay pink.

**Note**  The quickest way to create a link between single objects, is to hold down both the **SHIFT** and **CTRL** keys when you release the mouse button over the target object in Step 3. This bypasses the pop-up menu and creates a link from the source object to the target object.

4. You might see a message saying that a default link module does not exist. Click **Yes** to create it.

5. You might see a message saying that a linkset does not exist. Click **Yes** to create it.

**Explicitly defining the link start**

To create a link by explicitly defining the link start:

1. Select the object or objects that you want to link to or from.

2. Click **Link > Start Link**.
   
   If you selected multiple objects in Step 1, a message is displayed asking if you want to link to or from all the selected objects or the current object only. Select the appropriate option.
   
   The link start objects turn pink.

3. Select the object or objects that you want to link to or from.
   
   - Click **Link > Make Link from Start** to create links from the objects you selected in step 1.
   
   - Click **Link > Make Link to Start** to create links to the objects you selected in step 1.

   If you selected multiple objects in Step 3, a message is displayed asking if you want to create links to all the selected objects or to the current object only. Select the appropriate option.

4. You might see a message saying that a default link module does not exist. Click **Yes** to create it.

5. You might see a message saying that a linkset does not exist. Click **Yes** to create it.
Creating and editing external links

This section describes how to create and edit external links that are URLs, for example links to web pages, or other Rational DOORS databases. To create and edit external links you must have create or modify access to the object.

There are three options for creating external links. You can use:

• The Make External Link menu option to create external links to any URL.
  You can access the Make External Link menu option by selecting the object and clicking Link > Make External Link.

• The Make External and Edit External buttons on the object properties sheet.

• Drag-and-drop to create external links to formal module objects in other databases or to URLs that are displayed in Internet Explorer or Firefox browser windows. You cannot use drag-and-drop to create external links if you are in-place editing an object.

  When you drag-and-drop a browser URL, you must drag the icon to the left of the address in the address bar, not the address itself.

Note External links can also be used to facilitate integration between Rational DOORS and other applications. This use of external links is not discussed here, but information and examples are available in a white paper, which can be downloaded from our website at http://www.ibm.com/software/awdtools/doors/support/doc.html.

To create an external link using the menu option:

1. Select the object that you want to contain the external link, and click Link > Make External Link.

2. In the Make External Link dialog box, type a Name and Description for the link. The description will be displayed in the External Link sub-menu when you right-click on the link arrow.

3. Enter the URL for the link in the Link Path box.

   If you want to create an external link to an item in Rational DOORS, right-click on the item you want to link to and click Copy URL. This copies the item's URL to the system clipboard. You can then paste the URL into the Link Path box on the Make External Link dialog box.
Creating and editing external links

**Note** The link path must be no more than 256 characters long. If the link path contains spaces or special characters, the upper limit is less than 256.

4. Select **Open URL with default browser**.

5. Select whether you want the link to be displayed as an in-link or out-link in the module.

   This does not affect the link behavior. In either case, when you select the link the resource referenced by it is opened by the default browser. No corresponding link is created in the resource.

6. Click **OK**.

You can create a corresponding link in the resource back to the Rational DOORS object by copying the Rational DOORS URL from the object properties sheet and pasting it into the resource. If the resource is a Rational DOORS object, you can create a two-way link by creating an external link in that object.

**To create or edit an external link using the object properties sheet:**

1. In the module window, select the object where you want to create or edit external links.

2. Click **Link > Edit Links**.

   The object properties sheet is displayed, with the **Links** tab selected.

3. If you want to create an external link:
   a. Select the **Make External** button.
   b. In the **Make External Link** dialog box, type a **Name** and **Description** for the link. The description will be displayed in the External Link sub-menu when you right-click on the link arrow.
   c. Enter the URL for the link in the **Link Path** box.
     
     If you want to create an external link to an item in Rational DOORS, right-click on the item you want to link to and click **Copy URL**. This copies the item’s URL to the system clipboard. You can then paste the URL into the **Link Path** box on the **Make External Link** dialog box.

     **Note** The link path must be no more than 256 characters long. If the link path contains spaces or special characters, the upper limit is less than 256.
   d. Select **Open URL with default browser**.
e. Select whether you want the link to be displayed as an in-link or out-link in the module.

This does not affect the link behavior. In either case, when you select the link the resource referenced by it is opened by the default browser. No corresponding link is created in the resource.

4. If you want to edit an external link:
   a. Select the Edit External button.

   The Edit External Link dialog box is displayed. The Name, Description and Link Path text boxes are populated with information about the object or URL. The external link is created as an out-link by default.

   **Note** The link path must be no more than 256 characters long. If the link path contains spaces or special characters, the upper limit is less than 256.

   b. Edit the Name, Description, Link Path and Direction if necessary.

5. Click OK.

To create an external link using drag-and-drop:

1. Drag-and-drop the Rational DOORS formal module object, or the icon in the browser address bar to the object in which you want to create the external link.

2. Click Confirm.

   The Edit External Link dialog box is displayed. The Name, Description and Link Path text boxes are populated with information about the object or URL. The external link is created as an out-link by default.

   **Note** The link path must be no more than 256 characters long.
   If the link path contains spaces or special characters, the upper limit is less than 256.

3. Edit the Name, Description, Link Path and Direction if necessary, and then click OK.

   The external link is created, and the external link description is displayed in the External Link sub-menu when you right-click on the link arrow in the object.
Clearing the link start

The object or objects that are currently defined as your link start are highlighted with a pink background.

To clear the link start:
- Click Link > Clear Start.

You can do this in any formal module. You do not have to do it in the one that contains the current link start.

Link modules and linksets

Link modules store information about normal Rational DOORS links. Within each link module, the information is subdivided into linksets. Each linkset contains information about the links from one particular module to another.

For example, a link module has four linksets, which contain information about links for two modules, A and B:

<table>
<thead>
<tr>
<th>This linkset</th>
<th>Contains information about links from</th>
</tr>
</thead>
<tbody>
<tr>
<td>A =&gt; B</td>
<td>Module A to module B</td>
</tr>
<tr>
<td>B =&gt; A</td>
<td>Module B to module A</td>
</tr>
<tr>
<td>A =&gt; A</td>
<td>Module A to module A (links between objects within module A)</td>
</tr>
<tr>
<td>B =&gt; B</td>
<td>Module B to module B (links between objects within module B)</td>
</tr>
</tbody>
</table>

Notice that the direction of the links matters. Links from module A to B are not stored in the same linkset as links from module B to A.

Note External links are not stored in link modules.

Rational DOORS Links, the default link modules

By default, Rational DOORS uses link modules called Rational DOORS Links:
- The first time you create a link from a particular module, Rational DOORS offers to create a link module called Rational DOORS Links in the same folder as the module (if it does not already exist), and a linkset in Rational DOORS Links.
• Next time you create a link from the module, Rational DOORS uses the Rational DOORS Links module in the local folder. It offers to create a linkset in Rational DOORS Links if the linkset does not already exist.

For more information, see “Link module defaults,” on page 254.

**Why use other link modules?**

The Rational DOORS defaults are designed to meet the needs of most users. Most users will not even know what link modules and linksets they are using.

You should use other link modules if you want to use links to express different types of relationship, and you need to analyze your data according to the type of the link.

To do this, you create your own link modules, and use different link modules for different types of links. For example, you create a link module called Traceability Links for your traceability links, and a link module called Accounting Links for your accounting links.

You can then run traceability and other analyses on a particular type of link. You specify the link module you want to use for the analysis, so you only analyze links of the type that are stored in that link module.

**Note** If you want to create links in this way, you must use the `Links > Create Links` option from your module, and the module must not be set up to use mandatory linkset pairings.

**Controlling access to a link module**

To change the access rights for a link module, you must have admin access to the module.

**To change the access rights for a link module:**
1. In the module window, click **File > Module Properties**.
2. Click the **Access** tab.

   The current access rights for the module are displayed.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>See the module. If you do not have read access, the module is not displayed in your Database Explorer.</td>
</tr>
<tr>
<td>Create (C)</td>
<td>Create linksets in the module. Create attribute types and attribute definitions for the module.</td>
</tr>
<tr>
<td>Modify (M)</td>
<td>Change the module’s name, description, or attribute values. Create a link in the link module.</td>
</tr>
<tr>
<td>Delete (D)</td>
<td>Delete, undelete and purge the module. Delete a linkset from the module. Cut the module to the Database Explorer clipboard.</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Change the access rights for the module.</td>
</tr>
</tbody>
</table>

If the module is partitioned in, the access rights associated with the partition are displayed. These describe the maximum access that any user has. They override the RCMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RCMDA), but the module is partitioned in read-only, in practice the user has only read (R) access.

3. Make the changes you want.

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit from parent</td>
<td>Select this check box if you want the module to inherit its access rights from the project or folder that it is in. When this check box is selected, the list of access rights is disabled, and shows what access rights the module is inheriting.</td>
</tr>
</tbody>
</table>
4. Click OK.

**How copy and move affect links**

This topic looks at what happens when you copy or move objects that have links.

When you use cut and paste:

- The first time you paste, you simply move the thing you are pasting.
- If you paste it again, you copy it.

The following table describes the rules that apply when you copy or move objects by using either drag-and-drop or copy, cut and paste in the Database Explorer or module windows. External links are always copied because all the

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
</table>
| Add        | To add a new entry to the list of access rights:  
  a. Click Add.  
  The Add Access dialog box is displayed.  
  b. In the Name box, select the name of the user or group that you want to add an entry for.  
  c. Select the access rights you want to give them, and then click OK. |
| Remove     | To remove an entry from the list of access rights, select the entry, and then click Remove. |
| Edit       | To edit an entry in the list of access rights:  
  a. Select the entry then click Edit.  
  The Edit Access dialog box is displayed.  
  b. Select the access rights you want to give them, and then click OK. |
information about them is contained in the object, and they do not use link modules.

<table>
<thead>
<tr>
<th>If you</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move an object, module, folder or project that contains links</td>
<td>All the links are preserved.</td>
</tr>
</tbody>
</table>
| Copy an object that has links               | Out-links are copied if you copy the object within the same module. Each copied out-link uses the same link module as the original out-link. The following rules apply to in-links:  
  • If you are copying the object to another module, links are not copied.  
  • If you are copying the object within the same module, an in-link is only copied if you have modify access to the (source) object at the other end of the link.  
    If you have modify access, a message is displayed asking if you want to copy the in-link. If you do not have modify access, a message is displayed telling you that the in-link will not be copied and asking if you want to continue with the copy operation.  
    If an object you copy has a link that uses a mandatory linkset pairing, which goes through a link module that has one-to-one mapping, a message stating that links which have already satisfied the link mapping in the link module will not be copied is displayed when you paste the object.  
    • Click **Yes** to copy the object without the link  
    • Click **No** to cancel the copy operation |
Links

<table>
<thead>
<tr>
<th>If you</th>
<th>Then</th>
</tr>
</thead>
</table>
| Copy a formal or descriptive module that contains links | Out-links are always copied. An in-link is only copied if you also copy the module that contains the (source) object at the other end of the link. The link module used by the out-link in the copied module depends on two things:  
  • Whether the out-link in the source module uses a link module that is also being copied.  
  • If the link module is not being copied, whether the link module is local (a local link module has the same parent folder or project as the module itself).  
If the out-link uses a link module that is also being copied, the out-link in the copied module uses the copied link module.  
If the out-link uses a local link module, L, that is not being copied, the out-link in the copied module also uses a local link module. This link module is also called L, and is created if it does not already exist.  
If the out-link uses a non-local link module that is not being copied, the out-link in the copied module uses the same link module as the out-link in the source module. |
Editing links

This topic describes how to use the object properties sheet to:

- Show information about links.
- Delete links.
- Edit link attributes values (out-links and external links only).

**Note** You can use link attributes to record information about your links. For example, you might create an attribute called Purpose which you use to record why the link was created. For information about how to create a link attribute, see “Creating link attributes,” on page 247.

**To edit links:**

1. In the module window, select the object whose links you want to edit.

<table>
<thead>
<tr>
<th>If you</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy a folder or project that</td>
<td>Out-links are always copied. An in-link is only copied if you also copy the module that contains the (source) object at the other end of the link. The link module used by the out-link in the copied module depends on two things:</td>
</tr>
<tr>
<td>contains links</td>
<td>• Whether the out-link in the source module uses a link module that is also being copied.</td>
</tr>
<tr>
<td></td>
<td>• If the link module is not being copied, whether the link module is local (in this case, a local link module is one that has the same parent as the folder or project you are copying).</td>
</tr>
<tr>
<td></td>
<td>If the out-link uses a link module that is also being copied, the out-link in the copied module uses the copied link module.</td>
</tr>
<tr>
<td></td>
<td>If the out-link uses a local link module, L, that is not being copied, the out-link in the copied module also uses a local link module. This link module is also called L, and is created if it does not already exist.</td>
</tr>
<tr>
<td></td>
<td>If the out-link uses a non-local link module that is not being copied, the out-link in the copied module uses the same link module as the out-link in the source module.</td>
</tr>
</tbody>
</table>
2. Click **Link > Edit Links**.

   The object properties sheet is displayed, with the **Links** tab selected.

   A list of all the links in and out of the object is displayed.

   For each link:
   
   - The **In/Out** column tells you the direction of the link, and whether it is a normal Rational DOORS link or an external link.
   - The **Module/Description** column tells you:
     - For normal Rational DOORS links, the module that contains the object at the other end of the link. The path from the module’s nearest ancestor project is displayed.
     - For external links, the external link description
   - The **Baseline** column tells you what version of the source or target module the object is linked to. For external links this column is blank.
   - The **Object Heading/Text** column displays:
     - For normal Rational DOORS links, the first part of the **Object Heading**, if the object at the other end of the link has **Object Heading**. If it does not have **Object Heading**, the first part of the **Object Text** is displayed.
     - For external links, the external link name.
   - The **ID** column shows the object identifier of the object at the other end of the link. For external links, this column is blank.
   - The **Link Module** column tells you the link module that contains the link. The path from the link module’s nearest ancestor project is displayed. For external links, this column displays N/A.
   - The **Link Module Baseline** column tells you what version of the link module contains the link. For external links, this column displays N/A.

3. To follow a link, select it, and then click **Follow Link**.

4. For information about the **Make External** and **Edit External** buttons, see “Creating and editing external links,” on page 234.

5. To delete a link, select it, and then click **Delete**.

   **Note** You cannot undelete a link once you have deleted it.

6. To see information about a link’s attribute or edit that information:
   
   a. Select the link, and then click **Details**.

      If it is an out-link or an external link, you can edit any attribute values that you have modify access to.
Creating link attributes

To create a link attribute, you must have create and modify access to the module.

To create a link attribute:

1. Make sure you are in exclusive edit mode.

   The edit mode is shown on the status bar at the bottom of the module window. To change your edit mode, click Edit > Edit Mode > Exclusive Edit.

2. Click Edit > Attributes.

3. On the Attributes tab, a list of attributes is displayed.

4. If you want the new attribute to have a type that does not already exist, click the Types tab and create the type (see “Creating an attribute type,” on page 131).

5. On the Attributes tab, either click New to create an attribute from scratch, or select the attribute you want to copy, and then click Copy.

6. Type the name of the new attribute in the Name box, and enter additional information in the Description box.

7. Select the other options on the General tab.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name you want to give the new attribute. The name must be unique within the module.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the new attribute.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of the new attribute.</td>
</tr>
<tr>
<td>General tab</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>DXL attribute</td>
<td>Select this check box if you want to use a DXL program to assign values to the attribute. Then use <strong>Browse</strong> to select the DXL program you want to use.</td>
</tr>
<tr>
<td>Browse</td>
<td>If you selected the <strong>DXL attribute</strong> check box:</td>
</tr>
<tr>
<td></td>
<td><strong>a.</strong> Click <strong>Browse</strong> to select the DXL program.</td>
</tr>
<tr>
<td></td>
<td>A list of all predefined DXL programs that can be used to set attribute values is displayed.</td>
</tr>
<tr>
<td></td>
<td><strong>b.</strong> Select the program you want to use, and then click <strong>Apply</strong>. Alternatively, if you want to define a new program, click <strong>New</strong>.</td>
</tr>
<tr>
<td>Multi-valued</td>
<td>Select this check box if the attribute type has a base type of <strong>Enumeration</strong>, and you want to be able to store more than one value in the attribute.</td>
</tr>
<tr>
<td>Default value</td>
<td>If you want the new attribute to have a default value, select the <strong>Default value</strong> check box, and then type the value in the box.</td>
</tr>
<tr>
<td>Objects</td>
<td>Select this check box if you want the attribute to apply to the objects in the module.</td>
</tr>
<tr>
<td>Module</td>
<td>Select this check box if you want the attribute to apply to the module.</td>
</tr>
<tr>
<td>Inherit value</td>
<td>Select this check box if the attribute applies to objects, and if you want objects to be able to inherit the attribute value from their parent objects.</td>
</tr>
<tr>
<td></td>
<td>Note that if the attribute applies to both the module and objects in it, top-level objects do not inherit the value from the module.</td>
</tr>
<tr>
<td>Affect change bars</td>
<td>Select this check box if you want Rational DOORS to update an object’s change bar when anyone edits the attribute values.</td>
</tr>
</tbody>
</table>
Deleting links

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Affect change dates</td>
<td>Select this check box if you want DOORS to update an object’s last modified date when anyone edits the attribute values. For more information, see the section on understanding how dates and times are recorded in <em>Managing Rational DOORS</em>.</td>
</tr>
<tr>
<td>Affect change dates</td>
<td>Select this check box if you want Rational DOORS to update an object’s last modified date when anyone edits the attribute values.</td>
</tr>
<tr>
<td>Generate history</td>
<td>Select this check box if you want Rational DOORS to update the database history when anyone edits the attribute values.</td>
</tr>
</tbody>
</table>

8. By default, the attribute inherits its access rights from the module.

If you want to change its access rights use the *Access (Definition)* and *Access (Value)* tabs. For more information, see “Controlling access to an attribute definition,” on page 141 and “Controlling access to an attribute value,” on page 143.

9. Click **OK**.

10. Click **Close**.

11. Save the module to make the change permanent (click **File > Save**).

**Deleting links**

This topic describes how to delete links in bulk:

- You can delete normal Rational DOORS links from the current module to a particular module.
- You can delete all the normal Rational DOORS links in the current module.
- You can delete all the external links in the current module.

You can also delete links using the object properties sheet (see “Editing links,” on page 245).

**Note** You cannot undelete a link once you have deleted it.

To delete a normal Rational DOORS link you must have:
• Modify access to the source object and the link module.
• Read access to the target object.

To delete an external link you must have create or modify access to the object containing the link.

**To delete normal Rational DOORS links from the current module to a particular module:**

1. In the current module, select the objects you want to delete links from.
   - **Note** You can ignore this step if you want to delete links from every object in the current view.

2. Click **Link > Delete Links**.

3. Specify which objects you want to delete links to:
   - In the **Target module** box, type the name of the target module, or use **Browse** to locate it. You must specify the path to the module from its nearest ancestor project.
   - Click **Raise** to open the target module if it is not already open, or to raise it to the front of your screen if it is already open.
   - If you want to delete links to a subset of the objects in the current view, select the objects in the target module window.

4. In the **Link module** box, type the name of the link module, or use **Browse** to locate it. You must specify the path to the module from its nearest ancestor project.
   - To delete links the link module must be open. Click **Raise** to open it. If the link module is already open, clicking **Raise** will bring it to the front of your screen.

5. Use the **Link** drop-down list to specify what links you want to delete:
   - Select **Selection to selection** to delete links from all objects currently selected in the source module to all objects currently selected in the target module.
   - Select **Selection to display set** to delete links from all objects currently selected in the source module to all objects in the target module’s current view.
   - Select **Display set to selection** to delete links from all objects in the source module’s current view to all objects currently selected in the target module.
Creating links in bulk

- Select **Display set to display set** to delete links from all objects in the source module’s current view to all objects in the target module’s current view.

6. Select the **Confirm** check box if you want to get a confirmation message that tells you how many links are about to be deleted.

7. Click **OK**.

**To delete all the normal Rational DOORS links in a module:**

1. In the module window, click **Link > Delete All Links**.

2. A message is displayed asking if you really want to delete all the in- and out-links. Click **Confirm** to delete all links.

**To delete all external links in a module:**

1. In the module window, click **Link > Delete All External Links**.

2. A message is displayed asking if you really want to delete all the external in- and out-links. Click **Confirm** to delete all external links.

**Creating links in bulk**

This topic describes how to create links in bulk, from the current module to another module. You cannot use this tool to create external links in bulk.

**Note** You can also create links using drag-and-drop and the Link menu options (see “Creating links,” on page 232).

**To create links from the current module to a particular module:**

1. In the current module, select the objects you want to create links from.

   **Note** You can ignore this step if you want to create links from every object in the current view.

2. Click **Link > Create Links**.

3. Specify which objects you want to create links to:

   - In the **Target module** box, enter the target module, or use **Browse** to locate it. You must specify the path to the module from its nearest ancestor project.
   - Click **Raise** to open the target module if it is not already open, or to bring it to the front of your screen if it is already open.
   - If you want to create links to a subset of the objects in the current view, select the objects in the target module window.
4. In the **Link module** box, enter the link module you want to use, or use **Browse** to locate it. You must specify the path to the module from its nearest ancestor project.

If you want to look at the link module, click **Raise** to open it. If the link module is already open, clicking **Raise** will bring it to the front of your screen.

5. Use the **Link** drop-down list to specify what links you want to create:
   - Select **Selection to selection** to create links from all objects currently selected in the source module to all objects currently selected in the target module.
   - Select **Selection to display set** to create links from all objects currently selected in the source module to all objects in the target module’s current view.
   - Select **Display set to selection** to create links from all objects in the source module’s current view to all objects currently selected in the target module.
   - Select **Display set to display set** to create links from all objects in the source module’s current view to all objects in the target module’s current view.

6. Select the **Confirm** check box if you want to get a confirmation message that tells you how many links are about to be created.

7. Click **OK**.
Linking by attribute

If you have a module that contains an attribute whose values are the absolute numbers of objects in another module, you can automatically create links between the two modules.

For example, in this diagram module A has an attribute \texttt{Relates to} that stores the absolute number of the related object in module B. You can automatically create links between the related objects, as shown in the diagram above.

\textbf{Note} In the source module, the attribute that you use for linking must be of type Text. If it contains more than one absolute number, each number must be on a separate line.

\textbf{To link by attribute:}

1. In the source module window, click \texttt{Link}, and then \texttt{Link by Attribute}.
2. In the \texttt{Target module} box, type the name of the target module, or use \texttt{Browse} to locate it. You must specify the path to the module from its nearest ancestor project.
3. In the \texttt{Link module} box, type the name of the link module you want to use for the links, or use \texttt{Browse} to locate it. You must specify the path to the module from its nearest ancestor project.
4. In \texttt{Existing attributes}, select the attribute in the source module that you want to use. This is the attribute whose values are the absolute numbers of objects in the target module.
5. In the \texttt{Link direction} box, select the direction of the links.

You can create links from the source module to the target module, from the target module to the source module, or in both directions.
6. Click **OK**.

**Link module defaults**

For each pair of modules, you can define the default link modules that are used whenever anyone creates a link between the two modules.

If you have two modules, A and B, you can define two default link modules:

- The default link module that is used for links from A to B
- The default link module that is used for links from B to A

We call these **default linkset pairings**.

For example, links from requirements to use cases might be stored in the design link module, and links from requirements to test in the verification link module.

For information about how to define default linkset pairings, see “Creating default linkset pairings,” on page 255.

**Changing the default link module**

Your user **default link module** is used whenever you create a link and there is not a default linkset pairing for the source-to-target module pair.

By default, your default link module is **Rational DOORS Links**.

If you change your user default link module to say, **Mylinks**, whenever you create links between modules that do not have a default linkset pairing, Rational DOORS uses **Mylinks** in the source module’s folder. If the folder does not already contain a link module called **Mylinks**, Rational DOORS automatically creates it.

Alternatively, you can set your default link module to a particular link module in your Rational DOORS database, by specifying the full path of the link module, starting with its nearest ancestor project. Whenever you create links between modules that do not have a default linkset pairing, Rational DOORS uses this particular link module, regardless of which folder or project the source module is in.

**To change your default link module:**

1. In the Database Explorer, click **Tools > Options**.
2. Click the **Settings** tab.
3. In the **Default link module** box, type the default link module you want to use.
4. Click **OK**.
Creating default linkset pairings

For information about default linkset pairings, see “Link module defaults,” on page 254.

A module’s properties sheet shows the default linkset pairings for links from that module to other modules. To change the pairings you must have admin access to the folder or project that the module is in.

To create or change the default linkset pairings:

1. In the module window, click File > Module Properties.
2. Click the Linksets tab.
   
   A list of all the default linkset pairings for links from the current module is displayed.
3. To remove a pairing, select it then click Remove.
4. To add a new pairing:
   a. Click Add.
   b. In the Target module box, type the name of the target for the pairing, or use Browse to locate it. You can enter a target module that does not exist in the database. The module is not created, but the pairing is valid when the module is created.
   c. In the Link module box, type the name of the link module that you want to be the default for links from the current module to the specified target module, or use Browse to locate it. You can enter a module that does not exist in the database. The module is not created, but the linkset is valid when the module is created.
   d. Click OK.
      
      If the linkset pairing already exists in the module, an error message is displayed. Click OK to return to the Add Linkset Pairing dialog and amend your settings.
5. To edit a pairing:
   a. Select the entry you want to edit, and then click Edit.
   b. Edit the entry in the Target module or Link module box.
   c. Click OK.
6. Click OK.
Control on links for process management

An important aspect of requirements management is the organization of relationships between the data. Rational DOORS lets you control the type and direction of all links, created by all users. This feature helps to enforce and support your project process.

With Linkset Control, you define which links between documents are allowed and prohibit any other combinations. Consequently, users and project managers can be assured that they create the correct types of link.

You can also control where link information is stored for each source and target combination by specifying a default link module for that particular module pairing.

For the greatest control, you can specify that use of this link module is mandatory, forcing all users to store link information there, regardless of whether they have defined their own default link module. If that degree of control is not needed, you can make the link module overridable, so users can store information about their links in their own default link modules.

You must have administrative access to the parent folder of the source module to configure linkset definitions and enable linkset control.

To create linkset definitions:
1. Open your source module.
2. Click File > Module Properties.
   The Module Properties dialog box is displayed.
3. Click the Linksets tab.
4. Click Add.
   The Linkset Pairing dialog box is displayed.
5. In the Target module box, type the name of the target for the pairing, or use Browse to locate it.
6. In the Link module box, type the name of the link module that you want to use, or click Browse to locate it.
7. (Optional) Select the Link Module options you wish to use for this linkset:
   • If you select Mandatory, link information for this linkset can only be stored in the specified link module.
   • If you select Overridable, a user’s personal default link module will be used to store information about their links.
8. Click OK.
To enable linkset control on a module:

1. Open your source module.
2. Click File > Properties.
   
   The Module Properties dialog box is displayed.
3. Click the Linksets tab.
4. Select the option Only allow outgoing links to the target modules in the above list.
5. Click Apply, and then OK.

By default, linkset control is turned off.
Outgoing links use only those linkset pairings in the list—no others are allowed.

Showing link module information

To show the properties of a link module:

1. In the Database Explorer, make sure that link modules are being displayed.
   
   If necessary, click View > Show Link Modules.
2. Select the link module whose properties you want to show, and then click File > Properties.
3. The properties sheet for the module is displayed.

The following table describes the options on the General tab.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the module.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the module.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of item whose properties are being displayed. This is Link Module, and cannot be edited.</td>
</tr>
<tr>
<td>URL</td>
<td>The URL of the module.</td>
</tr>
<tr>
<td>List of attributes</td>
<td>This is a list of all the module’s attributes. For each attribute, it shows the name of the attribute and its value.</td>
</tr>
</tbody>
</table>
Creating a link module

To create a link module:

1. In the Database Explorer, select the folder or project you want to create the module in. This is the module’s parent.
   You must have create access to the parent.

2. Click File > New > Link Module.

3. In the Name box, type the name of the new module.
   The name can contain the following characters:
   - Alphanumeric characters (letters of the alphabet and numbers)
   - Space characters
   - Periods (.)
   - Underscores (_)
   - Hyphens (-)

4. If you want to enter additional information about the module, type it in the Description box.

5. In the Mapping box, specify what kind of links you want to store in the link module. You cannot change the link mapping after the module has been created.
   The following table describes each mapping.

<table>
<thead>
<tr>
<th>Mapping</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Many-to-many</td>
<td>Each object can have any number of in-links and</td>
</tr>
<tr>
<td></td>
<td>out-links.</td>
</tr>
</tbody>
</table>
Creating a link module

6. Click OK.

Note If you receive the error **Cannot create this Module: Lock request timed out** when you try to create the module, wait a moment, and then try again. This error is generated if another Rational DOORS user is performing a paste operation when you click OK to create the module.

Working with link modules

By default, link modules are hidden in the Database Explorer. To show link modules, click **View > Show Link Modules**.

To open a link module, double-click it in the Database Explorer.

Use the **Linkset** drop-down list on the link module’s **Linkset** toolbar to select which linkset you want to display. The full name of the linkset that is currently selected is displayed when you roll over the list box.

By default, the linkset in Matrix mode is displayed. A matrix of all the objects in the source and target modules is displayed. The source objects are shown vertically on the left, and the target objects are shown horizontally along the top. A highlighted square on the matrix means there’s a link between the two objects that intersect at that position.

If you select a highlighted square, you can use **Go to link source** and **Go to link target** on the **Link** toolbar to open the source or target module and go to the source or target object.

Note When you select a linkset in the link module, the source module of the linkset is opened in exclusive edit mode, but is not displayed. If you then try to open that module in read-only mode from the Database Explorer, it is displayed in exclusive edit mode. You can change to read-only mode by

<table>
<thead>
<tr>
<th>Mapping</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Many-to-one</td>
<td>Each object can have any number of out-links, but only one in-link.</td>
</tr>
<tr>
<td>One-to-many</td>
<td>Each object can have only one out-link, but any number of in-links.</td>
</tr>
<tr>
<td>One-to-one</td>
<td>Each object can have only one out-link, and one in-link. So each object can be linked to only one other object.</td>
</tr>
</tbody>
</table>
selecting Edit > Edit Mode > Read-Only in the formal module window.

To view linksets in Graphics mode, click View > Graphics Mode.
Just as with Graphics mode in formal modules, objects are shown as boxes.
Links are shown as red arrows connecting the source and target objects, with the current link highlighted as a black arrow.

Use Turn Graphics mode on or off on the Graphics toolbar to switch between Graphics mode and Matrix mode.

Creating a linkset

When you create a link, Rational DOORS automatically creates a linkset between the source and target modules, if it does not already exist. You can, however, create a linkset yourself.

To create a linkset:

1. In the Database Explorer, make sure that link modules are being displayed.
   If necessary, click View > Show Link Modules.
2. Select the link module you want to create the linkset in, and then click File > Open > Exclusive Edit.
   You must have create access to the link module.
3. In the link module window, click File > New > Linkset.
4. In the Source module box, type the name of the source module, or use Browse to locate it.
5. In the Target module box, type the name of the target module, or use Browse to locate it.
6. Click OK.

A linkset is created, which you can use for storing links from the specified source module to the specified target module.
The linkset is opened in Matrix mode.

Deleting a linkset

Deleting a linkset deletes all the links and link attributes it contains.
To delete a linkset you must have delete access to the link module, and for each link in the linkset, you need:
Deletion a linkset

- Modify access to the source object
- Read access to the target object

To delete a linkset:

1. In the link module window, open the linkset you want to delete, using the Show linkset drop-down list on the Linkset toolbar.
2. Click File > Delete > Linkset.
   A message is displayed asking if you really want to delete the linkset.
3. Click Yes.
About discussions

Discussions allow reviewers to exchange views about the content of a module or the content of an object within the module.

Instead of setting up linked review documents, or adding new text attributes to the module under review, Rational DOORS allows you to maintain running discussions about objects and modules. The discussions are presented to you as part of the properties of the object or module.

You need to be using a Rational DOORS 9.2 or later Database Server, and the server must be configured to exclude Rational DOORS 9.0 and 9.1 clients to make the discussions functionality fully available.

You can create, view and modify discussions for modules and for objects in modules.

Note You can maintain running discussions in baselines.

You can create and add comments to discussions for objects
in a baselined and for the baselined module itself. However, if there is a discussion that was created in a baseline, and you add a comment in a more recent version of the baseline or in the current version of the module, you cannot add comments to the baseline where the discussion was created.

### Controlling access for discussions in a module

You can control the access for the discussions in a module on the module properties sheet.

You can either allow everyone to create discussions or allow individual users and groups to create discussions.

To control the access for the discussions in a module, you must have admin access to the module.

You need to be using a Rational DOORS 9.2 or later Database Server, and the server must be configured to exclude Rational DOORS 9.0 and 9.1 clients to make the discussions functionality fully available.

**To control the access for the discussions in a module:**

1. In the module window, click **File > Module Properties**, and select the **Discussions Access List** tab.

   The **Discussions Access List** is displayed.

   If the list is disabled, either:
   - Discussions are not allowed for the database
     
     If you want to allow discussions for the database, and control access to discussions in this module, you need to open Database Properties, select the **Discussions Access** tab, and select the **Allow Discussions** (*access restrictions can be set on modules*) radio button.
   - Discussions are allowed for the database, and you cannot control access to discussions.
     
     If you want to control access to the discussions in this module, you need to open Database Properties, select the **Discussions Access** tab, and select the **Allow Discussions** (*access restrictions can be set on modules*) radio button.

2. If you want all users to participate in discussions in this module, select **Allow everyone to create discussions**.

3. If you want only specific users to participate in discussions:
Creating a module discussion

To create a module discussion:

1. In the module window, click **Discussions > New Module Discussion**. The **New Discussion** dialog box is displayed.
2. Enter a summary and your comment.
3. Click **Save**.

The comment is saved and the discussion created.

Viewing a module discussion

To view a module discussion:

1. In the module window, click **Discussions > View Module Discussions**. The properties sheet for the module is displayed with the **Discussions** tab selected.
2. If you want to view all the discussions for the module, select **View Closed Discussions**.
3. Click the discussion you want to view.

The full discussion is displayed.

Adding a comment to a module discussion

To add a comment to a module discussion:

1. In the module window, click **Discussions > View Module Discussions**. The properties sheet for the module is displayed with the **Discussions** tab selected.
2. If you want to view all the discussions for the module, select **View Closed Discussions**.
3. Click the discussion you want to add the comment to.
Discussions

The full discussion is displayed.

4. Click **Add comment**.

5. Enter your comment and click **Submit**.

The comment is added.

Closing a module discussion

**Note** Only a Database Manager, Project Manager or a Custom user whose set of powers includes Archive Data, Partition Data and Create Groups can delete a discussion.

You can also delete the discussion if you are the person who created the discussion, and you are included in the Discussions Access list for the module. For information about the Discussions Access list, see “Controlling access for discussions in a module,” on page 266.

To close a module discussion:

1. In the module window, click **Discussions > View Module Discussions**.

   The properties sheet for the module is displayed with the **Discussions** tab selected.

2. Click the discussion you want to close.

   The full discussion is displayed.

3. Select **Close discussion**, and enter a comment.

4. Click **Submit**.

   The comment is added and the discussion is closed.

Deleting a module discussion

**Note** Only a Database Manager, Project Manager or a Custom user whose set of powers includes Archive Data, Partition Data and Create Groups can delete a discussion.

You can also delete the discussion if you are the person who created the discussion, and you are included in the Discussions Access list for the module. For information about the Discussions Access list, see “Controlling access for discussions in a module,” on page 266.

To delete a module discussion:
1. In the module window, click **Discussions > View Module Discussions**. The properties sheet for the module is displayed with the **Discussions** tab selected.

2. Click the discussion you want to delete. The full discussion is displayed.

3. Select **Delete discussion**. A message is displayed asking if you really want to delete the discussion.

4. Click **OK**. The discussion is deleted.

**Reopening a module discussion**

**Note** Only a Database Manager, Project Manager or a Custom user whose set of powers includes Archive Data, Partition Data and Create Groups can delete a discussion. You can also delete the discussion if you are the person who created the discussion, and you are included in the Discussions Access list for the module. For information about the Discussions Access list, see “Controlling access for discussions in a module,” on page 266.

**To reopen a module discussion:**

1. In the module window, click **Discussions > View Module Discussions**. The properties sheet for the module is displayed with the **Discussions** tab selected.

2. Select **View Closed Discussions**.

3. Click the discussion you want to reopen. The full discussion is displayed.

4. Select **Re-open discussion**, and enter a comment.

5. Click **Submit**. The comment is added and the discussion is reopened.

**Creating an object discussion**

**To create an object discussion:**
1. Select the object in the module window, and click **Discussions > New Object Discussion**.

   The **New Discussion** dialog box is displayed.

2. Enter a summary and your comment.

3. Click **Save**.

   The comment is saved and the discussion created.

**Viewing an object discussion**

**To view an object discussion:**

1. Select the object in the module window, and click **Discussions > View Object Discussions**.

   The properties sheet for the object is displayed with the **Discussions** tab selected.

2. If you want to view all the discussions for the object, select **View Closed Discussions**.

3. Click the discussion you want to view.

   The full discussion is displayed.

   When you have finished viewing the discussion, you can use **Next** or **Previous** to display the discussions for the next or previous object.

**Adding a comment to an object discussion**

**To add a comment to an object discussion:**

1. Select the object in the module window, and click **Discussions > View Object Discussions**.

   The properties sheet for the object is displayed with the **Discussions** tab selected.

2. If you want to view all the discussions for the object, select **View Closed Discussions**.

3. Click the discussion you want to comment on.

4. Click **Add comment**.

5. Enter your comment and click **Submit**.

   The comment is added.
You can use **Next** or **Previous** to display the discussions for the next or previous object.

## Closing an object discussion

**Note** Only a Database Manager, Project Manager or a Custom user whose set of powers includes Archive Data, Partition Data and Create Groups can delete a discussion.

You can also delete the discussion if you are the person who created the discussion, and you are included in the Discussions Access list for the module. For information about the Discussions Access list, see “Controlling access for discussions in a module,” on page 266.

**To close an object discussion:**

1. Select the object in the module window, and click **Discussions > View Object Discussions**.
   
The properties sheet for the object is displayed with the **Discussions** tab selected.
2. Click the discussion you want to close.
   
The full discussion is displayed.
3. Select **Close discussion**, and enter a comment.
4. Click **Submit**.
   
The comment is added and the discussion is closed.

You can use **Next** or **Previous** to display the discussions for the next or previous object.

## Deleting an object discussion

**Note** Only a Database Manager, Project Manager or a Custom user whose set of powers includes Archive Data, Partition Data and Create Groups can delete a discussion.

You can also delete the discussion if you are the person who created the discussion, and you are included in the Discussions Access list for the module. For information about the Discussions Access list, see “Controlling access for discussions in a module,” on page 266.

**To delete an object discussion:**
1. Select the object in the module window, and click **Discussions > View Object Discussions**.
   The properties sheet for the object is displayed with the **Discussions** tab selected.

2. Click the discussion you want to delete.
   The full discussion is displayed.

3. Select **Delete discussion**.
   A message is displayed asking if you really want to delete the discussion.

4. Click **OK**.
   The discussion is deleted.

### Reopening an object discussion

**Note** Only a Database Manager, Project Manager or a Custom user whose set of powers includes Archive Data, Partition Data and Create Groups can delete a discussion.

You can also delete the discussion if you are the person who created the discussion, and you are included in the Discussions Access list for the module. For information about the Discussions Access list, see “Controlling access for discussions in a module,” on page 266.

**To reopen an object discussion:**

1. Select the object in the module window, and click **Discussions > View Object Discussions**.
   The properties sheet for the object is displayed with the **Discussions** tab selected.

2. Select **View Closed Discussions**.

3. Click the discussion you want to reopen.
   The full discussion is displayed.

4. Select **Re-open discussion**, and enter a comment.

5. Click **Submit**.
   The comment is added and the discussion is reopened.
19

Tracking changes and traceability

This chapter contains the following topics:

- Change bars
- Showing module history
- Redlining
- Link analysis
- Running a link analysis
- Traceability columns
- Adding a traceability column
- Using the traceability explorer
- Suspect links
- Showing suspect links
- Clearing suspect links
- Checking data against history

Change bars

Change bars let you track the changes to objects.

The color of an object’s change bar, a symbol and a tool-tip tell you the status of an object.

<table>
<thead>
<tr>
<th>Change bar</th>
<th>Example tool-tip</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Change bar" /></td>
<td><strong>New Object</strong></td>
<td>You have created the object during the current session and have not yet saved the changes.</td>
</tr>
<tr>
<td><img src="image" alt="Change bar" /></td>
<td><strong>Unsaved changes</strong></td>
<td>You have edited the object during the current session and have not yet saved the changes.</td>
</tr>
</tbody>
</table>
Tracking changes and traceability

You can control whether the symbol is displayed in the change bar by selecting or clearing the **Show symbols in change bars** check box on the **Settings** tab of the **Options** dialog box (Tools > Options). For more information about the **Options** dialog box, see “Showing your user options,” on page 403.

**Note** The **New Object** symbol is always displayed, even if the **Show symbols in change bars** check box is cleared.

Double-click an object’s change bar to show the history of changes for the object.

**Note** You can control what edits are associated with change bars. If you do not want to know when users edit a particular attribute, you can change the attribute’s definition to turn change bars off for that attribute.

### Showing module history

You can control what changes to objects are recorded in the history. If you do not want to know when users edit a particular attribute, you can change the attribute’s definition to turn history off for that object. You can choose whether to record the creation and deletion of links in the module history. By default, link history is generated. If you do not want to generate link history, clear **Generate**
Showing module history

The history for the creation and deletion of links on the General tab of module properties.

You can filter the history by user name or date, and you can export the history to a text file, so you can print it or insert it in other files.

For more information, see the section on understanding how dates and times are recorded in Managing Rational DOORS.

To show the history of a module:

1. In the module window, click File > Module Properties.
2. Click the History tab

The following table describes the options on the History tab.

<table>
<thead>
<tr>
<th>History tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View change as redlining</td>
<td>Select this check box to show the details of the change as redlined text. The example above shows the details of the history record with redlining turned on. Deletions are shown as red text with strikethrough, and insertions as blue text with underlining.</td>
</tr>
<tr>
<td>Goto Target Object</td>
<td>If you have selected to record history for the creation and deletion of links in the current module and you select a link history, the Details of selected history record displays the name and path to the link module and target module for the link. Click Goto Target Object to open the target module (if it is not already open) and display the target object. The Goto Target Object button is only displayed when a link history is selected.</td>
</tr>
<tr>
<td>All</td>
<td>This shows module and object history. The object history tells you about all the objects that have been created, deleted or edited since the module’s most recent baseline. If Generate history for the creation and deletion of links is selected, information about links that have been created or deleted since the module’s most recent baseline is displayed. Note You can also see an object’s history by double-clicking its change bar.</td>
</tr>
<tr>
<td>History tab</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Module</strong></td>
<td>This is the default. It shows the module history. Information about all the changes to module attributes is displayed, along with the attribute definitions and types that have been created, deleted or edited since the module’s most recent baseline.</td>
</tr>
</tbody>
</table>
| **Sessions**| Select this box to show the module session history, and then click **Refresh**. The following information about everyone who has opened the module since the module was created is displayed:  
  • The person’s Rational DOORS user name.  
  • A unique session identifier.  
  • When they opened the module.  
  • If they created a baseline, the name of the baseline. |
| **Dates**   | If you only want to see history information after a particular date or within a range of dates:  
  a. Select the **Dates** check box.  
  b. Type dates in the **From** and **To** boxes, or select them from the drop down calendars.  
  c. Click **Refresh**. |
| **User**    | If you only want to see history information for a particular user:  
  a. Select the **User** check box.  
  b. Type the user name.  
  c. Click **Refresh**. |
Redlining

Some changes in Rational DOORS can be viewed with redline markup. This makes it easy to see at a glance the changes that have been made to an attribute. Redline markup is available in:

- Module and object history
- The spelling checker
- The Change Proposal System
- The Module Comparison Wizard
- Details of suspect links

The comparison that generates the redline markup in Rational DOORS is made on a word by word basis between two static pieces of text using a longest
**Tracking changes and traceability**

**common subsequence** algorithm. Rational DOORS does not save information about individual keystrokes, so the redline markup might not reflect the sequence of changes performed by the user.

As the comparison is word by word, the redline markup might differ from what you might expect. For example, if Rational DOORS is comparing *ship wreck* to *shipwreck*, the redline markup will show *ship* as deleted, *wreck* as deleted and *shipwreck* as inserted.

Rational DOORS uses word level analysis rather than character level analysis for performance reasons.

### Link analysis

Link analysis tell you about links to or from the current module. It is an analysis of normal Rational DOORS links. External links are ignored during link analysis.

You can choose whether to analyze in-links or out-links.

- If you analyze in-links, information about the objects in the chain of links coming into the current module is displayed. Changes to these objects affect the current module.
- If you analyze out-links, information about the objects in the chain of links going out from the current module is displayed. These are the objects that are affected if you make any changes to the current module.

You can specify how far you want to travel down the chain of linked objects. This is the **depth** of the analysis.

For example, if you run an analysis with a depth of 2, information about the objects that are linked to the objects in the current module is displayed, along with the objects that are linked to those objects.
Running a link analysis

This topic describes how to run a link analysis for the current object that:

- Opens every module that contains a linked object
- Applies a filter so that only the linked objects are displayed

For more information, see “Link analysis,” on page 282.

To run the link analysis:

1. Select the object whose links you want to analyze.
2. Click Analysis > Links.
3. Use the Link direction radio buttons to specify whether you want to analyze in- or out-links.
4. Use the Select link module radio buttons to specify whether you want to restrict the analysis to links that use a specific link module:
   - Click All modules if you do not want to restrict the analysis.
   - If you want to restrict the analysis to links that use a particular link module, click Specific, and then either type the name of the module (specify the path from its nearest ancestor project), or use Browse to locate it.
5. In the Depth box, type the depth of analysis you want to use.
   - The default of 1 limits the analysis to objects that are directly linked to the current object in either the current module or other modules.
   - Greater levels of depth look at links that are 2 or more link jumps on from the current object. Again, these can be links in either the current module or other modules.
   - If the depth is 0, the analysis only looks for links in the current module.
6. Click OK to run the analysis.

If a source or target object is in another module, and the module is not already open, it is opened in read-only mode. The data in both modules is filtered to show only the linked objects.

Note If the source or target module is opened in read-only mode, and you change to exclusive edit mode, the filter applied by the link analysis is removed, and the current module view is loaded.
Traceability columns

A **traceability column** contains information about objects that are linked to or from objects in the current module.

Traceability columns are layout DXL columns. The values displayed in them are calculated by a DXL program that runs an impact or traceability analysis and then displays information about the linked objects.

By default traceability columns display the following information about each linked object:

- The name of the module that the linked object is in
- The value of its **Object Heading** attribute
- Its object identifier

You can display other information if you want. You can display other attribute values for the linked object, and you can display information about the attributes of the link itself, such as when the link was created.

Adding a traceability column

For information about traceability columns, see “Traceability columns,” on page 284.

**To add a traceability column to your current view:**

1. Click **Analysis > Wizard**.
   
   The wizard’s **Welcome** screen is displayed.

2. Define the type of links you want to analyze.
   
   - Click **In-links** or **Out-links** in the **Link direction** frame.
   
   - Select the link types you want to analyze. These can be either Rational DOORS links, External links or both.

3. Click **Next**.
   
   If you have selected to include Rational DOORS Links in the analysis, the Scope of analysis screen is displayed. If you are only analyzing external links, go to Step 7.

4. Use the **Select formal module** radio buttons to select which formal modules you want to analyze:
   
   - Click **All open modules** to analyze linked objects in all formal modules that are currently open.
Note  When you run an analysis, all the modules that satisfy the analysis are opened in the background. If you run a subsequent analysis in the same session, and click All open modules, these modules are included in the analysis.

- Click All modules to analyze linked objects in all formal modules, regardless of whether they are open or not.
- To analyze linked objects in a specific formal module, click Specific, and then either type the name of the module (specify the path from its nearest ancestor project), or use Browse to locate it.

5. Use the Select link module radio buttons to specify whether you want to restrict the analysis to links that use a specific link module:
- Click All modules if you do not want to restrict the analysis.
- To restrict the analysis, click Specific, and then either type the name of the link module (specify the path from its nearest ancestor project), or use Browse to locate it.

6. Click Next.

7. The information that is displayed on this screen depends on whether you are analyzing Rational DOORS links, external links or both. If you have included Rational DOORS links in your analysis, the Module and object attributes list and the Rational DOORS link attributes list are available. If you have included external links, the External link attributes list is available.

If you are only analyzing external links, got to Step 9.

By default, the traceability columns display the following information for each object that is the source or target of a Rational DOORS link:

- The object heading.
- The object identifier.
- Module Name (including path for other folders).

This option only displays the path to the module if it is in a different folder to the current module.

If you want to display the path regardless of the module’s location, clear Module Name (including path for other folders) and Module Name (no path) and select Module Name (including path).
If you do not want to display the path to the module, clear **Module Name (including path for other folders)** and **Module Name (including path)** and select **Module Name (no path)**.

If you want to display other items, select them in the list of **Module and object attributes**. Click an item to select it. Click it again to de-select it.

If you selected all formal modules or all open formal modules in Step 4, the list only shows system attributes.

8. By default, the traceability columns do not display any attribute values for the links themselves.

If you want to display link attribute values, select the attributes in the list of **Link attributes**. Click an item to select it. Click it again to de-select it.

9. By default the traceability column displays the description of any external links. If you want to include information from other attributes in the traceability column, select the attributes from the **External link attributes** list. Click an item to select it. Click it again to de-select it.

10. Click **Next**.

11. In the **Column width** box, specify how wide you want each traceability column to be, in pixels.

   **Note** Pixels are used to measure distances on computer screens. Open **Display** in the **Control Panel**, and then the **Settings** tab to find out how big your screen is in pixels.

12. Specify how the results of the analysis are to be displayed in the traceability columns:
   - By default, every attribute is displayed on a new line.
     Clear the **One attribute per line** check box if you want the attributes displayed in a continuous paragraph without line breaks between them.
   - By default, only attribute values are displayed in the columns, but not the names of the attributes.
     Select the **Show attribute names** check box if you want to see the names of the attributes as well as their values.
   - By default, OLE objects are not displayed in the columns.
     Select **Include OLE objects in text** if you want to see OLE objects.
Adding a traceability column

- If you want to truncate the value of each attribute that is displayed to a specified number of characters, select the **Trim each datum to** check box and type the number.
- If you want to truncate the entire string that is displayed to a specified number of characters, select the **Trim entire string to** check box and type the number.

13. Specify whether you want recursive analysis.
   
   If you want analysis of more than one level, select the **Recursive analysis** check box.

14. Specify whether you want the recursive analysis to be displayed in one column or in multiple columns.
   
   If you want the recursive analysis to be displayed in one column, clear the **Multiple columns** check box.

15. In the **Specify depth of analysis** box, specify the depth of the analysis. If you are only analyzing external links, only analyzing to one level, or want to display traceability information only from specified modules this check box is unavailable. The maximum depth is 10.

16. Determine whether you only want to display information about links to and from specific modules.
   
   Select or clear the **Display information only from selected modules** check box. If you are only analyzing external links, only analyzing to one level, or have specified a number of levels in the **Specify depth of analysis** box, this check box is unavailable.
   
   If you select this check box, click **Next** to go to the next screen to specify the modules. For information about the next screen of the wizard, go to the next step.
   
   If you do not select this check box, click **Finish** to add the traceability column to your current view. By default, the first column displays information about objects that are one link hop from the current object, the second column displays information about objects that are two link hops from the current object, and so on.

17. Specify the modules that you want to display link information about.
   
   Select a module in **Module Name**. The link information from or to this module will be displayed in the first traceability column. Select another module. The link information from or to this module will be displayed in the second traceability column, and so on until you have selected all the modules you want.
For example, you assign the first column to Module A, the second column to module B, and so on. Column 1 shows objects in Module A that are linked to the current module (the one you are analyzing). Column 2 shows objects in Module B that are linked to objects in Module A. Column 3 shows objects in Module C that are linked to objects in Module B, and so on.

For each object in the module you are analyzing, you can follow the chain of links through the various modules. You can see what objects in Module A it is linked to, and what objects in Module B those objects are linked to, and so on.

**To specify a chain of modules:**

a. Select the module you want to display in column 1, and then click **Next**.

b. Select the module you want to display in column 2, and then click **Next**.

c. Repeat until you have finished building up the chain of modules.

18. Click **Finish** to add the traceability column to your current view.

**Note** If you want to permanently add the new column to your view, follow the instructions in “Saving your current view,” on page 96.

**Using the traceability explorer**

Use the traceability explorer to see which objects in your current module have links and to navigate to the linked objects.

**To use the traceability explorer:**

1. In the module window, click **Analysis > Traceability Explorer**.

   A flat list of all the objects in your current view is displayed.

   If an object has a link, it has a plus sign (+) to the left.

2. By default, the Traceability Explorer shows objects that have in-links from modules that are open.

   To change the default, use the options on the **View** menu.

<table>
<thead>
<tr>
<th>View menu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>In-links</td>
<td>Only shows in-links.</td>
</tr>
<tr>
<td>Out-links</td>
<td>Only shows out-links.</td>
</tr>
</tbody>
</table>
Suspect links

3. Click the plus sign (+) to show the linked objects.
   • The arrow shows the direction of the links.
   • The status bar at the bottom on the screen shows the name of the module that the currently selected object is in.

4. To show the selected object, right-click **Show Object**.
   If it is in a module that is not currently open, the module is opened read-only with its current object set to the selected object.

**Navigating**

To navigate within the traceability explorer:

- Use the **Page Up, Page Down** and arrow keys
- Use the scroll bars
- Use the **HOME** and **END** keys to move to the first or last object in the current view

**Suspect links**

In a large database with multiple links, a change to one object might affect many other objects in the database. Rational DOORS prevents such changes being overlooked by marking objects that are linked to objects that have changed as having a suspect link. Users can check modules for suspect links, identify the change that has caused the link to become suspect, and update the objects accordingly.

**Note** The object that is changed is not marked as having a suspect link, but any objects that are linked to that object are marked as having a suspect link.

For example, if a user requirement is linked to a system requirement a change to the user requirement might require a change to the linked system requirement.
The system requirement is marked as having a suspect link, but the user requirement does not have a suspect link. When the system requirement has been checked and updated as required, the suspect link can be cleared from the system requirement.

If changes are made to both the source object and target object of a link, the link will be marked as suspect at both ends. If you clear the suspect link at the source it also clears the suspect link at the target.

**Caution** Only those attributes that have been set to affect change dates cause a link to be marked as suspect when they are edited. The **Affect change dates** setting can be selected by editing the attribute definition.

**Note** Since version 8 of Rational DOORS, date values are stored on the server in UTC (Universal Coordinated Time), and are displayed on the client according to the client time zone. In pre-8.0 versions of Rational DOORS, date attribute values did not include the information to make time zone adjustments, so date attribute values in migrated data may not display as expected. For example, if clients in multiple time zones were working on data, suspect links may not operate as you would expect. For more information, see the section on understanding how dates and times are recorded in *Managing Rational DOORS*.

**Showing suspect links**

Objects with suspect links can be identified by:

- Filtering on suspect links
- Displaying suspect link indicators
- Displaying the last change
- Displaying all suspect link information

**Filtering on suspect links**

You can apply a filter to your module so that only objects with suspect links are displayed. You can choose to filter on suspect in-links or suspect out-links, to all modules or to modules that are currently open.

To filter on suspect links, click **Analysis > Suspect Links > Filter**, and then the type of links that you want to filter on. You can choose from:
Showing suspect links

- In-links (open modules only)
- In-links (all modules)
- Out-links (open modules only)
- Out-links (all modules)

If you select one of the open modules only options, ensure that the target modules you want the suspect link filter to apply to are open.

Note This filter cannot be saved in a view.

Displaying suspect link indicators

You can insert a column to display link indicators, which flag objects that have suspect links.

A link arrow with a question mark is displayed beside objects with suspect links. This ?< indicates an incoming suspect link and this ?> indicates an outgoing suspect link. The link indicators column does not indicate the number of suspect links that an object has. To see more detailed information about suspect links see “Displaying all suspect link information,” on page 293.

To insert a column to display link indicators:

1. Click Analysis > Suspect Links > Display Indicators, and then the type of links you want to flag. You can choose from:
   - In-links (open modules only)
   - In-links (all modules)
   - Out-links (open modules only)
   - Out-links (all modules)

   Note If you select one of the open modules only options, ensure that the target modules you want to see suspect link indicators for are open.

Displaying the last change

You can insert a column that displays a summary of the last change that made a link suspect, for each object with in-links or out-links, to open modules or to all modules.

The following information is displayed in the column:

- The absolute path to the module containing the source or target of the suspect link
- The object ID of the object that is linked to
• The date and time that the object was last modified
• If suspicion has never been cleared, that is stated

**To insert a column displaying the last change that made the link suspect:**

1. Click **Analysis > Suspect Links > Display last change**, and then the type of links for which you want to see suspect link information. You can choose from:
   - In-links (open modules only)
   - In-links (all modules)
   - Out-links (open modules only)
   - Out-links (all modules)

**Note** If you select one of the **open modules only** options, ensure that the target modules you want to see suspect link information for are open.

**Displaying all suspect link information**

You can insert a column that displays all the suspect link information for each object with in-links or out-links, to open modules or to all modules.

The following information is displayed in the column:

• The absolute path to the module containing the source or target of the suspect link
• The **Object ID** of the source or target object
• The number of changes that have been made to the object since suspicion was last cleared
• The name of the attribute that has been modified, and the time that the modification was made

There can be multiple suspect link entries for one object.

If the source or target module has been baselined since the last time suspect links were cleared, there might have been changes to the source or target object that make the link suspect, but that cannot be displayed. This is because suspect link information is based on the object history of the source or target object. If the module has been baselined, the history is cleared from the current module version and stored in the baseline.

In this instance Rational DOORS states that the source or target module has been baselined, and that the baseline might contain details of changes that make the link suspect.
To insert a column that will display all the suspect link information:

1. Click **Analysis > Suspect Links > Display all changes**, and then the type of links for which you want to see suspect link information. You can choose from:
   - In-links (open modules only)
   - In-links (all modules)
   - Out-links (open modules only)
   - Out-links (all modules)

   **Note** If you select one of the **open modules only** options, ensure that the target modules you want to see suspect link information for are open.

**Clearing suspect links**

There are two ways to clear suspect links: **Clear** and **Clear All**.

- Use **Clear** to clear individual suspect in-links or out-links from a single object in a module
- Use **Clear All** to clear all suspect in-links or all suspect out-links or both from a module

**Caution** Save all open modules before clearing suspect links.

When you clear suspect links, it is the suspicion on the link that is cleared. This means that if there have been changes to both the source and target objects of a link, and you clear the suspect link at the source object, the suspicion is also cleared at the target.

**Access rights required for clearing suspect links**

If you want to clear suspect links, you must have the following access rights:

- The first time a suspect link is cleared, you must have **Create** access to the link module. This is because attributes are created in the link module to store suspect link information.
- Anyone who subsequently clears suspect links that go through that link module must have **Modify** access to the link module.
- You must have **Modify** access to both the source and target modules of the suspect link.
Using the Clear function

1. Click **Analysis > Suspect Links > Clear** in the module window.

   The **Clear Suspect Links** dialog box for the current object is displayed.

   **Important:** Rational DOORS opens all modules in the database that contain objects that are linked to the current object. These modules will be opened without being displayed. If you do not have read access to either the module containing the linked object or the linked object itself, Rational DOORS will not calculate suspect links.

   The information is displayed over two tabs: one for incoming links and one for outgoing links.

   The information displayed includes the following:
   - The absolute path of the module containing the linked object
   - The source or target object's identifier
   - The date and time of the last modification to the source or target object

2. Click **Next** or **Previous** to display the suspect links of the next or previous object in the current view.

3. To see more information about a suspect link, select it and click **Details**.

   The first change that caused the link to become suspect is displayed. Use the **Next** and **Previous** buttons to look through the changes that have been made to the linked object since suspicion was last cleared.

   Select **View change as redlining** to see the changes that have caused the link to be flagged as suspect with redline markup.

   If the source or target module has been baselined since the last time suspect links were cleared, there might have been changes to the source or target object that make the link suspect, but that cannot be displayed. This is because suspect link information is based on the object history of the source or target object. If the module has been baselined, the history is cleared from the current module version and stored in the baseline.

   In this instance, Rational DOORS states that the source or target module has been baselined, and that the baseline might contain details of changes that make the link suspect.

4. Click **OK** to return to the **Suspect Links** dialog box for the current object.

5. Selecting a single entry or multiple entries activates the **Clear** option.

6. Click **Clear** to clear the suspect links.
Rational DOORS performs an access control check to ensure that you have the necessary access to all formal and link modules required for update.

If you do not have the necessary access, an error message is displayed, or the **Clear** button is unavailable. For more information see “Access rights required for clearing suspect links,” on page 294.

7. **Click Close.**

   When you click Close, modules open for edit, which were opened for edit previously, are left unsaved.

   An information message is displayed.

8. You must save any open modules.

**Using the clear all function**

The **Clear All** suspect links option lets you clear all suspect incoming links, all suspect outgoing links, or both. If you have the module open in shareable edit mode, you can only clear suspect links in locked sections.

**To clear all suspect links:**

1. In the module window, click **Analysis > Suspect Links > Clear All.**

   The **Clear All Suspect Links** dialog box is displayed.

2. Select **Clear Suspect In-links, Clear Suspect Out-links**, or both.

3. **Click OK.**

   All suspect links will be cleared.

   An information message is displayed.

4. **You must save any open modules.**

**Checking data against history**

Rational DOORS contains a utility to detect and fix any discrepancies between the current data in a module and the history of the module. The following discrepancies can be detected and fixed:

- Objects that have been deleted or undeleted in history, and are not deleted or undeleted in the current data.

- Objects that have been purged in history, and still present in the current data.

- Links that have been created or deleted in history, and are not present or are still present in the current data.
• Attribute values where there is a difference between the current data and history, including text values, string values, enumerated values, integer values, real values, dates, or user names. Also included are differences in default values, inherited values and module attribute values.

Changes to attributes and objects that were not included in history recording cannot be detected by the utility.

Objects that were included in history recording and are not in the current data are reported in the log but cannot be recovered.

The utility produces a report of any discrepancies, and allows you to update a module with the differences.

There are a number of discrepancies that the utility cannot detect:

• If OLE data was not included in history when the history record was saved, OLE data will not be included in the updated attribute value.
• If the change recorded in the history record is simply adding an OLE object and no text to a text attribute that was previously, and is currently, empty, the discrepancy won't be detected.

If the value recorded in history is not now a valid value for the attribute, the tool will report this in the log, but it will not update the attribute value. This can happen as a result of changes in the attribute definition or type definition that have been made since the history item was recorded (for example, changing the values of an enumerated type).

To check data against history:

1. Log in to Rational DOORS as the Administrator user.

2. Open the module you want to check for discrepancies in exclusive edit mode.

3. Click Tools > Check data against history.

4. Accept the default location of the report file, or browse to a new location.

5. Select either Append output to existing contents or Discard existing file contents.

   This determines whether a new report file is created, or an existing report file is added to.

6. Select or clear the following check boxes:
   • Check history in all baselines (this check box is only available if there are any baselines for the module)
Checking data against history

If a baseline has been deleted, that baseline, along with any previous baselines, is not included in the check.

- **Check attribute values in deleted objects**
- **Update data to match latest history values**

Select this check box if you want to recover the lost data. Even if you select this check box changes are not made permanent until you save the module.

7. Click **OK**.
Tracking changes and traceability
This chapter contains the following topics:

- Baselines
- Viewing a baseline
- Baselining groups of modules
- Creating a baseline
- Copying a baseline
- Comparing baselines
- Deleting a baseline

**Baselines**

A baseline is a read-only version of a module. It captures a moment in time and preserves it until you delete the module.

When you create a baseline of a module, you create a copy of the module, which no-one can edit.

The baseline includes the history of the module:

- Information about all the attribute definitions and types that have been created, deleted or edited since the module’s most recent baseline.
- Information about all the objects that have been created, deleted or edited since the module's most recent baseline.
- Information about every module session (every time the module has been opened) since it was first created.

You can look at baselines (see “Viewing a baseline,” on page 300).

You can also create a module by copying a baseline. The new module contains all the same data as the baseline, but does not have any of the history information. For more information, see “Copying a baseline,” on page 302.

**Using baselines to improve performance**

Rational DOORS stores the history information for each module in a separate file in the database. The history files can get very big, because they can contain a lot of information about the changes made to the modules.
When you edit a module, Rational DOORS opens its history file. The bigger the history file, the longer it takes to open it.

To improve performance, regularly create baselines of your modules. Creating a baseline creates a new file that contains the baseline, together with all the history information, and erases the contents of the module’s history file. You can still access the history information; it is just stored in a different file which is not opened when you edit the module.

See “Comparing baselines,” on page 304 for information about comparing baselines.

**Viewing a baseline**

**To view a baseline:**

1. In the module window, click File > Baseline > View.
2. Select the baseline you want to view, and then click Open.

   If the baseline is part of a baseline set, the baseline set to which it belongs is displayed in the Baseline Set box. To see more information about the baseline set, click View.

   If the baseline has been deleted, the Open and Signatures buttons are unavailable. The user name of the user who deleted the baseline, and the date the baseline was deleted are displayed alongside the baseline.

**Baselining groups of modules**

If you have several modules that you want to baseline at the same time you can create a list of those modules, called a baseline set definition. Baseline set definitions are stored with either project or folder properties. When you want to baseline the modules, you access the baseline set definition from the project or folder properties dialog, create a baseline set, and then baseline the modules to that set.

Managing the baselining of large numbers of modules in this way has several advantages:

- Having all the modules listed together in the same place means that you never forget about one of the modules in the group when it is time to baseline them.

- Rational DOORS checks for locks on the modules before starting to baseline them. You do not get half way through baselining a group of modules to find that another user has locked one of them.
Creating a baseline

To create a baseline, you must have create or modify access to the module. You can only create a baseline of a formal module.

To create a baseline:

1. Make sure you are in exclusive edit mode.
   
   The edit mode is shown on the status bar at the bottom of the module window. To change your edit mode, click Edit > Edit Mode > Exclusive Edit.

2. Click File > Baseline > New.

3. Check that None is selected in the Baseline Set list.

4. Use the Version radio buttons to select the version number of the new baseline.

5. If you want the new baseline to have a suffix as well as a version number, type it in the Suffix box.

6. If you want to enter additional information about the baseline, type it in the Description box.

7. Click OK.
   
   The module is automatically closed and then opened again.

Copying a baseline

When you copy a baseline, you create a module. You can either:

- Copy all the information in the baseline.
  
  The new module contains exactly the same data as the baseline, except that it has no history information and no links.

- Copy only the objects that have headings.
This lets you create a module that has the same structure as the original module. The baseline is used as a template for the new module.

The new module is created in the same folder or project as the original module. You must have create access to this folder or project.

**To copy a baseline:**

1. In the module window, click **File > Baseline > Copy.**
2. Select the baseline you want to copy.
   
   **Note** You cannot copy baselines that have been deleted.

3. In the **Copy to new formal module** box, type the name you want to give the new module.

   The name is case-sensitive. For example, the names **Mymodule** and **MyMODULE** are different.

   The name must be unique within the parent project or folder. All the projects, folders and modules in the parent must have different names.

   The name can contain the following characters:
   
   • Alphanumeric characters (letters of the alphabet and numbers)
   • Space characters
   • Periods (.)
   • Underscores (_)
   • Hyphens (-)

4. If you want to enter additional information about the new module, type it in the **Description** box.

5. By default, the new module’s object identifiers start at 1 and have no prefix. If you want to override the default, use the **Start at** and **Prefix** boxes.

6. Use the **Include** radio buttons to specify what you want to copy:

   • Click **All information** to copy everything.
   • Click **Headings only** to copy only objects that have headings and only the **Object Heading** text for those object.

7. Click **OK.**

The new module is created. It inherits its access rights from its parent folder or project.
Comparing baselines

Rational DOORS records changes to data and stores complete baselines without using third-party tools. Rational DOORS offers an additional feature: baseline compare. This provides a list of the differences in the main column between any two baselines of the same module, recording:

- Any objects that have been modified in the main column
- Any objects that have been added or deleted in the main column

To compare baselines:

1. Open the module whose baselines you want to compare.

   Make sure filtering is turned off. If the module is filtered, and some objects are hidden, the results of the baseline comparison can be affected.

2. In the module window, click **File > Baseline > Compare**.

   The **Baseline Compare** window is displayed:

3. Select the baselines for comparison.

   **Note**: Rational DOORS treats the version in the left pane as the older of the two that are being compared. So when you perform a baseline compare, make sure you select the older baseline in the left pane. If you select a more recent version in the left pane, Rational DOORS will report additions to the module as deletions and vice versa. For example, if you baseline a module, and then add some text to an object, and then do a baseline compare, selecting the current version in the left pane, Rational DOORS reports the text you added as being deleted. This is because the version selected in the left pane (as far as Rational DOORS is concerned, the earlier version), contains text that does not exist in the version selected in the right pane. Rational DOORS therefore reports this text as being deleted.

4. Select the **Show Baselines** option if you want the baseline you selected to be opened. A filter is applied to both versions of the module so that only objects that have changed since the last baseline are displayed.

5. Click **Compare**.

   Rational DOORS tells you to how many differences there are between the baselines.
6. Click **OK**.

The **Baseline Comparison Results** dialog box is displayed with the **Plain View** tab selected.

Select the **Redlining View** tab if you want to see the changes as redlined text. Deletions are shown as red text with strikethrough, and insertions as blue text with underline.

If you selected the **Show Baseline** option in Step 3, the baseline is opened and objects that have changed are displayed.

**Deleting a baseline**

If a baseline is no longer needed it can be deleted. You must be a Database Manager or Custom user with Manage database powers to delete a baseline, and baseline deletion must be enabled for the database. The database default is to not allow baseline deletion. If you want baseline deletion to be enabled, contact your Rational DOORS administrator.

**Note** When a module is baselined all the history information stored in the module since the last baseline is transferred to the baseline. If you delete a baseline you are deleting the module history for that period. As a baseline deletion is not reversible you might want to archive the module before deleting the baseline so that it can be restored should you need to access that history information.

**To delete a baseline:**

1. Click **File > Baseline > Delete**.
2. Select the baseline you want to delete.

   If the baseline is part of a baseline set, the name of the baseline set is to which it belongs is displayed in the **Baseline Set** box. To see more information about the baseline set, click **View**.

3. Click **Delete**.
4. Click **Confirm** to delete the baseline.

   The baseline remains in the baseline list and your user name and the date of the deletion are displayed in the **Deleted By** and **Deleted On** columns.

**Note** If the baseline is part of a baseline set that is currently open, you cannot delete it.
Using Electronic Signatures

This chapter contains the following topics:

- Viewing signatures
- Signing a baseline
- Including signature information in printouts

Viewing signatures

To view signatures that have been made against a baseline:

1. Click File > Baseline > View.
   
   The View Baseline dialog box is displayed.

2. Select the baseline whose signatures you want to view and click Signatures.
   
   The Baseline Signatures dialog box is displayed.

Signatures that have been made against the baseline are displayed in the upper pane of the dialog box. The following information is displayed in the columns in the upper pane:

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Signatory</td>
<td>The Rational DOORS user name of the user who signed the baseline.</td>
</tr>
<tr>
<td>Date/Time</td>
<td>The date and time that the baseline was signed. Signatures are displayed in full chronological order. For more information, see the section on understanding how dates and times are recorded in Managing Rational DOORS.</td>
</tr>
<tr>
<td>Date/Time</td>
<td>The date and time that the baseline was signed. Signatures are displayed in full chronological order.</td>
</tr>
<tr>
<td>Label</td>
<td>If Rational DOORS was configured to use Signature Labels when the user signed the baseline, the label the signatory selected is displayed here. If signature labels were not being used when the user signed the baseline, this is blank.</td>
</tr>
</tbody>
</table>
To see more information about a signature, select it. The following information is displayed on the tabs in the lower pane of the dialog:

<table>
<thead>
<tr>
<th>Tab name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Comments</td>
<td>If the user added any comments when signing the baseline, they are displayed here.</td>
</tr>
</tbody>
</table>
| Details  | Database settings often change during the life-cycle of a module, so the Details tab displays information about the database at the time the signature was made.  
- If the database was configured to use passwords, “Signatory was required to re-authenticate” is displayed. If passwords were not in use “Signatory was not required to re-authenticate” is displayed.  
- Any restrictions on access are recorded.  
- The signature labels that were available to the user when signing the baseline are listed. |

### Signing a baseline

**To sign a baseline:**

1. In the baselined module click File > Baseline > View.  
The View Baselines dialog box is displayed.  
2. Select the baseline you want to sign and click Signatures.  
Any signatures that have been made against the baseline are displayed in the upper section of the Baseline Signature dialog box in chronological order. For details of the information that is recorded when you sign a baseline, see “Viewing signatures,” on page 307.  
3. Click Sign  
The Add Signature dialog box is displayed.
Including signature information in printouts

To include signature information in a printout:

1. In the formal module, click **File > Page Setup**.
   The **Page Setup** dialog is displayed.

2. Click the **Layout** tab and select the **Include Signature Information** check box.
   A page displaying the signature information is included after the title page when the module is printed.

---

**Note**  The **Sign** button is only activated once a baseline has been configured for sign off. If the **Sign** button is still unavailable after the baseline has been configured for sign off, it is because you have insufficient access rights, or the module has not been set up to use electronic signatures. In both of these instances contact the module owner.

4. Select a **Signature Label** from the drop-down list and add any comments to the **Comments** field. For example, you might want to state a reservation about a certain part of the module. Remember that once you add the signature you are unable to edit any part of it.

If the module owner has chosen not to use signature labels, the **Signature Labels** field is unavailable. You will still be able to add comments to make the meaning of your signature clear.

A **Full Name** might have been assigned when the Database Manager created your user account. If so, your Full Name is displayed, and is included with your electronic signature.

5. Click **OK**.
   The **Reconfirm User Details** dialog box opens.

6. Type your Rational DOORS user name and password (if required) and click **OK**.
   The dialog is dismissed and your signature is added to the list of signatures in the **Baseline Signatures** dialog box.
Printing reports

This chapter contains the following topics:

- Applying saved page setups
- Creating page setups
- Printing a module
- Using print preview
- Creating a report
- Printing and managing reports

Applying saved page setups

You can control the appearance of modules when they are printed by using page setups. Rational DOORS provides one predefined page setup, the Standard layout, which is used by default when you print a module. If you or any other user has created and saved a page setup, it is available to all Rational DOORS users from the Page setup dialog in any formal module.

To apply a saved page setup to your module:

1. In the module window, click File > Page Setup.

   A list of page setups is displayed in the left pane of the Page setup dialog box.

2. Select the page setup you want to use.

   You can view the settings associated with that setup by looking at the tabs on the right of the dialog box. If you want to print the module using these settings, click OK.

   If none of the available page setups is suitable, you can base a new page setup on an existing one. Select the page setup that is most like the one you want to create, and edit it. For information about how to create a page setup see “Creating page setups,” on page 311.

Creating page setups

To create or edit a page setup:

1. In a module window, click File > Page Setup.
2. On the left, a list is displayed of all the saved page setups for the database, and on the right, a series of tabs that can be used to define the layout of the module when it is printed. To see the settings associated with a saved page setup, select it in the left pane, and use the tabs to view the settings.

Note If you have not edited the settings on the page setup dialog, the module is printed using the Standard layout, which is provided with Rational DOORS. If no one has created and saved a page setup, the only setup listed in the left pane is Standard layout.

3. Select the page setup that is most like the one you want to create. You can change it to suit your needs.

4. Use the Format tab to specify whether you want to print the module in Table format or Book format. The options that are available on this tab depends on which format you select.

<table>
<thead>
<tr>
<th>Format selected</th>
<th>Appearance when printed</th>
<th>Options available for this format</th>
</tr>
</thead>
</table>
| Table           | Includes all the columns that are displayed in the current view, and looks the same as the module does on screen. The main column is always printed, even if it is not displayed in the view. | Cells  
You can select whether the table cells have borders, shading or are not marked.  
Column titles  
You can select whether column titles display on every page or only on the first page. |
Creating page setups

<table>
<thead>
<tr>
<th>Format selected</th>
<th>Appearance when printed</th>
<th>Options available for this format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Book</td>
<td>Each object’s <strong>Object Heading</strong> and/or <strong>Object Text</strong> is printed on a new line, followed by the attribute values held in any other displayed columns. For each displayed column, the column title is printed along with the value for that object.</td>
<td>You can choose whether to include or omit attributes with null values from your print out. If you include attributes with null values, each object that is printed will have a list of the displayed columns under it, even if the object has no values in any of those columns. If you omit attributes with null values, only columns that contain an attribute value for the object will be printed.</td>
</tr>
</tbody>
</table>

5. Use the **Layout** tab to specify the layout you want.

<table>
<thead>
<tr>
<th>Select this check box</th>
<th>To</th>
</tr>
</thead>
</table>
| Include title page    | Print a title (front) page. By default, the following information is printed on the title page:  
  - The path to the module from the parent project  
  - The module name  
  - The module version  
  - The name of the user who prints it  
  - The date the module is printed |
| Include filter criteria on title page | Include on the title page details of the filter criteria that are applied to the module. If the module is not filtered then **No filter applied** is printed on the title page. |
| Include sort criteria on title page | Include on the title page details of the sort criteria that are applied to the module. If the module is not sorted, **No sort applied** is printed on the title page. |
6. Use the **Paper Size** tab to define the paper size and page orientation. The dimensions are measured in either inches or millimeters, depending on your current user options settings. To change the settings, click **Tools > Options** in the Database Explorer, and then edit the **Settings** tab.

<table>
<thead>
<tr>
<th>Select this check box</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Include signature information</td>
<td>Insert after the title page a page containing all the signature information for the module. This check box only applies if the module is configured to use electronic signatures on baselines.</td>
</tr>
<tr>
<td>Include contents up to level</td>
<td>Include a contents page when the module is printed. The heading levels that are displayed in the contents page are defined using the drop-down list to the right of the box. For example, select 2 to print level 1 and 2 headings in the contents page. If the main column is not displayed in the view that you are printing, no table of contents is created or printed.</td>
</tr>
<tr>
<td>Insert page breaks up to level</td>
<td>Insert page breaks when the module is printed. Use the dropdown list to define what heading level will trigger a page break. For example, select 2 to start a new page for every level 1 heading and every level 2 heading.</td>
</tr>
<tr>
<td>Show change bars</td>
<td>Print change bars.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paper size</td>
<td>Select the paper size you want to use. If you select <strong>Custom</strong>, type the page width and height in the <strong>Width</strong> and <strong>Height</strong> boxes.</td>
</tr>
<tr>
<td>Width</td>
<td>The width of the printed page. This field is greyed unless the paper size is <strong>Custom</strong>.</td>
</tr>
<tr>
<td>Height</td>
<td>The height of the printed page. This field is greyed unless the paper size is <strong>Custom</strong>.</td>
</tr>
<tr>
<td>Portrait</td>
<td>Select if you want the page orientation to be portrait.</td>
</tr>
<tr>
<td>Landscape</td>
<td>Select if you want the page orientation to be landscape.</td>
</tr>
</tbody>
</table>
7. Use the **Margins** tab to define the page margins. The values are measured in either inches or millimeters, depending on your current user options settings. To change the settings, click **Tools > Options** in the Database Explorer, and then edit the **Settings** tab.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Top</td>
<td>Enter the distance you want between the top of the page and the top of the first line on the page.</td>
</tr>
<tr>
<td>Bottom</td>
<td>Enter the distance you want between the bottom of the page and the bottom of the last line on the page.</td>
</tr>
<tr>
<td>Left</td>
<td>Enter the distance you want between the left edge of the page and the left margin.</td>
</tr>
<tr>
<td>Right</td>
<td>Enter the distance you want between the right edge of the page and the right margin.</td>
</tr>
</tbody>
</table>

8. Use the **Headers** tab to define headers for the title page, the contents pages, and the body pages. The body pages are the pages that contain the module content.

You can either type the text that you want to be displayed in page headers directly into the appropriate box (**Left**, **Middle** or **Right**), or use rich text codes. Rich text codes automatically generate their associated value at print time. For example, use **&N** to include the page number:

<table>
<thead>
<tr>
<th>Code</th>
<th>Generates</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;N</td>
<td>Page number. Title pages are not numbered. Contents pages use roman numerals.</td>
</tr>
<tr>
<td>&amp;C</td>
<td>Total number of pages (for body pages only).</td>
</tr>
<tr>
<td>&amp;M</td>
<td>Module name.</td>
</tr>
<tr>
<td>&amp;P</td>
<td>Project name.</td>
</tr>
<tr>
<td>&amp;I</td>
<td>Database name.</td>
</tr>
<tr>
<td>&amp;L</td>
<td>Module location from the parent project.</td>
</tr>
</tbody>
</table>
You can combine text and codes. Enter Page &N of &C to print Page 1 of 15, for example.

You can apply rich text formatting to header text. Select the text or rich text codes, and then right-click and select the rich text format you want to apply.

9. Use the **Footers** tab to define footers for the title page, the contents pages, and the body pages. The body pages are the pages that contain the module content.

You can either type the text that you want to be displayed in page footers directly into the appropriate box (Left, Middle or Right), or use rich text codes. Rich text codes automatically generate their associated value at print time. For example, use **&N** to include the page number:

<table>
<thead>
<tr>
<th>Code</th>
<th>Generates</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;N</td>
<td>Page number. Title pages are not numbered. Contents pages use roman numerals.</td>
</tr>
<tr>
<td>&amp;C</td>
<td>Total number of pages (for body pages only).</td>
</tr>
<tr>
<td>&amp;M</td>
<td>Module name.</td>
</tr>
<tr>
<td>&amp;P</td>
<td>Project name.</td>
</tr>
<tr>
<td>&amp;I</td>
<td>Database name.</td>
</tr>
<tr>
<td>&amp;L</td>
<td>Module location from the parent project.</td>
</tr>
</tbody>
</table>
Printing a module

<table>
<thead>
<tr>
<th>Code</th>
<th>Generates</th>
</tr>
</thead>
</table>
| &V   | Module version.  
If it is a baseline, **Baseline** is printed along with the version number. If it is the current version, **Version** is printed along with the version number. |
| &U   | Session user name.|
| &D   | Session date.|
| &T   | Print time.|
| &A   | Rational DOORS product name.|
| &B   | Rational DOORS product version.|

You can combine text and codes. Enter **Page &N of &C** to print **Page 1 of 1**, for example.

Rich text formatting can be applied to footer text. Select the text or rich text codes, and then right-click and select the rich text format you want to apply.

10. If you want to use this page setup again, or if you want to make it available to other users, you can save it.

To save your page setup:

a. Click the **Save as** button on the left side of the dialog box.

b. Give your new page setup a name.

c. Click **OK**.

The page setup is saved, and can be used by you or any other Rational DOORS user on any module in the database.

11. If you do not want to save the page setup, click **OK**. Your settings are applied to the module, and persist in the current Rational DOORS session. They are not available to other modules, and are lost if you select a previously saved page setup.

**Printing a module**

To print a module:

- In the module window, click **File > Print**.
A standard **Print** window is displayed that lets you specify which printer you want to use, what pages you want to print, and so on.

**Note** You can also print from the **Print Preview** window and the **Report Manager** (see “Using print preview,” on page 318, and “Printing and managing reports,” on page 321).

### Using print preview

Use print preview to see what you are about to print, before you print it. If you like what is displayed, you can print directly from the **Print Preview** window.

**To use print preview:**

1. Open the module and set up the view you want to print.

   If you are printing in Book format, the main column is always printed, even if it is not displayed in the view. If the main column is not displayed in the view, no table of contents is created or printed.

   If you are printing in Table format, and you want to print the main column, the main column must be displayed in the view.

2. Click **File > Print Preview**.

3. In the **Printer** box, select the printer you want to use.

4. Use the **Preview range** radio buttons to select the pages you want to preview:
   
   - Click **Selected objects** to preview the objects that are currently selected in the module. If an object in a table is selected, the whole table is previewed.
   
   - Click **All** if you want to preview all the data in the current view.
   
   - Click **Current** if you want to preview the page that contains the current object.

   If your current page setup includes a title and/or contents page, the title and/or contents pages are included with the current page.

   - Click **Range** if you want to preview a range of pages, and then type the start and end page numbers in the **from** and **to** boxes.

   If your current page setup includes a title and/or contents page, the title and/or contents pages are included with the page range you select here.

5. Click **Preview**.

   The **Print preview** window is displayed.
Creating a report

Reports are useful if you regularly print a module using the same view and page setup. When you create a report what you are actually doing is associating a selected view and page setup with the module for printing purposes. You can then print the module at any time from the Database Explorer using these settings, without having to navigate to and open the module.

You use a wizard to create the report. You can select the view and page setup, give the report a name, and save it.

To create a report:

1. Open the module you want to create the report for.
2. Click **Tools > Wizards > Report**.
   The wizard **Welcome** screen is displayed.

3. Click **Next**.

4. Select the view you want to show in the report, and then click **Next**.

5. Select the page setup you want to use in the report, and then click **Next**.

6. In the **Name** box, type the name you want to give the report. This name is only used by the Report Manager to identify the report. It is not shown in the report itself.
   The report name must not exceed 80 characters.

7. If you want to enter additional information about the report, type it in the **Description** box. Again, this description is only used by the Report Manager. It is not shown in the report itself.

8. Click **Next**.

9. Click **Finish** to save the report details.

10. Click **OK**.

   **Note** To print the report, follow the instructions in “Printing and managing reports,” on page 321.

### Printing and managing reports

Once you have saved a report, it is accessed using the Database Explorer, not the module. A report is not a copy of a module at a particular point in time which can be printed later. It is an association between a module, a page setup and a view. When you print or view a report the module is opened read-only, with the view that you selected when creating the report displayed, and the page setup you selected applied.

**To print, view or delete a report:**

1. In the Database Explorer, select the project that contains the module whose report you want to print, view or delete.

   **Note** You must select a *project*. If there are no projects in the hierarchy, the report is not produced.

2. Click **Tools > Manage Reports**.

   A list of all the modules that have reports associated with them is displayed. Indented below each module is a list of its reports.
3. Select the report, and then either:
   - Click **Print** to print it. This opens the module and loads the view associated with the report, and then displays the standard **Print** window. Use the **Print** window to specify which printer you want to use, what pages you want to print, and so on.
   - Click **View** to open the module and load the view associated with it.
   - Click **Delete** to delete the report.

4. When you are finished, click **Close**.
23 Importing

This chapter contains the following topics:

- Importing from Microsoft Word
- Editing imported Word style information
- Importing plain text files
- Importing RTF files
- Importing spreadsheet files
- Importing FrameMaker files

Importing from Microsoft Word

This topic describes how to import data from Microsoft Word into a module’s main column. You import headings and text into the module’s Object Heading and Object Text attributes.

You import documents from Microsoft Word into Rational DOORS by exporting them from Microsoft Word.

You must open the target folder or project in the Database Explorer before Word can export data to it. You must also specify the module you want to import to, as described in the following sections. If the module does not exist, it is created during import. If the module exists, you are asked if you want to append the imported data to the module. If you do not want to append data, the import stops.

- Paragraphs in the Word document that have Outline levels 1 to 9 are imported as heading objects.
- You can choose to ignore section numbers in the Word headings.
- Auto-numbered section numbers are always ignored.
- Paragraphs formatted as Body text in Microsoft Word are stored in the Object Text attribute of objects. These are created one level below the heading object.
- OLE objects are imported and stored as OLE objects.
- Tables are imported as Rational DOORS tables.
- Bulleted lists are imported as Rational DOORS bulleted lists.
• Indented paragraphs in Word have identical indenting applied in Rational DOORS.
• All other styles are imported as object text.
• Unicode and other international data is included in the import.
• If you import a document containing hidden text to Rational DOORS, and then export the module back to Word, the hidden text will be displayed in the resulting Word document.
• You cannot import a document that contains objects created using Microsoft Equation 3.0.

You can capture the style formatting of paragraphs in your Word document for use in a later export to a new Word document.

**To import a document from Word into Rational DOORS:**

1. In the left pane of the Database Explorer, click the project or folder that you want to import the document into.
   
   You must have create access to this folder or project.

2. Start Word and open the document you want to send to Rational DOORS.

3. Click the **Export to DOORS** button on the Word toolbar, or click **Tools > Export to DOORS**.
   
   **Note** If you are running Rational DOORS through Citrix, Word must also be running through Citrix or the import will not work.

4. In the **Module Name** box, enter the name of the module you want to export to.

5. In the **Module Description** box, enter additional information about the module.

6. Optionally, in the **Module Prefix** box, enter the object identifier prefix.

7. In the **Absolute Numbers Start At** box, enter the object identifier starting number.

8. If you want to ignore section numbers in Word headings, select the **Remove heading numbers** check box.

   The auto-numbering produced by Rational DOORS might be different from the auto-numbering in the original document. If you have references to any of them, you should store the original numbers.
9. If you want to capture Word paragraph styles, select the **Capture paragraph styles** check box.

10. Click **Export**.

The module is created and opened, and the document is imported to it.

The **Progress** panel on the Export to DOORS dialog gives information about the export progress.

---

**Editing imported Word style information**

If you capture paragraph style information when you import data from Microsoft Word, the style information is stored in the **Paragraph Style** attribute.

The Paragraph Style attribute contains one or more `<attribute: style>` pairs. Each `<attribute:style>` pair defines the style that is applied to an attribute’s value when you export the data back to Word.

You can change the style information if, for example, you want to export the module to a Word file that uses a template with special styles.

You can edit the Paragraph Style attribute value in-place, but it is more efficient to use the **Edit Paragraph Style Attribute** tool.

The Paragraph Style attribute can store as many `<attribute: style>` pairs as you want.

The value of the Paragraph Style attribute is object specific, but it can contain style information for more than one attribute. This means that you could, for example, specify one style for the Object Heading attribute, and a different style for the Object Text attribute. If you then exported the object, Word would apply different styles to the data in each attribute.

The tool can manipulate the styles either for the current object or for every object in the current view.

Two settings have special significance:

- The Attributes setting
- The Properties setting

The Attributes setting lets you specify a default style which applies to every attribute which is not listed in the Paragraph Style attribute.

The Properties setting lets you specify styles for data in your view which are not attribute values, such as layout DXL and object identifiers.
You use the Attributes setting and the Properties setting in the same way as any other attributes. They have `<attribute:style>` pairs like any other values in the Paragraph Style attribute.

**To run the Edit Paragraph Style Attribute tool:**

1. Open the module whose Paragraph Style attribute you want to edit.
2. Click Tools > Support Tools > Edit Paragraph Style Attribute.
3. In the Attribute box, select the attribute that you want to specify a style for.
4. In the Paragraph style box, type the name of the Word style that you want to use for the attribute.

**Note** To delete the paragraph style information for the attribute, clear (delete all the text in) the Paragraph Style box.

5. If you want to change the Paragraph Style attribute of the current object only, click Apply to Current.
   
   If you want to change the Paragraph Style attribute of all objects in the current view, click Apply to All.

6. Click Close.

**Importing plain text files**

The import plain text tool reads a text file and populates the current module with objects created from its contents.

The imported file is placed after the current object.

The structure of the object hierarchy and the values of the object attributes are determined by the structure and content of the file.

You can use the importer to populate an empty module, or to extend a populated module.

**Basic import options**

The text file is analyzed to identify paragraphs and headings.

A paragraph consists of:

- A blank line
- Text
- A blank line
A heading consists of:

- A blank line
- A line of text that begins with a heading number

A heading is a numbered paragraph.

Heading numbers consist of any combination of digits and periods that start and end with a digit.

When the importer finds a heading, it creates a heading object at the level in the object hierarchy that corresponds to the heading number.

When the importer finds a non-heading paragraph, it stores the contents in a child of the previous heading object.

When the importer finds an enumerated list item, it creates a child object of the previous heading object.

You can tell the importer to create individual objects for each sentence in a paragraph or in a heading, or to import the entire text file into a single object.

Controlling text decomposition

The text decomposition level determines how objects are created during importing.

There are four levels of text decomposition:

- **None**
  
  No decomposition occurs.

  One object is created after the current object, and the entire file is stored in the **Object Text** attribute.

  Advanced functions cannot be used.

- **Paragraph**
  
  An object is created for each heading.

  An object is created for each paragraph.

- **Sentence**
  
  An object is created for each sentence in a heading.

  An object is created for each sentence in a paragraph.

- **Sentence with keywords**
The discovery of a sentence containing a keyword triggers the creation of a new object for the next sentence. The sentence containing the keyword is stored in the **Object Text** attribute.

All succeeding sentences are appended to the object text, until another sentence is found containing a keyword, which triggers the creation of the next object.

**Note**  The sentence that contains the keyword becomes the last sentence in the object. A new object is created for the sentence that immediately follows the keyword sentence.

**Attribute value assignment**

The **Object Heading** attribute is assigned the value of the string that:

- Starts with the first non-white-space character that follows a heading number.
- Ends with the last non-white-space character that precedes the first occurrence of a delimiter. A delimiter can be any of the following:
  - period space [ . ]
  - semicolon space [ ; ]
  - colon space [ : ]
  - space hyphen space [ - ]
  - carriage return

If a break is detected in the heading number sequence, heading objects are created to represent the missing headings in the sequence. You can specify the **Object Heading** that is assigned to the inserted heading objects.

By default, when the importer finds a heading paragraph, the object text is assigned the value of the string that:

- Starts with the text following the heading end delimiter.
- Ends with last non-white-space character that precedes a blank line.

You can override this default behavior by using advanced options.

When the importer finds a text paragraph, the **Object Text** attribute is assigned the value of the paragraph text.

The **Object Short Text** attribute of heading objects, is assigned the value of the **Object Heading** attribute (excluding the heading delimiter and security classification).
**Advanced importing options**

The advanced importing options let you:

- Control how list items are imported.
- Capture embedded data from the file.
- Control how carriage returns and chapter numbers are handled.
- Select the encoding you want to use to interpret the file.

**Controlling list import**

You can control importing of enumerated lists and document lists.

An **enumerated list** item is a line of text that starts with one of the following:

- `<optional white space> list_id. <mandatory white space>`
- `<optional white space> list_id) <mandatory white space>`
- `<optional white space> (list_id) <mandatory white space>`

where `list_id` is one of:

- Character in the range a - z
- Character in the range A - Z
- One or more arabic digits
- One or more roman digits

A **document list item** is a line of text that contains a user-specified delimiter. Document list items do not need to be preceded by a blank line.

There are two options for handling enumerated lists:

- **Extract enumerated list items**
  
  One object is created for each list item. The object hierarchy reflects the structure of the list.
  
  The **Object Short Text** is assigned the value of the first non-white-space character and succeeding characters of the list item, up to the first period followed by a space [. ]. It is truncated to 80 characters.

- **Extract document list items using delimiter**
  
  If a document list item is found, an object is created as a child of the previous heading object. The **Object Heading** attribute is assigned the value of the text that precedes the delimiter.
The **Object Text** attribute is assigned the value of the text that follows the delimiter.

**Capturing embedded data**

You can capture additional data embedded in the text file during the import. The data you want to capture is stored in attributes you specify before importing begins.

There are three options for capturing embedded data:

- **Heading number**
  The number of the paragraph (in the text file) that generated an object is captured. You can specify the attribute in which the heading number is stored. This creates traceability from each object to its origins in the input document. The heading number is the paragraph number of the preceding heading followed by a section number.

- **Security classification**
  Characters in parentheses ( ) preceded by white space and following a heading number are security classifications.
  You can specify an attribute in which the security classification is stored.
  Plain text paragraphs are assigned the same classification as the heading that precedes them. Headings without explicit security classifications are assigned a default classification (which you can specify).

- **Reference**
  Text in square brackets [ ] is treated as reference information, (for example, requirement identifiers). You can specify an attribute in which reference information is stored. Multiple references for the same object are stored as a comma-separated list.

**Controlling line breaks and chapter numbering**

Two options control how carriage returns and chapter numbers are handled:

- **Preserve carriage returns in paragraph text**
  Turning this option on lets you preserve carriage returns if the file only has carriage returns between paragraphs.
  Turning this option off lets you auto-wrap the object text, if the text file has carriage returns at the end of each line.

- **Preserve chapter numbers using default heading**
If there are breaks in the sequence of level 1 headings in the text file, you can automatically insert missing level 1 objects by turning this option on. You can specify a default value for the **Object Heading** attributes of the inserted level 1 objects.

This feature supports MIL-STD numbering for appendices (for example, 10.0, 20.0, 30.0).

**Importing plain text**

The import plain text tool is configurable, and you can save your configuration settings in a file for future use. This means you need only define the settings once for each file you want to import.

To import a plain text file:

1. Open the module that you want to import the text into.
2. Select the object immediately before the required location for the imported text.
3. Click **File > Import > Plain Text**.
4. Type the name of the file you want to import including the path, or use **Browse** to locate it.
5. Click **Import**.
6. Select the text decomposition level from the **Decomposition level** drop-down list.

The following table describes each level.

<table>
<thead>
<tr>
<th>Level</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>The text is imported as laid out in the file, but there is only one object.</td>
</tr>
<tr>
<td>Paragraph</td>
<td>The text is imported with one object for each block of text up to an empty line.</td>
</tr>
<tr>
<td>Sentence</td>
<td>The text is imported with one object for the text up to and including each period. A numbered list with a period following the number has a separate object for each number.</td>
</tr>
</tbody>
</table>
If you choose **Sentence w/keyword(s)**, the **Keywords** list becomes available. Select one or more keywords from the list that you want to trigger object creation.

If you choose **Sentence** or **Sentence w/keyword(s)**, the **Abbreviations** list becomes available. Select one or more abbreviations that you want recognized as valid. This avoids incorrect interpretation of abbreviations as sentence endings.

7. Click **Advanced** if you want to use the advanced options. For more information, see “Using the import plain text advanced options,” on page 332.

8. Click **Import**.

The file is imported after the current object.

### Using the import plain text advanced options

The advanced options let you control text decomposition, data capture, list importing, line break handling, chapter number handling and text encoding.

**To use the advanced options:**

1. Click **Advanced** on the **Configure Import** dialog box.

2. Select the **Heading Number, Security Classification** or **Reference** check boxes if you want to capture data of those types.

   The appropriate **in attribute** and **with default** boxes are activated.

3. Type the names of the attributes in which the captured data should be stored, in each of the active in attribute boxes.

4. Type default values for each of the attributes in the **with default** boxes.

5. If you want to preserve carriage returns, select the **Preserve carriage returns in paragraph text** check box.

6. If you want to preserve the chapter number sequence, select the **Preserve chapter numbers using default heading** check box and enter a default heading.
7. If you want to create objects for each enumerated list item, select the **Extract enumerated list items** check box.

8. If you want to create objects for document list items, select the **Extract document list items using delimiter** check box and enter the list item delimiter. For example, if the list items start with three hyphens in the text file, enter three hyphens in the **Delimiter** field.

**Note** The delimiter should be a string that does not occur in normal text. If the delimiter is found in normal text, the import creates an object for the text following it. For example, if the list items start with a single hyphen, any text following a hyphen is treated as a list element in the import.

9. If you want to limit the heading length, select **Maximum heading length** and enter a maximum length.

10. If the text decomposition level is **Sentence** or **Sentence w/keyword(s)**, add or remove keywords and abbreviations. For more information, see “Adding and removing keywords or abbreviations,” on page 333.

11. Select the encoding that you want to use to interpret the file. The **Encoding** list contains a list of the code pages that are available on your machine. Select the encoding that was used when the plain text file was created. You can check if you have selected the correct encoding by looking at the output in the preview pane. If the encoding is not correct, the preview pane might display symbols instead of text.

12. Click **OK**.

**Adding and removing keywords or abbreviations**

You can only add or remove keywords if the text decomposition level is set to **Sentence w/keyword(s)**.

**To add a keyword or abbreviation:**

1. Type the keyword or abbreviation in the appropriate field of the **Advanced Options** window.
2. Click **Add** to the right of the entry.

The keyword or abbreviation is listed in the appropriate field in the **Configure Import** window.

**To remove a keyword or abbreviation:**
1. In the **Configure Import** window, select the keywords and abbreviations you want to remove.

2. Click **Advanced**.

3. Click the **Remove** button.

### Importing RTF files

The Import RTF tool reads an RTF (Rich Text Format) file and populates the current module with objects created from its contents. Unicode and other international data is included in the import.

The imported objects are placed after the current object.

Before you can import an RTF file, you need to map the styles used in the RTF file to appropriate Rational DOORS features. The tool attempts to map the RTF heading styles to Rational DOORS features for you.

You can save a style mapping for future use.

If the tool finds any text before the first heading in the RTF file, the first object created has an **Object Heading** of **Front Matter**, and the text is stored in the **Object Text** attribute of the child of the heading object.

If the tool finds a picture embedded in a paragraph, it creates three objects. The first stores the text that precedes the picture; the second stores the picture; the third stores the text that follows the picture. The system attribute **PictureNum**, held in the object, stores a number that uniquely identifies the picture.

RTF tables are imported as Rational DOORS tables. Pictures contained in table cells are not imported.

Importing a document in RTF format might use more resources than importing the same document as a Microsoft Word document.

When you import an RTF document, a number of module attributes are created. These are used if the module is exported back to RTF, so that the resulting file has the same properties as the original.

**To import an RTF file:**

1. Open the module that is to contain the imported file.

2. Select the object immediately before the required location for the imported file.

3. Click **File > Import > RTF**.

4. Type the name of the RTF file you want to import including the path, or click **Browse** to locate it.
5. Click Import.
   You use the Map RTF Styles dialog box to tell Rational DOORS how to handle each RTF style in the file. The importer maps the heading styles that it can, and maps all other styles to object text.

6. Click one or more RTF styles that you want to map to a specific Rational DOORS feature.
   Double-clicking a selected style deselects all other selected styles, and selects the style you clicked.

7. Click the Rational DOORS feature you want to map the styles to.
   The mappings are defined.

8. Repeat Step 4 and Step 5 until all the styles are correctly mapped.

9. If you want to save the style mapping, enter the name of a settings file in the Settings file box, or use Browse to locate it, and click Save.

10. Select the styles that are in the document to be imported.
    This is necessary for Rational DOORS to treat the headings correctly. If you do not select the styles in the document, the first heading is made a Heading Level 1 during the import, regardless of its actual level.

11. Click Import.
    The file is imported after the current object.
    A progress bar shows how much has been done.

Importing spreadsheet files

The import spreadsheet tool imports comma separated value (CSV) and tab separated value (TSV) files that have been created with packages such as Microsoft Excel or Microsoft Access.

In CSV and TSV files, the rows and columns of the spreadsheet (or database table) are stored as lines of text.

Normally, each line represents a spreadsheet or database row, and contains data from each spreadsheet or database column. Each data item in a line is separated by a comma, or a tab, depending on the type of the file. However, if the file contains new line characters as part of the data, the strings that contain the new line characters are enclosed in quotes.

The import spreadsheet tool creates one object for each line in the file, and derives object attribute values from the TSV or the CSV data.

You can assign attribute values in two ways:
• Using an attribute list

If you use an attribute list, you create a list of existing attributes that correspond with the columns in the file you want to import. The attribute types must be appropriate for the data in each column, or importing fails. Where the importer encounters empty fields, it assigns default values.

• Using column labels

If you use column labels, the contents of the fields in the first line (the column labels) determine which attribute is used for each column.

Note The importer expects a label for the first column. If the spreadsheet does not have a label for the first column, you should add one; otherwise, the allocation of attributes does not work correctly.

If the attributes do not exist, the tool creates them. The attribute types are normally derived from the type of data found in the columns, but you can choose the type you want from a list of defined types.

If a spreadsheet has been imported, and you subsequently change it, you can update the imported data by re-importing the file using the **Update existing objects** option. This option also creates new objects if any have been added to the spreadsheet.

If you decide to modify a subset of your data after you have imported it, you should filter the data you want to change, export the filtered data using the export spreadsheet tool, modify the exported data and then re-import it with the same filter applied. By using the **Update Display set only** option you guarantee that the correct objects are updated.

Data items in a CSV or TSV file can have integer, real, date, or string values. Strings are typically contained within double quotes, and can contain commas, tabs, and line breaks. Double quotes can be imported if they are duplicated. For example, looking at the CSV file with a text editor, the following string:

"This string has a comma, which is not imported and a double quote "" too"

is imported as:

This string has a comma which is not imported and a double quote " too

**Importing a spreadsheet or database file**

To import a spreadsheet or database file:

1. Open the module that you want to import the spreadsheet into.
2. Select the object immediately before the required location for the imported text.

The imported file is placed after the current object.

3. Click File > Import > Spreadsheet.

4. If you are importing a CSV file, select the **Comma** radio button. If you are importing a TSV file, select the **Tab** radio button.

5. In the **Input file** box, type the name of the file you want to import or click **Browse** to locate it.

6. The following table describes the other options on the **Import Spreadsheet** dialog box.

<table>
<thead>
<tr>
<th>If you want to:</th>
<th>Then</th>
</tr>
</thead>
<tbody>
<tr>
<td>Import the file using an attribute list</td>
<td>Select <strong>From list</strong>. The <strong>Attributes to import</strong> and <strong>Existing attributes</strong> sections become available. Define or load an attribute list. For more information, see “Defining attribute lists for import,” on page 338 or “Loading saved attribute lists for import,” on page 339.</td>
</tr>
<tr>
<td>Import the file using column labels</td>
<td>Select <strong>By column labels</strong>.</td>
</tr>
<tr>
<td>Import the file to an empty module or to append objects to a populated module</td>
<td>Select <strong>Create new objects</strong>.</td>
</tr>
<tr>
<td>Update the attribute values of objects already in the module, and add objects that have been added to the CSV file</td>
<td>Select <strong>Update existing objects</strong>.</td>
</tr>
<tr>
<td>Update every object in the module</td>
<td>Select the <strong>All objects</strong> radio button. This option is only available if <strong>Update existing objects</strong> is selected.</td>
</tr>
<tr>
<td>Update objects in the current filter</td>
<td>Select the <strong>Display set only</strong> radio button. This option is only available if <strong>Update existing objects</strong> is selected.</td>
</tr>
</tbody>
</table>
If you want to: | Then
--- | ---
Specify the encoding that you want to use to interpret the file. | Click the Advanced button. The dialog box expands to display an encoding list, which contains a list of the code pages that are available on your machine, and a preview pane. Select the encoding that was used when the CSV file was created. You can check if this is the correct encoding by looking at the output in the preview pane. If the encoding is not correct, the preview pane might display symbols instead of text.

7. Click Import.

If you are importing by column labels, and one or more attributes need to be created, you must confirm the creation of each attribute.

- If you want to change the type of an attribute before the attribute is created, click Choose different type. For more information, see “Choosing attribute types,” on page 340.
- If you want to create an attribute without changing its type, click Confirm.

8. If you selected to create new objects, the file is imported. If you selected to update existing objects, the Select Key dialog box is displayed.

You use this dialog box to specify which column contains data that can uniquely identify every object that is created (or updated).

9. Select the column that uniquely identifies the objects, and click Select.

Importing runs to completion. When it is complete, a message box tells you how many objects were created or updated.

10. If you imported by column labels, and created new attributes, you must create new columns in the module to display those attributes. After creating the columns, save a new view.

**Defining attribute lists for import**

To define an attribute list:

1. On the Import Spreadsheet dialog box, select the From list radio button.
The Attributes to import and Existing attributes boxes become available.

2. From the Existing attributes list, select an attribute.

3. Click Add.

   The selected attribute is listed in the Attributes to import list.

4. Add, insert or delete attributes from the list until the attribute list matches the order of the columns in the file you want to import. If there are columns in the file that you do not want to import to Rational DOORS, add ignore to the attribute list for that column. For example if you have three columns in a spreadsheet, and you only want to import information from column one and column three you would add attribute 1, ignore and attribute 2 For more information, see “Using attribute list elements for import,” on page 339.

5. Click Save.

6. Type the name and path of a file to store the attribute list, or click Browse to locate it.

7. Click Save.

   The attribute list is saved. It can be loaded and used later. For more information, see “Loading saved attribute lists for import,” on page 339.

### Using attribute list elements for import

To insert an attribute into an attribute list:

1. In the Import Spreadsheet dialog box, select the attribute you want to add to the list from the Existing attributes list.

2. From the Attributes to import list, select the attribute before which you want to insert the new attribute.

3. Click Insert.

To delete an attribute from an attribute list:

1. From the Attributes to import list, select the attribute you want to delete.

2. Click Delete.

### Loading saved attribute lists for import

To load an attribute list:

1. In the Import Spreadsheet dialog box, click Load.
2. Type the name of the attribute list file you want to load including the path, or use **Browse** to locate it.

3. Click **Load**.

The attribute list is loaded, and the window is updated.

**Choosing attribute types**

When you import a spreadsheet by column labels, attributes are created in which the spreadsheet data is stored. The attribute types are derived from the types of data found in each column.

You are asked to confirm the type or choose a different one.

**To choose a different attribute type:**

1. Click **Choose different type**.
2. Select a new type for the attribute from the **Attribute types available** box.
3. Click **OK**.

**Importing FrameMaker files**

The import FrameMaker tool reads a Maker Interchange Format (MIF) file and populates the beginning of the current module with objects created from its contents. Before you can import a FrameMaker file, you have to map the styles used in the MIF file to suitable Rational DOORS features. You define the mapping as part of the import process. You can save the style mapping for future use.

- The FrameMaker importer only reads text from Text Flow A. Any text not in Text Flow A is not imported.
- Any text formatted in a style mapped to the Rational DOORS feature Ignore, is not imported.
- Text not mapped to any Rational DOORS feature is imported as object text.
- Pictures are not imported. References to pictures are stored in the **FramePicture** attribute.
- International data is imported using encoding that is supported by the MIF format.

Using the Import FrameMaker tool advanced options you can:

- Remove the auto-numbering from auto-numbered headings, to avoid confusion with Rational DOORS heading numbers.
If you decide not to remove auto-numbering, the numbers are enclosed in square brackets ([ ]).

- Create the Autonum attribute, which is assigned the value of auto-numbers, a bullet or a dash wherever auto-numbers, bulleted list items or dashed list items are found.

- Save MIF style definitions from the file in a module attribute.

- Select the encoding to be used to interpret the file in Rational DOORS.

Saving style definitions makes your modules bigger, but if you subsequently export data that you have imported, the style definitions are also exported. That means you do not have to import the exported MIF file using a template for the styles to take effect.

**Importing a MIF file**

To import a MIF file:

1. Click **File > Import > FrameMaker**.

2. Type the name of the file you want to import including the path, or use **Browse** to locate it.

3. Click **Import**.

4. Click one or more FrameMaker styles that you want to map to a specific Rational DOORS feature.

   Double-clicking a selected style deselects all other selected styles and selects the style you clicked.

5. Click the Rational DOORS feature you want to map the styles to.

   The mappings are defined.

6. Repeat Step 4 and Step 5 until all the styles are mapped.

7. If you want to save the style mapping, enter the name of a settings file in the **Settings file** box and click **Save**.

8. If you want to use advanced options, click **Advanced**. For more information, see “Using the import MIF advanced options,” on page 342.

9. Click **Import**.

The file is imported. A progress bar shows how much has been done.

**Note** A Rational DOORS module that has been exported to a MIF file cannot be imported back to Rational DOORS until it has
been loaded and saved in an application such as FrameMaker that can read MIF files.

**Using the import MIF advanced options**

To use the Import FrameMaker advanced options:

1. In the **Map FrameMaker 5 styles** dialog box, click **Advanced**.

2. If you want to store auto-numbering and list element identification in the **Autonum** attribute, select the **Create Autonum attribute to store autonumbers and list item identifiers** check box.

   The auto-numbering produced by Rational DOORS might be different from the auto-numbering in the original document. If you have references to any of them, you should store the original numbers.

3. If you want to remove auto-numbering from imported headings, select the **Remove autonumbers from headings** check box.

   If you want heading numbers in square brackets ([ ]), clear the check box.

   The auto-numbering produced by Rational DOORS might be different from the auto-numbering in the original document. If you have references to any of them, you should not remove them.

4. If you want to save the style definitions in your module, select the **Keep style definitions in module attribute** check box.

5. Click **OK**.
This chapter contains the following topics:

- Exporting to Microsoft Word
- Exporting to Microsoft Excel
- Exporting to Microsoft Outlook
- Exporting to Microsoft PowerPoint
- Exporting to HTML
- Exporting to plain text
- Exporting to RTF
- Exporting to spreadsheet
- Exporting to FrameMaker

Exporting to Microsoft Word

This topic describes how to export your current view to Microsoft Word.

- If your module contains Unicode or international data, this is included in the export and is encoded in rich text format.
- If your module contains hidden text that was previously imported from Word, the hidden text is displayed in the Word document when the module is exported.

To export to Microsoft Word:

1. In the module window, click **File > Save**.
   
   This saves the module. It makes sure that the data you export includes any changes you made recently.

   **Note** When you export modules to Microsoft Word, Rational DOORS uses the Windows clipboard. Make sure there is nothing on the clipboard that you do not want to lose before you export.

2. Click **File > Export > Microsoft Office > Word**.
   
   **Note** If you are running Rational DOORS through Citrix, Word must also be running through Citrix or the export will not work.
This option is unavailable if you do not have Word installed on your machine.

3. Use the **General** tab to specify what data you want to export.

<table>
<thead>
<tr>
<th><strong>General tab</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Layout</strong></td>
<td>Select either:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Book</strong> to use the book layout, which lists the data on separate lines. All the columns in the current view are exported.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Table</strong> to use the table layout, which lays the data out as a table, just like in Rational DOORS. All the columns in the current view are exported.</td>
</tr>
<tr>
<td><strong>Include DOORS Heading Numbers</strong></td>
<td>By default, the Rational DOORS heading numbers are exported with the <strong>Object Heading</strong> text. Clear this check box if you do not want to export Rational DOORS heading numbers.</td>
</tr>
<tr>
<td><strong>Issue a warning when an unregistered OLE object is exported as a picture</strong></td>
<td>Clear this check box if you do not want to be warned that the module you are exporting contains unregistered OLE objects. Unregistered OLE objects are exported as pictures and cannot be activated in Word.</td>
</tr>
<tr>
<td><strong>Include empty attributes</strong></td>
<td>Select this check box if you want to export attributes that do not contain any value to Word. By default Rational DOORS does not export empty attributes to Word.</td>
</tr>
</tbody>
</table>
Using Rational DOORS

Exporting to Microsoft Word

4. Optionally, use the **Advanced** tab to specify advanced options.

<table>
<thead>
<tr>
<th>Advanced tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Paragraph Style attribute</td>
<td>If you previously imported the data from Word, select this check box if you want to use the Word paragraph style information that was captured during the import. This information is stored in the module’s Paragraph Style attribute. The styles named in the Paragraph Style attribute are used to format the exported document.</td>
</tr>
<tr>
<td>Allow style mapping</td>
<td>Select this check box if you want to manually map Rational DOORS heading and text levels to the Word paragraph styles in the exported document. For example, you can say that you want level 1 headings in Rational DOORS to use the Heading 2 Word style.</td>
</tr>
<tr>
<td>Ignore DOORS table borders, put all borders on all cells</td>
<td>By default, the exported Word document uses the same table border settings as the Rational DOORS module. Select this check box if you want to ignore the table border settings in the Rational DOORS module, and put borders around all the table cells in the Word document.</td>
</tr>
<tr>
<td>AutoFormat</td>
<td>Select this check box if you want to ignore the column width settings in the Rational DOORS module, and let Word chose the column widths.</td>
</tr>
<tr>
<td>Use normal template</td>
<td>By default, the normal.dot Word template is attached to the exported document. If you want to use another template, clear this check box, and then type the name of the template file in the Template name box, or use Browse to locate the file.</td>
</tr>
<tr>
<td>Use horizontal line separators in book layout exports</td>
<td>When using book format, this will insert line separators between objects in the Word document.</td>
</tr>
</tbody>
</table>
5. Click Export.

6. If you selected the Allow style mapping check box on the Advanced tab, the Export to Word Style Mapping screen is displayed.

   The list on the left shows what mappings you’ll get. For example, by default, level 1 headings in Rational DOORS are mapped to the Heading 1 style in Word, and Rational DOORS bullets are mapped to standard Word bullets.

<table>
<thead>
<tr>
<th>To</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change a style</td>
<td>Select the item on the left.</td>
</tr>
<tr>
<td>mapping</td>
<td>Then in the list on the right, select the Word style you want to use.</td>
</tr>
<tr>
<td>Save the style</td>
<td>In the Settings file box, type the name of the file that you want to</td>
</tr>
<tr>
<td>mapping information</td>
<td>save the information in, or click Browse to locate it, and then click</td>
</tr>
<tr>
<td></td>
<td>Save.</td>
</tr>
<tr>
<td>Load style mapping</td>
<td>In the Settings file box, type the name of the file that contains the</td>
</tr>
<tr>
<td>information from a</td>
<td>style mapping information, or click Browse to locate it, and then click</td>
</tr>
<tr>
<td>file</td>
<td>Load.</td>
</tr>
</tbody>
</table>

7. When you have finished defining the mapping styles, click Close.

Exporting to Microsoft Excel

You can export your current view to Microsoft Excel.
• Columns other than the main column are always exported.
• You can control whether you export the main column too, and if so, which of its attributes you export.
• The maximum number of columns you can export to Microsoft Excel is 32.

**Note** When you export to Microsoft Excel, rich text formatting and special characters are not preserved. If you want to preserve rich text formatting, export to a Microsoft Word table, and then copy and paste the Word table into Excel.

**To export to Excel:**

1. In the module window, click **File > Save**.
   This saves the module. It makes sure that the data you export includes any changes you made recently.
2. Click **File > Export > Microsoft Office > Excel**.
   **Note** If you are running Rational DOORS through Citrix, Excel must also be running through Citrix or the export will not work.
3. Use the **Main column** drop-down list to specify whether you want to export the main column:
   • Select **Ignore** if you do not want to export the main column.
   • Select **Object Heading** to export the **Object Heading** attribute in the main column.
   • Select **Object Short Text** to export the **Object Short Text** attribute in the main column.
   • Select **Object Text** to export the **Object Text** attribute in the main column.
   • Select **Object Heading and Text** to export both the **Object Heading** and **Object Text** attributes in the main column.
4. Select the **Include column titles** check box if you want to export column titles.
5. Click **Export**.

The data is exported to Excel. Excel opens and displays the exported data.
Exporting to Microsoft Outlook

You can export a Rational DOORS object to Microsoft Outlook, as either a mail message or a note:

- The mail message has the **Object Heading** as its subject, and the **Object Text** as its contents
- The note contains the **Object Heading** and **Object Text**

**To export the current object to Microsoft Outlook:**

1. Click **File > Export > Microsoft Office > Outlook**.
   
   **Note** If you are running Rational DOORS through Citrix, Outlook must also be running through Citrix or the export will not work.

2. Use the **Send object to** drop-down list to specify how you want to export the object:
   - Select **Mail** to export it as a mail message
   - Select **Note** to export it as a note

3. Click **OK**.

The object is displayed in a mail message window, or as a new note in the Outlook **Notes** folder. You have to open the Outlook **Notes** folder to see the new note.

Exporting to Microsoft PowerPoint

You can export the **Object Heading** attribute, and optionally also the **Object Text** attribute, to a Microsoft PowerPoint presentation.

You can export all the objects in the current view or just the current object.

**To export to PowerPoint:**

1. In the module window, click **File > Save**.
   
   This saves the module. It makes sure that the data you export includes any changes you made recently.

2. If you only want to export one object, make the object you want to export the current object.

3. Click **File > Export > Microsoft Office > PowerPoint**.
Note If you are running Rational DOORS through Citrix, PowerPoint must also be running through Citrix or the export will not work.

4. Use the Export drop-down list to specify what you want to export:
   • Select Display set to export all the objects in the current view
   • Select Current object to export only the current object

5. Use the Objects to level drop-down list to select the lowest level of object that you want to export.

   Note Tables are not exported as one object. Each cell is exported as a single object at level 5. If you select a level less than 5, no tables are exported.

6. Select the Include title check box if you want to include a title slide at the start of the PowerPoint presentation.

7. Select the Ignore Object Text check box if you want to exclude the Object Text attribute from the PowerPoint presentation, and export only the Object Heading attribute.

8. Click Export.

The exported data is displayed as a PowerPoint presentation, which you can edit and save. You might have to resize any exported pictures and OLE objects.

Exporting to HTML

You can export either:
   • The current module
   • The current module and all the modules that have links to or from it

The exported HTML includes any pictures in the modules, and pictorial representations of any OLE objects in the modules.

If your document contains Unicode or international data, this is included in the export.

Note Because of a know issue with Firefox you cannot export the symbol font to HTML if you are using Firefox. For information about a workaround, see the Mozilla web site.

To export to HTML:

1. In the module window, click File > Save.
This saves the module. It makes sure that the data you export includes any changes you made recently.

2. Click **File > Export > HTML**.

3. Use the **Layout** drop-down list to specify which layout you want:
   - Select **Book** to use the book layout, which lists the attributes for each object on separate lines.
   - Select **Table** to use the table layout, which lays the data out as a table, just like in Rational DOORS.

4. Use the **Export** drop-down list to specify what you want to export:
   - Select **Current** to export the current module only
   - Select **All linked** to export the current module and all the modules that have links to or from it

5. Select the **Links** check box if you want to export link information.
   Links between objects are represented by hyperlinks. The text of the hyperlink tells you the direction of the link, and includes the **Object Heading**, **Object Short Text**, or **Object Text** of the object at the other end of the link.

6. Select the **Icons** check box if you want to use these icons to identify the type of each hyperlink in the exported HTML files:
   - ![A hyperlink to an object in the same module.](image)
   - ![A hyperlink to an object in a different formal module.](image)
   - ![A hyperlink to an object in a descriptive module.](image)
   - ![A hyperlink to a website.](image)
   - ![An external out-link](image)
   - ![An external in-link](image)

7. Select the **Change meter** check box to include change meters in the exported HTML files.
   Change meters indicate the age of the module, the age of the object and the number of changes made to the object.
   ![20](image)
   - The blue rectangle represents the age of the module.
   - The red rectangle represents the age of the object and when it was last modified relative to the age of the module. In the example, the object
was created halfway through the life of the module, and was last modified today. So, if the module was created four days ago, the object was created two days ago.

- The gray box displays the number of times the object has been modified.

8. Select the **Empty Attributes** check box to include attributes with no value in the exported HTML files.

9. Type the name of the file you want to export the data to, or use **Browse** to locate it.

10. If the view you are exporting to HTML has auto-indentation switched on, the **Preserve auto-indentation** check box is displayed and is selected by default. Clear this option if you do not want the generated HTML to be indented.

11. Click **Export**.

### Exporting to plain text

You can export your current view to a plain text (ASCII) file.

**To export to a plain text file:**

1. In the module window, click **File > Save**.

   This saves the module. It makes sure that the data you export includes any changes you made recently.

2. Click **File > Export > Plain Text**.

3. Use the **General** tab to specify the name of the file you want to export to, and the data you want to export to it.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Type the name of the file you want to export to, or use <strong>Browse</strong> to locate it.</td>
</tr>
</tbody>
</table>
| Layout      | Select either:  
|             | - **Book** to use the book layout, which lists the attributes for each object vertically, on separate lines.  
|             | - **Table** to use the table layout, which lays the data out as a table, just like in Rational DOORS. |
Exporting

4. Optionally, use the **Advanced** tab to specify advanced options.

<table>
<thead>
<tr>
<th><strong>Advanced tab</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Add line breaks</td>
<td>In Book layout, by default each attribute is on a single line. Select this check box if you want to add line breaks. Use the <strong>Line width</strong> box to specify how long you want the lines to be.</td>
</tr>
<tr>
<td>Tab separated columns</td>
<td>In Book layout, by default space characters are used to separate the columns. Select this check box if you want to use the tab character instead.</td>
</tr>
<tr>
<td>Line width</td>
<td>Use this box to specify the maximum line length, in characters.</td>
</tr>
<tr>
<td>Encoding</td>
<td>Select the encoding you want the exported file to use. This defaults to Latin1, or the code page you selected last time you exported a file to plain text. If you select a unicode code page, a Byte Order Marker (BOM) is inserted at the start of the file. This means that if you open the exported file in a different program, it should be able to interpret the file.</td>
</tr>
</tbody>
</table>

5. Click **Export**.

**Exporting to RTF**

You can export your current view to an RTF (Rich Text Format) file. Exports to RTF includes:

<table>
<thead>
<tr>
<th><strong>Include DOORS Heading Numbers</strong></th>
<th>By default, the Rational DOORS heading numbers are exported with the <strong>Object Heading</strong> text. Clear this check box if you do not want to export Rational DOORS heading numbers.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Include empty attributes</strong></td>
<td>Clear this check box if you do not want to export empty attributes to the plain text file.</td>
</tr>
</tbody>
</table>

6. Optionally, use the **Advanced** tab to specify advanced options.

<table>
<thead>
<tr>
<th><strong>Advanced tab</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Add line breaks</td>
<td>In Book layout, by default each attribute is on a single line. Select this check box if you want to add line breaks. Use the <strong>Line width</strong> box to specify how long you want the lines to be.</td>
</tr>
<tr>
<td>Tab separated columns</td>
<td>In Book layout, by default space characters are used to separate the columns. Select this check box if you want to use the tab character instead.</td>
</tr>
<tr>
<td>Line width</td>
<td>Use this box to specify the maximum line length, in characters.</td>
</tr>
<tr>
<td>Encoding</td>
<td>Select the encoding you want the exported file to use. This defaults to Latin1, or the code page you selected last time you exported a file to plain text. If you select a unicode code page, a Byte Order Marker (BOM) is inserted at the start of the file. This means that if you open the exported file in a different program, it should be able to interpret the file.</td>
</tr>
</tbody>
</table>

5. Click **Export**.
• OLE objects, but not pictures
• Unicode and other international data. This is encoded in rich text format.

To export to an RTF file:

1. In the module window, click File > Save.
   This saves the module. It makes sure that the data you export includes any changes you made recently.


3. Use the General tab to specify the name of the file you want to export to, and the data you want to export to it.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Enter the name of the file you want to export to, or use Browse to locate it.</td>
</tr>
<tr>
<td>Layout</td>
<td>Select either:</td>
</tr>
<tr>
<td></td>
<td>• Book to use the book layout, which lists the attributes for each object vertically, on separate lines. Only the Object Heading and Object Text attributes are exported.</td>
</tr>
<tr>
<td></td>
<td>• Table to use the table layout, which lays the data out as a table, just like in Rational DOORS. All the columns in the current view are exported.</td>
</tr>
<tr>
<td>Include DOORS Heading Numbers</td>
<td>By default, the Rational DOORS heading numbers are exported with the Object Heading text. Clear this check box if you do not want to export Rational DOORS heading numbers.</td>
</tr>
<tr>
<td>Issue a warning when an unregistered OLE object is exported as a picture</td>
<td>Clear this check box if you do not want to be warned that the module you are exporting contains unregistered OLE objects. Unregistered OLE objects are exported as pictures and cannot be activated in the RTF document.</td>
</tr>
</tbody>
</table>
4. Optionally, use the **Advanced** tab to specify advanced options.

<table>
<thead>
<tr>
<th><strong>Advanced tab</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Break before</td>
<td>Use these radio buttons to specify where you want page breaks in the RTF file. For example, if you select 2, page breaks are inserted before every level 1 and level 2 object.</td>
</tr>
<tr>
<td>Column titles</td>
<td>If you are using Table layout, use these radio buttons to specify which pages you want column titles on.</td>
</tr>
<tr>
<td>Include borders</td>
<td>If you are using Table layout, select this check box to add borders around the exported data, so that it looks like your module in Rational DOORS.</td>
</tr>
</tbody>
</table>

5. Click **Export**.

**Exporting to spreadsheet**

You can export your current view, or selected attributes, to a CSV (comma separated value) or a TSV (tab separated value) file. The exported file can be imported by packages such as Microsoft Excel or Microsoft Access.

In CSV and TSV files, the rows and columns of the spreadsheet (or database table) are stored as lines of text.

The export spreadsheet tool creates one line in the file for each object being exported.

Normally, each line represents one spreadsheet or database row. Each data item in a line is separated by a comma, or a tab, depending on the type of the file. However, if the data being exported contains new lines, the strings that contain the new line characters are enclosed in quotes.

You can create a list of attributes to export or you can export the columns in the current view.

You can include the names of the attributes in the file or, if you export the display set, you can include the column titles.

**Note** When you export to a spreadsheet, rich text formatting and special characters are not preserved. If you want to preserve rich text formatting, export to a Microsoft Word table, and then copy and paste the Word table into the spreadsheet.
To export to a CSV or TSV file:

1. In the module window, click File > Save.
   
   This saves the module. It makes sure that the data you export includes any changes you made recently.

2. Click File > Export > Spreadsheet.

3. If you want to export all the columns in your current view, go to Step 8.

4. If you want to specify which attributes are exported, click the Attributes from list radio button.

5. Select the attributes you want to export:
   
   - Select an attribute in the Existing attributes box
   - Click either Add or Insert to add the attribute to the Attributes to export box:
     
     - Use Add to add it before the selected entry in the Attributes to export box.
     
     - Use Insert to add it after.

6. Click Delete to delete an attribute from the Attributes to export box.

   Click Save to save the list of attributes to a file. Click Load to load a list of previously saved attributes from a file.

7. When the attribute list matches the order of the columns you want to export, go to Step 8.

8. Use the Include radio buttons to specify what objects you want to export:
   
   - Click All objects to export all the objects in the module
   - Click Display set only to export only the objects in the current view

9. If you want to include the column titles in the first line of the exported file, select the Include attribute names/column titles in first row check box.

10. Use the Data separator radio buttons to specify what type of file you want to export to:
   
   - Click Comma for a CSV file
   
   - Click Tab for a TSV file

11. Type the name of the file you want to export to, or use Browse to locate it.

12. If you want to specify an encoding for the exported file, click Advanced.

   An Encoding list box containing a list of the code pages that are available on your computer is displayed. Select the encoding you want to use.
Note Microsoft Excel 2000 does not support UTF-8 CSV files. If you are going to view the CSV file using Excel 2000, you need to export it with UTF-16 encoding.

13. Click Export.

Exporting to FrameMaker

You can export your current view to a Maker Interchange Format (MIF) file. International data that uses encoding supported by the MIF format is included in the export.

To export to a MIF file:

1. In the module window, click File > Save.
   This saves the module. It makes sure that the data you export includes any changes you made recently.

2. Click File > Export > FrameMaker.

3. Use the General tab to specify the name of the file you want to export to, and the data you want to export to it.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File name</td>
<td>Type the name of the file you want to export to, or use Browse to locate it.</td>
</tr>
<tr>
<td>Layout</td>
<td>Select either:</td>
</tr>
<tr>
<td></td>
<td>• Book to use the book layout, which lists the attributes for each object vertically, on separate lines. Only the Object Heading and Object Text attributes are exported.</td>
</tr>
<tr>
<td></td>
<td>• Table to use the table layout, which lays the data out as a table, just like in Rational DOORS. All the columns in the current view are exported.</td>
</tr>
<tr>
<td>Include DOORS Heading Numbers</td>
<td>By default, the Rational DOORS heading numbers are exported with the Object Heading text. Clear this check box if you do not want to export Rational DOORS heading numbers.</td>
</tr>
</tbody>
</table>
Exporting to FrameMaker

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Issue a warning when an unregistered OLE object is exported as a picture</td>
<td>Clear this check box if you do not want to be warned that the module you are exporting contains unregistered OLE objects. Unregistered OLE objects are exported as pictures and cannot be activated in the FrameMaker document.</td>
</tr>
</tbody>
</table>

4. Optionally, use the **Advanced** tab to specify advanced options.

<table>
<thead>
<tr>
<th>Advanced tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page breaks at level</td>
<td>Use these radio buttons to specify where page breaks are inserted in the MIF file. For example, if you select 2, page breaks are inserted before every level 1 and level 2 object.</td>
</tr>
<tr>
<td>Page orientation</td>
<td>If you are exporting using Book layout, use these radio buttons to select either portrait or landscape page orientation.</td>
</tr>
<tr>
<td>Use data saved from MIF import</td>
<td>If you are exporting using Book layout, select this check box if you are exporting data that was originally imported from a MIF file, and you want to re-use the formatting information that was extracted during the import. <strong>Note</strong> You need to import the resulting MIF file into FrameMaker, using a template that defines the relevant styles.</td>
</tr>
</tbody>
</table>

5. Click **Export**.

Rational DOORS creates a partial MIF file. To convert it to a standard MIF file, open it in FrameMaker and then save it. Note that you cannot import it into Rational DOORS until you have converted it to a standard MIF file.
This chapter contains the following topics:

- The Change Proposal System
- Change proposals and suggestions
- Change proposal roles
- Change proposal partner modules
- Duplicate sets
- Groups
- Creating groups
- Editing groups
- Submitting a change proposal
- Submitting a suggestion
- The review process
- Showing and reviewing individual change proposals
- Showing and reviewing groups
- Showing and reviewing suggestions
- Showing information about change proposals
- Managing duplicate sets
- Checking the approved changes
- Applying the approved changes

For information on how to set up and manage the Change Proposal System, see the Rational DOORS online help or Managing Rational DOORS.

The Change Proposal System

Managing changes to requirements is a major challenge for any organization. As your projects proceed, it is inevitable that you will need to make changes to requirements. Any changes, however, are bound to affect other requirements; a single change to one requirement can cause a cascade of potential changes to requirements throughout your system. With the Change Proposal System (CPS),
Rational DOORS offers you functionality to manage changes to the requirements in your system.

CPS allows you to:

- Propose a change to a requirement
  You can submit a proposed change, which can be either a change proposal or a suggestion.
- Combine change proposals that affect the same requirement
- Group together related change proposals that affect different requirements
- Review change proposals
  You can put together a review team to review and determine the impact of the proposed change throughout the whole system.
- Agree on and implement the agreed changes

Using CPS allows you to make sure that proposed changes are not lost or overlooked, and gives you a mechanism to make sure you understand the effect a change to one requirement will have to other requirements throughout the system.

**Change proposals and suggestions**

You can submit a proposed change, which can be either a change proposal or a suggestion.

<table>
<thead>
<tr>
<th>Proposal</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change proposal</td>
<td>This is a detailed proposal about a particular object, or several objects in a module. If the change proposal is against several objects, it is called a multiple change proposal. An example of a change proposal might be the proposal that the value of the Estimated Duration attribute for a particular object should be changed from 20 days to 30 days.</td>
</tr>
<tr>
<td>Suggestion</td>
<td>This is a high-level proposal about a project. For example, the suggestion that the project should have a test plan.</td>
</tr>
</tbody>
</table>
Change proposal roles

Managers set up the CPS, configuring the functionality to fit in with your own change management process, and assigning different roles to users. The roles are:

<table>
<thead>
<tr>
<th>Role</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change proposal manager</td>
<td>The change proposal managers control what data is configured for review, and who can review it. They control which users have which change proposal roles.</td>
</tr>
<tr>
<td>Standard</td>
<td>These are the ordinary users taking part in the review. They can submit proposals, and they can see the proposals submitted by themselves and by other users.</td>
</tr>
<tr>
<td>Change proposal reviewer</td>
<td>The change proposal reviewers are the members of the change proposal review team (sometimes called the Change Control Board, or CCB). They look at each proposal and decide on the appropriate course of action. They decide whether to accept, reject, or defer the proposal.</td>
</tr>
</tbody>
</table>

For more information on setting up the CPS, see the Rational DOORS online help or Managing Rational DOORS.

Change proposal partner modules

Each project that is configured for review has a CPS folder. This folder contains various modules used by the CPS, including:

- A **Suggestions** module, which contains all the suggestions submitted against the project.
- **Proposals** modules, which contain change proposals.
- If any groups have been created, a **Groups** module, which contains information about the groups in the Change Proposal System.

**Note** Never edit any of the modules in the Change Proposal System folder directly. Always use the procedures described in this chapter and in Managing Rational DOORS to manipulate the modules in this folder.
For information on how to set up and manage the CPS, see the Rational DOORS online help or Managing Rational DOORS.

Each module configured for review has its own Proposals module, which contains all the change proposals submitted against that module. We call it the Change Proposal Partner module. It has a name that begins with Proposals, followed by a number. For example, Proposals 35.

The Suggestions and Proposals modules have one section for each user taking part in the review. The Object Heading of each section is the unique identifier for the user.

**Duplicate sets**

Quite often two or more people make similar change proposals. When this happens, the change proposal review team can place the change proposals in a duplicate set. A duplicate set consists of one primary change proposal, and any number of duplicates.

In a duplicate set, only the primary change proposal is reviewed and applied. The duplicate change proposals are superseded by the primary change proposal, so the proposal you choose to be the primary change proposal in the set must contain the most complete information.

For example, if there are two similar change proposals, but one has been raised against a single object, and the other is a multiple change proposal, you should probably make the multiple change proposal the primary change proposal. If you make the multiple change proposal a duplicate in the set, only the object that is referenced by the primary change proposal is reviewed and applied.

The duplicate change proposals are made read-only when they are added to the duplicate set, and their status does not change throughout the review process. You can remove a duplicate change proposal from a set at any time. The change proposal becomes editable, and has the status that it had when it was added to the duplicate set.

The status of the set and any comments the review team want to make on it are recorded with the primary change proposal.

**Groups**

As requirements in Rational DOORS are often related to other requirements in the same or different modules, you can create groups of related change proposals. For example, if you raise a change proposal against a user requirement, it might involve changes to related system requirements and test
requirements. Putting all these change proposals into the same group means that they can be reviewed and applied together, or not applied at all.

Groups can contain change proposals from different modules that are configured as part of different CPSs. You can only add change proposals to groups that exist in folders that are direct ancestors of the CPS in the Rational DOORS database hierarchy. If you want a group to hold change proposals from a number of different CPSs and modules, you should create it at the top of the hierarchy of folders and projects. This means that it can be navigated to from all its descendents.

A multiple change proposal can be included in a group.

Only the primary change proposal in a duplicate set can be included in a group. Duplicates in a duplicate set cannot be included.

There are two types of groups, as described in the following table.

<table>
<thead>
<tr>
<th>Group type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Master</td>
<td>All the change proposals in the group inherit their status from the group. You should include change proposals in a master group if you want to prevent the review team from approving some of the change proposals but not others. For example, you might be proposing changes to several different requirements, but the changes are only valid if they are all considered together.</td>
</tr>
<tr>
<td>Subordinate</td>
<td>Change proposals that are members of a subordinate group can be reviewed independently of the group. The group inherits its status from the change proposal that is furthest behind in the review process. For example, a subordinate group that contains change proposals with the statuses New, Approved, On Hold and In Review will have a status of On Hold. You should include change proposals in a subordinate group if you would like them to be considered together, but they do not rely on each other for their validity. Note that the subordinate group status changes from New as soon as any of the change proposals it contains move into the review cycle.</td>
</tr>
</tbody>
</table>

The user who creates the group is the group owner. Only the group owner can change the group type and status.
Creating groups

1. In the Database Explorer, select a project or folder that is part of a configured change proposal system. This is the folder in which the group will be created and saved.

   See “Groups,” on page 363 for information about where in the hierarchy you should create groups.

2. Click **Tools > Change Proposal System > Manage Groups**.

3. Use the **Search up** and **Search down** buttons to navigate the hierarchy. You can only move between the database root and the folder from which you started the Manage Groups tool.

4. Click **New**.

5. Type a name for the group in the **Name** box, and select a **Type** for the group. You can change the group type at any time.

6. Click **OK**.

   The group is created and displayed in the list in the **Manage Groups** dialog box.

   Master groups are displayed with the **Master** icon ☑️, and subordinate groups with the **Subordinate** icon 🌟.

Editing groups

1. In the Database Explorer, select the project or folder that contains the group you want to edit.

2. Click **Tools > Change Proposal System > Manage Groups**.

3. Select the group you want to edit from the list and click **Edit**.

   You can change the group’s **Name** and **Type**, and if the group is of type **Master**, the **Status**.

Submitting a change proposal

For information about change proposals, see “The Change Proposal System,” on page 359.

**To submit a change proposal:**

1. In the module window, select the object you want to submit the proposal against.

   If your proposal is to insert a new object, you can select either:
• An object at the same level as the proposed new object.
• An object one level below the proposed new object.

2. Click **Tools > Change Proposal System > Submit Proposal**.

The change proposal form is displayed.

The following table describes the options on the form:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Applies to ‘n’ object(s)</td>
<td>The object IDs of the objects against which the proposal is being made. Note ‘n’ is the number of objects in the list.</td>
</tr>
<tr>
<td>Select objects</td>
<td>Click this button to add or remove objects from the list. If the change proposal is against more than one object in the module, it is called a Multiple change proposal.</td>
</tr>
<tr>
<td>Show change proposals</td>
<td>If there is only one object in the list, and it already has change proposals against it, this button is available. Click to see the change proposals.</td>
</tr>
<tr>
<td>Add to group/Remove from group</td>
<td>If this change proposal is related to other change proposals in this or other modules, you can group them together. This means that the change proposal review board can consider all the change proposals together and decide whether or not to apply them. For more information about groups, see “Groups,” on page 363. If you have submitted a change proposal in the current session and added it to a group, the next change proposal you submit is added to the same group by default. In this case the button is named Remove from group.</td>
</tr>
</tbody>
</table>
### Using the Change Proposal System

A list of the attributes that have been included in the change proposal system configuration, and to which you have a minimum of read access.

When you submit a change proposal, you can propose changes to more than one attribute. Select each attribute against which you want to raise a change proposal and fill in the changes you propose. An icon is displayed next to the attributes that you have proposed changes for.

If you have selected more than one object, remember that the changes you propose against different attributes will be applied to all the objects that you selected.

#### Reason for change
The reason why you are proposing the change. Try to give as much information as possible to help the change proposal review team understand your proposal properly and increase the chances of it being accepted.

#### Current
The current value of the attribute. If you have selected more than one object for the change proposal, the value of the object that was the current object when the Change Proposal was invoked is displayed.

#### Proposed
The proposed new value for the attribute.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Attributes available</td>
<td>A list of the attributes that have been included in the change proposal system configuration, and to which you have a minimum of read access. When you submit a change proposal, you can propose changes to more than one attribute. Select each attribute against which you want to raise a change proposal and fill in the changes you propose. An icon is displayed next to the attributes that you have proposed changes for. If you have selected more than one object, remember that the changes you propose against different attributes will be applied to all the objects that you selected.</td>
</tr>
<tr>
<td>Reason for change</td>
<td>The reason why you are proposing the change. Try to give as much information as possible to help the change proposal review team understand your proposal properly and increase the chances of it being accepted.</td>
</tr>
<tr>
<td>Current</td>
<td>The current value of the attribute. If you have selected more than one object for the change proposal, the value of the object that was the current object when the Change Proposal was invoked is displayed.</td>
</tr>
<tr>
<td>Proposed</td>
<td>The proposed new value for the attribute.</td>
</tr>
</tbody>
</table>

---

Using Rational DOORS
Submitting a change proposal

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enforce this attribute value</td>
<td>If the validity of your change proposal relies upon one or more of the object's attribute values not changing, you can enforce those attribute values as part of your change proposal. This means that if the attribute value has changed between you submitting the change proposal and the review board applying it, the value that the attribute had when you submitted the change proposal is applied. The value you enforce is the existing attribute value, so when you select this option the Proposed text box becomes unavailable. Changes to the attribute value are also flagged to the change proposal review team when they review the change proposal, and again when the change proposal is applied. Similarly if there are any other change proposals against that attribute, the review board will be notified of their existence.</td>
</tr>
<tr>
<td>Change type</td>
<td>You can select one of four possible change types:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Modify this object</strong> to change the selected attribute value for the selected object or objects.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Delete this object</strong> to delete the selected object or objects.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Add new object</strong> to add a new object at the same level as the current object. This option is disabled if you have selected more than one object for the change proposal.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Add new object (below)</strong> to add a new object one level below the current object. This option is disabled if you have selected more than one object for the change proposal.</td>
</tr>
<tr>
<td>Priority</td>
<td>Select the priority of your proposed change. Be realistic and do not exaggerate the importance of your proposal. The change proposal review team will probably downgrade the priority if you exaggerate.</td>
</tr>
</tbody>
</table>
3. If you want to submit the proposal against more than one object, click **Select Objects**.

4. You can add objects to the change proposal in three ways. In the formal module window:
   - Select the object that you want to add. In the **Select objects** dialog box, click **Current Object**, and then click **Add**.
   - Select the group of objects you want to add. In the **Select objects** dialog box, click **Selected objects**, and then click **Add**. A confirmation dialog is displayed showing the number of objects that will be added. Click **Confirm**.
   - Create a filter to display the objects that you want to add. In the **Select object** dialog box, click **Objects in current view**, and then click **Add**. If more than one object is displayed by the filter, a confirmation dialog is displayed showing the number of objects that will be added. Click **Confirm**.

   The selected object or objects are added to the list. Select an object from the list and click **Show** to display the object in the module window.

5. When you have added all the objects against which you want to make the change proposal, click **OK**.

   The Object Identifier of each object that is included in the change proposal is listed in the **Applies to ‘n’ objects** box.

6. If you want the change proposal to be part of a group, click **Add to group**.

   The **Select group** dialog box is displayed.

   Select the group you want the change proposal to be part of and click **Select**. If you want to add the change proposal to a group in a different folder, click **Search up** or **Search down** to locate the group. For more information about groups in the change proposal system, see “Groups,” on page 363 and “Creating groups,” on page 365.

7. In the **Change type** box, select the type of your proposed change.

8. Fill in the form:
   a. Select the attribute against which you want to propose a change.
   b. If you are proposing a new value for an attribute, type the new value in the **Proposed** box on the right of the screen.

      If you are proposing a change to an OLE object, double-click the object to activate it then make changes as required.
Submitting a suggestion

c. If the validity of changes you are proposing to other attributes relies on the selected attribute not changing, click **Enforce this attribute value**.

d. In the **Reason for change** box, type in the reason why you are proposing the change. If you have clicked **Enforce this attribute value**, explain the effect that changes to the attribute will have on your change proposal.

Try to give as much information as possible to help the change proposal review team understand your proposal properly and increase the chances of it being accepted.

e. In the **Priority** box, select the priority of your proposed change.

Be realistic and do not exaggerate the importance of your proposal. The change proposal review team will probably downgrade the priority if you exaggerate.

9. Repeat Step 8 for each attribute you want to propose changes for.

10. Click **Submit**.

A message stating that your change proposal has been submitted is displayed.

11. Click **OK** to acknowledge the message.

Rational DOORS can automatically e-mail you if the status of one of your proposals changes, for example, if one of your proposals is accepted.

To request e-mails, click **Tools > Options** in the Database Explorer, select the **General** tab, and then select **Email updates to change proposals**. If this box is disabled, your Database Manager has configured your database so that Rational DOORS cannot send e-mails.

---

Submitted a suggestion

For information about suggestions, see “The Change Proposal System,” on page 359.

When you submit a suggestion for a project, your suggestion is added to the Suggestions module in the CPS folder of the project.

**To submit a suggestion:**

1. In the Database Explorer, select the project you want to submit a suggestion for, or any folder or module in the project.

If you are working with projects that have sub-projects, and you select a folder or module, your suggestion is submitted to the Suggestions module
associated with the nearest ancestor project. The title bar on the suggestions form tells you which project this is.

2. Click **Tools > Change Proposal System > Submit Suggestion**.  
   A suggestion form is displayed.

3. Fill in the form:
   a. Type your suggestion in the **Suggestion** box.
   b. In the **Reason for change** box, type in the reason why you are proposing the change.  
      Try and give as much information as possible to help the change proposal review team understand your suggestion properly and increase the chances of it being accepted.
   c. In the **Suggestion type** box, select the type of your suggestion.
   d. In the **Priority** box, select the priority of your suggestion.

      Be realistic and do not exaggerate the importance of your suggestion. The change proposal review team will probably downgrade the priority if you exaggerate.

4. Click **Submit**.  
   A message saying that your suggestion has been submitted is displayed.

5. Click **OK** to acknowledge the message.

   Rational DOORS can automatically e-mail you if the status of one of your proposals changes, for example, if one of your proposals is accepted.

   To request e-mails, click **Tools > Options** in the Database Explorer, select the **General** tab, and then select **Email updates to change proposals**. If this check box is disabled, your Database Manager has configured your database so that Rational DOORS cannot send e-mails.

### The review process

When a change proposal is created, it can be created as an individual change proposal, or as part of a group. The way in which you review the change proposal depends on whether it was created as part of a group, and if so what type of group it is a member of.

If the change proposal is part of a master group, it must be reviewed alongside the other change proposals in the group. Once you have considered all the change proposals in the group, you set the status of the group accordingly. All the change proposals in the group inherit their status from the group.
If the change proposal is part of a subordinate group, you can review it alongside the other change proposals in the group, but you have to set the status of each change proposal individually.

If the change proposal is not part of a group, it is reviewed independently.

If a user wanted to raise the same change proposal against a number of objects in a module, all the objects to which the change proposal applies can be included in one change proposal, called a multiple change proposal. The objects to which the change proposal applies are listed in the review dialog box. If you approve a multiple change proposal, the change is applied to all the objects that were included in the change proposal.

When you review change proposals, you might or might not be able to edit the change proposal. This depends on how the change proposal system has been set up. If you want to be able to edit change proposals during the review process, contact the change proposal manager.

**Showing and reviewing individual change proposals**

This topic describes how to:

- Look at change proposals that have been submitted by yourself or others.
- Update the status of a change proposal, if you are a change proposal reviewer or change proposal manager, to reflect the outcome of the review.

This topic applies to change proposals that are not part of a group.

**To show or review change proposals:**

1. In the Database Explorer, open the module whose change proposals you want to review.

2. Click **Tools > Change Proposal System > Open CP Partner**.

   This opens the change proposal partner module. If your change proposal role is Standard, the module is opened read-only.

3. In the change proposal partner module, click **Tools > Change Proposal System > Review**.

   A **Review Proposals** window is displayed.

4. Click **Next** or **Previous** to display the next or previous proposal.

   By default, you can see all proposals. Use the **Show proposals** drop-down list to change the default. You can select:

   - Submitted by anyone
Using the Change Proposal System

• Submitted by this user (this shows all the proposals submitted by the user who submitted the proposal that you are currently looking at)
• For this object
• In this duplicate set
• In this group

5. If the proposal is against an OLE object, double-click the object to activate it. The OLE object can be opened read-only in the Current pane of the Review form for comparison.

6. You can view the suggested changes as redlining by selecting the View changes as redlining check box. Deletions are shown as red text with strikethrough, and insertions as blue text with underlining.

7. If you are a member of the change proposal review team and you want to add the change proposal to a group:
   a. Click Add to Group.
   b. Navigate to the group to which you want to add the change proposal by clicking Search up or Search down.
   c. Select the group you want and click Select.

   Note If you add the change proposal to a master group, the change proposal becomes a subordinate of that group, and its status is changed to the status of the master. The Status list is no longer available because subordinate change proposals inherit their status from the master group. You can remove the change proposal from the group by clicking Remove.

8. If you are a member of the change proposal review team and you want to change the status of a proposal to reflect the outcome of the review:
   a. In the Status box, select the status agreed by the change proposal review team.
   b. Optionally, in the Reviewers' comments box, type any comments the team wants to make about its decision.
   c. Click Save.

9. When you have finished, click Close.
Showing and reviewing groups

1. In the Database Explorer, select the project or folder that contains the group you want to review.

2. Click Tools > Change Proposal System > Manage Groups.

3. Select the group you want to review from the list, and click Review.
   The Review Group dialog box is displayed. It contains a list of the modules that contain change proposals that are part of the group. You review the change proposals module by module.

4. Select the module you want to review, and click Review.
   Note The Review button is disabled if the group has been applied.

The Review Grouped CPs in module dialog box is displayed.

5. You can add change proposals that have been raised against the current module, and are not members of any groups:
   a. Click Raise CP Module.
      The CP Partner module is displayed.
   b. Select the change proposal or change proposals you want to add to the group.
   c. In the Review Grouped CPs in module dialog box, select Current CP, Selected CP or CPs in current view, and click Add.

The change proposal or change proposals are added to the group. If a change proposal you have selected to add is already a member of a group, a message stating No CPs to process is displayed.

6. Select the change proposal that you want to review and click Review.
   The Review Change Proposals dialog box is displayed.

7. Click Next or Previous to display the next or previous proposal in the group.

8. If the proposal is against an OLE object, double-click the object to activate it. The OLE object can be opened read-only in the Current pane of the Review form for comparison.

9. You can view the suggested changes as redlining by selecting the View changes as redlining check box. Deletions are shown as red text with strikethrough, and insertions as blue text with underlining.
10. If you are a member of the change proposal review team and you want to remove a change proposal from the group click **Remove**. The change proposal is no longer associated with the group. If it was a subordinate change proposal, the **Status** list becomes available.

11. If you are a member of the change proposal review team and you want to change the status of a proposal that is a member of a subordinate group to reflect the outcome of the review:
   
a. In the **Status** box, select the status agreed by the change proposal review team.

b. Optionally, in the **Reviewers’ comments** box, type any comments the team wants to make about its decision.

c. Click **Save**.

d. When you have finished, click **Close**.

12. If you are the creator of a master group and you want to change the status of a master group to reflect the outcome of the review:
   
a. Click **Close** in the **Review Change Proposal** dialog box.

b. Click **Close** in the **Review Grouped CPs in module** dialog box.

c. In the **Review Group** dialog box, select a new **Group status** from the list.

If you are reviewing proposals that are part of a master group, you must change the status of the group in the **Review Group** dialog box. The status that you set there is inherited by all the change proposals that are member of the group.

### Showing and reviewing suggestions

This topic describes how to:

- Look at suggestions that have been submitted by yourself or others.
- Update the status of suggestions, if you are a change proposal reviewer or change proposal manager, to reflect the outcome of the review.

**To show or review proposals:**

1. In the Database Explorer, open the **Suggestions** module in the CPS folder of the project.

2. Click **Tools > Change Proposal System > Review**.

   The **Review Change Suggestions** dialog box is displayed.

3. Click **Next** or **Previous** to display the next or previous suggestion:
By default, you can see all suggestions. Use the **Show suggestions** drop-down list to change the default. You can select:

- Submitted by anyone
- Submitted by this user (this shows all the suggestions submitted by the user who submitted the suggestion that you are currently looking at)
- In this duplicate set

4. If a suggestion is a duplicate, click **To Primary CP** to display the primary change proposal for the duplicate set.

The **Review** window closes, and the **Proposals** module that contains the primary change proposal is opened, with the primary proposal as the current object.

5. If you are a member of the change proposal review team and you want to change the status of a suggestion to reflect the outcome of the review:
   a. In the **Status** box, select the status agreed by the change proposal review team.
   b. Optionally, in the **Reviewers' comments** box, type any comments the team wants to make about its decision.
   c. Click **Save**.

6. When you have finished, click **Close**.

**Showing information about change proposals**

This topic describes how to:

- Add a column to your current view that shows the number of change proposals submitted against each object in the module.
- Filter your current view to only show objects that have change proposals submitted against them.

You can do both at the same time.

**To show information about change proposals:**

1. In the module window, click **Tools > Change Proposal System > Show Information**.

2. Select the **Show number of proposals per object** check box to add a column to your current view that shows the number of change proposals submitted against each object.

Clear this check box to remove this column from your current view.
3. Select the **Filter to show objects with proposals** check box to apply a filter to your current view, so that only objects that have change proposals are displayed.

   Clear this check box to turn off this filter.

4. Click **Close**.

### Managing duplicate sets

For information about duplicate sets, see “Duplicate sets,” on page 363.

Members of the change proposal review team can:

- Create a duplicate set.
- Add a proposal to a duplicate set.
- Remove a proposal from a duplicate set.

**Note** A suggestion can only be added to a duplicate set as a duplicate. A suggestion cannot be the primary change proposal in a duplicate set.

To manage duplicate sets:

1. In the Database Explorer, open the module whose change proposals you want to manage.

2. Click **Tools > Change Proposal System > Open CP Partner**.

   This opens the change proposal partner module.

3. In the change proposal partner module, click **Tools > Change Proposal System > Manage duplicate sets**.

   On the left, the **Duplicate proposals** box lists all the proposals in either the current module or the Suggestions module, depending on which **Source of change proposals** button you select.

   On the right, the **Primary proposals** box lists all the proposals in the current module.

   If a proposal you select in either of these boxes is already a duplicate in a set, the details box displays information about the primary change proposal as well as the selected proposal.

4. To create a duplicate set:

   a. In the **Duplicate proposals** box, select the proposals that you want to be duplicates.
Managing duplicate sets

b. In the Primary proposals box, select the proposal that you want to be the primary change proposal.

c. Click Assign.

Primary change proposals have the Primary icon [P], and duplicate change proposals have the Duplicate icon [D].

5. To add a change proposal to a duplicate set and make it the new primary change proposal:

a. In the Duplicate proposals box on the left, select the change proposal that is currently the primary change proposal in the duplicate set.

b. In the Primary proposals box, select the change proposal that is to be the new primary change proposal.

c. Click Assign

The change proposal you selected from the Primary proposals list becomes the new primary change proposal in the duplicate set. The old primary change proposal and all its duplicates are reassigned as duplicates of the new primary change proposal.

6. To add another duplicate change proposal to a set:

a. In the Duplicate proposals box on the left, select the change proposal that you want to add to the duplicate set.

b. In the Primary proposals box, select the change proposal that is the primary change proposal in the set.

c. Click Assign

If you assign a primary change proposal to any other primary change proposal, it becomes a duplicate of the new primary change proposal, and its former duplicates become duplicates of the new primary change proposal.

If you assign a duplicate proposal in set A to a duplicate proposal in set B, the duplicate in set A is detached from its primary change proposal and becomes a duplicate of the primary change proposal in set B.

If you assign a primary change proposal to a proposal that is not part of a duplicate set, it and all its duplicates, become duplicates of the new primary change proposal.

7. To remove a proposal from a duplicate set:

a. In the Duplicate proposals box on the left, select the proposals you want to remove from their current duplicate sets.

b. Click Detach.
8. When you have finished, click **Close**.

**Checking the approved changes**

Before you apply the changes that have been approved, you should check that there are no conflicts between the approved change proposals. You can check for conflicts by clicking **Tools > Change Proposal System > Check** from the change proposal partner module, or by clicking the **Check** button on the **Manage Groups** dialog box.

**Note** You can check groups that are not in the approved state. Rational DOORS searches for conflicts as though the change proposals were approved.

An error or warning message might be displayed, depending on what conflicts are found.

To see which change proposals are generating conflict errors and warnings:

1. **Click View Report.**

   A conflict error is reported if two or more of the change proposals in the approved set would apply changes to the same attribute of the same object.

   A conflict warning is reported if:
   
   - Two or more of the change proposals in the approved set would apply changes to different attributes of the same object.
   - A change proposal in the approved set and one or more change proposals outside the approved set would apply changes to the same object.
   - A change proposal in the approved set has been set to **Enforce this attribute value**, and the attribute value has changed since the change proposal was submitted.

2. **Select a line in the report, and click Show.**

   The module containing the change proposal is displayed, with the object selected.

3. **You can save a copy of the report to your local machine.**

   a. Type a filename and path, or click **Browse** to select a location where the file can be saved

   b. **Click Save.**

      The report is created and saved in the location specified.
Applying the approved changes

When the change proposal review team has accepted and approved a change proposal or a group of change proposals, a member of the team applies the change or the group. The affected modules are updated to reflect the changes.

You can only apply change proposals. You cannot apply suggestions because they do not relate to any objects in the database.

**Note** If an attribute that has been configured for review is either renamed, deleted, or changed from being an object attribute to a module-only attribute, it is not possible to apply the proposal. If you try to apply an approved change proposal that has been made against such an attribute, an error message is displayed stating that the attribute cannot be found. In this instance, the affected change proposal should be rejected.

To apply approved change proposals:

1. In the Database Explorer, open the module that you want to apply the changes to.
2. Click **Tools > Change Proposal System > Open CP Partner**.
   
   This opens the change proposal partner module.
3. In the change proposal partner module, click **Tools > Change Proposal System > Apply**.
   
   The **Apply Change Proposals** window is displayed.
4. In the **Log file** box, type the name of the log file that you want to record the applied changes in including the path, or click **Browse** to locate it.
   
   **Note** You can use this log file for audit purposes.
5. If you want to apply all the approved proposals to the module, click **Apply All**.
   
   If you want to apply the current proposal:
   
   a. Click **Apply Current**.
   
   b. Use the **Next** and **Previous** buttons to change the current proposal.
   
   c. When you have finished, click **Close**.

   A message confirming that the changes have been made is displayed.
The original module is updated to reflect the proposed changes. In the Proposals module, the status of the applied proposals is changed from Approved to Applied.

To apply approved groups:

1. In the Database Explorer, click **Tools > Change Proposal System > Manage Groups**.
2. Navigate to, and select, the group you want to apply.
3. Click **Apply**.

Rational DOORS checks the proposals in the groups for conflicts.

- If there are no conflicts, the change proposals in the group are applied.
- If there are conflict warnings but no conflict errors, a warning message is displayed. If you want to apply the change proposals, click **Proceed with apply**.
- If there are conflict errors, you cannot apply the group until the errors are resolved.

For more information about conflicts and the conflict report, see “Checking the approved changes,” on page 381.
Test Tracking

If your project has testing requirements that are not particularly complex, you can manage testing in a Rational DOORS module. To do this you configure the module for test tracking.

In a test tracking module, you can set up each object as a Test Case. Test case objects can be organized under headings and sub-headings in the usual way. Each test case object should contain enough information in its attributes to allow a test technician to understand the requirements for the test, run the test against the product, and enter the results of the test into the object. The object can be linked to other objects in the database, such as the requirements being tested.

The object attributes that are used by the test technician can be split into two distinct groups:

• Attributes that define the test case

  These attributes are called Test Case Attributes. Test Case Attributes store background information for test technicians. For example, you might want to specify prerequisites for the test and provide details of the expected outcome.

• Attributes that store test results

  These attributes are called Test Run Attributes. Test Run Attributes are used to hold specific information about the results of each test run. For example, you might want information such as the test technician’s name, the
Using Rational DOORS to manage your testing

date the test was run, whether the test passed and so on to be recorded each time the test is run.

Test cases might need to be run several times during the development lifecycle. As a result of this requirement, you will need several copies of the Test Run Attributes so that a new set of test results can be recorded in the module for each test run. This can be done automatically in a test tracking module by creating a Test Run. The Test Run Attributes are duplicated and suffixed with a number, so you can easily identify the test run to which the results apply. The following table shows how you can build up test run attributes to keep track of test results from each test run. The original test run attributes are never used directly.

<table>
<thead>
<tr>
<th>Test Run Attribute name</th>
<th>Test Run 1</th>
<th>Test Run 2</th>
<th>Test Run 3</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test Date</td>
<td>Test Date 1</td>
<td>Test Date 2</td>
<td>Test Date 3</td>
</tr>
<tr>
<td>Test Technician</td>
<td>Test Technician 1</td>
<td>Test Technician 2</td>
<td>Test Technician 3</td>
</tr>
<tr>
<td>Test Status</td>
<td>Test Status 1</td>
<td>Test Status 2</td>
<td>Test Status 3</td>
</tr>
<tr>
<td>Actual Test Result</td>
<td>Actual Test Result 1</td>
<td>Actual Test Result 2</td>
<td>Actual Test Result 3</td>
</tr>
<tr>
<td>Additional Comments</td>
<td>Additional Comments 1</td>
<td>Additional Comments 2</td>
<td>Additional Comments 3</td>
</tr>
</tbody>
</table>

You can also create a form to display the test case attributes and test run attributes of each test case. This means that when a test run is ready, the test technician can select the first test case in the module, open the form and see immediately the background of the test case and the results that need to be recorded. The form has Next and Previous buttons so the tests can be stepped through one by one.

You can add a layout DXL column to any modules that are linked to the test module to display the status of tests linked to objects in the module as a tick or cross.

By using the test tracking tool you can build up a test history for your project, which is held together in one module.

If you are managing more complex projects, consider using formal test management tools, such as those provided by our partners.
Creating a test definition

If you already have a Rational DOORS module that you use for test tracking, you can configure it to use the test tracking tool, or you can create a module for test tracking. If you use an existing module, none of the data in the module is lost.

1. Select the module you want to set up for test tracking in the contents pane of the Database Explorer.

2. Click **Tools > Test Tracking > Create Test Definition**.

   The Create/Update Test Definitions dialog box is displayed.

   The dialog is split into three sections:

   • **Candidate Attributes**

     All object attributes that exist in the module and are suitable for use as test case or test run attributes are listed in this pane.

     **Note** Attributes that end with a space followed by a number cannot be used by the test tracking tool as this is the numbering format that is used to identify test run attributes.

   • **Test Case Attributes (common to all test runs)**

     Select the attributes in the Candidate Attributes list that you want to use as Test Case Attributes and click **Add** to move them into this list. These attributes provide the test technician with background information about the test.

     If a candidate attribute that you assign as a test case attribute inherits its access rights from its parent, the access to the attribute's value for the group Everyone else is changed to RMCD. This is the access right that is required by the average user to a test case attribute's value.

     If you have assigned specific access rights to users, or changed the inherited access rights for group Everyone else, those access rights are maintained.

   • **Test Run Attributes (duplicated for each test run)**

     Select the attributes in the Candidate Attributes list that you want to use as Test Run Attributes and click **Add** to move them into this list. These attributes are duplicated each time you create a test run, and suffixed with a number to identify the test run with which they are associated.
If a candidate attribute that you assign as a test run attribute inherits its access rights from its parent, the access to the attribute’s value for group Everyone else is changed to R. This is the access right that is required by the average user to a test run master attribute’s value.

If you have assigned specific access rights to users, or changed the inherited access rights for group Everyone else, those access rights are maintained.

3. To populate the module with attributes for use with the test tracking tool you can either:
   - Automatically create a set of default attributes
     Click **Create Default Attributes**. This creates a set of Test Case Attributes and Test Run Master Attributes that would typically be useful in test tracking.
   - Manually create new attributes
     In the test tracking module, click **Edit > Attributes**, create attributes in the usual way, and then click **Refresh** on the **Create/Update Test Definitions** dialog box. They are displayed in the **Candidate Attributes** list. You can then use the arrows to move them to the other lists and assign them for use in test tracking. For information about creating new attributes, see “Creating an attribute definition,” on page 137.

4. If you want to create a view to display the attributes you have assigned as Test Case Attributes, select **Create test definition view named** and either type a name, or leave the default. To create a view to display the attributes you have assigned as Test Run Attributes, select **Create test run view named** and either type a name for the view or leave the default.

5. Click **OK**.

6. Click to save when prompted.

Module attributes, which store information about the test tracking setup are created. These attributes are **T3 Edit Form Attributes, T3 Edit Form Dimensions, T3 Test Case Attributes, T3 Test Run Attributes** and **T3 Test Run Count**.

Object attributes that are assigned as Test Run Attributes are set to read-only. They are never used directly, but are copied for every test run that you create.

Data in existing attributes, which you have now assigned to test runs is not lost. Any existing attributes that you assign to Test Run are copied. The
original attributes remain unaltered. If you no longer need the original attributes, they can be deleted by clicking Edit > Attributes in the test tracking module, and deleting them in the usual way.

**Note** Only the attribute definition is copied. The attribute value of an existing attribute that you assign for use as a test run attribute is kept in the original attribute, but is not copied to the test run attribute.

### Updating test definitions

You can update test definitions at any time by changing the attributes that are assigned to Test Case definitions and Test Run definitions.

1. Click Tools > Test Tracking > Create/ Update Test Definitions in the module you want to update.
2. Make the changes you require. If you have assigned or removed attributes from the Test Case or Test Run definitions and you want to update the view to reflect these changes, select the appropriate Create View check box and enter the original view name. Your old view is updated.
3. Click OK and save your changes when prompted.

### Creating a form for recording test results

You can create a form, called the Test Run Results form, to display the test case attributes and test run attributes of each test case. This means that when you are ready to run a test set, the test technician can select the first test case in the module, open the form and see immediately the background of the test case and the results that need to be recorded. The form has Next and Previous buttons so the test cases can be stepped through one by one.

**To create the Test Run Results form:**

1. Click Tools > Test Tracking > Define Test Run Results Form.
2. Any of the attributes that are displayed in the lists on the left hand side of the dialog box can be displayed on the edit form. Select the attributes you want to appear on the form and move them into the list on the right side of the dialog using the Add buttons. To remove an attribute from the form, select it in the list on the right, and click Remove.
3. The attributes appear on the form in the order in which they are displayed in the list. You can reorder them by selecting them and moving them using the Move Up and Move Down buttons.
4. Preview the form by clicking the **Preview** button.

5. Click **OK** to save the form. The list of attributes you have chosen to include on the form is saved in the module attribute called **T3 Edit Form Attributes**.

### Preparing the module for a test run

Before a test technician can run any of the tests in the module you must create a test run. This creates a duplicate set of test run attributes into which the test technician can enter results for each object (test case) in the module.

For example, if you created a test run attribute **Test Technician**, when you create a test run the attribute is duplicated and suffixed with a number. Each time you create a test run another copy of the original attribute is made and the number is incremented. This makes it easy to see which test run the results are associated with.

#### To create a test run:

1. Click **Tools > Test Tracking > Create Test Run**.
   - A number is displayed in the **First Test Run Number** box. You can change this number, or leave the default. If you leave the default, the number will automatically increment for each new test run.
   - If you want to create a view to display the results of the test run, select **Create test run view** and enter a name for the view.
   - If you want the view to be derived from an existing view, select **based on view**, and select the view from the list. If no views are defined in the module, the **based on view** check box is unavailable.

2. Click **OK**.

   An information window is displayed. This tells you the test run number and the number of attributes that have been created.

3. Click **OK**.

   If you selected to create a view for the test run, an information window is displayed telling you that the view has been created.

4. Click **OK**.

   **Note**  When you create subsequent test runs, the test run number of the previous test run is displayed on the **Create Test Run** dialog box.
Running tests

Once a new test run has been created you can open the Test Case Edit Form, which displays the fields you need to complete for each test and background information about the test. You can then step through the test cases, and enter the required information.

You can have the module open in either exclusive edit mode or shareable edit mode to enter test run results. If you have the module open in shareable edit mode, you can only edit the objects that you have locked.

1. Select the test case you want to run and click Tools > Test Tracking > Enter Test Run Results. The Test Run Results form is displayed.
2. Complete the fields as required, and then click Apply.
   The results are saved in the attributes that have been created for this test run.
3. To run another test click Next or Previous.

Note If Refresh editor on current selection is selected, and you click on an object in the module, the form is updated to display the details for that test case.

Comparing test runs

You can select an enumerated attribute and compare two test runs based on that attribute. For example, you might want to compare the results held in the Test Status enumerated attribute to see changes in the pass rate for the tests.

To compare test runs:

1. Click Tools > Test Tracking > Compare Test Runs.
   The Compare Test Runs dialog box is displayed.
2. Select the enumerated attribute whose results you want to compare from the Enumerated attribute to compare drop-down list.
3. By default, the last two test runs are compared. If you want to compare different test runs, type the numbers in the Test runs to compare boxes.
4. Click Collect Data.
   The Old Value and New Value columns display all the changes to the attribute value you selected to compare, and the Number of test cases column displays the number of test cases that have changed in that way. In the following example, one test case has gone from Exempt to Pass, three have gone from Fail to Pass, two have passed both runs, and 21 have remained Undetermined.
You can sort the results in the **List view** by clicking the column title.

To see a graphic view of the results click the **Graphic View** tab.

5. If you want to filter the module based on any of these transitions, select the appropriate box or boxes next to the transition you want to filter on and click **Filter Tests**. For example, if you wanted to filter the module to only show tests that have changed from **Exempt** to **Pass**, select the first box in the example and click **Filter Tests**.

You can also filter the module from the **Graphic View** tab by selecting the circle that represents the transition on which you want to filter.

6. You can create a comparison view, which shows the differences between the two test runs in all the attribute columns that are displayed.

To create the comparison view, select **Convert View to show comparison** and select the view you want to convert from the list. Click **Filter Tests**.

The view you selected is displayed in the module and two sets of values (the results of each test run) are shown in each of the columns in the view. If you have also selected to filter the module on certain transitions, only the objects that match the filter are displayed.
Descriptive modules

In early versions of Rational DOORS, if you wanted to import data into Rational DOORS you had to use descriptive modules. Nowadays, however, Rational DOORS provides a large range of importers to let you import data from many different types of file, including text files (see “Importing,” on page 323).

You can still create descriptive modules, but you can only create them using DXL. As part of the DXL code you write to create the descriptive module, you specify the file containing the data you want to import. When you import the file, Rational DOORS imports it using the current active code page, for example Latin-1, unless it finds a Unicode Byte Order Marker (BOM) at the start of the file. If the file contains a BOM, the encoding is inferred from the marker.

You cannot edit the contents of a descriptive module but you can extract (copy) sections of its text to formal modules. The extraction process automatically creates links between the original text in the descriptive module and the copy in the formal module.

For example, you have a mail message that contains some requirements that you want to import into Rational DOORS. So you import the mail message into a descriptive module.

Then you mark up the text in the descriptive module that you want to extract. Each marked up requirement becomes an object in the descriptive module.

Finally, you extract the marked up objects. Rational DOORS automatically creates a link between each marked up object in the descriptive module and the copy of it in the formal module.
You cannot edit the text in the descriptive module, but you can edit the copy of the text in the formal module. You still have your descriptive module, with the original text, and links between the two modules.

**Controlling access to a descriptive module**

To change the access rights for a descriptive module, you must have admin access to the module.

**To change the access rights for a descriptive module:**

1. In the module window, click **File > Module Properties**.
2. Click the **Access** tab.

The current access rights for the module are displayed.

<table>
<thead>
<tr>
<th>You need this access right</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Read (R)</td>
<td>See the module. If you do not have read access, the module is not displayed in your Database Explorer. Set your own default view for the module (see “Setting default views,” on page 99).</td>
</tr>
<tr>
<td>Create (C)</td>
<td>Markup the module. Create attribute types and attribute definitions for the module.</td>
</tr>
<tr>
<td>Modify (M)</td>
<td>Change the module’s name, description, attribute values, or default view. Create baselines of the module.</td>
</tr>
<tr>
<td>Delete (D)</td>
<td>Delete, undelete and purge the module. Cut the module to the Database Explorer clipboard.</td>
</tr>
<tr>
<td>Admin (A)</td>
<td>Change the access rights for the module.</td>
</tr>
</tbody>
</table>
3. Make the changes you want.

<table>
<thead>
<tr>
<th>Access tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit from parent</td>
<td>Select this check box if you want the module to inherit its access rights from the project or folder that it is in. When this check box is selected, the list of access rights is unavailable, and shows what access rights the module is inheriting.</td>
</tr>
</tbody>
</table>
| Add                 | To add a new entry to the list of access rights:  
  a. Click Add.  
  The Add Access dialog box is displayed.  
  b. In the Name box, select the name of the user or group that you want to add an entry for.  
  c. Select the access rights you want to give them, and then click OK. |
| Remove              | To remove an entry from the list of access rights, select the entry, and then click Remove.                                                  |
| Edit                | To edit an entry in the list of access rights:  
  a. Select the entry then click Edit.  
  The Edit Access dialog box is displayed.  
  b. Select the access rights you want to give them, and then click OK. |
| Additional access    | Select the additional access rights that you want to propagate with create access. The additional rights are propagated to the objects in the module that inherit their access rights from the module. For more information, see “Propagating extra access rights with create,” on page 218. |

4. Click OK.

**Marking up a descriptive module**

To mark up a descriptive module:

1. Open the descriptive module that you want to mark up:
Using descriptive modules

a. In the Database Explorer, make sure that descriptive modules are being displayed.
   If necessary, click View > Show Descriptive Modules.

b. Double-click the descriptive module in the Database Explorer.

2. Click Edit > Object Properties.

3. If you have not marked up the module before, the entire contents of the module is displayed in the Editing Descriptive Text pane. Text in this pane can be selected, but cannot be edited.
   Select the text you want to mark up, and then click Markup.

4. The text you selected is displayed in the Editing Object Text box. It is now an object in the descriptive module. Notice that:
   • The attributes box is no longer empty. It now shows the attributes of the object. The Object Text attribute contains the text you selected.
   • There is now an Absolute number box at the top right of the window, which shows the absolute number of the object.

   Note  Text that has not been marked up does not have an absolute number or any attributes because it is not an object in the module. It is just unmarked up text.

5. Use the Next and Previous buttons to move through the module.
   When you find another piece of text that you want to mark up, select the text, and then click Markup.

   If you change your mind and decide that you do not want the mark up that is currently being displayed, click Undo Markup.

   Note  The Undo and Redo options on the Edit menu in the descriptive module window are not enabled, so you have to use the Edit Descriptive Object dialog box to undo markup.

6. When you have finished marking up the descriptive module, click Close.

7. Save the descriptive module (click File > Save).

Extracting marked up objects

When you have marked up your descriptive module, you can extract the marked up objects to a formal module. Extracting an object makes a copy of the object
in the formal module and creates a link between the original object in the descriptive module and the copy of it in the formal module.

Extracting copies the object text only. If you have created other attributes in the descriptive module, they are not copied to the formal module.

Note You can extract marked up objects from one descriptive module to two or more formal modules. You can also populate a formal module with objects extracted from two or more descriptive modules.

To extract marked up objects:

1. Open the descriptive module that you want to extract the data from.
   a. In the Database Explorer, make sure descriptive modules are being displayed.
      If necessary, click View > Show Descriptive Modules.
   b. Double-click the descriptive module in the Database Explorer.
2. In the descriptive module window, click Extract > Setup Extraction.
3. In the Target module box, type the name and path to the formal module that you want to extract the data to, or use Browse to locate it.
4. In the Link module box, type the name and path to the link module you want to use for the links between the descriptive and formal modules, or use Browse to locate it.
5. Click OK.
   Rational DOORS opens the formal module and the link module you selected in Step 3 and Step 4. The descriptive module is now set up for you to extract data.
6. In the formal module window, select the object that you want to copy the marked up object to. You can copy to the same level as this object, or to one level below it.
7. In the descriptive module window, select the marked up object that you want to copy.
8. In the descriptive module window, click Extract, and then either Extract to Current Level or Extract to One Level Below.
   An Edit Link Object dialog box is displayed. If you want, edit the attributes of the link that is created between the two objects, and then click OK.
9. Repeat Step 6 to Step 8 to extract other marked up objects.
10. When you have finished, save the descriptive module, the target formal module and the link module (in each module window, click File > Save).

The marked up objects are copied from the descriptive module to the formal module. A link is created between each object in the descriptive module and the copy of it in the formal module.

### Showing descriptive module properties

To show the properties of a descriptive module:

1. In the Database Explorer, make sure that descriptive modules are being displayed.
   
   If necessary, click View > Show Descriptive Modules.

2. Select the descriptive module whose properties you want to show, and then click File > Properties.

The properties sheet for the module is displayed.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name of the module.</td>
</tr>
<tr>
<td>Description</td>
<td>Additional information about the module.</td>
</tr>
<tr>
<td>Type</td>
<td>The type of item whose properties are being displayed. This is Descriptive Module, and cannot be edited.</td>
</tr>
<tr>
<td>List of attributes</td>
<td>This is a list of all the module’s attributes. For each attribute, it shows the name of the attribute and its value.</td>
</tr>
<tr>
<td>Edit</td>
<td>To change the value of an attribute:</td>
</tr>
<tr>
<td></td>
<td>a. Select the attribute in the list of attributes, and then click Edit.</td>
</tr>
<tr>
<td></td>
<td>b. Enter the new attribute value.</td>
</tr>
<tr>
<td></td>
<td>c. Click OK.</td>
</tr>
</tbody>
</table>
Displaying marked up items only

By default, when you open a descriptive module, the entire module is displayed. If you only want to see the marked up objects in the module, click View > Show > Marked Up Items Only.
Using descriptive modules
Showing your user options

To show your user options:

1. In the Database Explorer, click **Tools > Options**.

   The **General** tab shows the following information:

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Username</td>
<td>Your Rational DOORS user name. See your Database Manager if you want to change your user name.</td>
</tr>
<tr>
<td>Full Name</td>
<td>Your full name. This can be blank. If you sign a baseline, your Full Name is displayed as part of your electronic signature. See your Database Manager if you want to change your full name.</td>
</tr>
</tbody>
</table>
The **Display** tab shows information about your display schemes. For more information, see “Changing your display scheme,” on page 410.

<table>
<thead>
<tr>
<th>General tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Email</td>
<td>Your e-mail address.</td>
</tr>
<tr>
<td>System username</td>
<td>The user name you log in to your computer with. For example, your Windows 2003 user name. If your system user name is wrong or has changed, please let your Database Manager know, so they can update your user information.</td>
</tr>
<tr>
<td>Telephone</td>
<td>Your telephone number.</td>
</tr>
<tr>
<td></td>
<td>If you submit proposals using the Change Proposal System (CPS), this is displayed with your proposals. Leave this box blank if you do not want other people to see your telephone number.</td>
</tr>
<tr>
<td>Location</td>
<td>Your location.</td>
</tr>
<tr>
<td></td>
<td>If you submit proposals using the CPS, this is displayed with your proposals. Leave this box blank if you do not want other people to see your location.</td>
</tr>
<tr>
<td>User type</td>
<td>Your user type.</td>
</tr>
<tr>
<td></td>
<td>See your Database Manager if you want to change your user type.</td>
</tr>
<tr>
<td>User powers</td>
<td>Your user powers.</td>
</tr>
<tr>
<td></td>
<td>See your Database Manager if you want to change your user powers.</td>
</tr>
<tr>
<td>Additional information</td>
<td>Additional information about yourself.</td>
</tr>
<tr>
<td></td>
<td>If you submit proposals using the CPS, this is displayed with your proposals.</td>
</tr>
<tr>
<td>E-mail updates to change proposals</td>
<td>If you are using a Rational DOORS database server and you use the CPS to submit proposals, select this check box if you want to be notified by e-mail when the status of your proposals changes, for example when one of your proposals is accepted or rejected.</td>
</tr>
</tbody>
</table>
The **Security** tab shows information about your password and can be edited, as described in the following table:

<table>
<thead>
<tr>
<th>Security tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Change Password</td>
<td>To change your password:</td>
</tr>
<tr>
<td></td>
<td>a. Click <strong>Change Password</strong>.</td>
</tr>
<tr>
<td></td>
<td>b. Type your current password in the <strong>Old password</strong> box.</td>
</tr>
<tr>
<td></td>
<td>c. Type your new password in the <strong>New password</strong> box, and then type it again in the <strong>Confirm new password</strong> box.</td>
</tr>
<tr>
<td></td>
<td>d. Click <strong>OK</strong>.</td>
</tr>
<tr>
<td>Minimum password length</td>
<td>This is the minimum number of characters you must type when you change your password.</td>
</tr>
<tr>
<td></td>
<td>If it is 0, when you change your password, you can leave the new password boxes empty; in this case, you do not have to type in a password on the Rational DOORS login screen.</td>
</tr>
<tr>
<td>Expires after</td>
<td>This tells you when your password expires. It is measured in days, starting from when you last changed your password (see the <strong>Last changed</strong> box).</td>
</tr>
<tr>
<td></td>
<td>If your password has expired, the next time you log in, you’ll be asked to change your password.</td>
</tr>
<tr>
<td></td>
<td>If the value is 0, you are never asked to change your password.</td>
</tr>
<tr>
<td>Last changed</td>
<td>When your password was last changed.</td>
</tr>
<tr>
<td>Additional Authentication</td>
<td>This is a read-only check box and is only displayed if the Rational DOORS database is configured to use RDS for user authentication. If the check box is selected, the current user is required to perform additional authentication.</td>
</tr>
</tbody>
</table>

The **Groups** tab shows which groups you are in. See your Database Manager if you want to change your groups.
The **Settings** tab shows the following information:

<table>
<thead>
<tr>
<th>Settings tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show advanced system attributes</td>
<td>By default, screens that list system attributes do not include ones that are for Rational DOORS internal use only, such as <strong>OLEIconic</strong> and <strong>TableLeftBorder</strong>. Select this check box if you always want to see all advanced system attributes.</td>
</tr>
<tr>
<td>Show network server monitor</td>
<td>Select this check box if you are using a Rational DOORS database server, and you want to monitor network traffic between your computer and the server. When this check box is selected, an LED is added to the system tray on your Windows start bar. The LED flashes when data is being transferred to or from the Rational DOORS database server. Clear this check box to remove the LED from your system tray.</td>
</tr>
<tr>
<td>Show symbols in change bars</td>
<td>Select this check box if you want to display symbols in change bars. Change bars allow you to track the changes to objects. The status of an object can be communicated by: • The color of the change bar • A symbol • A tool-tip This check box allows you to control whether a symbol is displayed. <strong>Note</strong> The <strong>New Object</strong> symbol is always displayed in the change bar, even if this check box is cleared. For information about change bars, see “Change bars,” on page 277.</td>
</tr>
<tr>
<td>Settings tab</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Warn when view changes are to be lost</td>
<td>If you make changes to the module display, for example define and apply a filter or add a column, and do not save these changes as a view the changes are lost if you select a different view or close the module. When this check box is selected, a message is displayed warning that the changes you have made to the display will be lost unless you save the view.</td>
</tr>
<tr>
<td>Warn when restoring a change other than the most recent from history</td>
<td>If you restore a change from history, it is possible that the change might not have been the most recent. When this check box is selected, a warning message is displayed letting you know that the change is not the most recent. When this check box is cleared, no warning message is displayed and the change is restored. You can also control whether the warning is displayed by selecting or clearing the <strong>Do not show me this warning again</strong> check box on the warning itself.</td>
</tr>
<tr>
<td>Open last displayed folder or project on startup</td>
<td>Select this check box if you want the folder or project that was displayed when you closed your previous Rational DOORS session to be displayed the next time you log in.</td>
</tr>
<tr>
<td>Measurement units</td>
<td>This controls whether Rational DOORS uses inches or millimeters on Page Setup screens.</td>
</tr>
<tr>
<td>Default link module</td>
<td>This is the default link module that is used when you create links from one module to another and there is not a default linkset pairing for those two modules. By default, it is Rational DOORS Links. If you specify just the name of the module, without a path, Rational DOORS assumes the link module is in the same folder or project as the link’s source module. If you specify a full path, starting with a slash character (/), Rational DOORS uses the specified link module, regardless of which folder or project the link’s source module is in.</td>
</tr>
</tbody>
</table>
### Display schemes

Your display scheme controls the colors and fonts that are displayed in module windows. There are a number of standard display schemes:

<table>
<thead>
<tr>
<th>Settings tab</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web browser</td>
<td>This is the browser that Rational DOORS uses:</td>
</tr>
<tr>
<td></td>
<td>• If you click a URL in any module</td>
</tr>
<tr>
<td></td>
<td>• If you click the <strong>Rational DOORS on the Web</strong> help topics</td>
</tr>
<tr>
<td></td>
<td>This value is stored in the <strong>BrowserName</strong> parameter in the registry.</td>
</tr>
<tr>
<td>Recent module list size</td>
<td>Modules that have been opened recently are listed in the <strong>File</strong> menu. By default, the four most recently viewed modules are displayed. The path to the module from the nearest parent project is displayed in the module status bar when you hover the cursor over the module name. You can display up to nine recently opened modules in the file menu. Select the number you want to display from the list.</td>
</tr>
<tr>
<td>Switch view when navigating URL to an open module</td>
<td>View information is included with module, baseline and object URLs when the view displayed when the URL is copied is not the Standard view. You can select to never switch view, always switch view or be asked whether you want to switch view or not when you follow a URL that will result in the view in a module that is currently open being changed.</td>
</tr>
</tbody>
</table>

The **Spelling** tab shows information about the configuration of your spell checker. For more information about how to configure your spell checker, see “Configuring the spelling checker,” on page 415.

2. Click **OK**.

## Display schemes

Your display scheme controls the colors and fonts that are displayed in module windows. There are a number of standard display schemes:

- modern
- classic
- international modern
Changing your display scheme

- international classic
- high contrast #1
- high contrast #2
- high contrast black
- high contrast white

The Database Manager controls the default display scheme for your database. You can change your display scheme to select a different standard scheme, or you can define your own scheme.

High contrast display schemes

There are four standard high contrast display schemes:
- high contrast #1
- high contrast #2
- high contrast black
- high contrast white

These display schemes follow the pre-defined Windows schemes and work along with the Accessibility Options on the Control Panel.

For example, if you want to use the high contrast black display scheme in Rational DOORS, follow these steps:

1. Open Accessibility Options in the Control Panel, and then select the Display tab and select Settings. The Settings for High Contrast dialog box is displayed.
2. Select one of the high contrast black options from the High Contrast Appearance Scheme drop-down list, and click OK.
3. Select the Use High Contrast check box, and click OK.
4. Go to the Database Explorer and click Tools > Options.
5. Click the Display tab.
6. Select high contrast black in the Schemes panel.
7. Click Apply.

Changing your display scheme

The Database Manager controls the default display scheme for your database.
You can change your display scheme to select a different standard scheme, or you can define your own scheme.

**To change your display scheme:**

1. In the Database Explorer, click **Tools > Options.**
2. Click the **Display** tab.
   
   The **Schemes** panel contains a list of the display schemes you can use. Below the Schemes panel, you can set the line spacing you want to use to display textual attribute values. By default, the line spacing is single for all locales except Korean, Simplified Chinese and Traditional Chinese.

   On the right, the **Colors** and **Fonts** tabs show the colors and fonts for the selected display scheme.

   On the **Colors** tab, the colors of the various items are displayed. To change the color of an item, double-click it then select the new color.

   For information about the items, see “Display scheme items,” on page 412.

   On the **Fonts** tab, use the **Fonts used in** box to select one of the following options:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Headings</td>
<td>The font used in document mode to display headings.</td>
</tr>
<tr>
<td>Body text</td>
<td>The font used in document mode to display the object text in the main column.</td>
</tr>
<tr>
<td>Graphics</td>
<td>The font used in graphics mode.</td>
</tr>
</tbody>
</table>

   A list of the current settings for each object level is displayed.

   To change the settings for an entry in the list, double-click the entry and specify the new settings. In the **Preview** box, the current settings are displayed on the top line, and the proposed new settings on the line below.

3. To edit an existing display scheme:
   
   a. Select the scheme, and then edit the settings on the **Colors** and **Fonts** tabs.
   
   b. Click **OK**.

   The new colors and fonts are used the next time your screen is refreshed. To refresh your screen, click **View > Refresh.**
Display scheme items

4. To create a display scheme:
   a. Select the existing scheme that is closest to how you want the new scheme to look.
   b. Use the Colors and Fonts tabs to specify the colors and fonts you want.
   c. Click Save As.
   d. Type the name of your new scheme in the Save as box, and then click OK.
   e. Click OK.

   The new colors and fonts are used the next time your screen is refreshed. To refresh your screen, click View > Refresh.

5. To delete a display scheme:
   a. Select the scheme, and then click Delete.
   b. Click OK.

   Note If you select a font that is not available on the current desktop, a warning is displayed and the default font for the desktop is used in the current session. If the font you selected is available in subsequent sessions, it is used, if not the warning is displayed and the default font for the desktop is used.

Display scheme items

<table>
<thead>
<tr>
<th>Items that affect Document mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page background</td>
<td>Window background color for formal and descriptive modules when filtering and sorting are off.</td>
</tr>
<tr>
<td>Background—filtering</td>
<td>Window background color for formal and descriptive modules when filtering is on, but sorting is off.</td>
</tr>
<tr>
<td><strong>Items that affect Document mode</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>---------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Background—sorting</td>
<td>Window background color for formal and descriptive modules when sorting is on, but filtering is off.</td>
</tr>
<tr>
<td>Background—filtering &amp; sorting</td>
<td>Window background color for formal and descriptive modules when both filtering and sorting are on.</td>
</tr>
<tr>
<td>Text background</td>
<td>Background color for normal objects in formal and descriptive modules.</td>
</tr>
<tr>
<td>Current background</td>
<td>Background color for current object in formal and descriptive modules.</td>
</tr>
<tr>
<td>Title background</td>
<td>Column title’s background color in formal and descriptive modules.</td>
</tr>
<tr>
<td>Read-only text background</td>
<td>Background color for read-only text.</td>
</tr>
<tr>
<td>Lockable object background</td>
<td>Background color in shareable edit mode for objects that are in sections (objects that can be locked). In the modern display scheme, this color is used only for sections you have not locked. In the classic display scheme, it is used for sections you have locked as well as for sections you have not locked.</td>
</tr>
<tr>
<td>Data text</td>
<td>Normal object’s text color in formal and descriptive modules.</td>
</tr>
<tr>
<td>Title text</td>
<td>Column title’s text color in formal and descriptive modules.</td>
</tr>
<tr>
<td>Selected text</td>
<td>Text color for selected objects in formal and descriptive modules.</td>
</tr>
<tr>
<td>Read-only text</td>
<td>Color for data that you only have read access to. You cannot edit this data.</td>
</tr>
<tr>
<td>Deleted text</td>
<td>Text color for deleted objects.</td>
</tr>
<tr>
<td>Current outline</td>
<td>Color of lines above and below the current object in formal modules.</td>
</tr>
<tr>
<td>Grid Lines</td>
<td>Color of gridlines between objects in formal modules.</td>
</tr>
<tr>
<td>Current table cell background</td>
<td>Background color of current table cell in formal modules.</td>
</tr>
<tr>
<td>Link module page background</td>
<td>Window background color for link modules.</td>
</tr>
<tr>
<td><strong>Items that affect Document mode</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Link module text background</td>
<td>Background color for normal objects in link modules.</td>
</tr>
<tr>
<td>Link module current background</td>
<td>Background color for current source and target objects in link modules.</td>
</tr>
<tr>
<td>Link module title background</td>
<td>Background color for title in link modules, for all objects except the currently selected ones.</td>
</tr>
<tr>
<td>Link module data text</td>
<td>Text color in link modules.</td>
</tr>
<tr>
<td>In-place text</td>
<td>Text color when you edit in-place.</td>
</tr>
<tr>
<td>In-place background</td>
<td>Background color when you edit in-place.</td>
</tr>
<tr>
<td>Partitioned-out text</td>
<td>Color of partitioned-out text.</td>
</tr>
<tr>
<td>Partitioned-in (R) text</td>
<td>Color of partitioned-in (R) text.</td>
</tr>
<tr>
<td>Partitioned-in (RW) text</td>
<td>Color of partitioned-in (RW) text.</td>
</tr>
<tr>
<td>High indicator</td>
<td>Color of change bars for unsaved changes.</td>
</tr>
<tr>
<td>Medium indicator</td>
<td>Color of change bars for saved, but not baselined, changes.</td>
</tr>
<tr>
<td>Low indicator</td>
<td>Color of change bars for objects that have not been changed since the last baseline.</td>
</tr>
<tr>
<td>Links out indicator</td>
<td>Color of out-link arrows.</td>
</tr>
<tr>
<td>Links in indicator</td>
<td>Color of in-link arrows.</td>
</tr>
<tr>
<td>Links start indicator</td>
<td>Color of the object where a link start has been set.</td>
</tr>
</tbody>
</table>
### Items that affect Document mode

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>User 3 is used as the color of the <strong>use in graphical view</strong> column indicator. User 4 is used as the color of the <strong>use as datatip</strong> column indicator. The rest of these items are not used by Rational DOORS.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Title background (selected)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background color of column heading when selected.</td>
<td></td>
</tr>
</tbody>
</table>

### Items that affect Graphics mode

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Main window background color.</td>
</tr>
<tr>
<td>Color used to join levels of the hierarchy.</td>
</tr>
<tr>
<td>Color of the small squares and triangles that indicate that objects are being hidden because there is not space to display them on the screen.</td>
</tr>
<tr>
<td>Object text color.</td>
</tr>
<tr>
<td>Object background color.</td>
</tr>
<tr>
<td>Color used to indicate the presence of hidden objects.</td>
</tr>
<tr>
<td>Color used to indicate the current object.</td>
</tr>
<tr>
<td>Color used to indicate selected objects.</td>
</tr>
</tbody>
</table>
Configuring the spelling checker

In the Database Explorer, click **Tools > Options**, and then the **Spelling** tab to view the current settings for the spelling checker.

Your user settings were inherited from the database when your user account was created. You can alter these settings to suit your spell checking requirements.

The options are divided into three sections, which are explained in detail below.

### Available languages

All the language dictionaries that are supplied with Rational DOORS are listed in the **Selected Languages** list box. Rational DOORS can check spelling and grammar for some languages, and spelling only for others. If you select a language that Rational DOORS cannot check grammar for, the **Grammar level** list is unavailable.

The languages that are supplied with Rational DOORS are listed in the following table:

<table>
<thead>
<tr>
<th>Full spelling and grammar checking</th>
<th>Spelling checking only</th>
</tr>
</thead>
<tbody>
<tr>
<td>English (US)</td>
<td>Afrikaans</td>
</tr>
<tr>
<td>English (UK)</td>
<td>Catalan</td>
</tr>
<tr>
<td>Dutch</td>
<td>Czech</td>
</tr>
<tr>
<td>French</td>
<td>Danish</td>
</tr>
<tr>
<td>German (pre- and post-spelling reform)</td>
<td>Finnish</td>
</tr>
</tbody>
</table>
You can set the spelling checker rules that you want to apply for each language, by selecting a language from the list, and setting the options you require.

The panels immediately below the Selected Language list change depending on what language you select. For example, if you select English (US) you can include Legal and Business, Financial, Insurance lexicon supplements.

Click Use Locale Language to display your current locale language in the Selected Language list.

### Grammar

Rational DOORS checks the grammar and spelling in your Rational DOORS modules according to predefined rules. The rules that are applied by the spelling checker depend on the combination of Proofing mode and Grammar level that you select.

If you have selected a language that is only supported for spelling checking, the Proofing Mode panel is unavailable, and the Active rules list displays the rules for the Spelling only check.

Rational DOORS has three proofing modes, and three grammar levels:

<table>
<thead>
<tr>
<th>Proofing mode</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spelling only</td>
<td>Applies a limited set of rules that identify spelling mistakes and simple grammatical errors, such as capitalization and hyphenation errors. The grammar level does not affect this proofing mode.</td>
</tr>
</tbody>
</table>
Configuring the spelling checker

The **Active rules** list displays the rules that are turned on for the proofing mode and grammar level that you have selected. Select a rule in the list to display a detailed description of it in the **Rule description** box.

**Checking options**

Use these boxes to customize the spelling checker further:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show spelling errors first</td>
<td>Select this option to highlight spelling errors before grammatical problems.</td>
</tr>
<tr>
<td>Ignore read-only attributes</td>
<td>Select this option to only check attributes to which you have modify access. You cannot correct errors in text unless you have modify access to the attribute.</td>
</tr>
<tr>
<td>Use default language if attribute language not suitable</td>
<td>For information about how this setting affects the way in which Rational DOORS selects a language for checking, see the section Default language selection in Rational DOORS, which follows this table.</td>
</tr>
</tbody>
</table>

**Default language selection in Rational DOORS**

When you run the spelling checker, and select the attributes you want to check, Rational DOORS automatically checks in the locale language of the attribute. However, if the attribute’s locale language is not defined by the attribute or not supported by the spelling checker, Rational DOORS defaults to a different language. The language that Rational DOORS defaults to depends on whether you have selected the option **Use default language if attribute language not suitable**.
• If you select this option, and the attribute language is not suitable, Rational DOORS defaults to checking in the language that you have selected in the Selected language list. Make sure that when you close the Options dialog box, the language you want to use as the default is displayed in the Selected language list.

• If you do not select this option, and the attribute language is not suitable, Rational DOORS selects a language as described below:
  • The language defined by the system locale
  • If the system locale is not suitable, the first available language in the list is used. This is usually English (US)

In either case, you can select a different language for the spelling check in the Check Spelling dialog box. For information about how to use the spelling checker, see “Checking spelling,” on page 82.

Adding words to the dictionary

Rational DOORS provides two dictionaries that can be customized:

• Client dictionary
  The client dictionary is stored on the machine on which the Rational DOORS client is installed. This is not a personal dictionary. It can be accessed by any user of that client, including Citrix clients that access the client remotely, and remote access clients. Access controls cannot be set on the client dictionary. However, you cannot add words to the client dictionary if you do not have write access to the directory in which the client dictionary is stored.

• Database dictionary
  This dictionary is available to all Rational DOORS users. You need modify access to the database dictionary to be able to customize it. You can set access rights to control who can add and remove words, and who can change user’s access rights.

To add new words to a dictionary:

1. In the Database Explorer, click Tools > Manage Dictionaries.
   You can add words to the client dictionary or the database dictionary.

2. Select Client or Database from the Dictionary list.
3. Type the word you want to add to the selected dictionary in the **New Word** box.

4. Click **Add new word**.
   
The word is added to the selected dictionary.

**To add alternative words to the dictionary:**

1. In the Database Explorer, click **Tools > Manage Dictionaries**.
2. Select **Client** or **Database** from the **Dictionary** list.
3. Type the word for which you want to provide an alternative in the **As alternative to** box.
4. Type the suggested alternative in the **Suggest Word** box.
5. Click **Add alternative word**.
   
The word and its suggested alternative are added to the list on the left of the box.

**To remove a word or an alternative word from a dictionary:**

1. In the Database Explorer, click **Tools > Manage Dictionaries**.
2. Select the dictionary from which you want to remove the word from the **Dictionary** list.
3. Select the **Words** tab to remove a word from the dictionary, or the **Alternative words** tab to remove an alternative word from the dictionary.
4. Select the word you want to delete, and click **Remove selected word**.
   
The word is removed from the selected dictionary.

---

**Using the command line**

By default, when you start Rational DOORS, it looks at the settings in the registry to find out what configuration settings to use.

When you start Rational DOORS using the command line, you can use switches to override the default settings in the registry. You can also use the switches to add functionality to Rational DOORS. For example, you can use the `-cli` switch to execute your own DXL program before Rational DOORS starts up.

The command looks like this:

```
doors [switches]
```

For example, the following command starts Rational DOORS and opens the Car project in the Database Explorer:
C:\> cd "c:\program files\IBM\Rational\DOORS\9.2\bin"
C:\> doors -project Car

Notice that there’s a space between the switch (-project) and the parameter (Car).

If the parameter contains a space, enclose it in double quotes, like this:

C:\> cd "c:\program files\IBM\Rational\DOORS\9.2\bin"
C:\> doors -project "My project"

If the parameter is a path that contains any spaces, enclose the full path in quotes, like this:

C:\> cd "c:\program files\IBM\Rational\DOORS\9.2\bin"

Summary of command line switches

The following table lists all the switches that you can use on the Rational DOORS command line:

<table>
<thead>
<tr>
<th>Switch (abbreviation)</th>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-addins (-a)</td>
<td>addins_folders</td>
<td>A list of one or more paths to the folders that contain your DXL addins files. Use semicolons (;) to separate the entries in the list. Do not include spaces after the semicolons. Paths can be local paths, conventional drive mappings, or UNC (Universal Naming Convention) paths.</td>
</tr>
<tr>
<td>-attributeaddins (-A)</td>
<td>dxl_attributes_folders</td>
<td>A list of one or more paths to the folders that contain the programs that you can use for DXL attributes. Use semicolons (;) to separate the entries in the list. Do not include spaces after the semicolons. Paths can be local paths, conventional drive mappings, or UNC (Universal Naming Convention) paths.</td>
</tr>
</tbody>
</table>
### Summary of command line switches

<table>
<thead>
<tr>
<th>Switch (abbreviation)</th>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>-batch</code> (-b)</td>
<td>dxl_program</td>
<td>Runs Rational DOORS in batch mode, without the GUI. For more information, see “Running Rational DOORS in batch mode,” on page 428.</td>
</tr>
<tr>
<td><code>-caching</code> (-k)</td>
<td></td>
<td>Enables streaming for transfer of data between the database server and the client. This option might improve data transfer performance over a WAN. However, using this option offers a potential security risk. Data is cached to the localdata area of the client machine whilst loading, although it is cleared on load completion.</td>
</tr>
</tbody>
</table>
| `-cli` (-C)           | dxl_string or 
"#include <dxl_program>" | DXL that is executed at Rational DOORS startup, before the Rational DOORS splash screen is displayed. The parameter is either:  
• A DXL code fragment  
• A hash include statement that specifies the path to a DXL program |
| `-data` (-d)          | port@server | Specifies which Rational DOORS database to use. The parameter specifies the port that the server is using and the name of the server computer (for example, 36677@myserver). A Rational DOORS 9.2 client cannot use a pre-9.0 database server. |
### Switch (abbreviation) Parameter Description

<table>
<thead>
<tr>
<th>Switch (abbreviation)</th>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-defopenmode (-o)</td>
<td>One of the following: READONLY READ_WRITE READ_WRITE_SHARED</td>
<td>The default edit mode that formal modules are opened in when you double-click them in the Database Explorer. The parameter is READ_WRITE for exclusive edit mode and READ_WRITE_SHARED for shareable edit mode. Note that this parameter must be upper case, unless you use the single letter abbreviations (r, w and s).</td>
</tr>
<tr>
<td>-defopenlinkmode (-O)</td>
<td>One of the following: READONLY READ_WRITE READ_WRITE_SHARED</td>
<td>The default edit mode that formal modules are opened in when you open them by clicking a link arrow in another module. The parameter is READ_WRITE for exclusive edit mode and READ_WRITE_SHARED for shareable edit mode. Note that this parameter must be upper case, unless you use the single letter abbreviations (r, w and s).</td>
</tr>
<tr>
<td>-dxl (-D)</td>
<td>dxl_string or &quot;#include &lt;dxl_program&gt;&quot;</td>
<td>DXL that is executed immediately after Rational DOORS starts up. The parameter is either: • A DXL code fragment. • A hash include statement that specifies the path to a DXL program.</td>
</tr>
<tr>
<td>-home (-H)</td>
<td>doors_home</td>
<td>The Rational DOORS home folder. This is the path to the folder that Rational DOORS was installed into (the folder that has a bin folder which contains the doors.exe file).</td>
</tr>
</tbody>
</table>
### Summary of command line switches

<table>
<thead>
<tr>
<th>Switch (abbreviation)</th>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-layoutaddins (-L)</td>
<td>layout_dx1_folders</td>
<td>A list of one or more paths for layout DXL folders. Use semicolons (;) to separate entries in the list. Do not include spaces after the semicolons. Paths can be local paths, conventional drive mappings, or UNC (Universal Naming Convention) paths.</td>
</tr>
<tr>
<td>-localdata (-f)</td>
<td>local_folder</td>
<td>A folder on the local computer used as temporary storage for data copied from the Rational DOORS database server.</td>
</tr>
<tr>
<td>-logfile (-l)</td>
<td>logfile</td>
<td>A file in which Rational DOORS logs information. This is the full path, including the name of the log file.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you use this switch on the command line, it logs DXL errors in the file. Any reported DXL errors are logged in the file instead of being displayed on the screen.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you use this switch in the registry, it logs the information that is recorded in the Windows event log. The information is logged in the file as well as in the application log, where the records have DOORS_DB_SERVER in the Source field.</td>
</tr>
<tr>
<td>-notriggers (-T)</td>
<td></td>
<td>Turn off triggers. You must be either a Database Manager or a Custom user who has the power to manage the database.</td>
</tr>
<tr>
<td>-password (-P)</td>
<td>password</td>
<td>The password for the session.</td>
</tr>
</tbody>
</table>
On Windows computers you can use a shortcut to run Rational DOORS. For information about creating shortcuts, see your Windows online help.

You can use command line switches to override the default settings stored in the registry.
If you use command line switches to log in to Rational DOORS, the Message of the Day will not be displayed.

**To use a command line switch:**

1. Select the shortcut icon on your desktop, and then right-click **Properties**.
2. Click the **Shortcut** tab.
3. The Target box contains the command that is used to start Rational DOORS when you double-click the shortcut icon.

   Edit the command to add whatever switches you want to use (for more information, see “Summary of command line switches,” on page 421).

   **Note** Do not use the `-password` switch. It makes your password visible to other users, which could compromise security.

4. Click **OK**.

**Settings in the registry**

When you start Rational DOORS on a Windows computer, it uses the default configuration information in the registry, unless you use command line switches to override the defaults.

The registry has a directory containing the Rational DOORS 9.2 client configuration details, and a directory for the Rational DOORS 9.2 Server configuration, if the server is installed.

The default path to the Rational DOORS 9.2 registry entry is:

```
HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\DOORS.
```

**Caution** Do not directly edit the registry as this might corrupt your Rational DOORS installation. See your system administrator or your Rational DOORS administrator before making any changes.

The keywords are the same as the command line switches (see “Summary of command line switches,” on page 421).

You do not need to use quotes when the parameter includes spaces.

You cannot point your **ServerData** registry key to a mapped network drive. If you want to point to a mapped network drive for the server data, you can run `doorsd` in a console window.
The EXPORTDIRECTORY keyword

The EXPORTDIRECTORY keyword has no command line equivalent.

It specifies the default path used by the Rational DOORS exporters in the File > Export submenu.

When you use an exporter, the value of EXPORTDIRECTORY is automatically updated to match the path you exported the data to.

The EXPORTDIRECTORY environment variable

The EXPORTDIRECTORY environment variable has no command line equivalent.

It specifies the default path used by the Rational DOORS exporters in the File > Export submenu.

When you use an exporter, the value of EXPORTDIRECTORY is automatically updated to match the path you exported the data to.

Running Rational DOORS in batch mode

You can use the -batch command line switch to run Rational DOORS in batch mode. Rational DOORS starts up without the GUI (it suppresses the login screen and the Database Explorer), runs the specified DXL program, and then stops.

When you use the -batch switch you normally need other switches like -user, -password and -project in order to log in and specify the current project.

The parameter of the -batch switch specifies the file that contains the DXL program that you want to run in batch mode. For example:

C:\> doors -b dxl_programs\batch_analysis.dxl -p Car -u "Jill"

Configuring the Welcome Screen

You can set up Rational DOORS to display the Welcome Screen whenever users log in to Rational DOORS. You can control:

- The link, company name and graphic that is displayed as Home. For information, see “Configuring Home,” on page 428.
- The links on the Documentation Welcome Screen and the Support Welcome Screen. For information, see “Configuring the links on the Welcome Screens,” on page 429.

Configuring Home

To configure Home:
1. Log in to Rational DOORS as a Database Manager or a Custom user who has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.
   If necessary, click View > Database View.

3. In the left pane, click Database , and then click File > Properties.

4. Click the Welcome Screen tab.

5. Select Edit Link.
   The Welcome Screen Link Configuration screen is displayed.

6. In the Image box, type the name of the image file you want to display or use Browse to locate it.

7. Enter a name for the link in Label.

8. Enter the URL you want to link to.

9. Click OK.

**Configuring the links on the Welcome Screens**

To configure the links on the Welcome Screens:

1. Log in to Rational DOORS as a Database Manager or a Custom user who has the power to manage the database.

2. In the Database Explorer, make sure the Database view is selected.
   If necessary, click View > Database View.

3. In the left pane, click Database , and then click File > Properties.

4. Click the Welcome Screen tab.

5. Select the Welcome Screen you want to edit, and select Edit Section.
   The Welcome Screen Link Configuration screen is displayed.

6. Display or hide the section by selecting or clearing Section is visible.

7. In the Section image box, type the name of the image file you want to display or use Browse to locate it.

8. Enter a name in Section title.

9. Enter the text you want to display in the section.

10. Enter a name for the link in Label label.

11. Enter the URL you want to link to.

12. Click OK.
Changing the email address of the problem report

Rational DOORS has an automated problem reporting system that sends a report to Rational DOORS Support. If you want to send the problem to someone other than Rational DOORS Support, for example to your internal support you can change the default email address of the problem report.

To change the email address of the problem report:

1. Open System in the Control Panel.
2. On the Advanced tab, click Environment Variables, and then click New under variables.
   
   The New User Variable window is displayed
3. In Variable Name enter RTL_RECIP, the variable that controls the address used by the problem report.
4. In Variable Value enter the email address you want to use.
5. Click OK to add the value.
6. Click OK to save the value in the environment variables.

Click OK to save the value in the system.
This chapter lists the buttons used in Rational DOORS.

- Module buttons
- Database buttons

**Module buttons**

<table>
<thead>
<tr>
<th>Button</th>
<th>Function and any (keyboard shortcut)</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Baseline" /></td>
<td>Compare baselines</td>
<td>Baseline</td>
</tr>
<tr>
<td><img src="image" alt="Baseline" /></td>
<td>Copy baseline</td>
<td>Baseline</td>
</tr>
<tr>
<td><img src="image" alt="Baseline" /></td>
<td>Create new baseline</td>
<td>Baseline</td>
</tr>
<tr>
<td><img src="image" alt="Baseline" /></td>
<td>View baselines</td>
<td>Baseline</td>
</tr>
<tr>
<td><img src="image" alt="Clipboard" /></td>
<td>Copy (CTRL+C)</td>
<td>Clipboard</td>
</tr>
<tr>
<td><img src="image" alt="Clipboard" /></td>
<td>Cut (CTRL+X)</td>
<td>Clipboard</td>
</tr>
<tr>
<td><img src="image" alt="Clipboard" /></td>
<td>Paste (CTRL+V)</td>
<td>Clipboard</td>
</tr>
<tr>
<td><img src="image" alt="Column" /></td>
<td>Edit selected column properties</td>
<td>Column</td>
</tr>
<tr>
<td><img src="image" alt="Column" /></td>
<td>Insert new column</td>
<td>Column</td>
</tr>
<tr>
<td><img src="image" alt="Column" /></td>
<td>Remove selected column</td>
<td>Column</td>
</tr>
<tr>
<td><img src="image" alt="Column Alignment" /></td>
<td>Auto indent main column</td>
<td>Column Alignment</td>
</tr>
<tr>
<td><img src="image" alt="Column Alignment" /></td>
<td>Center column</td>
<td>Column Alignment</td>
</tr>
<tr>
<td><img src="image" alt="Column Alignment" /></td>
<td>Justify column</td>
<td>Column Alignment</td>
</tr>
<tr>
<td><img src="image" alt="Column Alignment" /></td>
<td>Left align column</td>
<td>Column Alignment</td>
</tr>
<tr>
<td><img src="image" alt="Column Alignment" /></td>
<td>Right align column</td>
<td>Column Alignment</td>
</tr>
<tr>
<td><img src="image" alt="Commit" /></td>
<td>Accept changes (CTRL+M)</td>
<td>Commit</td>
</tr>
</tbody>
</table>
## Rational DOORS buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Function and any (keyboard shortcut)</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td>![x]</td>
<td>Discard changes (ESC)</td>
<td>Commit</td>
</tr>
<tr>
<td>![folder]</td>
<td>Create new discussion for module</td>
<td>Discussion</td>
</tr>
<tr>
<td>![folder]</td>
<td>Create new discussion for object</td>
<td>Discussion</td>
</tr>
<tr>
<td>![folder]</td>
<td>View discussions for module</td>
<td>Discussion</td>
</tr>
<tr>
<td>![folder]</td>
<td>View discussions for object</td>
<td>Discussion</td>
</tr>
<tr>
<td>![filter]</td>
<td>Apply Filtering to Explorer</td>
<td>Display</td>
</tr>
<tr>
<td>![filter]</td>
<td>Filter on/off</td>
<td>Display</td>
</tr>
<tr>
<td>![filter]</td>
<td>Filter properties</td>
<td>Display</td>
</tr>
<tr>
<td>![graphics]</td>
<td>Graphics mode on/off</td>
<td>Display</td>
</tr>
<tr>
<td>![module]</td>
<td>Module explorer on/off</td>
<td>Display</td>
</tr>
<tr>
<td>![outline]</td>
<td>Outlining mode on/off</td>
<td>Display</td>
</tr>
<tr>
<td>![filter]</td>
<td>Reapply filter</td>
<td>Display</td>
</tr>
<tr>
<td>![sort]</td>
<td>Sorting on/off</td>
<td>Display</td>
</tr>
<tr>
<td>![edit exclusive]</td>
<td>Edit mode exclusive edit</td>
<td>Edit Mode</td>
</tr>
<tr>
<td>![edit]</td>
<td>Edit mode read-only</td>
<td>Edit Mode</td>
</tr>
<tr>
<td>![edit]</td>
<td>Edit mode shareable edit</td>
<td>Edit Mode</td>
</tr>
<tr>
<td>![export]</td>
<td>Export to Word</td>
<td>Export</td>
</tr>
<tr>
<td>![bold]</td>
<td>Bold (CTRL+B)</td>
<td>Formatting</td>
</tr>
<tr>
<td>![bullets]</td>
<td>Bullets</td>
<td>Formatting</td>
</tr>
<tr>
<td>![indent decrease]</td>
<td>Decrease indent</td>
<td>Formatting</td>
</tr>
<tr>
<td>![indent increase]</td>
<td>Increase indent</td>
<td>Formatting</td>
</tr>
<tr>
<td>![italics]</td>
<td>Italics (CTRL+I)</td>
<td>Formatting</td>
</tr>
<tr>
<td>![strike]</td>
<td>Strikethrough (CTRL+SHIFT+S)</td>
<td>Formatting</td>
</tr>
<tr>
<td>Button</td>
<td>Function and any (keyboard shortcut)</td>
<td>Toolbar</td>
</tr>
<tr>
<td>--------</td>
<td>-------------------------------------</td>
<td>---------</td>
</tr>
<tr>
<td><img src="image" alt="underline" /></td>
<td>Underline (CTRL+U)</td>
<td>Formatting</td>
</tr>
<tr>
<td><img src="image" alt="clear" /></td>
<td>Clear link start</td>
<td>Link</td>
</tr>
<tr>
<td><img src="image" alt="link" /></td>
<td>Make link from start (SHIFT+CTRL+F)</td>
<td>Link</td>
</tr>
<tr>
<td><img src="image" alt="link" /></td>
<td>Make link to start (SHIFT+CTRL+M)</td>
<td>Link</td>
</tr>
<tr>
<td><img src="image" alt="link" /></td>
<td>Make new external link</td>
<td>Link</td>
</tr>
<tr>
<td><img src="image" alt="link" /></td>
<td>Start link (CTRL+I)</td>
<td>Link</td>
</tr>
<tr>
<td><img src="image" alt="module" /></td>
<td>Edit module properties</td>
<td>Module</td>
</tr>
<tr>
<td><img src="image" alt="print" /></td>
<td>Print (CTRL+P)</td>
<td>Module</td>
</tr>
<tr>
<td><img src="image" alt="save" /></td>
<td>Save (CTRL+S)</td>
<td>Module</td>
</tr>
<tr>
<td><img src="image" alt="find" /></td>
<td>Find (CTRL+F)</td>
<td>Navigation</td>
</tr>
<tr>
<td><img src="image" alt="find" /></td>
<td>Find next (F3)</td>
<td>Navigation</td>
</tr>
<tr>
<td><img src="image" alt="find" /></td>
<td>Find previous (SHIFT+F3)</td>
<td>Navigation</td>
</tr>
<tr>
<td><img src="image" alt="go" /></td>
<td>Go to (CTRL+G)</td>
<td>Navigation</td>
</tr>
<tr>
<td><img src="image" alt="delete" /></td>
<td>Delete object (DELETE)</td>
<td>Object</td>
</tr>
<tr>
<td><img src="image" alt="demote" /></td>
<td>Demote object (CTRL+ALT+RIGHT)</td>
<td>Object</td>
</tr>
<tr>
<td><img src="image" alt="edit" /></td>
<td>Edit object properties (CTRL+E)</td>
<td>Object</td>
</tr>
<tr>
<td><img src="image" alt="new" /></td>
<td>New object at this level (CTRL+N)</td>
<td>Object</td>
</tr>
<tr>
<td><img src="image" alt="new" /></td>
<td>New object below (CTRL+L)</td>
<td>Object</td>
</tr>
<tr>
<td><img src="image" alt="promote" /></td>
<td>Promote object (CTRL+ALT+LEFT)</td>
<td>Object</td>
</tr>
<tr>
<td><img src="image" alt="edit" /></td>
<td>Edit object heading (CTRL+H)</td>
<td>Object Edit</td>
</tr>
<tr>
<td><img src="image" alt="edit" /></td>
<td>Edit object text (CTRL+T)</td>
<td>Object Edit</td>
</tr>
<tr>
<td><img src="image" alt="swap" /></td>
<td>Swap heading and text</td>
<td>Object Edit</td>
</tr>
<tr>
<td><img src="image" alt="spell" /></td>
<td>Check spelling (CTRL+K)</td>
<td>Spelling</td>
</tr>
</tbody>
</table>
### Rational DOORS buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Function and any (keyboard shortcut)</th>
<th>Toolbar</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Table" /></td>
<td>Edit table properties</td>
<td>Table</td>
</tr>
<tr>
<td><img src="image" alt="Table" /></td>
<td>Insert table</td>
<td>Table</td>
</tr>
<tr>
<td><img src="image" alt="Table" /></td>
<td>Insert table column</td>
<td>Table</td>
</tr>
<tr>
<td><img src="image" alt="Table" /></td>
<td>Insert table row</td>
<td>Table</td>
</tr>
</tbody>
</table>

### Database buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Function and any (keyboard shortcut)</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Folder" /></td>
<td>Create new folder</td>
</tr>
<tr>
<td><img src="image" alt="Project" /></td>
<td>Create new project</td>
</tr>
<tr>
<td><img src="image" alt="Up" /></td>
<td>Navigate up one level</td>
</tr>
<tr>
<td><img src="image" alt="Heart" /></td>
<td>Add to favorites</td>
</tr>
<tr>
<td><img src="image" alt="Users" /></td>
<td>Manage users and groups</td>
</tr>
<tr>
<td><img src="image" alt="Formal" /></td>
<td>Create new formal module (CTRL+M)</td>
</tr>
<tr>
<td><img src="image" alt="Link" /></td>
<td>Create new link module (CTRL+L)</td>
</tr>
<tr>
<td><img src="image" alt="Read-only" /></td>
<td>Open module read-only (CTRL+R)</td>
</tr>
<tr>
<td><img src="image" alt="Shareable" /></td>
<td>Open module shareable edit (CTRL+S)</td>
</tr>
<tr>
<td><img src="image" alt="Exclusive" /></td>
<td>Open module exclusive edit (CTRL+E)</td>
</tr>
<tr>
<td><img src="image" alt="Trash" /></td>
<td>Delete (DELETE)</td>
</tr>
</tbody>
</table>
This chapter contains the following topics:
- DXL
- Developing DXL programs
- Browsing the DXL library
- Converting layout DXL to attribute DXL

**DXL**

The Rational DOORS eXtension Language (DXL) is an easy-to-learn scripting language that you can use to control and extend Rational DOORS functionality. DXL is syntactically similar to C and C++.

You can use DXL to:
- Automate routine or complex tasks, such as calculating attribute values.
- Respond to events by triggering custom programs.
- Add your own options to Rational DOORS menus.

For a full description of DXL, see the *DXL Reference Manual*, which is available as a PDF and from the Help menu.

**Developing DXL programs**

You can use the DXL Interaction window to develop small DXL programs.

For large-scale program development, you should use a third-party editing tool when coding, and then load your code into the DXL Interaction window to execute and debug it.

**Note** You can set up a menu option in Rational DOORS to run your third party editing tool.

**To use the DXL Interaction window:**

1. In either the Database Explorer or a module window, click **Tools > Edit DXL**.
   
   **Note** If the Run and Save as buttons are disabled, the database might be set up to stop users from editing and
running DXL. In this instance, contact the database manager.

2. Either type or load your program into the DXL input pane.
   Click Load to load the contents of a file. Click Browse to load a program from the DXL library.

3. Click Run to run the program in the DXL input pane.
   Any error messages that are generated are displayed in the DXL output pane.

4. Click Next error to see the next error message. The contents of the DXL input pane are scrolled to the line of source code that caused the error displayed in the DXL output pane.

5. Click Print to print the contents of the DXL input pane with line numbers.

6. Click Save as to save the contents of the DXL input pane to a file.
   Right-click anywhere in the DXL input pane to display a pop-up menu.

<table>
<thead>
<tr>
<th>Menu option</th>
<th>Submenu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Load</td>
<td>Loads the contents of a text file into the DXL input pane. You can also use drag-and-drop to load a file directly from Windows Explorer.</td>
</tr>
<tr>
<td></td>
<td>Save</td>
<td>Saves the changes you made to the text in the DXL input pane.</td>
</tr>
<tr>
<td></td>
<td>Save as</td>
<td>Saves the contents of the DXL input pane to another file.</td>
</tr>
<tr>
<td></td>
<td>New</td>
<td>Clears the DXL input pane. If you have made changes to the text that have not yet been saved, you are asked if you want to save them.</td>
</tr>
<tr>
<td>Edit</td>
<td>Select all</td>
<td>Selects all the text in the DXL input pane.</td>
</tr>
<tr>
<td></td>
<td>Deselect all</td>
<td>Deselects the selected text.</td>
</tr>
<tr>
<td></td>
<td>Copy</td>
<td>Copies the selected text to the clipboard.</td>
</tr>
</tbody>
</table>
Browsing the DXL library

The DXL library is in the Rational DOORS home directory’s /lib/dxl folder. You can browse the DXL library by clicking the **Browse** button when you are:

- Using the **DXL Interaction** window to find a DXL program to run
- Creating a DXL attribute to find a DXL program to use for the attribute
- Creating a layout DXL column to find a DXL program to use for the layout DXL column

The **DXL Browse Tools** window is displayed. The DXL programs and the buttons displayed depend on where you were when you clicked the **Browse** button.

The results of running a DXL program can depend on whether you select the **Edit DXL** menu option on a module or on the database. For example, some DXL programs need to be run from within a module, and will fail if you run them from the database.

<table>
<thead>
<tr>
<th>Menu option</th>
<th>Submenu option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td></td>
<td>Moves the selected text to the clipboard.</td>
</tr>
<tr>
<td>Paste</td>
<td></td>
<td>Copies the text on the clipboard to the DXL input pane.</td>
</tr>
<tr>
<td>Undo</td>
<td></td>
<td>Undoes the last edit action.</td>
</tr>
<tr>
<td>Search</td>
<td>Search</td>
<td>Finds a string of text in the DXL input pane. The search is case-sensitive.</td>
</tr>
<tr>
<td></td>
<td>Again</td>
<td>Repeats the search.</td>
</tr>
<tr>
<td></td>
<td>Replace</td>
<td>Replaces one string of text with another. You can replace text strings one at a time or all at once.</td>
</tr>
<tr>
<td></td>
<td>Goto line</td>
<td>Moves the cursor to the start of a specified line number.</td>
</tr>
</tbody>
</table>
Note If the Run or Edit buttons are disabled, the database might be set up to stop users from editing and running DXL. In this instance, contact the database manager.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply</td>
<td>Assigns the selected program to your DXL attribute or layout DXL column.</td>
</tr>
<tr>
<td>Current</td>
<td>Edits the program currently assigned to your DXL attribute or layout DXL column.</td>
</tr>
<tr>
<td>Describe</td>
<td>Shows the description of the selected program.</td>
</tr>
<tr>
<td>Edit</td>
<td>Edits the selected program.</td>
</tr>
<tr>
<td>New</td>
<td>Lets you define a new program for your DXL attribute or layout DXL column.</td>
</tr>
<tr>
<td>Run</td>
<td>Runs the selected program in your DXL Interaction window.</td>
</tr>
</tbody>
</table>

Converting layout DXL to attribute DXL

Values that are stored in layout DXL columns are recalculated every time Rational DOORS refreshes the display. The constant recalculation of the values is memory intensive and can lead to poor performance. If you do not need your DXL program to update dynamically, you can convert the contents of your layout DXL column to attribute DXL.

To convert a layout DXL column:

1. Open the module that contains the layout DXL you want to convert in exclusive edit mode. You must have create access to the module.
2. Select the view that includes the layout DXL column you want to convert.
3. Click Tools > Support Tools > Convert Layout DXL to Attribute DXL.
   The Convert Layout DXL dialog box is displayed. It contains a list of the Layout DXL columns in the current view.
4. Select the column that you want to convert and click Convert.

A message is displayed stating that the DXL has been successfully converted, and the new Attribute DXL column is added to the view.
This chapter describes the keyboard shortcuts you can use instead of clicking menu options with your mouse:

- CTRL keys
- Rich text
- Function keys
- Keypad keys
- Navigation Keys

**CTRL keys**

The following table lists the control key shortcuts:

<table>
<thead>
<tr>
<th>Keys</th>
<th>Context</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+A</td>
<td>Formal module</td>
<td>Edits the attribute in the next column.</td>
</tr>
<tr>
<td>CTRL+C</td>
<td>Database Explorer</td>
<td>Copies the currently selected items to the Database Explorer clipboard.</td>
</tr>
<tr>
<td></td>
<td>Formal module</td>
<td>Copies the currently selected objects to the module’s object clipboard.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you are editing an object, it copies the currently selected text to the system clipboard.</td>
</tr>
<tr>
<td>CTRL+D</td>
<td>Database Explorer</td>
<td>Creates a new descriptive module.</td>
</tr>
<tr>
<td></td>
<td>Formal module</td>
<td>Discards a data change during an edit (deletes the edits you made to the current object).</td>
</tr>
<tr>
<td></td>
<td>Link module</td>
<td>Deletes a link.</td>
</tr>
<tr>
<td>CTRL+E</td>
<td>Database Explorer</td>
<td>Opens the module in Exclusive edit mode</td>
</tr>
<tr>
<td>Keys</td>
<td>Context</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Formal module</td>
<td>Displays the object properties sheet, so you can edit objects.</td>
</tr>
<tr>
<td></td>
<td>Link module</td>
<td>Displays the Edit Link Object sheet if a link is selected.</td>
</tr>
<tr>
<td>CTRL+F</td>
<td>Database Explorer</td>
<td>Creates a new formal module.</td>
</tr>
<tr>
<td></td>
<td>Formal module</td>
<td>Finds text in the module.</td>
</tr>
<tr>
<td>CTRL+G</td>
<td>Formal module</td>
<td>Goes to a particular object in the module.</td>
</tr>
<tr>
<td>CTRL+H</td>
<td>Formal module</td>
<td>Edits the <strong>Object Heading</strong> attribute for the current object.</td>
</tr>
<tr>
<td>CTRL+I</td>
<td>Database Explorer</td>
<td>Moves focus between the toolbar, favorites, location, Database Explorer pane and Contents pane.</td>
</tr>
<tr>
<td></td>
<td>Formal module</td>
<td>Starts a link.</td>
</tr>
<tr>
<td>CTRL+K</td>
<td>Formal module</td>
<td>Runs the spelling checker.</td>
</tr>
<tr>
<td>CTRL+L</td>
<td>Database Explorer</td>
<td>Creates a new link module.</td>
</tr>
<tr>
<td></td>
<td>Formal module</td>
<td>Creates a new object one level below the current object.</td>
</tr>
<tr>
<td></td>
<td>Link module</td>
<td>Creates a new linkset.</td>
</tr>
<tr>
<td>CTRL+M</td>
<td>Formal module</td>
<td>Makes a data change (accepts the edits you made to the current object; they are stored in memory).</td>
</tr>
<tr>
<td>CTRL+N</td>
<td>Formal module</td>
<td>Creates a new object at the same level as the current object.</td>
</tr>
<tr>
<td></td>
<td>Link module</td>
<td>Creates a new link.</td>
</tr>
<tr>
<td>CTRL+P</td>
<td>Formal module</td>
<td>Prints the module.</td>
</tr>
<tr>
<td>CTRL+R</td>
<td>Database Explorer</td>
<td>Opens the module Read-only.</td>
</tr>
<tr>
<td>Keys</td>
<td>Context</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Formal Module</td>
<td>Removes the contents of an attribute when it is open for in-place edit.</td>
</tr>
<tr>
<td>CTRL+S</td>
<td>Database Explorer</td>
<td>Opens the module in Shareable edit mode</td>
</tr>
<tr>
<td></td>
<td>Any module</td>
<td>Saves the module.</td>
</tr>
<tr>
<td>CTRL+T</td>
<td>Formal module</td>
<td>Edits the <strong>Object Text</strong> attribute of the current object.</td>
</tr>
<tr>
<td>CTRL+V</td>
<td>Database Explorer</td>
<td>Pastes the contents of the Database Explorer clipboard to the Database Explorer.</td>
</tr>
</tbody>
</table>
|             | Formal module            | If you are editing an object, it pastes the contents of the system clipboard.  
|             |                          | Otherwise it pastes the contents of the module’s object clipboard. New objects are created at the same level as the current object. |
| CTRL+X      | Database Explorer        | Cuts the currently selected items, and places them on the Database Explorer clipboard. |
|             | Formal module            | Cuts the currently selected objects to the module’s object clipboard.  
<p>|             |                          | If you are editing an object, it copies the currently selected text to the system clipboard. |
| CTRL+Z      | Any module               | Undoes your last edit.                                                      |
| CTRL+RETURN | Database Explorer        | Opens selected module in default edit mode.                                 |
|             | Formal module            | Creates an object at the same level as the current object, when you are editing in-place. |</p>
<table>
<thead>
<tr>
<th>Keys</th>
<th>Context</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+LEFT ARROW</td>
<td>Formal module</td>
<td>Goes to the current object’s parent. If you are editing text, moves the insertion point one word to the left</td>
</tr>
<tr>
<td>CTRL+RIGHT ARROW</td>
<td>Formal module</td>
<td>Goes to the current object’s first child. If you are editing text, moves the insertion point one word to the right</td>
</tr>
<tr>
<td>CTRL+HOME</td>
<td>Formal Module</td>
<td>When editing text, moves the insertion point to the start of the attribute.</td>
</tr>
<tr>
<td>CTRL+END</td>
<td>Formal Module</td>
<td>When editing text, moves the insertion point to the end of the attribute.</td>
</tr>
<tr>
<td>CTRL+Double-click on</td>
<td>Formal Module</td>
<td>Goes to <strong>Edit Value</strong> editor of that attribute.</td>
</tr>
<tr>
<td>attribute</td>
<td></td>
<td></td>
</tr>
<tr>
<td>RETURN</td>
<td>Formal Module</td>
<td>When editing attributes goes to same attribute for the next object (for enumerated lists only)</td>
</tr>
<tr>
<td>CTRL+Right SHIFT</td>
<td>Formal Module</td>
<td>When in-place editing, right aligns the attribute value for right-to-left reading order.</td>
</tr>
<tr>
<td>CTRL+Left SHIFT</td>
<td>Formal Module</td>
<td>When in-place editing, left aligns the attribute value for left-to-right reading order.</td>
</tr>
<tr>
<td>CTRL+SHIFT+F</td>
<td>Formal Module</td>
<td>When a link start is defined, creates a link from the start object.</td>
</tr>
<tr>
<td>CTRL+SHIFT+M</td>
<td>Formal Module</td>
<td>When a link start is defined, creates a link to the start object.</td>
</tr>
<tr>
<td>CTRL+SHIFT+O</td>
<td>Database Explorer</td>
<td>Opens the <strong>Customize Toolbars</strong> dialog box.</td>
</tr>
</tbody>
</table>
The functions in the following table are only available when you are editing attributes of type Text or String in a formal module:

<table>
<thead>
<tr>
<th>Keys</th>
<th>Context</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CTRL+SHIFT+ENTER</td>
<td>Formal Module</td>
<td>When in-place editing, inserts a soft return.</td>
</tr>
</tbody>
</table>

### Function keys

The functions in the following table are available in formal modules and the Database Explorer:

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Displays help in the Database Explorer and in module windows, but not in dialog boxes.</td>
</tr>
<tr>
<td>F2</td>
<td>Database Explorer - Displays the properties sheet of the item selected in the right pane.</td>
</tr>
<tr>
<td>Key</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>F2</td>
<td>In Module - Add the current object to a selection. For example, you can use F2 to select object 1 then use F2 to select object 5, and all the objects in between will be selected. You can then use F2 to select object 9 and all the objects between object 5 and object 9 will be added to the selection.</td>
</tr>
<tr>
<td>SHIFT+F2</td>
<td>Clears the current selection.</td>
</tr>
<tr>
<td>F3</td>
<td>In Module - Select</td>
</tr>
<tr>
<td>F3</td>
<td>Finds the next object in the module when using the Find function.</td>
</tr>
<tr>
<td>SHIFT+F3</td>
<td>Finds the previous object in the module when using the Find function.</td>
</tr>
<tr>
<td>F4</td>
<td>Deletes the current object.</td>
</tr>
<tr>
<td>F5</td>
<td>Refreshes the screen.</td>
</tr>
<tr>
<td>SHIFT+F5</td>
<td>Refreshes the module</td>
</tr>
<tr>
<td>F6</td>
<td>Compresses the current object if outlining is turned on.</td>
</tr>
<tr>
<td>SHIFT+F10</td>
<td>In the Database Explorer and in module windows, displays the context menu (equivalent to right-clicking).</td>
</tr>
</tbody>
</table>
Keypad keys

The functions in the following table only work if you turn the NUM LOCK off by pressing **NUM LOCK**.

<table>
<thead>
<tr>
<th>Keypad key</th>
<th>Description</th>
<th>With CTRL</th>
</tr>
</thead>
<tbody>
<tr>
<td>HOME 7</td>
<td>Moves to the first object in a formal module.</td>
<td>When editing text, moves the insertion point to the start of the attribute</td>
</tr>
<tr>
<td>END 1</td>
<td>Moves to the last object in a formal module.</td>
<td>When editing text, moves the insertion point to the end of the attribute</td>
</tr>
<tr>
<td>PAGE UP 9</td>
<td>Moves up a screen, unless in a formal module in Graphics mode, where the whole tree is rotated.</td>
<td>In a formal module in Graphics mode, redraws the whole tree with the parent aligned in a more compact form.</td>
</tr>
<tr>
<td>PAGE DOWN 3</td>
<td>Moves down a screen in a formal or descriptive module.</td>
<td></td>
</tr>
<tr>
<td>LEFT ARROW 4</td>
<td>In link modules, moves to the previous target object.</td>
<td>In formal modules, moves to the parent of the current object.</td>
</tr>
<tr>
<td>RIGHT ARROW 6</td>
<td>In link modules, moves to the next target object.</td>
<td>In formal modules, moves to the first child of the current object.</td>
</tr>
<tr>
<td>UP ARROW 8</td>
<td>In formal modules, moves to the previous object. In link modules, moves to the next source object.</td>
<td>In formal modules, moves to the previous object at the same level, skipping child objects.</td>
</tr>
<tr>
<td>DOWN ARROW 2</td>
<td>In formal modules, moves to the next object. In link modules, moves to the previous source object.</td>
<td>In formal modules, moves to the next object at the same level, skipping child objects.</td>
</tr>
</tbody>
</table>
Keyboard shortcuts

<table>
<thead>
<tr>
<th>Keypad key</th>
<th>Description</th>
<th>With CTRL</th>
</tr>
</thead>
<tbody>
<tr>
<td>INSERT 0</td>
<td>Creates an object one level below the current object.</td>
<td>Creates an object at the same level as the current object.</td>
</tr>
<tr>
<td>DELETE .</td>
<td>Deletes an object or link.</td>
<td></td>
</tr>
<tr>
<td>+</td>
<td>Decompresses the current object if outlining is turned on. In the Database or Module Explorer, expands the current item to display the items at the next level.</td>
<td></td>
</tr>
<tr>
<td>-</td>
<td>Compresses the current object if outlining is turned on. Collapses the entire directory of the Database or Module explorer, if you have the root node selected.</td>
<td></td>
</tr>
<tr>
<td>*</td>
<td>Expands the entire directory of the Database or Module explorer, if you have the root node selected.</td>
<td></td>
</tr>
</tbody>
</table>

Navigation Keys

The following table lists the navigation key shortcuts:

<table>
<thead>
<tr>
<th>Press</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>INSERT</td>
<td>Create an object one level below the current object.</td>
</tr>
<tr>
<td>CTRL+INSERT</td>
<td>Create an object at the same level as the current object.</td>
</tr>
<tr>
<td>HOME</td>
<td>Go to the first object in the module.</td>
</tr>
<tr>
<td>END</td>
<td>Go to the last object in the module.</td>
</tr>
<tr>
<td>CTRL+HOME</td>
<td>If you are editing text, moves the insertion point to the start of the attribute.</td>
</tr>
<tr>
<td>Press</td>
<td>To</td>
</tr>
<tr>
<td>------------------------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>CTRL+END</td>
<td>If you are editing text, moves the insertion point to the end of the attribute.</td>
</tr>
<tr>
<td>PAGE UP</td>
<td>If you are in Document mode, scroll up one screen.</td>
</tr>
<tr>
<td></td>
<td>If you are in Graphics mode, rotate the tree clockwise through 90 degrees.</td>
</tr>
<tr>
<td>PAGE DOWN</td>
<td>If you are in Document mode, scroll down one screen.</td>
</tr>
<tr>
<td></td>
<td>If you are in Graphics mode, rotates the objects clockwise.</td>
</tr>
<tr>
<td>UP ARROW</td>
<td>If you are in Document mode, go to the next or previous object.</td>
</tr>
<tr>
<td>DOWN ARROW</td>
<td>If you are in Graphics mode, move up or down the tree hierarchy.</td>
</tr>
<tr>
<td>CTRL+UP ARROW, CTRL+DOWN ARROW</td>
<td>Move from the current object to the sibling above or below it.</td>
</tr>
<tr>
<td></td>
<td>If the focus is on the left pane of the Module Explorer, they scroll.</td>
</tr>
<tr>
<td></td>
<td>If you are editing text, moves the insertion point to the start or end of the attribute.</td>
</tr>
<tr>
<td>CTRL+SHIFT+UP ARROW, CTRL+SHIFT+DOWN ARROW</td>
<td>Scrolls smoothly through the module contents.</td>
</tr>
<tr>
<td>CTRL+LEFT ARROW, CTRL+RIGHT ARROW</td>
<td>Go to the current objects parent (left arrow) or first child (right arrow).</td>
</tr>
<tr>
<td></td>
<td>If the focus is on the left pane of the Module Explorer, they scroll.</td>
</tr>
<tr>
<td></td>
<td>If you are editing text, moves the insertion point to the start or end of the previous or next word.</td>
</tr>
</tbody>
</table>
**Keyboard shortcuts**

<table>
<thead>
<tr>
<th>Press</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>SHIFT+RETURN</td>
<td>If you are in document mode, edit the current object in-place. If you are already editing the current object, goes to the next object. It does nothing if you are in Graphics mode, or if the focus is on the left pane of the Module Explorer.</td>
</tr>
<tr>
<td>MENU</td>
<td>In the Database Explorer and in module windows, displays the context menu (equivalent to right-clicking or SHIFT+F10).</td>
</tr>
</tbody>
</table>
This chapter contains the following topics:

- Contacting IBM Rational Software Support
- Prerequisites
- Submitting problems
- Other information

### Contacting IBM Rational Software Support

If the self-help resources have not provided a resolution to your problem, you can contact IBM Rational Software Support for assistance in resolving product issues.

**Note** If you are a heritage Telelogic customer, you can go to [http://support.telelogic.com/toolbar](http://support.telelogic.com/toolbar) and download the IBM Rational Telelogic Software Support browser toolbar. This toolbar helps simplify the transition to the IBM Rational Telelogic product online resources. Also, a single reference site for all IBM Rational Telelogic support resources is located at [http://www.ibm.com/software/rational/support/telelogic/](http://www.ibm.com/software/rational/support/telelogic/)

### Prerequisites

To submit your problem to IBM Rational Software Support, you must have an active Passport Advantage® software maintenance agreement. Passport Advantage is the IBM comprehensive software licensing and software maintenance (product upgrades and technical support) offering. You can enroll online in Passport Advantage from [http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html](http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html).

- For further assistance, contact your IBM representative.

To submit your problem online (from the IBM Web site) to IBM Rational Software Support, you must additionally:
Contacting support

- Be a registered user on the IBM Rational Software Support Web site. For details about registering, go to http://www-01.ibm.com/software/support/.
- Be listed as an authorized caller in the service request tool.

Submitting problems

To submit your problem to IBM Rational Software Support:

1. Determine the business impact of your problem. When you report a problem to IBM, you are asked to supply a severity level. Therefore, you need to understand and assess the business impact of the problem that you are reporting.

Use the following table to determine the severity level.

<table>
<thead>
<tr>
<th>Severity</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>The problem has a critical business impact: You are unable to use the program, resulting in a critical impact on operations. This condition requires an immediate solution.</td>
</tr>
<tr>
<td>2</td>
<td>This problem has a significant business impact: The program is usable, but it is severely limited.</td>
</tr>
<tr>
<td>3</td>
<td>The problem has some business impact: The program is usable, but less significant features (not critical to operations) are unavailable.</td>
</tr>
<tr>
<td>4</td>
<td>The problem has minimal business impact: The problem causes little impact on operations or a reasonable circumvention to the problem was implemented.</td>
</tr>
</tbody>
</table>

2. Describe your problem and gather background information. When describing a problem to IBM, be as specific as possible. Include all relevant background information so that IBM Rational Software Support specialists can help you solve the problem efficiently. To save time, know the answers to these questions:

- What software versions were you running when the problem occurred?

To determine the exact product name and version, use the option applicable to you:
• Start the IBM Installation Manager and select **File > View Installed Packages.** Expand a package group and select a package to see the package name and version number.
• Start your product, and click **Help > About** to see the offering name and version number.

• What is your operating system and version number (including any service packs or patches)?
• Do you have logs, traces, and messages that are related to the problem symptoms?
• Can you recreate the problem? If so, what steps do you perform to recreate the problem?
• Did you make any changes to the system? For example, did you make changes to the hardware, operating system, networking software, or other system components?
• Are you currently using a workaround for the problem? If so, be prepared to describe the workaround when you report the problem.

3. Submit your problem to IBM Rational Software Support. You can submit your problem to IBM Rational Software Support in the following ways:
   • **Online:** Go to the IBM Rational Software Support Web site at https://www.ibm.com/software/rational/support/ and in the Rational support task navigator, click **Open Service Request.** Select the electronic problem reporting tool, and open a Problem Management Record (PMR), describing the problem accurately in your own words.

   For more information about opening a service request, go to http://www.ibm.com/software/support/help.html

   You can also open an online service request using the IBM Support Assistant. For more information, go to http://www-01.ibm.com/software/support/isa/faq.html.

   • **By phone:** For the phone number to call in your country or region, go to the IBM directory of worldwide contacts at http://www.ibm.com/planetwide/ and click the name of your country or geographic region.

   • **Through your IBM Representative:** If you cannot access IBM Rational Software Support online or by phone, contact your IBM Representative. If necessary, your IBM Representative can open a service request for you. You can find complete contact information for each country at http://www.ibm.com/planetwide/.
If the problem you submit is for a software defect or for missing or inaccurate documentation, IBM Rational Software Support creates an Authorized Program Analysis Report (APAR). The APAR describes the problem in detail. Whenever possible, IBM Rational Software Support provides a workaround that you can implement until the APAR is resolved and a fix is delivered. IBM publishes resolved APARs on the IBM Rational Software Support Web site daily, so that other users who experience the same problem can benefit from the same resolution.

Other information

For Rational software product news, events, and other information, visit the IBM Rational Software Web site on http://www.ibm.com/software/rational/.
© Copyright IBM Corporation 1993, 2010

US Government Users Restricted Rights - Use, duplication, or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.

This information was developed for products and services offered in the U.S.A. IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send written license inquiries to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual Property Department in your country or send written inquiries to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND,
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain transactions. Therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

Intellectual Property Dept. for Rational Software
IBM Corporation
1 Rogers Street
Cambridge, Massachusetts 02142
U.S.A.

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

Any performance data contained herein was determined in a controlled environment. Therefore, the results obtained in other operating environments may vary significantly. Some measurements may have been made on development-level systems and there is no guarantee that these measurements will be the same on generally available systems. Furthermore, some measurements may have been estimated through extrapolation. Actual results
may vary. Users of this document should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to the names and addresses used by an actual business enterprise is entirely coincidental.

If you are viewing this information softcopy, the photographs and color illustrations may not appear.

Additional legal notices are described in the legal_information.html file that is included in your software installation.

**Trademarks**

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the Web at www.ibm.com/legal/copytrade.html.

Windows is a trademark of Microsoft Corporation in the United States, other countries, or both.

**Text proofing system copyrights**

International Proofreader™ English (US and UK) text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ French text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ German text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.
International Proofreader™ Afrikaans text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Catalan text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Czech text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Danish text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Dutch text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Finnish text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Greek text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Italian text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Norwegian, text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Portuguese, text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Russian, text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

International Proofreader™ Spanish, text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.
International Proofreader™ Swedish, text proofing system © 2003 by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.

Other company, product or service names may be trademarks or service marks of others.
Index

A

Access rights
  inheritance, 185, 187
  propagating, 188
  understanding, 183
Activating OLE objects, 165
Adding
  columns, 136
  graph columns, 139
  icon columns, 143
Advanced filters
  understanding, 88
  using, 90
Applying approved change proposals, 339
Applying approved group change proposals, 340
ASCII, 311
Attribute definitions
  changing access rights, 114
  creating, 110
  deleting, 123
  editing, 117
  importing, 122
  showing, 109
Attribute types
  changing access rights, 106
  creating, 105
  deleting, 109
  editing, 108
  importing, 122
  showing, 104
Attribute values
  changing access rights, 116
  copying, 124
  measuring frequency, 125
Attributes
  copying between modules, 64
  creating link attributes, 215
  linking by attribute, 221
  T3, 344
  Test Case attributes, 341
  Test Run attributes, 341

B

Baselines
  and discussions, 231
  comparing, 265
  copying, 263
  creating, 263
  deleting, 266
  opening, 262
  signing, 268
  understanding, 261
  viewing electronic signatures, 267
Buttons
  changing on Database Explorer, 7
  changing on module toolbars, 7
  database, 386
  module, 383

C

Change bars, 239
Change proposal partner modules, 321
Change proposal roles, 321
Change Proposal System
  check, 338
  groups, 322
    master, 323
    subordinate, 323
  understanding, 319
Change proposals
  applying approved, 339
  applying approved group, 340
  description, 320
  multiple, 320
  reviewing, 331, 334
  reviewing groups, 333
  showing, 331
  showing groups, 333
  showing information about, 335
  submitting, 324
  suggestions, 320
Changing
  column information, 137
  Database Explorer display, 5
  display levels, 132
Checking data against history, 257
Checking your spelling, 58
Closing modules, 22
Color-coding data, 138
Columns
  adding, 136
  editing column information, 137
  inserting in tables, 155
  showing column information, 135
  working with, 134
Command line
  switches, 374
  using, 373
Comparing modules, see Module Comparison Wizard
Compressing parts of the hierarchy, 134
Converting layout DXL to attribute DXL, 390
Create links tool, 219
Creating
  baselines, 263
  change proposal groups, 324
  folders, 191
  formal modules, 23
  link modules, 226
  links, 202
  linkset definitions, 224
  linksets, 228
  objects, 51
  reports, 279
  tables, 154
Customize toolbars
  Database Explorer, 7
  module, 7
Cutting, copying and pasting
  in module window, 21
  in the Database Explorer, 20

D
Database, searching, 83
Database buttons, 386
Database Explorer
  changing the display, 5
  cutting, copying and pasting, 20
  Favorites field, 9
  Location field, 8
  making selections, 6
  selecting multiple items, 7
  using drag-and-drop, 17
Database Explorer buttons, 7
Database Explorer toolbars, 7
Deactivating OLE objects, 165
Default link modules, 222
Default linkset pairings, 223
Default view
  module default view, 75
  setting, 75
  user default view, 75
Deleting
   baselines, 266
   folders, 194
   links, 217
   linksets, 228
   modules, 32
   objects, 56
   OLE objects, 172
   tables, 159
   views, 81
Demote object, 54
Descriptive modules
   changing access rights, 350
   marking up, 351
   showing marked up items, 355
   showing properties, 354
   understanding, 349
Dictionaries, 369, 372
Discussions
   and baselines, 231
   controlling access in a module, 232
   for modules
      about, 231
      adding comments, 233
      closing, 234
      creating, 233
      deleting, 234
      reopening, 235
      viewing, 233
   for objects
      about, 231
      adding comments, 236
      closing, 237
      creating, 235
      deleting, 237
      reopening, 238
      viewing, 236
Display levels, 132
Display Link Indicators column, 253
Display modes
   changing between, 132
   document mode, 131
   graphics mode, 131
Display schemes
   about, 362
   changing, 363
   high contrast, 363
   items, 365
Document mode
   turning on and off, 132
   understanding, 131
Drag-and-drop
   in a module window, 17
   in the Database Explorer, 17
Duplicate sets
   managing, 336
   understanding, 322
DXL
   attributes, 123
   developing programs, 387
   editing a DXL attribute definition, 120
   library, 389
   understanding, 387
   using, 387
DXL Attribute Wizard, 113
E
Edit modes
   changing, 36
   understanding, 36
Editable sections, 37
Editing
   change proposal groups, 324
   column information, 137
   extended undo, 50
   folder properties, 194
   imported Word style information,
285
    links, 213
    marked up objects, 352
    objects, 46
    undo, 50
    views, 76
Electronic signatures
    printing, 269
    signing, 268
    viewing, 267
EXPORTDIRECTORY, 380
Exporting
    FrameMaker, 316
    HTML, 309
    Microsoft Excel, 306
    Microsoft Outlook, 308
    Microsoft PowerPoint, 308
    Microsoft Word, 303
    plain text, 311
    RTF, 312
    spreadsheets, 314
Extended undo facility, 50

F
Favorites
    organizing items, 9
    understanding, 9
Filtering data, 88, 90
Filters
    advanced, 88
    filtering the Module Explorer, 93
    reapplying, 93
    simple, 87
    turning on and off, 93
Finding
    and replacing text in modules, 85
    text in modules, 84

Folders
    changing access rights, 192
    creating, 191
    deleting, 194
    editing properties, 194
    purging, 194
    undeleting, 194
    unlocking, 196
Formal modules
    changing access rights, 24
    creating, 23
    finding and replacing text, 85
    searching for objects that contain text, 84
    showing properties, 29
Forms
    creating, 67
    deleting, 70
    editing, 69
    running, 69
FrameMaker
    exporting, 316
    importing, 300

G
Going directly to an object, 86
Grammar-checker, 370
Graph columns, 139
Graph Wizard, 139
Graphics mode
    turning on and off, 132
    understanding, 131
Groups, understanding, 184
Groups modules, 321

H
History, 257

I
IBM Customer Support, 401
Icon columns, 143
Iconizer Wizard, 143
Importing
database files, 295
FrameMaker, 300
Microsoft Word, 283
plain text, 286
RTF, 294
spreadsheets, 295
Inheritance
access rights, 185
example, 187
In-links, 201
In-place editing, 41
Inserting
OLE objects, 166
pictures, 164
symbols, 61
templates, 62
URLs, 61
Jumping directly to an object, 86
Keyboard shortcuts
CTRL keys, 391
functions, 395
keypad keys, 397
navigating, 127
navigation, 398
rich text, 395
Layout DXL columns
about, 123
converting to attribute DXL, 390
Link analysis
running, 245
understanding, 244
Link arrows, 201
Link modules
changing access rights, 208
creating, 226
defaults, 222
showing properties, 225
understanding, 207
working with, 227
Linking by attribute, 221
Links
clearing the start, 207
creating, 202
deleting, 217
editing, 213
link arrows, 201
understanding, 199
Linkset Control, 224
Linkset definitions, 224
Linkset pairings, 222
Linksets
creating, 228
deleting, 228
understanding, 207
Location field, 8
Locks
managing, 195
unlocking objects, 195
Making selections
in a module window, 16
in the Database Explorer, 6
Marking up descriptive modules, 351
Merging object text, 65
Module buttons
about, 383
changing, 7
Module Comparison Wizard
introduction, 145
running, 146
using, 145
Module default view, 75
Module Explorer
  filtering, 93
  using, 130
Module toolbars, 7
Module window
  cutting, copying and pasting, 21
  making selections, 16
  using drag-and-drop, 17
Modules
  about discussions, 231
  adding comments, 233
  closing, 22, 33
  closing discussions, 234
  creating, 23
  creating discussions, 233
  creating objects, 51
  deleting, 32
  deleting discussions, 234
  deleting links, 218
  dividing up into editable sections, 39
  finding and replacing text, 85
  inserting as a table, 154
  navigating using the keyboard, 127
  opening, 11
  paste special, 27
  printing, 277
  purging, 32
  reopening discussions, 235
  saving your changes, 51
  searching for objects that contain
  text, 84
  selecting everything, 17
  selecting multiple objects, 16
  setting up for sharing, 38
  showing history, 240
  showing link module properties, 225
  showing properties, 29
  showing statistics, 31
  undeleting, 32
  understanding, 349
  unlocking, 196
  viewing discussions, 233
Moving directly to an object, 86

O
Object copier, 64
Object properties sheet, 46
Object splitter, 62
Object text, 65
Objects
  about discussions, 231
  adding comments, 236
  changing access rights, 52
  closing discussions, 237
  copying between modules, 64
  creating discussions, 235
  deleting, 56
  deleting discussions, 237
  demoting, 54
  editing marked up objects, 352
  jumping to objects, 86
  not displayed, 6
  promoting, 54
  purging, 56
  reopening discussions, 238
  undeleting, 56
  viewing discussions, 236
OLE objects
  activating and deactivating, 165
  copy and pasting, 168
  cutting, copying and pasting, 170
  deleting, 172
  editing properties, 170
  history, 172
  inserting, 166
  resizing, 169
  setting OLE open limit, 173
  understanding, 164
  understanding registered and unregistered, 173
OLE open limit, 173
Opening
  baselines, 262
  modules, 11
Outlining, 133
Out-links, 201

P
Page setups
  applying, 271
  creating, 271
Pictures
  inserting, 164
  working with pictures, 163
Plain text
  exporting, 311
  importing, 286
Print preview, 278
Printing
  electronic signatures, 269
  modules, 277
  reports, 280
Promote object, 54
Propagating access rights, 188
Proposals modules, 321

R
Rational DOORS
  configuring, 357
  running in batch mode, 380
  starting, 3
  stopping, 22
Rational DOORS Links, 207
Redline markup column, 150
Redlining, 243
Registry settings, 379
Regular expressions, 95
Replacing text in modules, 85
Reports
  creating, 279
  printing, viewing or deleting, 280
Request lock
  module, 12
  section, 41
RTF
  exporting, 312
  importing, 294
RTL_RECIP, 382

S
Searching
  for objects that contain text, 84
  the database, 83
Sections
  locking, 40
  unlocking, 40
Selecting
  everything in a module, 17
  items in the Database Explorer, 6
  multiple items in the Database Explorer, 7
  multiple objects in a module, 16
Setting the default view, 75
Setting up modules for sharing, 38
Shareable edit mode, 39
Shortcuts, 378
Showing and hiding parts of the
Index

hierarchy, 134
Showing column information, 135
Simple filters
understanding, 87
using, 88
Sorting
objects, 94
turning on and off, 95
understanding, 93
Spell-checker
configuring, 369
using, 58
Split Object Heading from Object Text, 56
Starting Rational DOORS, 3
Stopping Rational DOORS, 22
Suggestions
reviewing, 334
submitting, 329
Suggestions modules, 321
Suspect links
clearing, 255
display all changes, 254
display all information, 254
display last change, 253
Display Link Indicators column, 253
filtering, 252
understanding, 251
Swap object heading and text attributes, 55
Symbols, 61
System attributes, 99

T
T3 attributes, 344

Tables
changing properties, 156
creating, 154
deleting, 159
inserting a module as a table, 154
inserting columns, 155
inserting rows, 155
purging, 159
undeleting, 159
understanding, 153
Templates, 62
Test Case attributes, 341
Test definitions
creating, 343
updating, 345
Test Run attributes, 341
Test Run Results form, 345
Test Tracking
comparing tests, 347
introduction, 341
preparing the module, 346
running tests, 347
Text
finding and replacing in modules, 85
finding in modules, 84
Traceability columns
adding, 246
understanding, 246
Traceability Explorer, 250

U
Understanding change proposal groups, 322
Undoing an edit, 50
Unlocking
folders, 196
modules, 196
projects, 196
URLs, 61
User default view, 75
User options, 357
Index

V
Views
  changing access rights, 79
  deleting, 81
  editing, 76
  saving current module view, 72
  understanding, 71

W
Welcome Screen
  configuring home, 380
  configuring links, 381